Subject: RE: Another requirement [Re: New (-02) version of IPv6 CPE Router draft is available for review]

From: Francois-Xavier Le Bail <[email-masked]>
Date: Thu, 31 Jul 2008 08:11:59 -0700 (PDT)

--- On Thu, 7/31/08, Wes Beebee (wbeebee) <[email-masked]> wrote:
> The route should go to the LAN ports (for the delegate
> prefix).  If the LAN ports happen to not be up, doesn't this 
> cause the packet to be > dropped?  If the destination matches a 
> loopback, then the packets can be
> serviced by the loopback.  If there is no LAN port (# of
> LAN ports = 0),
> and if the device still does DHCPv6 PD (for other
> addresses), then a
> null route may be appropriate as long as the other
> addresses get
> serviced at a higher priority.

For example, if the delegated prefix is a /56 and the CPE use
a /64 prefix for a subnet on a LAN Bridge and another /64 for a
subnet on another LAN interface outside the bridge,
there are many prefix/subnet not used.

Packet to theses unused prefix/subnet will loop without a discard 
or unreachable route.

Francois-Xavier

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On
> Behalf Of Francois-Xavier Le Bail
> Sent: Thursday, July 31, 2008 10:17 AM
> To: [email-masked]
> Subject: Another requirement [Re: New (-02) version of IPv6
> CPE Router
> draft is available for review]
> 
> Another requirement:
> 
> The CPE should install a discard (null) or unreachable
> route for the
> delegated prefix.
> 
> Without, a packet to an unused subnet (belonging to the
> delegated
> prefix) will loop between the CPE (default route to the
> Edge Router) and
> the Edge Router (route for the delegated prefix to the
> CPE).
> 
> The only difference between the two options is: with
> unreachable route
> the CPE return ICMPv6 "Destination Unreachable/no
> route to destination"
> message to the source address instead of only silently
> discard the
> packet.
> 
> Francois-Xavier

---

From: "Wes Beebee (wbeebee)" <[email-masked]>
Date: Thu, 31 Jul 2008 11:19:32 -0400

Agreed.  Perhaps a low precedence route (when all else but the default
route fails to match) that's a null route would be desirable..

- Wes 

-----Original Message-----
From: Francois-Xavier Le Bail [mailto:[email-masked]] 
Sent: Thursday, July 31, 2008 11:12 AM
To: [email-masked]; Wes Beebee (wbeebee)
Subject: RE: Another requirement [Re: New (-02) version of IPv6 CPE
Router draft is available for review]

--- On Thu, 7/31/08, Wes Beebee (wbeebee) <[email-masked]> wrote:
> The route should go to the LAN ports (for the delegate prefix).  If 
> the LAN ports happen to not be up, doesn't this cause the packet to be

> > dropped?  If the destination matches a loopback, then the packets 
> can be serviced by the loopback.  If there is no LAN port (# of LAN 
> ports = 0), and if the device still does DHCPv6 PD (for other 
> addresses), then a null route may be appropriate as long as the other 
> addresses get serviced at a higher priority.

For example, if the delegated prefix is a /56 and the CPE use a /64
prefix for a subnet on a LAN Bridge and another /64 for a subnet on
another LAN interface outside the bridge, there are many prefix/subnet
not used.

Packet to theses unused prefix/subnet will loop without a discard or
unreachable route.

Francois-Xavier

> Subject: Another requirement [Re: New (-02) version of IPv6 CPE Router

> The CPE should install a discard (null) or unreachable route for the 
> delegated prefix.
> 
> Without, a packet to an unused subnet (belonging to the delegated
> prefix) will loop between the CPE (default route to the Edge Router) 
> and the Edge Router (route for the delegated prefix to the CPE).
> 
> The only difference between the two options is: with unreachable route

> the CPE return ICMPv6 "Destination Unreachable/no route to 
> destination"
> message to the source address instead of only silently discard the 
> packet.
> 
> Francois-Xavier

---

From: Francois-Xavier Le Bail <[email-masked]>
Date: Thu, 31 Jul 2008 08:33:13 -0700 (PDT)

> route fails to match) that's a null route would be

Yes, and with the Good Old "Longest prefix match", no problem of 
precedence.

Francois-Xavier

> prefix).  If 
> route to

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 31 Jul 2008 08:43:43 -0700

>Sent: Thursday, July 31, 2008 8:12 AM
>Subject: RE: Another requirement [Re: New (-02) version of 
>IPv6 CPE Router draft is available for review]
>

But is this so surprising? Any requesting router that is
delegated a prefix is implicitly responsible for proper
stewardship of the prefix; this is not specific to just
the CPE router case.

So, is any additional specification needed and (if so)
should it be done here or within a broader context?
  
Fred
[email-masked]

---

From: "Wes Beebee (wbeebee)" <[email-masked]>
Date: Thu, 31 Jul 2008 11:49:29 -0400

There may be problem with precedence if the PD is a /64 and there is one
LAN port that's a /64,
you'd have to make sure that the null route was lower precedence than
the LAN port otherwise
you might not have connectivity.  So yes, we do need to specify that the
null route is lower 
precedence than other routes except for the default route.

- Wes

-----Original Message-----
From: Francois-Xavier Le Bail [mailto:[email-masked]] 
Sent: Thursday, July 31, 2008 11:33 AM
To: [email-masked]; Wes Beebee (wbeebee)
Subject: RE: Another requirement [Re: New (-02) version of IPv6 CPE

Francois-Xavier

> > [mailto:[email-masked]] On Behalf Of Francois-Xavier Le 
> > Bail

---

From: Francois-Xavier Le Bail <[email-masked]>
Date: Thu, 31 Jul 2008 08:57:27 -0700 (PDT)

> precedence than other routes except for the default route.

Agreed

> > > the LAN ports happen to not be up, doesn't
> this
> > cause the packet to be
> > 
> > > > dropped?  If the destination matches a
> loopback,
> > then the packets
> > > can be serviced by the loopback.  If there is no
> LAN
> > port (# of LAN
> > > ports = 0), and if the device still does DHCPv6
> PD
> > (for other
> > > addresses), then a null route may be appropriate
> as
> > long as the other
> > > Subject: Another requirement [Re: New (-02)
> version of
> > IPv6 CPE Router
> > 
> > > Without, a packet to an unused subnet (belonging
> to
> > the delegated
> > > prefix) will loop between the CPE (default route
> to
> > the Edge Router)
> > > and the Edge Router (route for the delegated
> prefix to
> > the CPE).
> > >

---

From: "Wes Beebee (wbeebee)" <[email-masked]>
Date: Thu, 31 Jul 2008 11:57:55 -0400

> So, is any additional specification needed and (if so) should it be
done here or within a broader context?

If someone writes some other document on proper population of routing
tables/stewardship of prefixes, then the CPE Router document can
reference that other document - but I think that we can address this
specific issue with a single sentence in the CPE Router document.

- Wes

-----Original Message-----
From: Templin, Fred L [mailto:[email-masked]] 
Sent: Thursday, July 31, 2008 11:44 AM
To: Francois-Xavier Le Bail; [email-masked]; Wes Beebee (wbeebee)
Subject: RE: Another requirement [Re: New (-02) version of IPv6 CPE

>> the LAN ports happen to not be up, doesn't this cause the packet to 
>> be > dropped?  If the destination matches a loopback, then the 
>> packets can be serviced by the loopback.  If there is no LAN port (# 
>> of LAN ports = 0), and if the device still does DHCPv6 PD (for other 

>Packet to theses unused prefix/subnet will loop without a discard or 

But is this so surprising? Any requesting router that is delegated a
prefix is implicitly responsible for proper stewardship of the prefix;
this is not specific to just the CPE router case.

So, is any additional specification needed and (if so) should it be done
here or within a broader context?
  
Fred

>> Subject: Another requirement [Re: New (-02) version of IPv6 CPE 
>> The only difference between the two options is: with unreachable 
>> route the CPE return ICMPv6 "Destination Unreachable/no route to 
>> destination"