Subject: Re: I-D Action:draft-ietf-v6ops-ipv6-cpe-router-02.txt

From: Francois-Xavier Le Bail <[email-masked]>
Date: Thu, 5 Nov 2009 09:18:10 -0800 (PST)

Hi,

A CE router often contain a bridge on the LAN side with Ethernet, Wifi interfaces attached to it.

Without MLD snooping [RFC4541] on the LAN bridge, a multicast flow will flood all segments on all interfaces.

Significant bandwidth can be wasted by flooding.

That is why I propose a L-10 requirement:

L-10: If the CE router is build with a bridge on the LAN side, it MUST
      use MLD snooping [RFC4541] to avoid flooding multicast frames on
      all segments.

Best regards,
Francois-Xavier

--- On Mon, 10/26/09, [email-masked] <[email-masked]> wrote:

> From: [email-masked] <[email-masked]>
> Subject: I-D Action:draft-ietf-v6ops-ipv6-cpe-router-02.txt
> To: [email-masked]
> Cc: [email-masked]
> Date: Monday, October 26, 2009, 5:45 PM
> A New Internet-Draft is available
> from the on-line Internet-Drafts directories.
> This draft is a work item of the IPv6 Operations Working
> Group of the IETF.
> 
> 
>     Title       
>    : Requirements for IPv6 Customer Edge
> Routers
>     Author(s)   
>    : H. Singh, et al.
>     Filename        :
> draft-ietf-v6ops-ipv6-cpe-router-02.txt
>     Pages       
>    : 14
>     Date         
>   : 2009-10-26
> 
> This document specifies requirements for an IPv6 Customer
> Edge (CE)
> router.  Specifically, the current version of this
> document focuses
> on the provisioning of an IPv6 CE router and the
> provisioning of IPv6
> hosts attached to it.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-v6ops-ipv6-cpe-router-02.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail
> reader
> implementation to automatically retrieve the ASCII version
> of the
> Internet-Draft.
>

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Thu, 5 Nov 2009 11:58:49 -0600

Francois-Xavier,

Please note that this version of the CE Rtr draft (-02) which we call as
Phase I does not included any mcast behavior definition.  The SP's
working on the design team could not agree to putting mcast in the Phase
I document.  So when the Phase II gets worked on, as we have discussed
in the v6ops mailer in the past, this bridged mcast will be added as a
requirement in the document.  Do expect such text in the Phase II
document.

Note the Phase II document (after the San Francisco IETF in March 2009)
is the document below.

http://tools.ietf.org/id/draft-wbeebee-v6ops-ipv6-cpe-router-bis-01.txt

Since mcast was moved out of CE Rtr Phase I, it is included as is in the
bis doc above.  "As is" means what we agreed upon in the v6ops mailer
with you on MLDv2 snooping.  This is the text we have

If the CPE Router hardware includes a network bridge between the WAN
interface and the LAN interface(s), then the CPE Router MUST support
MLDv2 snooping as per [RFC4541].

When the design team starts work on Phase II document, this bis version
will also morph into the format being used in the
raft-ietf-v6ops-ipv6-cpe-router-02.txt.

Thanks,

Hemant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Francois-Xavier Le Bail
Sent: Thursday, November 05, 2009 12:18 PM
To: [email-masked]
Subject: Re: I-D Action:draft-ietf-v6ops-ipv6-cpe-router-02.txt

Hi,

A CE router often contain a bridge on the LAN side with Ethernet, Wifi
interfaces attached to it.

Without MLD snooping [RFC4541] on the LAN bridge, a multicast flow will
flood all segments on all interfaces.

Best regards,
Francois-Xavier

> draft-ietf-v6ops-ipv6-cpe-router-02.txt
http://www.ietf.org/internet-drafts/draft-ietf-v6ops-ipv6-cpe-router-02.
txt