Subject: Re: [v6ops] On/off switch [draft-ietf-v6ops-happy-eyeballs WGLC]

From: Teemu Savolainen <[email-masked]>
Date: Fri, 30 Sep 2011 22:25:23 -0700

I object MUST for configuration option, as for some class of hosts,
like embedded systems, it is not always feasible to have such settings
supported.

Teemu

Sent from my Windows Phone
From: Brian E Carpenter
Sent: 28.9.2011 3:16
To: Jeroen Massar
Cc: [email-masked]
Subject: Re: [v6ops] On/off switch [draft-ietf-v6ops-happy-eyeballs
WGLC]
Marc,

On 2011-09-28 02:57, Jeroen Massar wrote:
> On 2011-09-27 15:53 , Marc Blanchet wrote:
>> Le 2011-09-27 à 09:47, Marc Blanchet a écrit :
>>
>>>>> I would like to see a knob that would have the possible values as:
>>>>> - default  (HE no pref between v4 or v6)
>>>>> - v6 (HE does pref v6 by some minimal increment)
>>>>> - off  (disable HE)
>>>>>
>>>>> The way to implement this might be:
>>>>> - off: value = 65535
>>>>> - default: value = 0
>>>>> - v6: value = number of ms "advantage for ipv6"
> [..]
>
>> btw, I can provide text if there is support in wg for this idea.
>
> I would say that it is a great thing to add, but just an on/off is
> already good enough from my POV.

I agree; maybe on/off as a MUST and the ms of bias as a MAY?

I don't see anybody opposing the general idea, anyway.

   Brian

>
> The above proposal would give the advantage to be able to easily
> distribute a site-wide (given that one control all the hosts involved)
> bonus for IPv6 in case a site is connected over a tunnel or other
> mechanism which causes a bit more latency on the IPv6 side.
>
> The other way to counter that disadvantage is just delaying IPv4 packets
> at the moment, but that is far from a proper solution.
>
> Greets,
>  Jeroen
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Doug Barton <[email-masked]>
Date: Fri, 30 Sep 2011 23:31:12 -0700

A qualification there would be reasonable. "For systems where user
configuration is possible ..." or something more elegant. :)

That said I tend to agree with James Woodyatt that providing a knob to
turn it off is likely to lead to the results that he predicted. In
principle I really don't like the idea of "forcing it down the user's
throats," but I think that the only way it will actually be successful
is if they can't turn it off.

OTOH, there is (obviously) no way to prevent vendors from providing one,
so perhaps what is really needed is a discussion of the merits of both
options.

Doug

-- 

	Nothin' ever doesn't change, but nothin' changes much.
			-- OK Go

	Breadth of IT experience, and depth of knowledge in the DNS.
	Yours for the right price.  :)  http://SupersetSolutions.com/