Subject: [v6ops] I-D Action: draft-ietf-v6ops-3gpp-eps-07.txt

From: [email-masked]
Date: Wed, 21 Sep 2011 21:52:30 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the IPv6 Operations Working Group of the IETF.

	Title           : IPv6 in 3GPP Evolved Packet System
	Author(s)       : Jouni Korhonen
                          Jonne Soininen
                          Basavaraj Patil
                          Teemu Savolainen
                          Gabor Bajko
                          Kaisu Iisakkila
	Filename        : draft-ietf-v6ops-3gpp-eps-07.txt
	Pages           : 35
	Date            : 2011-09-21

   Use of data services in smart phones and broadband services via HSPA
   and HSPA+, in particular Internet services, has increased rapidly and
   operators that have deployed networks based on 3GPP network
   architectures are facing IPv4 address shortages at the Internet
   registries and are feeling a pressure to migrate to IPv6.  This
   document describes the support for IPv6 in 3GPP network
   architectures.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-v6ops-3gpp-eps-07.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-v6ops-3gpp-eps-07.txt

---

From: "George, Wes" <[email-masked]>
Date: Fri, 23 Sep 2011 15:34:11 -0400

One question about this draft. In section 5 covering address management, the draft is unclear as to whether 3GPP EPS supports IPv6-only operation, and whether there are any special implementation considerations around this.
Since in many cases, it is possible to provision IPv4 addresses on demand based on whether the data connection on the device is active or idle, one would think that it would make a lot of sense to extend this so that you could provision IPv4 and IPv6 addresses independently based on which is needed to complete the requested service.
There are references in earlier sections to "IPv4 and/or IPv6 addresses" but 5.1 says "ipv4 address configuration is always performed during PDP...setup". 6.1 and 8.4 seems to imply that IVP6 only is supported, but is unclear about whether once an IPv6-only session is established, if an IPv4 session can also be established (on-demand) at a later point, and if the two can be torn down independently. There is also text in section 7 that says that in dual-stack scenarios, the number of IPv4 addresses in use is not lessened by an increase in the amount of active IPv6 devices.

So I'm looking for clarity on a specific scenario -
A device which supports dual-stack is configured as IPv6-only by default. It has active traffic moving over IPv6, and then it tries to connect to something that is only available via IPv4. Is it possible for the device to trigger the setup of an IPv4 session? Does it have to tear down the existing IPv6-only session to move to a dual-stack? When it is done using IPv4 and that goes idle, can it tear down the IPv4 session if IPv6 is still active? I think that 8.7 is covering this case, but it's unclear to me. Also, if this is supported, what is the expected setup time? That is, could you actually stand up an IPv4 session before the connection attempt times out, or would the device have to have some intelligence to defer/retry the connection attempt while it sets up its IPv4 address?

Is the behavior in the above scenario dictated by the 3GPP spec, or by this draft?

Thanks,

Wes

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, September 22, 2011 12:53 AM
To: [email-masked]
Cc: [email-masked]
Subject: [v6ops] I-D Action: draft-ietf-v6ops-3gpp-eps-07.txt

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-v6ops-3gpp-eps-07.txt
_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Hui Deng <[email-masked]>
Date: Sun, 25 Sep 2011 08:29:25 +0800

I believe that there is possibility about IPv6 only PDP,
if this draft isn't clear about this, I would recommend it need to be
udpated.

Regards,

-Hui

2011/9/24 George, Wes <[email-masked]>

> One question about this draft. In section 5 covering address management,
> the draft is unclear as to whether 3GPP EPS supports IPv6-only operation,
> and whether there are any special implementation considerations around this.
> Since in many cases, it is possible to provision IPv4 addresses on demand
> based on whether the data connection on the device is active or idle, one
> would think that it would make a lot of sense to extend this so that you
> could provision IPv4 and IPv6 addresses independently based on which is
> needed to complete the requested service.
> There are references in earlier sections to "IPv4 and/or IPv6 addresses"
> but 5.1 says "ipv4 address configuration is always performed during
> PDP...setup". 6.1 and 8.4 seems to imply that IVP6 only is supported, but is
> unclear about whether once an IPv6-only session is established, if an IPv4
> session can also be established (on-demand) at a later point, and if the two
> can be torn down independently. There is also text in section 7 that says
> that in dual-stack scenarios, the number of IPv4 addresses in use is not
> lessened by an increase in the amount of active IPv6 devices.
>
> A device which supports dual-stack is configured as IPv6-only by default.
> It has active traffic moving over IPv6, and then it tries to connect to
> something that is only available via IPv4. Is it possible for the device to
> trigger the setup of an IPv4 session? Does it have to tear down the existing
> IPv6-only session to move to a dual-stack? When it is done using IPv4 and
> that goes idle, can it tear down the IPv4 session if IPv6 is still active? I
> think that 8.7 is covering this case, but it's unclear to me. Also, if this
> is supported, what is the expected setup time? That is, could you actually
> stand up an IPv4 session before the connection attempt times out, or would
> the device have to have some intelligence to defer/retry the connection
> attempt while it sets up its IPv4 address?
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the IPv6 Operations Working Group
> of the IETF.
>
> This E-mail and any of its attachments may contain Time Warner Cable
> proprietary information, which is privileged, confidential, or subject to
> copyright belonging to Time Warner Cable. This E-mail is intended solely for
> the use of the individual or entity to which it is addressed. If you are not
> the intended recipient of this E-mail, you are hereby notified that any
> dissemination, distribution, copying, or action taken in relation to the
> contents of and attachments to this E-mail is strictly prohibited and may be
> unlawful. If you have received this E-mail in error, please notify the
> sender immediately and permanently delete the original and any copy of this
> E-mail and any printout.

---

From: jouni korhonen <[email-masked]>
Date: Sun, 25 Sep 2011 18:38:36 +0300

Wes,

> One question about this draft. In section 5 covering address management, the draft is unclear as to whether 3GPP EPS supports IPv6-only operation, and whether there are any special implementation c…

Section 6.2 says:

   3.  For 2G/3G access to EPC core (PDN-GW via S4-SGSN) from Release-8
       there are three IP PDP Types, IPv4, IPv6 and IPv4v6 which gets
       mapped to PDN Connection type.  Minimum one PDP Context is needed
       to get dual stack connectivity.

   4.  For LTE (E-UTRAN) access to EPC core from Release-8 there are
       three IP PDN Types, IPv4, IPv6 and IPv4v6.  Minimum one PDN
       Connection is needed to get dual stack connectivity.

This could probably be explicitly stated earlier.

Nothing specific about PDP/PDN Type IPv6.. apart it being IPv6 only.

> Since in many cases, it is possible to provision IPv4 addresses on demand based on whether the data connection on the device is active or idle, one would think that it would make a lot of sense to…

There is so called "deferred address allocation" for IPv4 in case of Dual-Stack. It is not actually described in the draft due being IPv4 specific stuff and rather ugly as a DHCPv4-based solution. (i.e. the UE opens Dual-Stack connection which is provisioned as supporting deferred IPv4 address allocation. Then somehow defers DHCPv4 operation until it needs IPv4 address.. this can be somewhat hard to get deterministically working on the UE side).

> There are references in earlier sections to "IPv4 and/or IPv6 addresses" but 5.1 says "ipv4 address configuration is always performed during PDP...setup". 6.1 and 8.4 seems to imply that IVP6 only…

Nothing prevents (if allowed by the subscription) the UE opening another PDP Context/PDN Connection of type IPv4 later on.. but that then implies two bearers, which for most operators seems to no-go. You cannot, though, upgrade an existing PDP/PDN Type on fly e.g. from IPv6 to IPv4v6.

> A device which supports dual-stack is configured as IPv6-only by default. It has active traffic moving over IPv6, and then it tries to connect to something that is only available via IPv4. Is it possible for the device to trigger the setup of an IPv4 session? Does it have to tear down the existing IPv6-only session to move to a dual-stack? When it is 

Sure. This is UE implementation specific issue. Network side only cares about subscription provisioning in this case i.e. both IPv4 and IPv6 must be provisioned to the UE

> done using IPv4 and that goes idle, can it tear down the IPv4 session if IPv6 is still active? I think that 8.7 is 

Sure. AGain up to the UE implementation.

> covering this case, but it's unclear to me. Also, if this is supported, what is the expected setup time? That is, could

PDP Context/PDN Connection setup time (in case of default bearer) is not the fastest operation and depends on various things. Bringing up the radio alone takes several seconds (quickly did few test and they were around 5sec on 3G).

>  you actually stand up an IPv4 session before the connection attempt times out, or would the device have to have some intelligence to defer/retry the connection attempt while it sets up its IPv4 address?
> 

An UE vendor can implement such.. if they so wish. 

- JOuni

---

From: "George, Wes" <[email-masked]>
Date: Mon, 26 Sep 2011 09:26:55 -0400

Thank you, much clearer now. This is all helpful explanation that I believe should be added to the draft. I realize that some of it is specific to IPv4, but when considering a dual-stack network + IPv4 exhaustion (which is discussed in the draft) I think that it makes some sense to discuss this as a potential IPv4 address-conservation mechanism that doesn't necessarily require NAT. Regarding setup times - assuming that the radio is already active, we're talking about a variant of the DHCPv4 response times for a device with an active IPv6 connection to stand up IPv4, not the time necessary to stand up the radio connection, right?

Also, I think that you'll see carriers re-evaluating their stance on single vs dual PDP contexts as IPv4 addressing constraints become a concern and IPv6-capable UEs become more common and widely deployed, so while I would cite that as a current limiting factor, I certainly wouldn't use that as a reason to exclude that use case and its operational/deployment considerations from the draft. 

Thanks,

Wes

-----Original Message-----
From: jouni korhonen [mailto:[email-masked]] 
Sent: Sunday, September 25, 2011 11:39 AM
To: George, Wes
Cc: [email-masked]
Subject: Re: [v6ops] I-D Action: draft-ietf-v6ops-3gpp-eps-07.txt

Wes,

- JOuni