Subject: [v6ops] 6204bis progress and way forward

From: Fred Baker <[email-masked]>
Date: Fri, 2 Dec 2011 16:32:15 -0800

The following is a problem, a suggestion, and a question.

As you know, I bcc'd a number of folks on an email asking what and when we should do with this. Joel and I got a few over 50 emails in response. I had given a number of possible options: deliver to IESG (Ron) in December 2011, by IETF 83 (March), by IETF 84 (July), in the later half of 2012, or in 2013. I got answers supporting each of those options.

However, there were two predominant views. View (1) says that there is a need to push 6204bis out in December; view (2) says the same but adds that some pet point has to be addressed. Unfortunately, it's very difficult for me to identify a consensus on the pet points - they are themselves all over the map.

Which leaves me with a quandary. The volume of email traffic, both on v6ops@ and on the design team's lists, tells me that we're not done. But at the same time, I see serious scope creep - "we want to wait until 4rd is an RFC" and similar pet projects could take an arbitrary amount of time. I feel that it is necessary to define a scope for the current draft, and provide a game plan for updates to it relating to the various projects.

It seems to me that the best bet would be to define that 6204bis is essentially the document we have now (updating 6204 to include 6rd and ds-lite, and describing a generic CPE router without specific accomodation of Cable, DSL, Fiber, or 3GPP), publish it as updating 6204 (the IPv6-ready logo test depends on elements of both), and let future small memos further update it with respect to their specific interests. If, for example, 3GPP wants to have a document that significantly differs and addresses the tethering mode of a handset, 3GPP can submit one, we can discuss is, and push it through as an appropriate document for 3GPP environments. Which raises interesting questions for LTE.

We may also want to add the word "wireline" to the title to clarify that we are doing this.

What do people think about this approach?

---

From: Lorenzo Colitti <[email-masked]>
Date: Fri, 2 Dec 2011 16:51:22 -0800

On Fri, Dec 2, 2011 at 16:32, Fred Baker <[email-masked]> wrote:

> It seems to me that the best bet would be to define that 6204bis is
> essentially the document we have now (updating 6204 to include 6rd and
> ds-lite, and describing a generic CPE router without specific accomodation
> of Cable, DSL, Fiber, or 3GPP), publish it as updating 6204 (the IPv6-ready
> logo test depends on elements of both), and let future small memos further
> update it with respect to their specific interests.

It seems to me that at the moment there are a couple things that aren't
fully baked yet: transition coexistence (including sunsetting, etc.) and
PCP. Wasn't the consensus in Montreal to proceed only with a small document
containing only updates to WAN-side and LAN-side requirements and nothing
else?

---

From: Fred Baker <[email-masked]>
Date: Fri, 2 Dec 2011 18:06:24 -0800

On Dec 2, 2011, at 4:51 PM, Lorenzo Colitti wrote:

> It seems to me that the best bet would be to define that 6204bis is essentially the document we have now (updating 6204 to include 6rd and ds-lite, and describing a generic CPE router without specific accomodation of Cable, DSL, Fiber, or 3GPP), publish it as updating 6204 (the IPv6-ready logo test depends on elements of both), and let future small memos further update it with respect to their specific interests.
> 
> It seems to me that at the moment there are a couple things that aren't fully baked yet: transition coexistence (including sunsetting, etc.) and PCP. Wasn't the consensus in Montreal to proceed only with a small document containing only updates to WAN-side and LAN-side requirements and nothing else?

Yes, but the discussion since added 6rd and ds-lite. That is required by certain ISPs, and specifically the BBF and Cable Labs, for networks using their technology. In addition, the PCP chairs tell us that draft-ietf-pcp-base is headed to the IESG momentarily as well.

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Sat, 3 Dec 2011 07:10:34 -0600

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Lorenzo Colitti
Sent: Friday, December 02, 2011 7:51 PM
To: Fred Baker (fred)
Cc: [email-masked] WG
Subject: Re: [v6ops] 6204bis progress and way forward

fully baked yet: transition coexistence (including sunsetting, etc.) and
PCP. Wasn't the consensus in >Montreal to proceed only with a small
document containing only updates to WAN-side and LAN-side requirements
and nothing else?

We may want to check the notes and audio from v6ops session in Quebec
City because I heard that the transition tech from rfc6204bis at the
time should move to a shorter new rfc6204bis document and then ship so
that by mid 2012 one could get CPE to support transition tech in RFC
form from 2011.  The two transition tech that have been included in
rfc6204bis for over one year are DS-Lite and 6rd.

Hemant

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Sat, 3 Dec 2011 07:58:24 -0600

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Fred Baker (fred)
Sent: Friday, December 02, 2011 9:06 PM
To: Lorenzo Colitti
Cc: [email-masked] WG
Subject: Re: [v6ops] 6204bis progress and way forward

>Yes, but the discussion since added 6rd and ds-lite. That is required
by certain ISPs, and specifically the BBF and Cable >Labs, for networks
using their technology. In addition, the PCP chairs tell us that
draft-ietf-pcp-base is headed to the >IESG momentarily as well.

Right on PCP.  The plan of record for the rfc6204bis document is to add
a requirement for a PCP client on the CPE router WAN if the PCP base
document heads to the IESG and/or the rfc6204bis document is in the
IESG.  Pending issues for rfc6204bis are outlined below.

1.  6rd sunsetting requirements on the CPE router are close to being
complete.  Will work with MarkT and the design team to close on this one
when MarkT gets back from PTO. 

2.  Coexistence will add details for DS-Lite sunsetting and flush out
any other details in Coexistence.  Text has already been emailed to the
design team and some DS-Lite interested parties.  One of the authors of
the DS-Lite RFC has also worked with myself and Wes to close on the
DS-Lite sunsetting text.  

3.  We have responded to all of MarkT comments and some text (mostly
minor) will change in the document from his comments.

4.  The WPD-7 bullet in the document is not agreeable to some DHC folks
and a discussion has been initiated in the DHC WG.  Please see

     http://www.ietf.org/mail-archive/web/dhcwg/current/msg12188.html

Thanks,

Hemant

---

From: Wuyts Carl <[email-masked]>
Date: Mon, 5 Dec 2011 07:56:27 +0100

Well, if the RFc6204 gets replaced by RFc6204bis, then I'd say it's ok with its current content, targeting global IPv6 and some tunneling (DSLIte and 6RD).  Already dragging along PCP as well to it seems a bit too soon looking today at PCP.

Carl Wuyts
GCD System Architect Networking
Connect Division

[email-masked]<mailto:[email-masked]>
tel.: +32 3 443 65 90
<http://twitter.com/#!/TechnicolorIPv6>
<http://www.technicolor.com/>
Prins Boudewijnlaan 47  -  2650 Edegem  -  Belgium

Technicolor Delivery Technologies Belgium NV
Registered office (maatschappelijke zetel): Prins Boudewijnlaan 47, 2650 Edegem, Belgium
Company registration number (ondernemingsnummer): 0428837295 - RPR Antwerpen

Help preserve the color of our world - Think before you print.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Hemant Singh (shemant)
Sent: zaterdag 3 december 2011 14:58
To: Fred Baker (fred); Lorenzo Colitti
Cc: [email-masked]
Subject: Re: [v6ops] 6204bis progress and way forward

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Fred Baker (fred)
Sent: Friday, December 02, 2011 9:06 PM
To: Lorenzo Colitti
Cc: [email-masked]<mailto:[email-masked]> WG
Subject: Re: [v6ops] 6204bis progress and way forward

>Yes, but the discussion since added 6rd and ds-lite. That is required by certain ISPs, and specifically the BBF and Cable >Labs, for networks using their technology. In addition, the PCP chairs tell us that draft-ietf-pcp-base is headed to the >IESG momentarily as well.

Right on PCP.  The plan of record for the rfc6204bis document is to add a requirement for a PCP client on the CPE router WAN if the PCP base document heads to the IESG and/or the rfc6204bis document is in the IESG.  Pending issues for rfc6204bis are outlined below.

1.  6rd sunsetting requirements on the CPE router are close to being complete.  Will work with MarkT and the design team to close on this one when MarkT gets back from PTO.

2.  Coexistence will add details for DS-Lite sunsetting and flush out any other details in Coexistence.  Text has already been emailed to the design team and some DS-Lite interested parties.  One of the authors of the DS-Lite RFC has also worked with myself and Wes to close on the DS-Lite sunsetting text.

3.  We have responded to all of MarkT comments and some text (mostly minor) will change in the document from his comments.

4.  The WPD-7 bullet in the document is not agreeable to some DHC folks and a discussion has been initiated in the DHC WG.  Please see

Thanks,

Hemant

---

From: Mark Townsley <[email-masked]>
Date: Mon, 5 Dec 2011 14:02:59 +0100

On Dec 3, 2011, at 2:58 PM, Hemant Singh (shemant) wrote:

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Fred Baker (fred)
> 2.  Coexistence will add details for DS-Lite sunsetting and flush out any other details in Coexistence.  Text has already been emailed to the design team and some DS-Lite interested parties.  One of the authors of the DS-Lite RFC has also worked with

You have to rationalize 6rd and native and ds-lite interfaces together. If the "6rd people" just look at the 6rd text and the "ds-lite people" just look at the ds-lite text, you'll end up with significant problems.

> myself and Wes to close on the DS-Lite sunsetting text. 

Please do share this minor text that addresses all my concerns. I haven't seen it, and I can't imagine "only minor" changes unless you are simply dismissing or fundamentally misunderstanding some of the concerns I have tried to express. 

- Mark

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Mon, 5 Dec 2011 08:08:48 -0600

From: Mark Townsley [mailto:[email-masked]] 
Sent: Monday, December 05, 2011 8:03 AM
To: Hemant Singh (shemant)
Cc: Fred Baker (fred); Lorenzo Colitti; [email-masked]
Subject: Re: [v6ops] 6204bis progress and way forward

>You have to rationalize 6rd and native and ds-lite interfaces together.
If the "6rd people" just look at the 6rd text and the "ds-lite people"
just look at the ds-lite text, you'll end >up with significant problems.

The CE router design team has folks in the 6rd and DS-Lite camps.   We
will also send the text for review to v6ops when the design team review
is completed.   

Hemant

---

From: Wes Beebee <[email-masked]>
Date: Mon, 05 Dec 2011 11:11:44 -0500

> You have to rationalize 6rd and native and ds-lite interfaces together. If the
"6rd people" just look at the 6rd text and the "ds-lite people" just look at the
ds-lite text, you'll end up with significant problems.

Which is precisely why we¹re addressing coexistence of both 6rd and ds-lite
in the same document - 6204bis.  Simply having just a ³6rd sunsetting
document² alone is not sufficient to address the problems a CPE router
vendor will face.

- Wes

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Mon, 5 Dec 2011 10:12:32 -0600

>Please do share this minor text that addresses all my concerns. I
haven't seen it, and I can't imagine "only minor" changes unless you are
simply dismissing or fundamentally misunderstanding some of the
>concerns I have tried to express. 

Please see my replies to you review in several emails sent to v6ops.  My
responses do say when I thought your comment was a nit.

Hemant

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 5 Dec 2011 14:21:44 -0500

> In addition, the PCP chairs tell us that draft-
> ietf-pcp-base is headed to the IESG momentarily as well.

If PCP is still being considered for inclusion, I'd really like to see
some recommended text. I don't recall having seen anything, yet, that
provided a complete but concise description of the desired functions, in
requirements format. As discussed previously, a blanket "must support
PCP" is insufficient. I think we left off at a general understanding of
"must support PCP IPv4 client to the WAN" and some UPnP IGD PortMapping
to PCP interworking function. But I really don't know. In the absence of
proposed text, I would assume that PCP is not in.
Barbara

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Mon, 5 Dec 2011 13:45:20 -0600

W-x: The CE router WAN interface SHOULD support a PCP client as
specified in [PCP-base].

Hemant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of STARK, BARBARA H
Sent: Monday, December 05, 2011 2:22 PM
To: Fred Baker (fred); Lorenzo Colitti
Cc: [email-masked]
Subject: Re: [v6ops] 6204bis progress and way forward

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 5 Dec 2011 15:09:29 -0500

> W-x: The CE router WAN interface SHOULD support a PCP client as

Wouldn't this also mean that the CE router would have to support PCP
client for IPv6? Does that make sense? I thought it was only needed for
IPv4.
Barbara

---

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 5 Dec 2011 20:11:45 +0000

It seems to me there is consensus at a fundamental level and that is to
move RFC6204bis forward.  I think we should be careful not to mistake
email volume on subjects that are of interest to individuals as a lack of
consensus.  Further, delaying the progress that several of us are strongly
in favor of because of miscellaneous email volume hardly seems appropriate.

I recommend that we evaluate the email threads and distill these down to
some high level topics that can be prioritized and addressed
systematically over time.

It seems to me that we are in the midst of an email DoS that is delaying
events that the majority desire.

John
=========================================
John Jason Brzozowski
Comcast Cable
e) mailto:[email-masked]
o) 609-377-6594
m) 484-962-0060
w) http://www.comcast6.net
=========================================

On 12/2/11 7:32 PM, "Fred Baker" <[email-masked]> wrote:

>As you know, I bcc'd a number of folks on an email asking what and when
>we should do with this. Joel and I got a few over 50 emails in response.
>I had given a number of possible options: deliver to IESG (Ron) in
>December 2011, by IETF 83 (March), by IETF 84 (July), in the later half
>of 2012, or in 2013. I got answers supporting each of those options.
>
>However, there were two predominant views. View (1) says that there is a
>need to push 6204bis out in December; view (2) says the same but adds
>that some pet point has to be addressed. Unfortunately, it's very
>difficult for me to identify a consensus on the pet points - they are
>themselves all over the map.
>
>Which leaves me with a quandary. The volume of email traffic, both on
>v6ops@ and on the design team's lists, tells me that we're not done. But
>at the same time, I see serious scope creep - "we want to wait until 4rd
>is an RFC" and similar pet projects could take an arbitrary amount of
>time. I feel that it is necessary to define a scope for the current
>draft, and provide a game plan for updates to it relating to the various
>projects.
>
>ds-lite, and describing a generic CPE router without specific
>accomodation of Cable, DSL, Fiber, or 3GPP), publish it as updating 6204
>(the IPv6-ready logo test depends on elements of both), and let future
>small memos further update it with respect to their specific interests.
>If, for example, 3GPP wants to have a document that significantly differs
>and addresses the tethering mode of a handset, 3GPP can submit one, we
>can discuss is, and push it through as an appropriate document for 3GPP
>environments. Which raises interesting questions for LTE.
>

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Mon, 5 Dec 2011 14:24:36 -0600

+1 to John's comments.   Thanks, John.

Hemant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Brzozowski, John
Sent: Monday, December 05, 2011 3:12 PM
To: Fred Baker (fred); [email-masked] WG
Subject: Re: [v6ops] 6204bis progress and way forward

It seems to me there is consensus at a fundamental level and that is to
move RFC6204bis forward.  I think we should be careful not to mistake
email volume on subjects that are of interest to individuals as a lack
of
consensus.  Further, delaying the progress that several of us are
strongly
in favor of because of miscellaneous email volume hardly seems
appropriate.

John

On 12/2/11 7:32 PM, "Fred Baker" <[email-masked]> wrote:

>We may also want to add the word "wireline" to the title to clarify
that
>we are doing this.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 06 Dec 2011 09:34:20 +1300

Please let's see a new draft ASAP, so that we can all look at the
exact diffs. It's the WG that decides, not the DT.

Regards
   Brian

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Mon, 5 Dec 2011 15:44:51 -0600

Brian,

Just posted a new copy.  An email should arrive shortly.

Hemant

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Monday, December 05, 2011 3:34 PM
To: Hemant Singh (shemant)
Cc: Brzozowski, John; Fred Baker (fred); [email-masked]
Subject: Re: [v6ops] 6204bis progress and way forward

Regards
   Brian