Subject: [v6ops] draft-ietf-v6ops-happy-eyeballs

From: Marc Blanchet <[email-masked]>
Date: Wed, 21 Dec 2011 10:16:44 -0500

Hi, from draft-ietf-v6ops-happy-eyeballs:

<quote>
5.3.  Three or More Interfaces

   A dual-stack host normally has two logical interfaces:  an IPv6
   interface and an IPv4 interface.  However, a dual-stack host might
   have more than two logical interfaces because of a VPN (where a third
   interface is the tunnel address, often assigned by the remote
   corporate network) or because of multiple physical interfaces such as
   wired and wireless Ethernet, because the host belongs to multiple
   VLANs, or other reasons.  The interaction of Happy Eyeballs with more
   than two logical interfaces is for further study.
</quote>

I think this text above is underspecified and the problem is much more complex than what is currently written. 
I'm not sure what to write to help, but at least it should reference to the MIF problem statement [RFC6418]. 
There is also a draft about HE and MIF, maybe it should be referenced too?
Maybe some text around this should be added:
<suggested_text_to_add>
In the context of multiple interfaces, or multiple provisioning domains, the algorithm described in this document
might lead to wrong results or failed connections, as some of these issues are described in [RFC6418]. 
Therefore, in the context of multiple interfaces or multiple provisioning domains, additional processing such
as [draft-chen-mif-happy-eyeballs-extension] or else must be implemented to properly handle this situation.
</suggested_text_to_add>

Marc.

---

From: GangChen <[email-masked]>
Date: Fri, 23 Dec 2011 11:58:22 +0800

> There is also a draft about HE and MIF, maybe it should be referenced too?

+1

> properly handle this situation.

We (HE-MIF-extension authors) are targeting to solve the issues in the
context of multiple interfaces. For the suggested text, please allow
me to revise a little.

Since RFC6418 describes some particular issues in the context of
multiple interfaces, or multiple provisioning domains, the algorithm
described in this document is mainly focusing on the context of
single-home. Therefore, in the context of multiple interfaces or
multiple provisioning domains, additional processing such as
[draft-chen-mif-happy-eyeballs-extension] or else must be implemented
to properly handle this situation.

BRs

Gang

---

From: Fred Baker <[email-masked]>
Date: Thu, 22 Dec 2011 23:47:41 -0800

So, what you're saying is that it has multiple addresses, some of which might be IPv4 and some of which might be IPv6, and the number of addresses is independent of the number of physical interface?

On Dec 21, 2011, at 7:16 AM, Marc Blanchet wrote:

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops