Subject: [v6ops] Checking an outcome on the list

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 7 Nov 2013 22:56:58 +0000

We say we check f2f decisions on the mailing list to ensure that everyone had a chance to speak. Let's do that.

In IETF 88, we discussed a number of drafts. Of these:
  - draft-ietf-v6ops-balanced-ipv6-security will start a two week WGLC on Monday morning New Zealand time.
  - draft-ietf-v6ops-nat64-experience appears to have reached closure. We have one additional revision coming, and then will do a 1 week last call, probably early December.
  - draft-liu-bonica-v6ops-dhcpv6-slaac-problem documents what seems to be a real problem. 
      1) In your opinion, should draft-liu-bonica-v6ops-dhcpv6-slaac-problem be adopted as WG draft draft-ietf-v6ops-dhcpv6-slaac-problem and matured into a problem statement to present to 6man?
      2) In your opinion, should v6ops invite a draft (which we might adopt as a working group draft) that gives current guidance to operators regarding the use of DHCP and SLAAC in their networks?
  - Should draft-chen-v6ops-ipv6-roaming-analysis be adopted as WG draft draft-ietf-v6ops-ipv6-roaming-analysis?

I'll collect up the responses in a week and make a determination based on that. I'm interested in your viewpoint, whether positive or negative. If you would prefer to send it privately to [email-masked], that works too.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 08 Nov 2013 12:39:15 +1300

>   - draft-ietf-v6ops-balanced-ipv6-security will start a two week WGLC on Monday morning New Zealand time.

Good choice (of time zone)

>       1) In your opinion, should draft-liu-bonica-v6ops-dhcpv6-slaac-problem be adopted as WG draft draft-ietf-v6ops-dhcpv6-slaac-problem and matured into a problem statement to present to 6man?

Yes

>       2) In your opinion, should v6ops invite a draft (which we might adopt as a working group draft) that gives current guidance to operators regarding the use of DHCP and SLAAC in their networks?

Assuming you mean "based on current specifications and implementations", yes.

>   - Should draft-chen-v6ops-ipv6-roaming-analysis be adopted as WG draft draft-ietf-v6ops-ipv6-roaming-analysis?

No objection.

    Brian

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 8 Nov 2013 02:43:00 +0100 (CET)

>  - draft-ietf-v6ops-balanced-ipv6-security will start a two week WGLC on Monday morning New Zealand time.

Support.

>  - draft-ietf-v6ops-nat64-experience appears to have reached closure. We have one additional revision coming, and then will do a 1 week last call, probably early December.

Support.

>      1) In your opinion, should draft-liu-bonica-v6ops-dhcpv6-slaac-problem be adopted as WG draft draft-ietf-v6ops-dhcpv6-slaac-problem and matured into a problem statement to present to 6man?

Yes.

>      2) In your opinion, should v6ops invite a draft (which we might adopt as a working group draft) that gives current guidance to operators regarding the use of DHCP and SLAAC in their networks?

Yes.

>  - Should draft-chen-v6ops-ipv6-roaming-analysis be adopted as WG draft draft-ietf-v6ops-ipv6-roaming-analysis?

Yes.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Cong Liu <[email-masked]>
Date: Thu, 7 Nov 2013 18:15:05 -0800

Hi all,

2013/11/7 Fred Baker (fred) <[email-masked]>

> Monday morning New Zealand time.
I support

>   - draft-ietf-v6ops-nat64-experience appears to have reached closure. We
> have one additional revision coming, and then will do a 1 week last call,
> probably early December.
>
I support

>       1) In your opinion, should
> draft-liu-bonica-v6ops-dhcpv6-slaac-problem be adopted as WG draft
> draft-ietf-v6ops-dhcpv6-slaac-problem and matured into a problem statement
> to present to 6man?
>
Yes

>       2) In your opinion, should v6ops invite a draft (which we might
> adopt as a working group draft) that gives current guidance to operators
> regarding the use of DHCP and SLAAC in their networks?
>
Yes

Yes

>
> I'll collect up the responses in a week and make a determination based on
> that. I'm interested in your viewpoint, whether positive or negative. If
> you would prefer to send it privately to [email-masked],
> that works too.
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>
>
Best Regards,
Cong

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 8 Nov 2013 17:54:46 +0000

________________________________________
From: [email-masked] [[email-masked]] on behalf of Fred Baker (fred) [[email-masked]]
Sent: 08 November 2013 6:56
To: [email-masked] WG
Subject: [v6ops] Checking an outcome on the list

<Sheng> Support for advancing.

<Sheng> Support for advancing. I was one of volunteer reviewer from last meeting. The current version has addressed my comments. In general, I think the document is mature for next stage.

<Sheng> Yes. The stand-alone problem document is also worth of publishing as a RFC. Then the guidance document below can refer to it without having to rediscribe the issues again.

<Sheng> Yes.

<Sheng> Yes. This document is quite helpful.

Regards,

Sheng

---

From: Alexandru Petrescu <[email-masked]>
Date: Sat, 09 Nov 2013 11:50:45 +0100

Le 07/11/2013 23:56, Fred Baker (fred) a écrit :
> We say we check f2f decisions on the mailing list to ensure that
> everyone had a chance to speak. Let's do that.
>
[...]
> - Should draft-chen-v6ops-ipv6-roaming-analysis be adopted as WG
> draft draft-ietf-v6ops-ipv6-roaming-analysis?

I support adoption of this draft.

I just looked at it in some detail.

I think it deserves enumerating a few practical use-cases where IPv6
roaming occurs, including extremes like changing operator in same place,
or through same operator but crossing a national border.

I also wonder about which cellular technology is involved in this
roaming: 3G, 4G, or CDMA.

And to expose that - just like in IPv4 - ongoing IPv6 sessions are
breaking upon roaming.

Alex

>
> I'll collect up the responses in a week and make a determination
> based on that. I'm interested in your viewpoint, whether positive or
> negative. If you would prefer to send it privately to
> [email-masked], that works too.
>
>
>
> _______________________________________________ v6ops mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Hui Deng <[email-masked]>
Date: Tue, 12 Nov 2013 08:39:36 +0800

Hi Alex,

I may mis removed v6ops during my last reply, here I add again.

I tried before, which does roam across couple of GGSNs area without broken.

I guess that your geting lost of the continuity might because that your
mobile coverage is not very good, after you drive into or train run into
some no coverage area, then you need to reconnect with your data
connection. this is quite usual case in USA and EU, but not in Asia because
of density living area.

thanks for the discussion

DENG Hui

2013/11/11 Alexandru Petrescu <[email-masked]>

> Hui,
>
> Thanks for the reply.
>
>
> Le 10/11/2013 23:25, Hui Deng a écrit :
>
>> Alex, I guess that I am not clear in the last email. Home routed
>>
>> means that there is home GGSN (kind of anchor point),
>>
>
> ok.
>
>
>  wherever you go, the address is always the same if you keep visiting
>> the internet, local/visiting SGSN will always tunnel your traffic
>> back to the home GGSN,
>>
>
> Ok, in principle, by specification.
>
>
>  then your session won't break.
>>
>
> But has one tried it in practice?
>
> I have tried it, and the sessions do seem to break when roaming: train
> and car roaming.
>
>
>  In the case you turn off your mobile (such as flight to another
>> country), after you landed, your phone will get IP address from your
>>  home GGSN as well, wherever you go in the visiting country, every
>> SGSN in the visiting country will always tunnel your traffic back to
>> your home GGSN, then your session won't break as well.
>>
>
> I may agree that the network will tunnel back traffic to home operator.
>
> And I agree that in the plane roaming case, after switching the
> smartphone on/off/on, a new address will be acquired and thus sessions
> would break.
>
> On another hand, in the train or car roaming case, when the smartphone
> is _not_ turned off, the sessions still do break upon changing from one
> country to another.
>
> How about trying it and reporting?
>
> Also, I think this discussion is worth discussing publicly.  I am sorry
> if I may make statements that may sound too direct.
>
> Alex
>
>  thanks for your discussion Best regards, DENG Hui
>>
>>
>> 2013/11/10 Alexandru Petrescu <[email-masked]
>> <mailto:[email-masked]>>
>>
>>
>> Hui,
>>
>> Thanks for the email.
>>
>> Le 10/11/2013 14:32, Hui Deng a écrit :
>>
>> Alex, thanks for your discussion in the list. Inline please, "==>"
>>
>>
>> 2013/11/9 Alexandru Petrescu <[email-masked]
>> <mailto:[email-masked]>
>> <mailto:[email-masked]
>>
>> <mailto:[email-masked]>>>
>>
>>
>> - Should draft-chen-v6ops-ipv6-roaming-____analysis be adopted as WG
>> draft draft-ietf-v6ops-ipv6-roaming-____analysis?
>>
>>
>>
>>
>> roaming occurs, including extremes like changing operator in same
>> place, or through same operator but crossing a national border.
>>
>> ==> Mobile communication whatever 3G,4G/CDMA could support session
>> continuity if you really drive the car country by country. because
>> it always home routed.(GGSN,PDSN,PDN GW)
>>
>>
>> Even if it is 'home'-routed I think communications break.  (your use
>> of the term 'home' is different than the 'Home Agent', I think).
>>
>> But I noticed when I am in a train and switch country the IP address
>> of the mobile changes.  I have no Mobile IP in that mobile, so I have
>> to restart the ongoing google maps, or the ongoing youtube.
>>
>> Even if I had Mobile IP software in the mobile terminal, I don't know
>> what is the Home Agent address in the cellular operator network?
>> Actually I suppose not any operator offers Home Agent address.
>>
>> In the roaming discussion there are at least two different cases: - I
>> stay attached to home operator because that home operator is present
>> in the visited country as well. - or I am offered the choice to
>> switch to one in a list of different operators in that new country.
>>
>> For both these cases I think the IP address of the Mobile Terminal
>> changes.
>>
>>
>> ==> As said in the above both IPv4 and IPv6 don't have signanificant
>> issue about roaming
>>
>>
>> It seems to me, Hui, you didnt try it.  There doesnt seem to be
>> experimentatin behind this...
>>
>>
>> This draft discussed several different cases like v4v6 pdp support
>> in the roaming country et al. if every deployed mobile
>> gateway/handset can support the latest version, then that won't be
>> any issue.
>>
>>
>> Does the latest version require the terminal to use Mobile IP
>> software?
>>
>> Thanks,
>>
>> Alex
>>
>> Best regards, DENG Hui
>>
>>
>> Alex
>>
>>
>> [email-masked] <mailto:[email-masked]>
>> <mailto:[email-masked]
>>
>> <mailto:[email-masked]>>, that works too.
>>
>>
>>
>> ___________________________________________________ v6ops mailing
>> list [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>> <mailto:[email-masked]>>
>> https://www.ietf.org/mailman/____listinfo/v6ops
>> <https://www.ietf.org/mailman/__listinfo/v6ops>
>> <https://www.ietf.org/mailman/__listinfo/v6ops
>> <https://www.ietf.org/mailman/listinfo/v6ops>>
>>
>>
>>
>> ___________________________________________________ v6ops mailing
>> list [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>> <mailto:[email-masked]>>
>> https://www.ietf.org/mailman/____listinfo/v6ops
>> <https://www.ietf.org/mailman/__listinfo/v6ops>
>> <https://www.ietf.org/mailman/__listinfo/v6ops
>> <https://www.ietf.org/mailman/listinfo/v6ops>>
>>
>>
>>
>>
>>
>>
>
>

---

From: Ida Leung <[email-masked]>
Date: Mon, 11 Nov 2013 20:17:16 -0500

Response to your questions:

1/ I agreed this approach for the draft.

2/
 draft-chen-v6ops-ipv6-roaming-analysis should be adopted as WG draft.
 That helps the mobile operators to realize the problem they are facing and
together to find a way to fix it/workaround it.  We have been facing some
of the roaming issues mentioned in the draft.

Thanks,

...Ida

...Ida

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 12 Nov 2013 12:06:10 +0100

Hello Hui,

Le 12/11/2013 01:39, Hui Deng a écrit :
> Hi Alex, I may mis removed v6ops during my last reply, here I add
> again. I tried before, which does roam across couple of GGSNs area
> without broken.

In that experimentation, were the GGSNs belonging to the same operator,
or to different operators?

Did the terminal keep the same IPv6 address?

> I guess that your geting lost of the continuity might because that
> your mobile coverage is not very good,

Well, it is not that simple.  In one particular IPv4 trial the train
line is covered by several cellular networks, even when crossing
national border.

> after you drive into or train run into some no coverage area, then
> you need to reconnect with your data connection. this is quite usual
>  case in USA and EU, but not in Asia because of density living area.

I am not sure what you mean, but in EU many areas are well populated.

I have tried to roam with the IPv6 connection of a particular cellular
operator, by going from one country to another, and by switching on and
off the handset during travel: either imposed by flight procedures, or
because not enough battery.  In principle, the IPv6 roaming works fine
in several countries in the EU.

It all depends what we call 'roaming'.

What I have not tried is the following two scenarios:
- roam IPv6 from one country to the next, keeping same IPv6 operator,
   without switching off the handset.  Note whether or not the ongoing
   applications break at handover.  Maybe by car or by train.
- roam IPv6 from one IPv6 operator to another IPv6 operator, without
   switching off the handset.  Maybe not being mobile at all.

They can easily be tried.

Intuitively, I would say that applications get interrupted, because
there would be change in the IPv6 address allocated to the smartphone.

I may be wrong though.

Alex

> thanks for the discussion DENG Hui
>
>
> 2013/11/11 Alexandru Petrescu <[email-masked]
> I have tried it, and the sessions do seem to break when roaming:
> train and car roaming.
>
>
> smartphone on/off/on, a new address will be acquired and thus
> sessions would break.
>
> On another hand, in the train or car roaming case, when the
> smartphone is _not_ turned off, the sessions still do break upon
> changing from one country to another.
>
> Also, I think this discussion is worth discussing publicly.  I am
> sorry if I may make statements that may sound too direct.
>
> Alex
>
> <mailto:[email-masked]>> <mailto:alexandru.petrescu@
> <mailto:alexandru.petrescu@>__g__mail.com <http://gmail.com>
>
> <mailto:[email-masked]>>>>
>
>
> - Should draft-chen-v6ops-ipv6-roaming-______analysis be adopted as
> WG draft draft-ietf-v6ops-ipv6-roaming-______analysis?
>
>
>
>
> continuity if you really drive the car country by country. because it
> always home routed.(GGSN,PDSN,PDN GW)
>
>
> Even if I had Mobile IP software in the mobile terminal, I don't
> know what is the Home Agent address in the cellular operator
> network? Actually I suppose not any operator offers Home Agent
> address.
>
> In the roaming discussion there are at least two different cases: -
> I stay attached to home operator because that home operator is
> present in the visited country as well. - or I am offered the choice
> to switch to one in a list of different operators in that new
> country.
>
> This draft discussed several different cases like v4v6 pdp support in
> the roaming country et al. if every deployed mobile gateway/handset
> can support the latest version, then that won't be any issue.
>
>
> <mailto:[email-masked]>> <mailto:v6ops-chairs@tools.
> <mailto:v6ops-chairs@tools.>__i__etf.org <http://ietf.org>
>
> <mailto:[email-masked]>>>, that works too.
>
>
>
> _____________________________________________________ v6ops mailing
> <mailto:[email-masked]>> <mailto:[email-masked]
> <mailto:[email-masked]> <mailto:[email-masked]
> <mailto:[email-masked]>>>
> https://www.ietf.org/mailman/______listinfo/v6ops
> <https://www.ietf.org/mailman/____listinfo/v6ops>
> <https://www.ietf.org/mailman/____listinfo/v6ops
> <https://www.ietf.org/mailman/__listinfo/v6ops>>
> <https://www.ietf.org/mailman/____listinfo/v6ops
> <https://www.ietf.org/mailman/listinfo/v6ops>>>
>
>
>
> _____________________________________________________ v6ops mailing
> <mailto:[email-masked]>> <mailto:[email-masked]
> <mailto:[email-masked]> <mailto:[email-masked]
> <mailto:[email-masked]>>>
> https://www.ietf.org/mailman/______listinfo/v6ops
> <https://www.ietf.org/mailman/____listinfo/v6ops>
> <https://www.ietf.org/mailman/____listinfo/v6ops
> <https://www.ietf.org/mailman/__listinfo/v6ops>>
> <https://www.ietf.org/mailman/____listinfo/v6ops
> <https://www.ietf.org/mailman/listinfo/v6ops>>>
>
>
>
>
>
>
>
>

---

From: Tore Anderson <[email-masked]>
Date: Wed, 13 Nov 2013 08:21:19 +0100

* Alexandru Petrescu

> there would be change in the IPv6 address allocated to the smartphone.

I have experience with your second case above: When I roam from one
operator to another within Norway, my IPv6 address does not change, and
any existing connections do not get interrupted. Layer 3 appears to be
completely unaware that roaming occurs.

Next time I drive across the border to Sweden I'll test your first case
too. It would surprise me if the behaviour was any different though.

Tore