Subject: Re: [v6ops] DHCPv6/SLAAC Make Hosts Confusing-//RE: new draft: draft-liu-bonica-v6ops-dhcpv6-slaac-problem

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Oct 2013 08:07:33 -0400

On Oct 30, 2013, at 4:22 AM, Mark ZZZ Smith <[email-masked]> wrote:
> I think DHCPv6 is really solving the application layer configuration problem, which is independent of and not specific to the underlying links and network layer parameters.

Actually DHCPv6 is a poor solution to that problem, because application configuration is not typically network-specific.  This has been discussed at some length recently on the IETF mailing list.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Oct 2013 17:23:55 -0400

On Oct 30, 2013, at 4:06 PM, Mark ZZZ Smith <[email-masked]> wrote:
> I have recently been thinking a bit more about that in the context of the DHCPv6 option transparency draft I posted, and have started to wonder if LDAP or SLP style directories would be better, with a special well known directory branch to represent network or subnet local application parameters.

No, that's not the issue at all.  The issue is that there is typically nothing the local network can tell you about, e.g., which SMTP server will work with your email address, or which POP or IMAP server might store your email.   In the general case, those services are not even present on the local network, so the local network has no way to tell you about them, and even if it did, why would you trust it to do so?