Subject: Re: [v6ops] new draft: draft-v6ops-pmtud-ecmp-problem

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 1 Sep 2014 18:56:08 +0000

On Aug 25, 2014, at 4:47 AM, [email-masked] wrote:

> A new draft has been posted, at http://datatracker.ietf.org/doc/draft-v6ops-pmtud-ecmp-problem/. Please take a look at it and comment.

As noted, there’s a draft. We have, for the past week or so, had a discussion in the thread “PMTUD problem”.

Question for the masses: what do we want to do with this draft? At IETF 90, we discussed adopting an updated version as a working group draft. Do we want to do that? 

More importantly, what outcome do we want. Does it need to become an RFC as operational viewpoint or procedure? Do we want to make recommendations to tcpm, 6man, or someone else, and specifically what recommendations?

---

From: Ray Hunter <[email-masked]>
Date: Tue, 02 Sep 2014 10:54:38 +0200

> More importantly, what outcome do we want. Does it need to become an RFC as operational viewpoint or procedure? Do we want to make recommendations to tcpm, 6man, or someone else, and specifically w…
I've read the draft.

I think the more generic problem statement is "Using ICMPv6 PTB 
signaling for path MTU discovery is currently unreliable" together with 
the related problem "fragmentation doesn't work even if the IPv6 stack 
knows the path MTU "

Whether that be due to:
-bad implementations
-ECMP
-filters
-tunnels
.....

The result is a global clamp of 1280 octets. And individual applications 
that have to perform their own application layer message fragmentation.

Would a draft summarizing the ICMP PTB problem, investigating potential 
alternative sources of path MTU information, and alternative signaling 
mechanisms for path MTU, fit within v6ops remit?

The (lack of) support for fragmentation already seems to be well known.

-- 
Regards,
RayH

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 2 Sep 2014 23:55:00 +0000

On Sep 2, 2014, at 6:54 PM, Ray Hunter <[email-masked]> wrote:

> Would a draft summarizing the ICMP PTB problem, investigating potential alternative sources of path MTU information, and alternative signaling mechanisms for path MTU, fit within v6ops remit?

I think this draft is trying to be that. What would definitely be within our remit would be operational advice, as in "advice from operators to operators", and advice to other working groups of the form "X needs to be improved, we like Y, but it has problems {Z}". What would be outside our remit would be changes to protocols.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 03 Sep 2014 13:16:07 +1200

BTW the draft name is a bit schlonky. Isn't there supposed
to be an -ietf in there?

   Brian

On 03/09/2014 11:55, Fred Baker (fred) wrote:
> ------------------------------------------------------------------------
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 3 Sep 2014 01:39:30 +0000

On Sep 3, 2014, at 11:16 AM, Brian E Carpenter <[email-masked]> wrote:

> BTW the draft name is a bit schlonky. Isn't there supposed to be an -ietf in there?

Well, only after we have seen fit to make it a working group draft; I would expect a ‘-jaeggli’ in the corresponding position. Our beloved AD seems to have difficulties reproducing names that IETF tools recognize, and in counting. The history of its name is:

-rw-r--r--  1 fred  admin  11001 Feb 15  2014 draft-v6ops-jaeggli-pmtud-ecmp-problem-00.txt
-rw-r--r--  1 fred  admin  13661 Mar  5  2014 draft-v6ops-jaeggli-pmtud-ecmp-problem-01.txt
-rw-r--r--  1 fred  admin  13590 Jun  2 17:26 draft-jaeggli-v6ops-pmtud-ecmp-problem-00.txt
-rw-rw-r--  1 fred  admin  14643 Jul  4 02:51 draft-jaeggli-v6ops-pmtud-ecmp-problem-01.txt
-rw-r--r--  1 fred  admin  15293 Aug 25 09:22 draft-v6ops-pmtud-ecmp-problem-00.txt

---

From: joel jaeggli <[email-masked]>
Date: Tue, 02 Sep 2014 18:45:29 -0700

>> BTW the draft name is a bit schlonky. Isn't there supposed to be an -ietf in there?

I was asked to change the name after the presentation so I interpreted
that a inv9tationtion to do so.

in practice I tend to be guided by the metadata in the tracker and not
by the unstructured string that is the filename. that said at some point
I was bit sloppy.