Subject: [v6ops] As promised...

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 23 Jul 2015 13:10:12 +0000

https://tools.ietf.org/html/draft-ietf-v6ops-reducing-ra-energy-consumption
  "Reducing energy consumption of Router Advertisements", Andrew
  Yourtchenko, Lorenzo Colitti, 2015-07-23,

We had quite a bit of discussion Tuesday, especially considering the length (or brevity) of this draft.

I'd suggest you read it. Especially given the number of "+2" comments on the list, I tend to think we can come to consensus relatively quickly on it. If there are lingering issues, let's get them out of the way.

---

From: Francisco Paletta <[email-masked]>
Date: Thu, 23 Jul 2015 14:39:34 -0300

Hello,

I believe it's a good "best practice".

I just have suggestions regarding the "3. Consequences" points 2 and 3.
Despite the fact that frequent RA messages are causing those consequences,
they should not be used as base to support this recommendation.

In my opinion, the frequency or broadness of RA messages should not cause a
device to disrupt it's communication. The device must deal with it another
way. Obviously they can benefit from the changes in RA messages behaviors.
But should not be the motivation.

Nevertheless I agree that once the device receives an information and have
to deal with it, it spends power on that process and we should control that
to favor battery-powered devices.

Regards,

Francisco Paletta

2015-07-23 10:10 GMT-03:00 Fred Baker (fred) <[email-masked]>:

> I'd suggest you read it. Especially given the number of "+2" comments on
> the list, I tend to think we can come to consensus relatively quickly on
> it. If there are lingering issues, let's get them out of the way.
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>
>

---

From: Jason Fesler <[email-masked]>
Date: Thu, 23 Jul 2015 14:50:04 -0700

> I believe it's a good "best practice".

+1.   We use unicast responses at $dayjob, across a variety of
devices, and see no harmful effects. It has helped keep
multicast/broadcast volume over the radio down to manageable levels;
and as a side effect, helped with keeping people's pocket phones from
catching fire.

---

From: Owen DeLong <[email-masked]>
Date: Thu, 23 Jul 2015 19:26:22 -0700

That’s sort of akin to saying “DDoS must not disrupt a device’s normal operation”.

If you flood a link with traffic, stuff’s going to break.

There are scenarios where multicast traffic can get out of control, including RA and related.

Reducing the number of multicast RAs to those periodic ones necessary to refresh timers of every host on the link just makes sense.

As such, I think the consequences are perfectly valid justification in addition to the other points raised.

Owen

> On Jul 23, 2015, at 10:39 , Francisco Paletta <[email-masked]> wrote:
> 
> Hello,
> 
> I just have suggestions regarding the "3. Consequences" points 2 and 3. Despite the fact that frequent RA messages are causing those consequences, they should not be used as base to support this recommendation.
> 
> In my opinion, the frequency or broadness of RA messages should not cause a device to disrupt it's communication. The device must deal with it another way. Obviously they can benefit from the changes in RA messages behaviors. But should not be the motivation.
> 
> Nevertheless I agree that once the device receives an information and have to deal with it, it spends power on that process and we should control that to favor battery-powered devices.
> 
> Regards,
> 
> Francisco Paletta
> 
> 
> 2015-07-23 10:10 GMT-03:00 Fred Baker (fred) <[email-masked] <mailto:[email-masked]>>:
> https://tools.ietf.org/html/draft-ietf-v6ops-reducing-ra-energy-consumption <https://tools.ietf.org/html/draft-ietf-v6ops-reducing-ra-energy-consumption>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/v6ops <https://www.ietf.org/mailman/listinfo/v6ops>
> 
>

---

From: Francisco Paletta <[email-masked]>
Date: Fri, 24 Jul 2015 00:05:52 -0300

I'm not saying I don't support the recommendation in this draft. I
acknowledge all the benefits.

I'm just saying that the motivation should not be the issues presented on
the references [1] and [2] on the doc. We can change configurations on the
routers and achieve best scenario for devices but we cannot guarantee that
in all cases, and therefore the devices need to be able to handle heavy
traffic and avoid situations like the ones referenced (normal scenarios).

Using a metaphor to compare, this is like asking to reduce a speed limit on
a road because drivers don't use safety belt. Of course there are many
safety reasons to slow down traffic speed, but should not be because people
don't want to buckle up...

Francisco

2015-07-23 23:26 GMT-03:00 Owen DeLong <[email-masked]>:

> Reducing the number of multicast RAs to those periodic ones necessary to
> refresh timers of every host on the link just makes sense.
>
> In my opinion, the frequency or broadness of RA messages should not cause
> a device to disrupt it's communication. The device must deal with it
> another way. Obviously they can benefit from the changes in RA messages
> behaviors. But should not be the motivation.
>