Subject: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 14 Nov 2016 14:08:54 +0900

I think this can be also useful in data-centre scenarios (hosting/housing, etc.).

It will be nice to include some text (abstract, intro, may be somewhere else) to made it clear that scenario.

I’m happy to write down some specific changes if you like.

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Tim Chown <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 14 de noviembre de 2016, 13:44
Para: v6ops list <[email-masked]>
Asunto: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

    Hi,
    
    I like the draft. 
    
    Some generally very minor comments:
    
    - Move the ‘Benefits..’ sentence to the end of the abstract.
    
    - "at current time there is a non-trivial UE/subscriber base not supporting DHCPv6 IA_NA” - well, there’s another way to fix that, but… :)  
    
    - s/his/their
    
    - In section 4 you say the UE SHOULD NOT perform stateful DHCP.  What happens if it does? (draft-ietf-v6ops-dhcpv6-slaac-problem-07 discusses such issues)
    
    - RFC 6343, 6180, 6106 and I-D.ietf-v6ops-v4v6tran-framework are in the references, but not the text.
    
    Best wishes,
    Tim 

    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: "Brzozowski, John" <[email-masked]>
Date: Mon, 14 Nov 2016 11:40:03 +0000

Jordi,

I would be willing to consider this, so please feel free to send some text for us to consider.  However, in the spirit keeping things based on reality I hesitate to go too far down the DC path, mainly because this has not deployed in this context to date.  So I propose we limited, high-level references to other possible deployment uses cases.  In the future we may very well be able to point to other I-Ds like the one below:

https://tools.ietf.org/html/draft-pioxfolks-6man-pio-exclusive-bit-01

Thanks for the review and the offer to write some text.

John
+1-484-962-0060

-----Original Message-----
From: v6ops <[email-masked]> on behalf of JORDI MARTINEZ <[email-masked]>
Reply-To: JORDI MARTINEZ <[email-masked]>
Date: Monday, November 14, 2016 at 14:08
To: v6ops <[email-masked]>
Subject: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

    
    
    Regards,
    Jordi

    -----Mensaje original-----
    De: v6ops <[email-masked]> en nombre de Tim Chown <[email-masked]>
    Responder a: <[email-masked]>
    Fecha: lunes, 14 de noviembre de 2016, 13:44
    Para: v6ops list <[email-masked]>
    Asunto: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01
    
        Hi,
        
        I like the draft. 

        
        
        - s/his/their

        
        Best wishes,
        Tim

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 14 Nov 2016 21:50:49 +0900

Ok, trying not to change too much, minimalistic approach just to note that the same procedure works for a data centre:

1. Abstract
Replace “shared network, like Wi-Fi or Ethernet” with “shared network, either wired or wireless, such as Ethernet, WiFi, etc.”
2. Introduction.
After the 1st paragraph, add a new one short one to clarify what UE means here.
	In the context of this document, UE can be a “regular” end-user-equipment, as well as a server in a datacentre, assuming a shared network (wired or wireless).

3. Section 5 (IPv6 Neighbourship Discovery Best Practices), I believe the actual text “the applicable MaxRtrAdvInterval on the WLAN-GW MUST therefore be lower than the preferred lifetime”, WLAN-GW is referring to the first hop router, maybe from a previous text considering only WiFi? If that’s the case, then I will suggest this alternative:
“the applicable MaxRtrAdvInterval on the first hop router MUST therefore be lower than the preferred lifetime”

4. Section 5 (IPv6 Neighbourship Discovery Best Practices), “ … removed from the First Hop Router to avoid ongoing resource depletion”, replace with “… removed from the First Hop Router to avoid ongoing resource depletion in the case of non-permanent UE, such as in the case of WiFi hotspots”.

5. Section 5 (IPv6 Neighbourship Discovery Best Practices), after “temporary 'private' addresses.”, add this sentence:

“Similarly, when using this technology in a datacentre, the UE server may need to use several addresses from the same /64, for example because is using multiple virtual hosts, containers, etc. in the bridged virtual switch.” … then keep going with existing text “This can lead to …”

6. Section 5 (IPv6 Neighbourship Discovery Best Practices), type … ”The First Hop Provder” replace with “The First Hop Provider”. Also note the duplicated reference to RFC4941 before this text.

Note that 1, 3 and 6, are also an input to the actual text, even in the case you don’t want to consider the data centre thing, just to make sure to clarify that is valid in other shared technologies and not just in WiFi or Ethernet …

Regards,
Jordi

-----Mensaje original-----
De: "Brzozowski, John" <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 14 de noviembre de 2016, 20:40
Para: "[email-masked]" <[email-masked]>, v6ops list <[email-masked]>
Asunto: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

    Jordi,

    
    
    John
    +1-484-962-0060
    
    -----Original Message-----
    From: v6ops <[email-masked]> on behalf of JORDI MARTINEZ <[email-masked]>
    Reply-To: JORDI MARTINEZ <[email-masked]>
    Date: Monday, November 14, 2016 at 14:08
    To: v6ops <[email-masked]>
    Subject: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

        
        
        Regards,
        Jordi

        -----Mensaje original-----
        De: v6ops <[email-masked]> en nombre de Tim Chown <[email-masked]>
        Responder a: <[email-masked]>
        Fecha: lunes, 14 de noviembre de 2016, 13:44
        Para: v6ops list <[email-masked]>
        Asunto: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01
        
            Hi,
            
            I like the draft. 

            
            
            - s/his/their

            
            Best wishes,
            Tim

---

From: Hemant Singh <[email-masked]>
Date: Mon, 14 Nov 2016 08:36:24 -0500

On Mon, Nov 14, 2016 at 7:50 AM, JORDI PALET MARTINEZ <
[email-masked]> wrote:

>
> >Note that 1, 3 and 6, are also an input to the actual text, even in the
> case you don’t want to consider the data centre thing, just to make sure to
> clarify that is valid in other shared technologies and not >just in WiFi or
> Ethernet …
>
>
> I hear John as considering Comcast Xfinity wifi for the document.  I agree
to clarify that the document covers only such a specific wifi network.  We
should not add the kitchen sink to the document.  After all, even cable
broadband and cellular wireless use a shared medium, it's not just the data
center,  Where do we stop?

Hemant

---

From: Tim Chown <[email-masked]>
Date: Mon, 14 Nov 2016 16:00:35 +0000

On 14 Nov 2016, at 13:36, Hemant Singh <[email-masked]<mailto:[email-masked]>> wrote:

On Mon, Nov 14, 2016 at 7:50 AM, JORDI PALET MARTINEZ <[email-masked]<mailto:[email-masked]>> wrote:

>Note that 1, 3 and 6, are also an input to the actual text, even in the case you don’t want to consider the data centre thing, just to make sure to clarify that is valid in other shared technologies and not >just in WiFi or Ethernet …

I hear John as considering Comcast Xfinity wifi for the document.  I agree to clarify that the document covers only such a specific wifi network.  We should not add the kitchen sink to the document.  After all, even cable broadband and cellular wireless use a shared medium, it's not just the data center,  Where do we stop?

I agree here. I think it’s best to be as specific as possible in the document and put it out there as a BCP.  Hence my earlier suggestion to tighten up the abstract to be more specific (that RA-based prefix configuration is used, etc).  Nothing then precludes DHCP-PD being used elsewhere or in the future.

Overall the draft is great - it describes an innovative deployment well.  It just needs some editorial polish and it’s good to go.

Tim

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 15 Nov 2016 04:16:54 +0900

Responding to both Hemant and Tim …

I will agree with what you say if what I’m suggesting requires many changes in the actual text, but is not the case. They are minor clarifications that accommodates something with clearly happens in both scenarios. At the end the existing document already mentions Ethernet, so, we are not broadening the original scope, just making it more explicit.

I think we need to balance (and not just for this document), when we can apply something with minor wording to two well defined cases, among having just one document instead of having to different documents, saying the same, one for the WiFi case, one for the shared Ethernet.

It doesn’t make any sense for the IETF to have “more” documents in those cases. What we do afterwards, make a copy of the document and replace WiFi with Ethernet, so we ask the possible targets of this work to read the same document twice?

By the way, I also understood from John, that a specific document with the WiFi roll-out will follow … So more specific details about that will be there.

Regards,
Jordi

-----Mensaje original-----
De: Tim Chown <[email-masked]>
Responder a: <[email-masked]>
Fecha: martes, 15 de noviembre de 2016, 1:00
Para: Hemant Singh <[email-masked]>, v6ops list <[email-masked]>
CC: Jordi Palet Martinez <[email-masked]>
Asunto: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

    On 14 Nov 2016, at 13:36, Hemant Singh <[email-masked]> wrote:

    >Note that 1, 3 and 6, are also an input to the actual text, even in the case you don’t want to consider the data centre thing, just to make sure to clarify that is valid in other shared technolo…

    I hear John as considering Comcast Xfinity wifi for the document.  I agree to clarify that the document covers only such a specific wifi network.  We should not add the kitchen sink to the document.  After all, even cable broadband and cellular
     wireless use a shared medium, it's not just the data center,  Where do we stop?

    

    I agree here. I think it’s best to be as specific as possible in the document and put it out there as a BCP.  Hence my earlier suggestion to tighten up the abstract to be more specific (that RA-based prefix configuration is used, etc).  Nothing then precludes
     DHCP-PD being used elsewhere or in the future.

    Tim

---

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 15 Nov 2016 01:47:42 +0000

Thank you Jordi for the quick turnaround, will take a look and circle back via email.

John
+1-484-962-0060

-----Original Message-----
From: v6ops <[email-masked]> on behalf of JORDI MARTINEZ <[email-masked]>
Reply-To: JORDI MARTINEZ <[email-masked]>
Date: Monday, November 14, 2016 at 21:50
To: v6ops <[email-masked]>
Subject: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

    1. Abstract

    

    
    
    Regards,
    Jordi

    -----Mensaje original-----
    De: "Brzozowski, John" <[email-masked]>
    Responder a: <[email-masked]>
    Fecha: lunes, 14 de noviembre de 2016, 20:40
    Para: "[email-masked]" <[email-masked]>, v6ops list <[email-masked]>
    Asunto: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01
    
        Jordi,

        
        
        John
        +1-484-962-0060
        
        -----Original Message-----
        From: v6ops <[email-masked]> on behalf of JORDI MARTINEZ <[email-masked]>
        Reply-To: JORDI MARTINEZ <[email-masked]>
        Date: Monday, November 14, 2016 at 14:08
        To: v6ops <[email-masked]>
        Subject: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

            
            
            Regards,
            Jordi

            -----Mensaje original-----
            
                Hi,
                
                I like the draft. 

                
                
                - s/his/their

                
                Best wishes,
                Tim

---

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 15 Nov 2016 04:45:21 +0000

Jordi,

I am willing to consider the inclusion of additional text (probably in the abstract) that outlines additional use cases where this approach may be applicable.  However, without real deployment experience I hesitate add too much additional text relating to these other use cases.

Regarding your last sentence below, there are no additional drafts planned that describe our deployment of IPv6 for Wi-Fi.  I apologize if I seemed to indicate otherwise.

John
+1-484-962-0060

-----Original Message-----
From: v6ops <[email-masked]> on behalf of JORDI MARTINEZ <[email-masked]>
Reply-To: JORDI MARTINEZ <[email-masked]>
Date: Tuesday, November 15, 2016 at 04:16
To: v6ops <[email-masked]>
Subject: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

    

    
    Regards,
    Jordi

    -----Mensaje original-----
    De: Tim Chown <[email-masked]>
    Responder a: <[email-masked]>
    Fecha: martes, 15 de noviembre de 2016, 1:00
    Para: Hemant Singh <[email-masked]>, v6ops list <[email-masked]>
    CC: Jordi Palet Martinez <[email-masked]>
    Asunto: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

        

        

        

        Tim

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 15 Nov 2016 13:56:17 +0900

I saw now from where it comes the idea about your deployment draft. It is in the draft:

6.  Future work

   o  Informational draft regarding WLAN IPv6 Deployment technology
      experiences roll-out

Regards,
Jordi

-----Mensaje original-----
De: "Brzozowski, John" <[email-masked]>
Responder a: <[email-masked]>
Fecha: martes, 15 de noviembre de 2016, 13:45
Para: "[email-masked]" <[email-masked]>, v6ops list <[email-masked]>
Asunto: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

    Jordi,

    
    John
    +1-484-962-0060
    
    -----Original Message-----
    From: v6ops <[email-masked]> on behalf of JORDI MARTINEZ <[email-masked]>
    Reply-To: JORDI MARTINEZ <[email-masked]>
    Date: Tuesday, November 15, 2016 at 04:16
    To: v6ops <[email-masked]>
    Subject: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

        

        
        Regards,
        Jordi

        -----Mensaje original-----
        De: Tim Chown <[email-masked]>
        Responder a: <[email-masked]>
        Fecha: martes, 15 de noviembre de 2016, 1:00
        Para: Hemant Singh <[email-masked]>, v6ops list <[email-masked]>
        CC: Jordi Palet Martinez <[email-masked]>
        Asunto: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

            

            

            

            Tim

---

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 15 Nov 2016 07:57:55 +0000

Ah ha…in the revision Gunter and I are going to post this week this section will be removed.  ;)

John
+1-484-962-0060

-----Original Message-----
From: v6ops <[email-masked]> on behalf of JORDI MARTINEZ <[email-masked]>
Reply-To: JORDI MARTINEZ <[email-masked]>
Date: Tuesday, November 15, 2016 at 13:56
To: v6ops <[email-masked]>
Subject: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

    6.  Future work

    Regards,
    Jordi

    -----Mensaje original-----
    De: "Brzozowski, John" <[email-masked]>
    Responder a: <[email-masked]>
    Fecha: martes, 15 de noviembre de 2016, 13:45
    Para: "[email-masked]" <[email-masked]>, v6ops list <[email-masked]>
    Asunto: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01
    
        Jordi,

        
        John
        +1-484-962-0060
        
        -----Original Message-----
        From: v6ops <[email-masked]> on behalf of JORDI MARTINEZ <[email-masked]>
        Reply-To: JORDI MARTINEZ <[email-masked]>
        Date: Tuesday, November 15, 2016 at 04:16
        To: v6ops <[email-masked]>
        Subject: Re: [v6ops] Comments on draft-ietf-v6ops-unique-ipv6-prefix-per-host-01

            

            
            Regards,
            Jordi

            -----Mensaje original-----

                

                

                

                Tim