Subject: [v6ops] FW: I-D Action: draft-woodworth-bulk-rr-07.txt

From: "Woodworth, John R" <[email-masked]>
Date: Tue, 30 Jan 2018 00:12:53 +0000

Greetings WG Members,

Below is the latest release of our draft.  It was posted a few months back but
we expect to complete a new version very soon incorporating some valuable
feedback we’ve received.

We have been primarily working with the DNSOP WG but since our draft has great
potential in the IPv6 namespace (forward and reverse) were hoping to get
feedback and insight somewhat unique to this audience.

We are open to any questions/ comments and would be grateful for examples of
any real-world issues where pattern-based DNS records would either solve
or greatly minimize the problem.

For example - on the IPv4 side we have seen several zone-files, heavy in
$GENERATE's, fail to AXFR due to large (>110MB) expanded file sizes even though
the original was comfortably under 10MB.  Our draft would potentially make the
file even smaller and able to AXFR without increasing its size over-the-wire.

Thank you for your time and any assistance you are able to offer.

Regards,
John

-------- Original message --------
From: [email-masked]
Subject: [DNSOP] I-D Action: draft-woodworth-bulk-rr-07.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Domain Name System Operations WG of the IETF.

        Title           : BULK DNS Resource Records
        Authors         : John Woodworth
                          Dean Ballew
                          Shashwath Bindinganaveli Raghavan
                          David C Lawrence
Filename        : draft-woodworth-bulk-rr-07.txt
Pages           : 16
Date            : 2017-10-30

Abstract:
   The BULK DNS resource record type defines a method of pattern-based
   creation of DNS resource records based on numeric substrings of query
   names.  The intent of BULK is to simplify generic assignments in a
   memory-efficient way that can be easily shared between the primary
   and secondary nameservers for a zone.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-woodworth-bulk-rr/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-woodworth-bulk-rr-07
https://datatracker.ietf.org/doc/html/draft-woodworth-bulk-rr-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-woodworth-bulk-rr-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop
-- THESE ARE THE DROIDS TO WHOM I REFER:

This communication is the property of CenturyLink and may contain confidential or privileged information. Unauthorized use of this communication is strictly prohibited and may be unlawful. If you have received this communication in error, please immediately notify the sender by reply e-mail and destroy all copies of the communication and any attachments.

---

From: Fred Baker <[email-masked]>
Date: Mon, 29 Jan 2018 16:28:35 -0800

Are you hoping to get the discussion on dnsop, or to happen here and be forwarded or observed?

> On Jan 29, 2018, at 4:12 PM, Woodworth, John R <[email-masked]> wrote:
> 
> Greetings WG Members,
> 
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Woodworth, John R" <[email-masked]>
Date: Tue, 30 Jan 2018 08:00:50 +0000

>-----Original Message-----
> From: Fred Baker [mailto:[email-masked]]
>
>

Hi Fred,

Thanks for your feedback!

We've been communicating with dnsop but wanted to make sure we
included all the right voices (due diligence).

I was thinking we would discuss it here but understand there
is a fair bit of overlap so am fine with whatever happens
organically.

Thanks,
John

---

From: 神明達哉 <[email-masked]>
Date: Tue, 30 Jan 2018 09:57:51 -0800

At Tue, 30 Jan 2018 00:12:53 +0000,

> or greatly minimize the problem.

I suspect the draft is mostly about DNS specific details that many of
the v6ops participants don't bother to care:-) So I guess this email
thread at dnsop provides nice higher-level background:
https://www.ietf.org/mail-archive/web/dnsop/current/msg20488.html

My interpretation of the thread is that the dnsop WG was generally not
fully convinced about the need for a new trick to provide individual
(different) IPv6 reverse DNS records (i.e. PTR) for a large IPv6
address space, given that the complexity of the proposal and the
impact on implementations would be quite significant.  If v6ops can
help the discussion, I guess it would be opinions on the need for such
bulk PTRs for IPv6 addresses from large-scale IPv6 operators. (I'm not
that kind of person so I can't provide it, unfortunately).

--
JINMEI, Tatuya

---

From: "Woodworth, John R" <[email-masked]>
Date: Wed, 31 Jan 2018 18:13:34 +0000

> From: [email-masked] [mailto:[email-masked]] On Behalf Of ????
>
> My interpretation of the thread is that the dnsop WG was generally
> not fully convinced about the need for a new trick to provide individual
> help the discussion, I guess it would be opinions on the need for
> such bulk PTRs for IPv6 addresses from large-scale IPv6 operators.
> (I'm not that kind of person so I can't provide it, unfortunately).
>
> --
> JINMEI, Tatuya
>

Hi Jinmei,

Thank you for your comments.

It seems there are a number of members that feel it's perfectly
reasonable to ignore IPv6 PTR's altogether.

Unfortunately, I am not in a position to do so because as a
provider we are expected to provide our customers with quality
service and honor reasonable requests.

Since a number of commercial vendors *already* offer this feature
to their customers I do not believe it to be an unreasonable request.

Rather than hack together another such service, I feel it better
serves our customers and the community as a whole to provide
"compatibility" with this feature and not just add to the number
of proprietary solutions currently *unable* to play nice with
one another as we have today.

While working through the concept, which was IPv4 motivated, in order
to help in the day-to-day real-world problem of managing thousands
of $GENERATE's.  "Who could possibly be against transferable
$GENERATE's?", we thought.  "$GENERATE's unable to step on other
records, this will surely be celebrated!", we said and chose
to share.

Now here we are, decidedly hung up on the "icing" (IPv6)
of all things :) .

In any case, thank you again for taking the time to comment,
it is greatly appreciated.

/John

---

From: 神明達哉 <[email-masked]>
Date: Wed, 31 Jan 2018 10:57:35 -0800

At Wed, 31 Jan 2018 18:13:34 +0000,

> reasonable to ignore IPv6 PTR's altogether.

I thought it was more subtle.  In my understanding it was about the
need for a standard DNS protocol extension to provide different PTRs
for a large set (say, /64) of different IPv6 addresses.  And my
understanding is that the dnsop people didn't see a strong need for
it, especially if it requires a substantial protocol enhancement.
This message in the dnsop thread I referred to shows that:
https://www.ietf.org/mail-archive/web/dnsop/current/msg20507.html

In my previous comment I tried to point out that if v6ops people have
some opinion on this point (either positive or negative) that would be
good feedback to the dnsop discussion.

--
JINMEI, Tatuya

---

From: "Woodworth, John R" <[email-masked]>
Date: Wed, 31 Jan 2018 19:50:06 +0000

> I thought it was more subtle.  In my understanding it was about the need for
> a standard DNS protocol extension to provide different PTRs for a large set
> (say, /64) of different IPv6 addresses.  And my understanding is that the
> dnsop people didn't see a strong need for it, especially if it requires a
> substantial protocol enhancement.
> In my previous comment I tried to point out that if v6ops people have some
> opinion on this point (either positive or negative) that would be good
> feedback to the dnsop discussion.
>
> --
> JINMEI, Tatuya
>
Thanks again!  I agree, this is exactly what I was hoping for (v6ops feedback).

/John