Subject: [v6ops] IETF 102 Agenda

From: Fred Baker <[email-masked]>
Date: Fri, 8 Jun 2018 17:58:56 -0700

Permit me to comment on the IETF 102 agenda as it appears to be shaping up.

We have
 - an invited talk by George Michaelson of APNIC, who has been looking at IPv6 traffic in world economies
   (You might find the observations surprising; hint, guess which economy has the most IPv6 traffic? Which markets?)
 - draft-ietf-v6ops-transition-ipv4aas
 - draft-ietf-v6ops-ipv6rtr-reqs

draft-ietf-v6ops-conditional-ras is under discussion in the IESG, and is waiting for draft-ietf-rtgwg-enterprise-pa-multihoming before proceeding. We have several other individual contributions, and have discussed most of them on the list since IETF 101. The chairs don't see a supporting interest level in them at this time.

We have two slots, two hours each, at IETF 102. The chairs are right now contemplating using one a slot for those three topics and perhaps a set of lightning talks, and letting the second slot go.

To change that, we need to see new drafts (e.g., new content) and supporting list traffic.

Your turn...

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 11 Jun 2018 16:59:07 +0000

Hi Fred,

'draft-templin-v6ops-pdhost' has been updated, and received list traffic both
before and after the update was posted. Please add to the agenda.

Thanks - Fred

> -----Original Message-----
> From: v6ops [mailto:[email-masked]] On Behalf Of Fred Baker
> Sent: Friday, June 08, 2018 5:59 PM
> To: [email-masked] list <[email-masked]>
> Subject: [v6ops] IETF 102 Agenda
> 
> draft-ietf-v6ops-conditional-ras is under discussion in the IESG, and is waiting for draft-ietf-rtgwg-enterprise-pa-multihoming before
> proceeding. We have several other individual contributions, and have discussed most of them on the list since IETF 101. The chairs
> don't see a supporting interest level in them at this time.
> 
> We have two slots, two hours each, at IETF 102. The chairs are right now contemplating using one a slot for those three topics and
> perhaps a set of lightning talks, and letting the second slot go.
>

---

From: Fred Baker <[email-masked]>
Date: Mon, 11 Jun 2018 11:46:32 -0700

> before and after the update was posted. Please add to the agenda.

Hi. I'm looking at the discussion post-IETF-101, and looking for someone saying "I support this draft. I think it describes something I want to deploy in my network." This is an operational working group; I'm looking especially for comments from network operators. This is a discussion you and I have had a number of times. What the chairs want to give agenda time to is drafts that the working group participants find useful and interesting. We gauge that from list discussion. So it's not "number of comments, when comments are specifically solicited, exceed zero", but "someone said it was useful and interesting in their deployment".

Since IETF 101, we have had two threads on the subject of pdhost. I initiated "let's discuss this" in late April: https://www.ietf.org/mail-archive/web/v6ops/current/msg29222.html.

In that thread, we had comments from
  - Dusan Medric, who wondered whether there was a discussion of allocating a prefix (such as a /64) to a host,
  - Joe Touch, Mark Smith, and Ole Troan regarding the distinction a "weak" and a "strong" host and between a "platform", a "router", a "host", and a "node", and
  - Alexandre Petrescu, on the utility in his IOT MIPv6 network.

I initiated another after your update on 29 May (https://www.ietf.org/mail-archive/web/v6ops/current/msg29275.html). In that, you and Alexandre Petrescu discussed the utility of this in his IOT environment, in which he wanted to use RFC 3633 to delegate a prefix to an IOT router for use in an enclave in his network. You and he disagreed on what was to be done with the delegated prefix.

I'm still looking for a comment from a working group participant saying s/he finds draft-templin-v6ops-pdhost, in its 21st revision, "useful and interesting". What I see is 14 emails since IETF 101, many of which you responded to, from people who fundamentally disagreed with you on one point or another.

General comment to those on the CC line: if this draft describes something useful to you in your network, your comment can dramatically change the conversation between Fred and myself.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 11 Jun 2018 21:14:42 +0200

I'm sure in March I confirmed that I will like to see this work as WG item, but can't find my email ...

Anyway, I just read the last version, and again, I confirm that I believe it is useful and will like to see this work to progress as WG item.

Regards,
Jordi

-----Mensaje original-----
De: v6ops <[email-masked]> en nombre de Fred Baker <[email-masked]>
Fecha: lunes, 11 de junio de 2018, 20:47
Para: Fred Templin <[email-masked]>
CC: "[email-masked] list" <[email-masked]>
Asunto: Re: [v6ops] IETF 102 Agenda

    

    
    
    General comment to those on the CC line: if this draft describes something useful to you in your network, your comment can dramatically change the conversation between Fred and myself.
    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 11 Jun 2018 19:48:16 +0000

Hi Fred,

There was a similar question back in the March 2018 timeframe, and there were
several responses in support. The document was then presented remotely at
IETF101, but there was no time left over for questions afterwards.

I am planning to attend IETF102 in person, so would be better able to interact
and get  a sense of the room.

Thanks - Fred

> From: Fred Baker [mailto:[email-masked]]
> Sent: Monday, June 11, 2018 11:47 AM
> To: Templin (US), Fred L <[email-masked]>
> Cc: [email-masked] list <[email-masked]>
> Subject: Re: [v6ops] IETF 102 Agenda
> 
> Hi. I'm looking at the discussion post-IETF-101, and looking for someone saying "I support this draft. I think it describes something I
> want to deploy in my network." This is an operational working group; I'm looking especially for comments from network operators.
> This is a discussion you and I have had a number of times. What the chairs want to give agenda time to is drafts that the working group
> participants find useful and interesting. We gauge that from list discussion. So it's not "number of comments, when comments are
> specifically solicited, exceed zero", but "someone said it was useful and interesting in their deployment".
> 
> Since IETF 101, we have had two threads on the subject of pdhost. I initiated "let's discuss this" in late April:
> https://www.ietf.org/mail-archive/web/v6ops/current/msg29222.html.
> 
> I initiated another after your update on 29 May (https://www.ietf.org/mail-archive/web/v6ops/current/msg29275.html). In that, you
> and Alexandre Petrescu discussed the utility of this in his IOT environment, in which he wanted to use RFC 3633 to delegate a prefix to
> an IOT router for use in an enclave in his network. You and he disagreed on what was to be done with the delegated prefix.
> 
> I'm still looking for a comment from a working group participant saying s/he finds draft-templin-v6ops-pdhost, in its 21st revision,
> "useful and interesting". What I see is 14 emails since IETF 101, many of which you responded to, from people who fundamentally
> disagreed with you on one point or another.
> 
> General comment to those on the CC line: if this draft describes something useful to you in your network, your comment can
> dramatically change the conversation between Fred and myself.

---

From: Erik Nygren <[email-masked]>
Date: Tue, 12 Jun 2018 11:41:33 -0400

I'm also supportive of the WG taking this on and discussing on the agenda
in IETF102.

On Mon, Jun 11, 2018 at 3:48 PM, Templin (US), Fred L <
[email-masked]> wrote:

> > Hi. I'm looking at the discussion post-IETF-101, and looking for someone
> saying "I support this draft. I think it describes something I
> > want to deploy in my network." This is an operational working group; I'm
> looking especially for comments from network operators.
> > This is a discussion you and I have had a number of times. What the
> chairs want to give agenda time to is drafts that the working group
> > participants find useful and interesting. We gauge that from list
> discussion. So it's not "number of comments, when comments are
> > Since IETF 101, we have had two threads on the subject of pdhost. I
> initiated "let's discuss this" in late April:
> >   - Dusan Medric, who wondered whether there was a discussion of
> allocating a prefix (such as a /64) to a host,
> >   - Joe Touch, Mark Smith, and Ole Troan regarding the distinction a
> "weak" and a "strong" host and between a "platform", a "router",
> > a "host", and a "node", and
> > I initiated another after your update on 29 May (
> https://www.ietf.org/mail-archive/web/v6ops/current/msg29275.html). In
> that, you
> > and Alexandre Petrescu discussed the utility of this in his IOT
> environment, in which he wanted to use RFC 3633 to delegate a prefix to
> > an IOT router for use in an enclave in his network. You and he disagreed
> on what was to be done with the delegated prefix.
> >
> > I'm still looking for a comment from a working group participant saying
> s/he finds draft-templin-v6ops-pdhost, in its 21st revision,
> > "useful and interesting". What I see is 14 emails since IETF 101, many
> of which you responded to, from people who fundamentally
> > General comment to those on the CC line: if this draft describes
> something useful to you in your network, your comment can

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 14 Jun 2018 16:54:41 +0000

Hi Fred,

I went carefully over all of the comments received since IETF101 and have submitted a
-21 revision that I think should satisfy the comments raised (see below). Here is the
changelog:

---
   Changes from -20to -21:

   o  Re-worked classic routing model section

   o  Included multi-addressing case where addresses may be assigned to
      applications

   o  Removed strong/weak end system discussions
---

I also changed the title to "Multi-Addressing Considerations for IPv6 Prefix Delegation"
because the focus is really on multi-addressing considerations in the presence of
prefix delegation and not as much on prefix delegation "models".

Please consider this version for presentation at IETF102.

Thanks - Fred
[email-masked]

----
A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Multi-Addressing Considerations for IPv6 Prefix Delegation
        Author          : Fred L. Templin
	Filename        : draft-templin-v6ops-pdhost-21.txt
	Pages           : 14
	Date            : 2018-06-14

Abstract:
   IPv6 prefixes are typically delegated to requesting routers which
   assign them to their downstream-attached links and networks.  The
   requesting node can provision the prefix according to whether it acts
   as a router on behalf of any downstream networks and/or as a host on
   behalf of its local applications.  In the latter case, the requesting
   node can use portions of the delegated prefix for its own multi-
   addressing purposes.  This document therefore considers prefix
   delegation consideations for both the classic routing and various
   multi-addressing use cases.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-templin-v6ops-pdhost/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-templin-v6ops-pdhost-21
https://datatracker.ietf.org/doc/html/draft-templin-v6ops-pdhost-21

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-templin-v6ops-pdhost-21