Subject: Re: [v6ops] When IPv6 breaks IPv4

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 13 Jun 2018 11:20:44 +0200

Le 27/04/2018 à 05:12, Jen Linkova a écrit :
> On Thu, Apr 26, 2018 at 6:42 PM, Alexandre Petrescu
> <[email-masked]> wrote:
>> Even us, at IETF, whenever we write a new hot Internet Draft we put it
>> on an IPv4 website first.
> Actually we we don't.
> 
>> (I guess datatracker is not reachable on IPv6,
>> just guess.)
> 
> I've just completely disabled IPv4 on my workstation and
> https://datatracker.ietf.org works just fine (I tested browsing the
> drafts and some links on WG Chair dashboard).

I have just used an IPv6 linux laptop on an IPv6 cellular link that 
gives no IPv4.

The laptop connects ok to https://ietf.org, tools.ietf.org.  I have even 
tried to register for the next meeting.  I went with the process up to 
filling the data, but stopped there.

There are however some websites that dont work, like github.com.  Many 
people use github for IETF work like drafts, charters, etc.

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 13 Jun 2018 14:29:17 +0200

> people use github for IETF work like drafts, charters, etc.

Other important thing that does not work on IPv6 is paypal.com.  I just 
tried it and it does not work on IPv6, whereas ietf.org works ok on IPv6.

paypal is very important for me during the registration process to 
participate to IETF.  It is very important because I prefer it for 
security reasons.  In the past I had some problems paying with something 
else than paypal.  Now I prefer paypal for whatever I pay.

Without paying with paypal I would not register to IETF.

(this time I dont come to IETF, so it is not really paramount 
importance, but just to let you know: somebody that wants to use IPv6 
and paypal to come to IETF can not).

(this email was sent from a Windows client whose IPv4 box was unchecked, 
and the cellular network access is of PDP type 'IPv6', and with a smtp 
server from google).

Alex
> 
> Alex
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 13 Jun 2018 14:47:34 +0200

When going to IETF meetings, one is concerned about which hotel to book. 
  Typically the concerns are the price range, distance from IETF venue, 
transportation, comfort conditions, WiFi, breakfast, rating by others, etc.

One other interesting criterion is whether the reservation with the link 
provided by IETF can be made on IPv6, or not.

For IETF 102
Fairmont the Queen Elizabeth: IPv6 reservation ok
Le Centre Sheraton: IPv6 reservation not possible
others...

Alex

---

From: Fred Baker <[email-masked]>
Date: Thu, 14 Jun 2018 10:52:38 -0700

For the record, I don't think the subject of registering for IETF meetings, hotel choice, using PayPal, and using Github is covered in the IPv6 charter. Yes, I'd like PayPal, Github, and a variety of other web sites to implement IPv6. I'm pretty sure their maintainers are not reading this list.

> On Jun 13, 2018, at 5:47 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> When going to IETF meetings, one is concerned about which hotel to book.  Typically the concerns are the price range, distance from IETF venue, transportation, comfort conditions, WiFi, breakfast, rating by others, etc.
> 
> One other interesting criterion is whether the reservation with the link provided by IETF can be made on IPv6, or not.
> 
> For IETF 102
>> I have just used an IPv6 linux laptop on an IPv6 cellular link that gives no IPv4.
>> The laptop connects ok to https://ietf.org, tools.ietf.org.  I have even tried to register for the next meeting.  I went with the process up to filling the data, but stopped there.
>> There are however some websites that dont work, like github.com.  Many people use github for IETF work like drafts, charters, etc.
>> Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 15 Jun 2018 11:10:56 +0200

Le 14/06/2018 à 19:52, Fred Baker a écrit :
[...]

> For the record, I don't think the subject of registering for IETF
> meetings, hotel choice, using PayPal, and using Github is covered in
> the IPv6 charter.

I agree with you.

But if we wanted to work on that Charter by only using IPv6 technology 
then we would have great success, only with a few quirks: paypal, hotel 
choice and github.

That is a question of _using_ IPv6 technology.

There are many ways to try the use of IPv6 technology.

One great way is to try the use of the IPv6 technology while we are at 
an IETF meeting.  They offer some ESSID that does only IPv6.  I did that 
and it is a great testing.

However, while doing that test on ESSID that is IPv6 only I felt that 
other tests were needed from elsewhere than IETF.  Because we were 
already at IETF, but there is a need to come to IETF first.

So now, before coming at IETF, is a great time to test IPv6.  To answer 
the question: how IPv6 can help to come to IETF?  Or how IPv6 is a break 
in coming to IETF?

> Yes, I'd like PayPal, Github, and a variety of
> other web sites to implement IPv6. I'm pretty sure their maintainers
> are not reading this list.

Well, I can pick one.  The github.  What is the postmaster address at 
github?  I can write her an email.

(I want to complain to her not only about IPv6, but also about their 
storage format: they break UTF-8, and as such people's names get wrong 
in drafts; examples available upon request).

Alex

>> When going to IETF meetings, one is concerned about which hotel to
>> book.  Typically the concerns are the price range, distance from
>> IETF venue, transportation, comfort conditions, WiFi, breakfast,
>> rating by others, etc.
>> 
>> One other interesting criterion is whether the reservation with the
>> link provided by IETF can be made on IPv6, or not.
>> 
>> For IETF 102 Fairmont the Queen Elizabeth: IPv6 reservation ok Le
>> Centre Sheraton: IPv6 reservation not possible others...
>> 
>> Alex
>> 
>>>>> Even us, at IETF, whenever we write a new hot Internet Draft
>>>>> we put it on an IPv4 website first.
>>>> Actually we we don't.
>>>> 
>>>>> (I guess datatracker is not reachable on IPv6, just guess.)
>>>> 
>>>> https://datatracker.ietf.org works just fine (I tested browsing
>>>> the drafts and some links on WG Chair dashboard).
>>> I have just used an IPv6 linux laptop on an IPv6 cellular link
>>> that gives no IPv4. The laptop connects ok to https://ietf.org,
>>> tools.ietf.org.  I have even tried to register for the next
>>> meeting.  I went with the process up to filling the data, but
>>> stopped there. There are however some websites that dont work,
>>> like github.com.  Many people use github for IETF work like
>>> drafts, charters, etc. Alex 
>>> _______________________________________________ v6ops mailing
>>> list [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>> 
>> _______________________________________________ v6ops mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 15 Jun 2018 11:31:41 +0200

> and it is a great testing.

I mean I did some testing.  The ESSID with IPv6 only was designed and 
deployed by IETF network designers.

Alex

---

From: Fred Baker <[email-masked]>
Date: Fri, 15 Jun 2018 08:22:25 -0700

> On Jun 15, 2018, at 2:10 AM, Alexandru Petrescu <[email-masked]> wrote:
> 
> Well, I can pick one.  The github.  What is the postmaster address at github?  I can write her an email.

That would be a constructive course of action. On this list, I'm afraid the discussion is off topic.

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 15 Jun 2018 18:28:59 +0200

Le 15/06/2018 à 17:22, Fred Baker a écrit :
> [SECURITE : MISE EN QUARANTAINE DES PIECES JOINTES POTENTIELLEMENT DANGEREUSES]
> 
> Ce message contient des pieces jointes potentiellement dangereuses car susceptibles de contenir des virus. Pour lutter contre l'expansion de ce type d'attaque, les documents [null] ont ete retires du message original ci-dessous. Pour les documents Office, le CEA recommande l'usage exclusif des formats plus recents exempts de macros comme DOCX, XLSX, PPTX, merci de le signaler a votre expediteur.
> 
> Pour de plus amples informations ou pour connaitre les mecanismes de mise en quarantaine, vous pouvez vous rapprocher de votre service informatique ou consulter le site USCIpedia - rubrique PureMessage.
> 
> ----------------MESSAGE ORGINAL ci-dessous------------------
> 
> 
> 

Why I posted here? this kind of discussion was on-topic during the IETF 
meeting in Singapore on the '100attendees' email list.  Absent that 
list, I supposed v6ops email list was appropriate.

I supposed, maybe wrongly, that github not doing IPv6 would have been a 
reason of concern for Microsoft after having acquired github, Microsoft 
who _was_ on topic to talk on v6ops about IPv6 in the office.

I will stop here.

Alex