Subject: [v6ops] iOS12 IPv6-only

From: <[email-masked]>
Date: Fri, 19 Oct 2018 16:50:32 +0000

Hi folks,
I want to mention iOS12 is driving our IPv6-only rollout.
Thanks to Apple make use of 464xlat for tethering (i.e. specific to wifi tethering interface to cellular), this has allowed us to skip dualstack on our common APN.
So I believe onboard apps just use Happy Eyeballs v2.
Nick
https://stats.labs.apnic.net/ipv6/AS12576?a=12576&c=GB&x=1&s=0&p=1&w=15

---

From: Kristian McColm <[email-masked]>
Date: Fri, 19 Oct 2018 17:36:28 +0000

Hi Nick,

That's good news! Do you know of any way to determine if 464XLAT/clat is active on the IOS12 device? With Android it was merely a matter of bringing up a shell with adb and looking for the clat interface but with IOS its not so simple unfortunately.

I am trying to determine under what conditions the clat is brought up on IOS12 for selfish reasons.

Regards
Kristian

From: v6ops <[email-masked]> On Behalf Of [email-masked]
Sent: October 19, 2018 12:51
To: [email-masked]
Subject: [v6ops] iOS12 IPv6-only

Hi folks,
I want to mention iOS12 is driving our IPv6-only rollout.
Thanks to Apple make use of 464xlat for tethering (i..e. specific to wifi tethering interface to cellular), this has allowed us to skip dualstack on our common APN.
So I believe onboard apps just use Happy Eyeballs v2..
Nick
https://stats.labs.apnic.net/ipv6/AS12576?a=12576&c=GB&x=1&s=0&p=1&w=15

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 22 Oct 2018 12:23:04 +0200

Le 19/10/2018 à 18:50, [email-masked] a écrit :
> Thanks to Apple make use of 464xlat for tethering (i..e. specific to 
> wifi tethering interface to cellular), this has allowed us to skip 
> dualstack on our common APN.

I am happy to see IPv6-only rollout plan.

But I do not understand what do you plan for IPv6 tethering?  Do you use 
DHCPv6 Prefix Delegation?

Alex

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 22 Oct 2018 13:13:47 +0200 (CEST)

> DHCPv6 Prefix Delegation?

All phones I am aware of use https://datatracker.ietf.org/doc/rfc7278/ 
(64SHARE) to extend the WAN /64 to a single LAN.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 29 Oct 2018 15:31:42 +0100

Le 22/10/2018 à 13:13, Mikael Abrahamsson a écrit :
>> But I do not understand what do you plan for IPv6 tethering?  Do you 
>> use DHCPv6 Prefix Delegation?
> 

I guess these phones dont understand the bit 'L' in RA to stand for 
'on-link' prefix, right?  (the link between phone and PGW is distinct 
than the wifi link; one bit can not hold three values).

(these remarks came to me while reviewing a draft by somebody else about 
a related topic).

Alex

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 29 Oct 2018 15:35:05 +0100 (CET)

> than the wifi link; one bit can not hold three values).

The link between PGW and phone is a point-to-point link. No ND is 
performed. PGW doesn't have any addresses on this link.

If you want to nit-pick that into this being two links that's fine, but 
it's also pointless. 64SHARE works fine and has been deployed into 
billions of devices.

---

From: Joel Jaeggli <[email-masked]>
Date: Mon, 29 Oct 2018 08:03:16 -0700

> On Oct 29, 2018, at 07:35, Mikael Abrahamsson <[email-masked]> wrote:
> 
>> I guess these phones dont understand the bit 'L' in RA to stand for 'on-link' prefix, right?  (the link between phone and PGW is distinct than the wifi link; one bit can not hold three values).
> 
> The link between PGW and phone is a point-to-point link. No ND is performed. PGW doesn't have any addresses on this link.

ND and the associated collection of host routes does not scale in this context, so this is essentially prefix per host. What you do with it ultimately is your business…

> 
> If you want to nit-pick that into this being two links that's fine, but it's also pointless. 64SHARE works fine and has been deployed into billions of devices.