Subject: [v6ops] Proposed agenda for IETF 103

From: Fred Baker <[email-masked]>
Date: Tue, 23 Oct 2018 07:46:40 +0200

Ron and I are proposing this as the agenda this time around: https://datatracker.ietf.org/meeting/103/materials/agenda-103-v6ops-02

If there is time at the end of the meeting and people want to do what amounts to a lightning talk, we can open the floor for that. However, with a single two-hour slot, I expect it will be a busy meeting.

In case it's useful to you, I have included some additional links in the attached file - data tracker, html draft, discussion thread, and rfcdiff against the previous version if any.

--------------------------------------------------------------------------------
Victorious warriors win first and then go to war,
Defeated warriors go to war first and then seek to win.
     Sun Tzu

---

From: Davey Song <[email-masked]>
Date: Tue, 23 Oct 2018 14:28:41 +0800

I'm confused that in IETF BKK some busy working group like v6ops and dnsop
only has one sesion (2 hours). Usually they had 2 . Is IETF BKK sepcially
and the schedule is so packed?

Davey

On Tue, 23 Oct 2018 at 13:47, Fred Baker <[email-masked]> wrote:

> Ron and I are proposing this as the agenda this time around:
> https://datatracker.ietf.org/meeting/103/materials/agenda-103-v6ops-02
>
> If there is time at the end of the meeting and people want to do what
> amounts to a lightning talk, we can open the floor for that. However, with
> a single two-hour slot, I expect it will be a busy meeting.
>
> In case it's useful to you, I have included some additional links in the
> attached file - data tracker, html draft, discussion thread, and rfcdiff
> against the previous version if any.
>
>
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Fred Baker <[email-masked]>
Date: Tue, 23 Oct 2018 10:57:44 +0200

On Oct 23, 2018, at 8:28 AM, Davey Song <[email-masked]> wrote:
> I'm confused that in IETF BKK some busy working group like v6ops and dnsop only has one sesion (2 hours). Usually they had 2 . Is IETF BKK sepcially and the schedule is so packed?

First, yes, IETF 103 is different than other IETFs in several ways. It is discussed in an email: https://www.ietf.org/mail-archive/web/ietf/current/msg107813.html. In short, while Fridays have always been a day few people wanted to have their meeting on, this time there are no scheduled meetings on Friday. In addition, we have no 2.5 hour sessions. V6ops has historically usually used at least one 2.5 hour session, and often two 2 hour sessions. In essence, the number of slots is less, and their length is reduced.

Ron and I have gone back and forth on scheduling, both on the number of meeting slots we ask for and how they are used. At IETF 101, we only asked for one 2.5 hour slot, and wound up pushing a lot of work (too much, in hindsight) into that slot. At IETF 102, we asked for two slots (one of which wound up on Friday), and wound up using one for v6ops work and the other as an open session. For IETF 103, in view of the experiment the IESG is carrying out, we only asked for one slot, and it was the largest available to us - two hours.

Let me walk through the process by which Ron and I develop the agenda. I have attached a file I create daily for my own amusement (I do this for each IETF working group and IRTF RG), because I find it useful. It sorts out the drafts currently before the working group by their status with the RFC Editor, IESG, and Working Group, and among documents at our level, divides between those that have been updated since the last IETF meeting and those that have not. It tells us how to review discussion of a given draft - not just on v6ops@, but on all IETF mailing lists, as that is sometimes useful to know. Drafts that are eligible for agenda time are those that are at the working group level (sometimes ones the AD or IESG is kicking around, but those are exceptions), are within the scope of our charter, have been updated since the last meeting, and have had recent supportive discussion on the mailing list.

To expound slightly on that last concept - it's one that seems to get discussed from time to time - we're looking for discussion (no mail since last IETF => no discussion) and support (not just "gee, that could be an interesting concept intellectually", but "and I think I would like to deploy it in my part of the world if it meets my needs, which I might need to discuss"). This is an operational community, and yes, we're looking for operational comments. Others are welcome too, of course - I'm an example of "other" - but operators are at the head of the line in consideration.

Ron and I also apply some editorial judgement, of course.

For IETF 103, Ron and I originally asked Xing Li to talk about CERNET2, which has been an IPv6-only network for about ten years, and connects a couple hundred universities in China. We have been inviting a talk each meeting to let people talk about their experience with IPv6-only networking, or to cover nascent topics. We had three drafts that pretty clearly needed discussion, and we posted those in a provisional agenda. We had three requests for time in addition to that, one of which came from you. We reviewed the mailing list discussion (your was interesting in that it was largely cross-posted with dnsop, so many of the messages were duplicated), and tried to figure out what was most interesting to the working group. We accepted one of the drafts "time permitting", we decided to not include yours for reasons I described to you in email, and for the third request added an "AOB" section to the agenda.

Something else we have been doing - which I have experimented with before and between IETF 101 and 102 and then 102 and 103 - is asking the working group once a week to look at some draft (usually a v6ops draft, but sometimes others) and comment on it from an operational perspective. Obvious objectives there include improvement of the draft and giving he chairs guidance on what should happen with it if anything. We have had a couple of instances where the discussion made it pretty clear that the draft should be adopted by the working group or progressed in status, and a few discussions that have been well-characterized with a yawn. Besides improving drafts and pushing status along, we hope that this helps offload and improve the f2f meeting. This happened for your draft during the last week in September.

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: Davey Song <[email-masked]>
Date: Tue, 23 Oct 2018 17:40:29 +0800

Thanks for your sharing and I feel grateful for the Chair's effort to
schedule all this with transparency. I'm sorry for over demanding it.

Davey

On Tue, 23 Oct 2018 at 16:57, Fred Baker <[email-masked]> wrote:

> > I'm confused that in IETF BKK some busy working group like v6ops and
> dnsop only has one sesion (2 hours). Usually they had 2 . Is IETF BKK
> sepcially and the schedule is so packed?
>
> First, yes, IETF 103 is different than other IETFs in several ways. It is
> discussed in an email:
> https://www.ietf.org/mail-archive/web/ietf/current/msg107813.html. In
> short, while Fridays have always been a day few people wanted to have their
> meeting on, this time there are no scheduled meetings on Friday. In
> addition, we have no 2.5 hour sessions. V6ops has historically usually used
> at least one 2.5 hour session, and often two 2 hour sessions. In essence,
> the number of slots is less, and their length is reduced.
>
> Ron and I have gone back and forth on scheduling, both on the number of
> meeting slots we ask for and how they are used. At IETF 101, we only asked
> for one 2.5 hour slot, and wound up pushing a lot of work (too much, in
> hindsight) into that slot. At IETF 102, we asked for two slots (one of
> which wound up on Friday), and wound up using one for v6ops work and the
> other as an open session. For IETF 103, in view of the experiment the IESG
> is carrying out, we only asked for one slot, and it was the largest
> available to us - two hours.
>
> Let me walk through the process by which Ron and I develop the agenda. I
> have attached a file I create daily for my own amusement (I do this for
> each IETF working group and IRTF RG), because I find it useful. It sorts
> out the drafts currently before the working group by their status with the
> RFC Editor, IESG, and Working Group, and among documents at our level,
> divides between those that have been updated since the last IETF meeting
> and those that have not. It tells us how to review discussion of a given
> draft - not just on v6ops@, but on all IETF mailing lists, as that is
> sometimes useful to know. Drafts that are eligible for agenda time are
> those that are at the working group level (sometimes ones the AD or IESG is
> kicking around, but those are exceptions), are within the scope of our
> charter, have been updated since the last meeting, and have had recent
> supportive discussion on the mailing list.
>
> To expound slightly on that last concept - it's one that seems to get
> discussed from time to time - we're looking for discussion (no mail since
> last IETF => no discussion) and support (not just "gee, that could be an
> interesting concept intellectually", but "and I think I would like to
> deploy it in my part of the world if it meets my needs, which I might need
> to discuss"). This is an operational community, and yes, we're looking for
> operational comments. Others are welcome too, of course - I'm an example of
> "other" - but operators are at the head of the line in consideration.
>
> For IETF 103, Ron and I originally asked Xing Li to talk about CERNET2,
> which has been an IPv6-only network for about ten years, and connects a
> couple hundred universities in China. We have been inviting a talk each
> meeting to let people talk about their experience with IPv6-only
> networking, or to cover nascent topics. We had three drafts that pretty
> clearly needed discussion, and we posted those in a provisional agenda. We
> had three requests for time in addition to that, one of which came from
> you. We reviewed the mailing list discussion (your was interesting in that
> it was largely cross-posted with dnsop, so many of the messages were
> duplicated), and tried to figure out what was most interesting to the
> working group. We accepted one of the drafts "time permitting", we decided
> to not include yours for reasons I described to you in email, and for the
> third request added an "AOB" section to the agenda.
>
> Something else we have been doing - which I have experimented with before
> and between IETF 101 and 102 and then 102 and 103 - is asking the working
> group once a week to look at some draft (usually a v6ops draft, but
> sometimes others) and comment on it from an operational perspective.
> Obvious objectives there include improvement of the draft and giving he
> chairs guidance on what should happen with it if anything. We have had a
> couple of instances where the discussion made it pretty clear that the
> draft should be adopted by the working group or progressed in status, and a
> few discussions that have been well-characterized with a yawn. Besides
> improving drafts and pushing status along, we hope that this helps offload
> and improve the f2f meeting. This happened for your draft during the last
> week in September.
>
>
> The fact that there is a highway to hell and a stairway to heaven is an
> interesting comment on projected traffic volume...
>
>

---

From: Ron Bonica <[email-masked]>
Date: Tue, 23 Oct 2018 19:45:57 +0000

Looks good to me

> -----Original Message-----
> From: Fred Baker <[email-masked]>
> Sent: Tuesday, October 23, 2018 1:47 AM
> To: [email-masked] list <[email-masked]>
> Cc: Warren Kumari <[email-masked]>; Ron Bonica
> <[email-masked]>
> Subject: Proposed agenda for IETF 103
> 
> If there is time at the end of the meeting and people want to do what amounts
> to a lightning talk, we can open the floor for that. However, with a single two-
> hour slot, I expect it will be a busy meeting.
> 
> In case it's useful to you, I have included some additional links in the attached
> file - data tracker, html draft, discussion thread, and rfcdiff against the
> previous version if any.