Subject: [v6ops] update draft-shytyi-v6ops-danir-03?

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 17 Sep 2019 10:18:02 +0200

Hi v6ops,

Our draft draft-shytyi-v6ops-danir-03.txt is about to expire.

We think about updating it with an implementation section.

What do you think about this draft?

Alex and Dmytro

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 17 Sep 2019 14:00:13 +0000

I think it is very similar to drafts I have presented in v6ops in the past:

https://datatracker.ietf.org/doc/draft-templin-v6ops-pdhost/
https://datatracker.ietf.org/doc/draft-templin-6man-dhcpv6-ndopt/

We also have implementation experience with these drafts.

Thanks - Fred

From: v6ops [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Tuesday, September 17, 2019 1:18 AM
To: [email-masked]
Subject: [v6ops] update draft-shytyi-v6ops-danir-03?

Hi v6ops,

Alex and Dmytro

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 18 Sep 2019 09:22:29 +0200

Thank you for the pointers, we will add reference to them.  These drafts 
are indeed in the same space.

Alex

Le 17/09/2019 à 16:00, Templin (US), Fred L a écrit :
> *From:*v6ops [mailto:[email-masked]] *On Behalf Of *Alexandre 
> Petrescu
> *Sent:* Tuesday, September 17, 2019 1:18 AM
> *To:* [email-masked]
> *Subject:* [v6ops] update draft-shytyi-v6ops-danir-03?
>
> Hi v6ops,
>

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 18 Sep 2019 16:10:47 +0000

Alex, my documents were presented at v6ops sessions multiple times with corresponding
discussion on the list, but we were told there was not enough interest to adopt them as wg
items. If the climate in v6ops has somehow changed since then, then I think my docs would
be the ones used as a starting point but could consider combining in some way?

Here is another active document with an approach to Prefix Registration (as opposed to
Prefix Delegation) that is being considered for civil aviation:

https://datatracker.ietf.org/doc/draft-templin-atn-aero-interface/

Thanks - Fred

From: Alexandre Petrescu [mailto:[email-masked]]
Sent: Wednesday, September 18, 2019 12:22 AM
To: Templin (US), Fred L <[email-masked]>; [email-masked]
Subject: Re: [v6ops] update draft-shytyi-v6ops-danir-03?

Thank you for the pointers, we will add reference to them.  These drafts are indeed in the same space.

Alex

Thanks - Fred

From: v6ops [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Tuesday, September 17, 2019 1:18 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [v6ops] update draft-shytyi-v6ops-danir-03?

Hi v6ops,

Alex and Dmytro

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 19 Sep 2019 09:01:40 +0200

Le 18/09/2019 à 18:10, Templin (US), Fred L a écrit :
> Alex, my documents were presented at v6ops sessions multiple times
> with corresponding discussion on the list, but we were told there was
> not enough interest to adopt them as wg items. If the climate in
> v6ops has somehow changed since then, then I think my docs would be
> the ones used as a starting point but could consider combining in 
> some way?

I have not seen a sign of climate change in v6ops WG with respect to 
this kind of problem: DHCPv6 Prefix Delegation and prefix division for 
mobile router on cellular links.

If there is change, I think indeed a generic approach considering 
domains like civil aviation as well as IoT class devices, tethered 
smartphones and mobile routers, is appropriate.  They are all mobile 
computers that need to connect to an IPv6 fixed network, in a scalable 
manner.

> https://datatracker.ietf.org/doc/draft-templin-atn-aero-interface/

It's an interesting draft.  Maybe we can advantageously refer bilaterally.

Alex

> 
> Thanks - Fred
> 
> *From:*Alexandre Petrescu [mailto:[email-masked]] 
> *Sent:* Wednesday, September 18, 2019 12:22 AM *To:* Templin (US),
> Fred L <[email-masked]>; [email-masked] *Subject:* Re:
> [v6ops] update draft-shytyi-v6ops-danir-03?
> 
> Petrescu *Sent:* Tuesday, September 17, 2019 1:18 AM *To:*
> [email-masked] <mailto:[email-masked]> *Subject:* [v6ops] update
> draft-shytyi-v6ops-danir-03?
> 
> Hi v6ops,
>

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Fri, 20 Sep 2019 14:41:51 +0000

Hi Alex,

> It's an interesting draft.  Maybe we can advantageously refer bilaterally.

The draft has not quite crossed over from the aviation domain into the IETF yet,
but a reference could be added to the next version. I am contemplating adding
a short section on "Prefix Delegation vs Prefix Registration", where Delegation
is when the requesting node does not know beforehand what prefix the network
will give it, and Registration is when the requesting node already knows its prefix
and is just wanting for the network to inject it into the routing system. We deal
with both in the aviation domain, but expect that commercial aircraft will have
pre-placed prefixes that never change and need only be registered with the
routing system upon network join. (In fact, maybe I will just cut-and-paste
this text into  the draft.)

Thanks - Fred