Subject: [v6ops] Fwd: New Version Notification for draft-shytyi-v6ops-danir-04.txt

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 19 Sep 2019 08:54:11 +0200

Hi,

We have submitted a new version of this draft with text that includes 
comments from participants in v6ops WG.

Yours,

Alex and Dmytro

-------- Message transféré --------
Sujet : 	New Version Notification for draft-shytyi-v6ops-danir-04.txt
Date : 	Wed, 18 Sep 2019 12:54:13 -0700
De : 	[email-masked]
Pour : 	Dmytro Shytyi <[email-masked]>, Alexandre Petrescu 
<[email-masked]>, Alexandre Petrescu <[email-masked]>

A new version of I-D, draft-shytyi-v6ops-danir-04.txt
has been successfully submitted by Dmytro Shytyi and posted to the
IETF repository.

Name: draft-shytyi-v6ops-danir
Revision: 04
Title: DHCPv6_PD, PDP and NDP Implementation in IoT Router (DANIR)
Document date: 2019-09-17
Group: Individual Submission
Pages: 19
URL: https://www.ietf.org/internet-drafts/draft-shytyi-v6ops-danir-04.txt
Status: https://datatracker.ietf.org/doc/draft-shytyi-v6ops-danir/
Htmlized: https://tools.ietf.org/html/draft-shytyi-v6ops-danir-04
Htmlized: https://datatracker.ietf.org/doc/html/draft-shytyi-v6ops-danir
Diff: https://www.ietf.org/rfcdiff?url2=draft-shytyi-v6ops-danir-04

Abstract:
This document provides a description of the implementation of Dynamic
Host Configuration Protocol version 6 Prefix Delegation, Neighbour
Discovery Protocol and of the use of the Packet Data Protocol in an
Internet of Things Router. This Internet of Things Router is
connected on a cellular network; it is a DHCPv6-PD Client and it
requests a /56 pool of prefixes from the server; the DHCPv6-PD server
is placed in the PGW and is a part of the cellular infrastructure.
After the pool of prefixes is delegated, the Internet of Things
Router derives sub-prefixes from the prefix pool; each one of these
sub-prefixes is aimed at one ingress interface.

After the Internet of Things Router finishes the network prefix
assignment procedure, it advertises the network prefixes on the
ingress links by using the Neighbour Discovery protocol. Finally,
when Hosts receive the sub-prefixes via Router Adverticement
messages, they configure the Global Unique Address with the Stateless
Address Auto-configuration protocol.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Dmytro Shytyi <[email-masked]>
Date: Mon, 30 Sep 2019 22:57:59 +0200

Dear members of v6ops,

We released a new version of draft-shytyi-v6ops-danir-04.

The update includes the implementation section with link to opensource code (we have published Lite Linux kernel implementation of the DHCPv6PD and ND)

Also we added "Related work" section. We also made the VM virtualbox where one could find an implementation.

We invite you to comment this draft. You are also welcome to answer the questions below:

We have a VM that includes implementation DHCPv6PD and ND described in this draft.

If you find it is interesting, please comment: "I find interesting that there is a VM that implements approach described in the draft"

If you are interested to get a link to the VM with implementation, comment "I would like to get a link to download the VM"

We propose an overview of the process of IPv6 prefix delegation and further sharing information via RA messages.

If you find that this approach is well described, please  comment "I find that draft well describes the process of DHCPv6PD and ND"

If you aware/not aware of another kernel implementation of this draft, please comment "I am aware/not aware of another kernel implementation of this draft".

____________
Best Regards,
Alex and Dmytro

---- On Wed, 18 Sep 2019 21:54:13 +0200  <[email-masked]> wrote ----

A new version of I-D, .txt 
has been successfully submitted by Dmytro Shytyi and posted to the 
IETF repository. 

Abstract: 

 

The IETF Secretariat