Subject: [v6ops] Fwd: New Version Notification for draft-link-dhc-v6only-01.txt

From: Jen Linkova <[email-masked]>
Date: Tue, 10 Dec 2019 11:02:04 +1100

Hello,

Thanks to everyone for very productive centi-thread on
draft-link-dhc-v6only-00 ;)
Here is the improved version, -01.

The main changes:

- The option is not zero length anymore. It has 4-bytes value which
might contain V6ONLY_WAIT timer. Benefits:
    --- allows the network administrators to pilot the changes and
rollback quickly if needed;
    --- addressed some concern about an option having zero length
(allegedly it might confuse some clients)

- Using a dedicated address to return to clients is now an optional
optimisation. By default the server is expected just to return a
random address (as usual).

- Typos fixed (probably some new typos added though).

The authors would like the DHC WG to consider adopting this document.

Thank you!

---------- Forwarded message ---------
From: <[email-masked]>
Date: Tue, Dec 10, 2019 at 10:44 AM
Subject: New Version Notification for draft-link-dhc-v6only-01.txt
To: Tomek Mrugalski <[email-masked]>, Lorenzo Colitti
<[email-masked]>, Jen Linkova <[email-masked]>, Michael C.
Richardson <[email-masked]>

A new version of I-D, draft-link-dhc-v6only-01.txt
has been successfully submitted by Jen Linkova and posted to the
IETF repository.

Name:           draft-link-dhc-v6only
Revision:       01
Title:          IPv6-Only-Preferred Option for DHCP
Document date:  2019-12-09
Group:          Individual Submission
Pages:          10
URL:
https://www.ietf.org/internet-drafts/draft-link-dhc-v6only-01.txt
Status:         https://datatracker.ietf.org/doc/draft-link-dhc-v6only/
Htmlized:       https://tools.ietf.org/html/draft-link-dhc-v6only-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-link-dhc-v6only
Diff:           https://www.ietf.org/rfcdiff?url2=draft-link-dhc-v6only-01

Abstract:
   This document specifies a DHCP option to indicate that a host
   supports an IPv6-only mode and willing to forgo obtaining an IPv4
   address if the network provides IPv6 connectivity.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

-- 
SY, Jen Linkova aka Furry

---

From: <[email-masked]>
Date: Tue, 10 Dec 2019 10:31:31 +0000

Hi Jen,

Thank you for sharing this updated version. Below some points that I do think need more clarification in the I-D: 

(1) The document is too NAT64 centric. The proposal may apply as well for other IPv6-only deployment scenarios (typically, unmanaged IPv6-only CPEs with IPv4aaS).

(2) A discussion on the benefit of this extra signal compared to relying on existing signals (pref64, aftr_name, map_container...). For example, a host that supports the option is ready to wait at minimum 300s and disable its IPv4 configuration regardless of what is happening on the IPv6 leg. How is that superior to a host delaying DHCP process by xxx ms should be explained further.  

(3) How "IPv6-only preferred" mode is supposed to be set at the host side:

==
   A DHCP client SHOULD allow a device administrator to configure
   IPv6-only preferred mode either for a specific interface (to indicate
   that the device is IPv6-only capable if connected to a NAT64 network
   via that interface) or for all interfaces.  
==

* I guess the default value when the option is supported by a host is to disable including it in the request. The document should include a discussion on the default behavior. 
* If an explicit action is needed from the user to enable including the option, having a discussion to what extent the feature is likely to be enabled would be needed.

(4) The document is still mixing the DHCP client vs. host behaviors. For example, 

   Clients not capable of operating in an IPv6-only NAT64 environment
   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   MUST NOT include the IPv6-only Preferred option in the Parameter
   Request List of any DHCP packets and MUST ignore that option in
   packets received from DHCP servers.

does not make sense for a DHCP client. 

Also, how the host is able to assess/determine that it is (not) capable to behave in the IPv6 mode? 

(5) The definition of IPv4aaS is not aligned with other RFCs: e.g., RFC8585 says the following: 

   "IPv4aaS" stands for "IPv4-as-a-Service", meaning transition
   technologies for delivering IPv4 in IPv6-only connectivity.

While yours is: 

   IPv4-as-a-Service: a deployment scenario when end hosts are expected
   to operate in IPv6-only mode by default and IPv4 addresses can be
   assigned to some hosts if those hosts explicitly opt-in to receiving
   IPv4 addresses.

(6) Do you consider a host with CLAT function as an IPv6-only host?

If so, the following definition should be updated to refer to "IPv4 connectivity" rather than "IPv4" in general. This is because an IPv4 address is required for CLAT for example.

==
   IPv6-only capable host: a host which does not require IPv4 and can
   operate on IPv6-only networks.
==

(7) Wouldn't the following add an extra delay for applications requiring CLAT?

==
The host MAY disable IPv4 stack
   completely for V6ONLY_WAIT seconds or until the network disconnection
   event happens.
==

(8) Consider returning an address from the range defined in RFC7335 for IPv6-only hosts. Such IPv4 addresses are required anyway for some IPv6-only hosts (those with a CLAT for example).

====
   The result is that 192.0.0.0/29 may be used in any system
   that requires IPv4 addresses for backward compatibility with IPv4
   communications in an IPv6-only network but does not emit IPv4 packets
   "on the wire".
====

Cheers,
Med

> -----Message d'origine-----
> De : dhcwg [mailto:[email-masked]] De la part de Jen Linkova
> Envoyé : mardi 10 décembre 2019 01:02
> À : [email-masked]
> Cc : V6 Ops List
> Objet : [dhcwg] Fwd: New Version Notification for draft-link-dhc-v6only-
> 01.txt
> 
> Hello,
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 10 Dec 2019 16:11:16 +0000

Hi:

Is (8):

	====

But RFC7335 says (in section 4):

   IANA has defined a well-known range, 192.0.0.0/29, in [RFC6333],
   which is dedicated for DS-Lite.  As defined in [RFC6333], this subnet
   is only present between the B4 and the Address Family Transition
   Router (AFTR) and never emits packets from this prefix "on the wire".  <---
   464XLAT has the same need for a non-routed IPv4 prefix, and this same
   need may be common for other similar solutions.  It is most prudent
   and effective to generalize 192.0.0.0/29 for the use of supporting
   IPv4 interfaces in IPv6 transition technologies rather than reserving
   a prefix for every possible solution.

So, this address is only used "on the host" (not on the wire), so why would there be any need for the DHCP server to assign this address?

And as the IPv6-only option means that the host never completes the DHCPDISCOVER/OFFER/REQUEST/ACK (stops at OFFER), this work could not be used to assign any address.

- Bernie

-----Original Message-----
From: dhcwg <[email-masked]> On Behalf Of [email-masked]
Sent: Tuesday, December 10, 2019 5:32 AM
To: Jen Linkova <[email-masked]>; [email-masked]
Cc: V6 Ops List <[email-masked]>
Subject: Re: [dhcwg] Fwd: New Version Notification for draft-link-dhc-v6only-01.txt

Hi Jen,

==

While yours is: 

==

==

====

Cheers,
Med

> Envoyé : mardi 10 décembre 2019 01:02 À : [email-masked] Cc : V6 Ops 
> List Objet : [dhcwg] Fwd: New Version Notification for 
> draft-link-dhc-v6only- 01.txt
> 
> Hello,
> 
> A new version of I-D, draft-link-dhc-v6only-01.txt has been 
> successfully submitted by Jen Linkova and posted to the IETF 
> repository.
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at 
> tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> --

---

From: Ted Lemon <[email-masked]>
Date: Tue, 10 Dec 2019 08:39:21 -0800

I really think you should have a clear justification for doing anything other than returning 0.0.0.0.   Anything else is going to be more complicated in the long term.   The justification “because 0.0.0.0 would be filtered out by the server” seems like it’s very implementation-dependent and not really that big a deal.   Is that your only reason?

> On Dec 10, 2019, at 8:11 AM, Bernie Volz (volz) <[email-masked]> wrote:
> 
> Hi:
> 
> Is (8):
> 
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 10 Dec 2019 16:53:30 +0000

I've debated that issue on end and not going to do it any further. I completely disagree - server should return whatever it would have returned if the option is were not present.

- Bernie

---

From: Ted Lemon <[email-masked]>
Date: Tue, 10 Dec 2019 09:09:35 -0800

> I've debated that issue on end and not going to do it any further. I completely disagree - server should return whatever it would have returned if the option is were not present.

How about “server SHOULD return 0.0.0.0; server MAY return some other bogus address, which the client MUST ignore”?   The reason I’m hassling you about this is that you have a very specific solution in mind, and it’s not a long-term solution.   I don’t mind accommodating your solution, but I don’t want to be married to it for the rest of eternity.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 10 Dec 2019 17:16:32 +0000

> From: Ted Lemon
> 
> I really think you should have a clear justification for doing anything other
> than returning 0.0.0.0.   Anything else is going to be more complicated in the
> long term.   The justification “because 0.0.0.0 would be filtered out by the
> server” seems like it’s very implementation-dependent and not really that
> big a deal.   Is that your only reason?

Some CE routers are coded to have special handling for 0.0.0.0. Multiple ISPs use that address for IPTV multicast traffic (on a VLAN dedicated to that traffic). I could envision such routers having issues with getting 0.0.0.0 from DHCPv4. CE router vendors and their chipset vendors do the darnedest things sometimes (as Cloudflare discovered wrt 1.1.1.1).  I think widespread testing of CE routers is needed if the returned address is going to be required to 0.0.0.0. 

Here is language from BBF TR-124 (requirement LAN.IGMP.ROUTED): "It MUST be possible to configure a WAN-facing IPv4 interface with an IPoE encapsulation and no IPv4 address visible by the access network. It MUST be possible to receive multicast traffic on such an interface, independent of whether upstream IGMP is sent on this interface or not. The RG's IGMP proxy-routing function MUST be able to send upstream IGMP traffic on such an interface, using an unspecified (0.0.0.0/::) IPv4 source address."

I'm leaning toward not over-specifying what address gets returned.
Barbara

> > 	(8) Consider returning an address from the range defined in RFC7335
> for IPv6-only hosts. Such IPv4 addresses are required anyway for some IPv6-
> only hosts (those with a CLAT for example).
> >
> > 	====
> > So, this address is only used "on the host" (not on the wire), so why would
> there be any need for the DHCP server to assign this address?
> >
> > And as the IPv6-only option means that the host never completes the
> DHCPDISCOVER/OFFER/REQUEST/ACK (stops at OFFER), this work could not
> be used to assign any address.
> >
> > - Bernie
> >
> > Thank you for sharing this updated version. Below some points that I do
> think need more clarification in the I-D:
> >
> > (1) The document is too NAT64 centric. The proposal may apply as well for
> other IPv6-only deployment scenarios (typically, unmanaged IPv6-only CPEs
> with IPv4aaS).
> >
> > (2) A discussion on the benefit of this extra signal compared to relying on
> existing signals (pref64, aftr_name, map_container...). For example, a host
> that supports the option is ready to wait at minimum 300s and disable its IPv4
> configuration regardless of what is happening on the IPv6 leg. How is that
> superior to a host delaying DHCP process by xxx ms should be explained
> further.
> >
> > * I guess the default value when the option is supported by a host is to
> disable including it in the request. The document should include a discussion
> on the default behavior.
> > * If an explicit action is needed from the user to enable including the
> option, having a discussion to what extent the feature is likely to be enabled
> would be needed.
> >
> > If so, the following definition should be updated to refer to "IPv4
> connectivity" rather than "IPv4" in general. This is because an IPv4 address is
> required for CLAT for example.
> >
> > ==
> > (8) Consider returning an address from the range defined in RFC7335 for
> IPv6-only hosts. Such IPv4 addresses are required anyway for some IPv6-only
> hosts (those with a CLAT for example).
> >
> > ====
> >> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_internet-2Ddrafts_draft-2Dlink-2Ddhc-2Dv6only-
> 2D01.txt&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=33aAfD-_FR1KRE0V6ypGFDGQdX-
> 9KUziTA0aOUPM_fc&s=DzE8klltpk82gJ3XzwS9A8PiHNYR2q402g8UWh8Xt2U
> &e=
> >> Status:         https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dlink-2Ddhc-
> 2Dv6only_&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=33aAfD-_FR1KRE0V6ypGFDGQdX-
> 9KUziTA0aOUPM_fc&s=FBjuCqg_Ixxezn9-
> uLWOLklYsoQIldbHPwLSnrlQJFQ&e=
> >> Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dlink-2Ddhc-2Dv6only-
> 2D01&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=33aAfD-_FR1KRE0V6ypGFDGQdX-
> 9KUziTA0aOUPM_fc&s=_t-
> fCYtxlOU9YxIBkkb7oscAi6CY_02zzn1qqNOuo0Q&e=
> >> Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_html_draft-2Dlink-2Ddhc-
> 2Dv6only&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=33aAfD-_FR1KRE0V6ypGFDGQdX-
> 9KUziTA0aOUPM_fc&s=bJXJbD0K1NOH_N4nGk96SdlvK8QCFJyAKK6gU0dPtr
> E&e=
> >> Diff:           https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dlink-2Ddhc-2Dv6only-
> 2D01&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8Tq4vrfog&m=33aAfD-_FR1KRE0V6ypGFDGQdX-
> 9KUziTA0aOUPM_fc&s=IPcu30Gmr2x1twxcRh4EnDeO_ojo0HmPxDuZnO9oIF
> 4&e=
> >>
> >> Abstract:
> >> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mai
> >> lman_listinfo_dhcwg&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY
> >> 8Tq4vrfog&m=33aAfD-_FR1KRE0V6ypGFDGQdX-
> 9KUziTA0aOUPM_fc&s=AstqYdooWFy
> >> nLiqa7N_ScMghbhhKVAmCSZ8xOiJ6jfM&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> > man_listinfo_dhcwg&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8T
> > q4vrfog&m=33aAfD-_FR1KRE0V6ypGFDGQdX-
> 9KUziTA0aOUPM_fc&s=AstqYdooWFynLi
> > qa7N_ScMghbhhKVAmCSZ8xOiJ6jfM&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> > man_listinfo_v6ops&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-
> 8sc8SY8T
> > q4vrfog&m=33aAfD-_FR1KRE0V6ypGFDGQdX-
> 9KUziTA0aOUPM_fc&s=oCMmIfgiQWTZbA
> > 6Rx5Lakxg6tbO2d2vg5h9asQ6lnZk&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_dhcwg&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=33aAfD-
> _FR1KRE0V6ypGFDGQdX-
> 9KUziTA0aOUPM_fc&s=AstqYdooWFynLiqa7N_ScMghbhhKVAmCSZ8xOiJ6jf
> M&e=

---

From: David Farmer <[email-masked]>
Date: Tue, 10 Dec 2019 11:24:17 -0600

Bernie,

Could you provide a couple of pointers to threads where the 0.0.0.0 address
issue was discussed?

I would like to better understand the issues around using 0.0.0.0 as the
address returned, with making you re-debate the issue.

Thanks

On Tue, Dec 10, 2019 at 10:53 AM Bernie Volz (volz) <[email-masked]> wrote:

> I've debated that issue on end and not going to do it any further. I
> completely disagree - server should return whatever it would have returned
> if the option is were not present.
>
> - Bernie
>
> Cc: [email-masked]; Jen Linkova <[email-masked]>;
> [email-masked]; V6 Ops List <[email-masked]>
> I really think you should have a clear justification for doing anything
> other than returning 0.0.0.0.   Anything else is going to be more
> complicated in the long term.   The justification “because 0.0.0.0 would be
> filtered out by the server” seems like it’s very implementation-dependent
> and not really that big a deal.   Is that your only reason?
>
> >       (8) Consider returning an address from the range defined in
> RFC7335 for IPv6-only hosts. Such IPv4 addresses are required anyway for
> some IPv6-only hosts (those with a CLAT for example).
> >
> >       ====
> > So, this address is only used "on the host" (not on the wire), so why
> would there be any need for the DHCP server to assign this address?
> >
> DHCPDISCOVER/OFFER/REQUEST/ACK (stops at OFFER), this work could not be
> used to assign any address.
> >
> > - Bernie
> >
> > (1) The document is too NAT64 centric. The proposal may apply as well
> for other IPv6-only deployment scenarios (typically, unmanaged IPv6-only
> CPEs with IPv4aaS).
> >
> > (2) A discussion on the benefit of this extra signal compared to relying
> on existing signals (pref64, aftr_name, map_container...). For example, a
> host that supports the option is ready to wait at minimum 300s and disable
> its IPv4 configuration regardless of what is happening on the IPv6 leg. How
> is that superior to a host delaying DHCP process by xxx ms should be
> explained further.
> >
> disable including it in the request. The document should include a
> discussion on the default behavior.
> option, having a discussion to what extent the feature is likely to be
> enabled would be needed.
> >
> connectivity" rather than "IPv4" in general. This is because an IPv4
> address is required for CLAT for example.
> >
> > ==
> >> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-link-dhc-v6only
> >> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-link-dhc-v6only-01
> >>
> >> Abstract:

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 10 Dec 2019 18:08:00 +0000

You can probably see much of the discussion by going to https://mailarchive.ietf.org/arch/browse/dhcwg/?q=0.0.0.0 (search DHC WG mailing list for 0.0.0.0) – just look at the recent emails from December 2019.

BTW: I am personally done debating the issue (this is not a DHC WG co-chair statement related to the WG discussion), but just that I am done debating this myself (as there’s little point in repeating my arguments). It will be up to the WG to decide (via rough consensus) as to what ends up in the document if it is adopted.

  *   Bernie

From: David Farmer <[email-masked]>
Date: Tuesday, December 10, 2019 at 12:24 PM
To: Bernie Volz <[email-masked]>
Cc: Ted Lemon <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [v6ops] [dhcwg] Fwd: New Version Notification for draft-link-dhc-v6only-01.txt

Bernie,

Could you provide a couple of pointers to threads where the 0.0.0.0 address issue was discussed?

I would like to better understand the issues around using 0.0.0.0 as the address returned, with making you re-debate the issue.

Thanks

On Tue, Dec 10, 2019 at 10:53 AM Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:
I've debated that issue on end and not going to do it any further. I completely disagree - server should return whatever it would have returned if the option is were not present.

- Bernie

-----Original Message-----
From: Ted Lemon <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, December 10, 2019 11:39 AM
To: Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Jen Linkova <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; V6 Ops List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [v6ops] [dhcwg] Fwd: New Version Notification for draft-link-dhc-v6only-01.txt

> On Dec 10, 2019, at 8:11 AM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi:
>
> Is (8):
>
>          The result is that 192.0.0.0/29<http://192.0.0.0/29> may be used in any system
>   IANA has defined a well-known range, 192.0.0.0/29<http://192.0.0.0/29>, in [RFC6333],
>   and effective to generalize 192.0.0.0/29<http://192.0.0.0/29> for the use of supporting
> From: dhcwg <[email-masked]<mailto:[email-masked]>> On Behalf Of
> [email-masked]<mailto:[email-masked]>
> To: Jen Linkova <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> Cc: V6 Ops List <[email-masked]<mailto:[email-masked]>>
>   The result is that 192.0.0.0/29<http://192.0.0.0/29> may be used in any system
>> De : dhcwg [mailto:[email-masked]<mailto:[email-masked]>] De la part de Jen Linkova
>> Envoyé : mardi 10 décembre 2019 01:02 À : [email-masked]<mailto:[email-masked]> Cc : V6 Ops
>> From: <[email-masked]<mailto:[email-masked]>>
>> To: Tomek Mrugalski <[email-masked]<mailto:[email-masked]>>, Lorenzo Colitti
>> <[email-masked]<mailto:[email-masked]>>, Jen Linkova <[email-masked]<mailto:[email-masked]>>, Michael C.
>> Richardson <[email-masked]<mailto:[email-masked]>>
>>
>>
>>
>> tools.ietf.org<http://tools.ietf.org>.
>>
>> The IETF Secretariat
>>
>>
>> --
>> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
v6ops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/v6ops

David Farmer               Email:[email-masked]<mailto:[email-masked]>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 10 Dec 2019 10:21:11 -0800

> Some CE routers are coded to have special handling for 0.0.0.0. Multiple ISPs use that address for IPTV multicast traffic (on a VLAN dedicated to that traffic). I could envision such routers having…

The idea here is that the returned address is bogus and won’t work.   So if the CE router tries to use it for anything, it’s going to break, whether it’s 0.0.0.0 or 192.0.0.0.

> Here is language from BBF TR-124 (requirement LAN.IGMP.ROUTED): "It MUST be possible to configure a WAN-facing IPv4 interface with an IPoE encapsulation and no IPv4 address visible by the access network. It MUST be possible to receive multicast traffic on such an interface, independent of whether upstream IGMP is sent on this interface or not. The RG's IGMP proxy-routing function MUST be able to send upstream IGMP traffic on such an interface, using an unspecified (0.0.0.0/::) IPv4 source address.”

I don’t think this would be violated.   Is DHCPv4 currently configuring an address of 0.0.0.0 for IGMP to use?  :)

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 10 Dec 2019 19:41:11 +0000

On Dec 10, 2019, at 9:16 AM, STARK, BARBARA H <[email-masked]<mailto:[email-masked]>> wrote:
Some CE routers are coded to have special handling for 0.0.0.0. Multiple ISPs use that address for IPTV multicast traffic (on a VLAN dedicated to that traffic). I could envision such routers having issues with getting 0.0.0.0 from DHCPv4. CE router vendors and their chipset vendors do the darnedest things sometimes (as Cloudflare discovered wrt 1.1.1.1).  I think widespread testing of CE routers is needed if the returned address is going to be required to 0.0.0.0.

Consider the possibility of a CE router that says: “Proper DHCP servers don’t send bogus addresses. I’m receiving a bogus address from this DHCP server. That means this DHCP server must be compromised, which means the network is compromised, which means I can trust nothing on this network. I shall now (choice A) cease all communication with this network; (or choice B) continue to send DHCPv4 messages frequently until I get one that has a non-bogus address.” We just don’t know. We had no idea that there were chipsets in routers with chipset firmware that considered messages to/from 1.1.1.1 a threat and a security violation. It’s important not to assume that routers are tolerant of 0.0.0.0 in DHCP responses. I think whoever wants 0.0.0.0 mandated or preferred needs to be the one to prove that it would not cause harm, because I’m not seeing evidence of real benefit of such normative language. If the IP address(es) to return are left up to the deployer, then the deployer can make sure whatever they do works in their network, with their server and middleboxes and whatever clients are attaching. [BTW, Ted, I’m having to change my email client settings every time to have different rules for responses to text vs. html/rich text – this is IETF, darn it, so we should all be using plain text; personal experiment over; rules favoring plain text are staying and no more switching options to satisfy people who don’t reply to text with text.]

---

From: Ted Lemon <[email-masked]>
Date: Tue, 10 Dec 2019 11:44:22 -0800

On Dec 10, 2019, at 11:41 AM, STARK, BARBARA H <[email-masked]> wrote:
> Consider the possibility of a CE router that says: “Proper DHCP servers don’t send bogus addresses. I’m receiving a bogus address from this DHCP server. That means this DHCP server must be compromised, which means the network is compromised, which means I can trust nothing on this network. 

That DHCP client would be a DHCP client that doesn’t implement the specification, since the specification would say MUST accept yiaddr=0.0.0.0 when in v6-only mode.   That client would not be asking for the v6-only option, and hence would never see a yiaddr of 0.0.0.0.

---

From: <[email-masked]>
Date: Wed, 11 Dec 2019 06:28:18 +0000

Hi Bernie, 

Please see inline. 

Cheers,
Med

> De : Bernie Volz (volz) [mailto:[email-masked]]
> Envoyé : mardi 10 décembre 2019 17:11
> À : BOUCADAIR Mohamed TGI/OLN; Jen Linkova; [email-masked]
> Cc : V6 Ops List
> Objet : RE: [dhcwg] Fwd: New Version Notification for draft-link-dhc-
> v6only-01.txt
> 
> Hi:
> 
> Is (8):
> 

[Med] This is to ease remote troubleshooting of the IPv4aaS component (CLAT, B4) of the IPv6-only host. Controlling the IPv4 address configured locally allows to make use of tools such as PROBE (https://tools.ietf.org/html/rfc8335) to remotely assess the status of the IPv4aaS component via an IPv6 network.

> that supports the option is ready to wait at minimum 300s and disable its
> IPv4 configuration regardless of what is happening on the IPv6 leg. How is
> that superior to a host delaying DHCP process by xxx ms should be explained
> further.
>

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 11 Dec 2019 11:20:06 +0000

Not sure how this is supposed to work today (is this documented somewhere)? Is dhcp server already assigning addresses in the special range? If so, why not continue that practice and don’t honor the ipv6-only option on server.

- Bernie

> On Dec 11, 2019, at 1:28 AM, "[email-masked]" <[email-masked]> wrote:
> 
> Hi Bernie, 
> 
> Please see inline. 
> 
> Cheers,
> Med
>

---

From: <[email-masked]>
Date: Wed, 11 Dec 2019 12:48:57 +0000

Re-,

Please see inline. 

Cheers,
Med

> Envoyé : mercredi 11 décembre 2019 12:20
> À : BOUCADAIR Mohamed TGI/OLN
> Cc : Jen Linkova; [email-masked]; V6 Ops List
> Objet : Re: [dhcwg] Fwd: New Version Notification for draft-link-dhc-
> v6only-01.txt
> 
> Not sure how this is supposed to work today (is this documented somewhere)?
> Is dhcp server already assigning addresses in the special range?

[Med] DHCP servers are not used today to assign these addresses. The selection of the address is local to the host. There is no ambiguity for some IPv4aaS techniques (DS-Lite uses 192.0.0.2) but not for CLAT (192.0.0.0/29).

 If so, why
> not continue that practice and don’t honor the ipv6-only option on server.

[Med] That wouldn't work because my proposal is for the server to return the ** same ** address to all requesting hosts with ipv6-only enabled. That address will be passed to modules such as CLAT. This behavior is already required by this draft: 

   As an optional optimization an IPv6-mostly pool MAY be configured
   with a dedicated IPv4 address to be returned to IPv6-only capable
   clients.  In that case the server SHOULD specify that address as the
   client's network address and MUST NOT verify its uniqueness.
                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

The value I see in returning an address from this well-known range is that the host does not even need to pause, i.e., this text won't be required anymore in the draft: 

==
If the
   IPv6-only Preferred option returned by the server contains non-zero
   value the client SHOULD set the V6ONLY_WAIT timer to that value.  If
   the server returns zero value the client MUST use its own
   configuration for V6ONLY_WAIT timer.  The client SHOULD stop the DHCP
   configuration process for at least V6ONLY_WAIT seconds or until a
   network attachment event happens.  The host MAY disable IPv4 stack
   completely for V6ONLY_WAIT seconds or until the network disconnection
   event happens.
==

The host won't emit IPv4 packets "on the wire" when assigned with such address.

> would
> > [Med] This is to ease remote troubleshooting of the IPv4aaS component
> (CLAT, B4) of the IPv6-only host. Controlling the IPv4 address configured
> locally allows to make use of tools such as PROBE
> (https://tools.ietf.org/html/rfc8335) to remotely assess the status of the
> IPv4aaS component via an IPv6 network.
> >
> >>
> for
> on
> >> Also, how the host is able to assess/determine that it is (not) capable
> to
> >> behave in the IPv6 mode?
> >>
> >> (5) The definition of IPv4aaS is not aligned with other RFCs: e.g.,
> RFC8585
> >> says the following:
> >>
> >>> Diff:           https://www.ietf.org/rfcdiff?url2=draft-link-dhc-
> v6only-
> >> 01
> >>>
> >>> Abstract:

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 11 Dec 2019 13:30:06 +0000

Med:

If this option is in play, no address is "assigned" to the client as that requires the DHCPREQUEST/DHCPACK messages and the client "stops" after a DHCPOFFER if the option was returned. So, you can't use this if you want to assign an address.

I'm not sure what is being done today:
1) Are you saying there is no support for this in DHCP. If so, then this is not something that can be used to activate this support.
2) Are you saying that it works fine as is today (since the DHCP server can be configured (somehow) to return this). If so, then don't use the option (at least on the server for the pools).

I think your request is different than this ipv6-only option. So, if you feel that something is needed, feel free to write a draft (likely it would require a new option that the server is told to do this special behavior).

- Bernie

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Wednesday, December 11, 2019 7:49 AM
To: Bernie Volz (volz) <[email-masked]>
Cc: Jen Linkova <[email-masked]>; [email-masked]; V6 Ops List <[email-masked]>
Subject: RE: [dhcwg] Fwd: New Version Notification for draft-link-dhc-v6only-01.txt

Re-,

Please see inline. 

Cheers,
Med

> De : Bernie Volz (volz) [mailto:[email-masked]] Envoyé : mercredi 11 
> décembre 2019 12:20 À : BOUCADAIR Mohamed TGI/OLN Cc : Jen Linkova; 
> [email-masked]; V6 Ops List Objet : Re: [dhcwg] Fwd: New Version 
> Notification for draft-link-dhc- v6only-01.txt
> 

 If so, why

==
If the

> >> De : Bernie Volz (volz) [mailto:[email-masked]] Envoyé : mardi 10 
> >> décembre 2019 17:11 À : BOUCADAIR Mohamed TGI/OLN; Jen Linkova; 
> >> [email-masked] Cc : V6 Ops List Objet : RE: [dhcwg] Fwd: New 
> >> Version Notification for draft-link-dhc- v6only-01.txt
> >>
> >> Hi:
> >>
> >> Is (8):
> >>
> >> RFC7335 for IPv6-only hosts. Such IPv4 addresses are required 
> >> anyway for some
> IPv6-
> (CLAT, B4) of the IPv6-only host. Controlling the IPv4 address 
> configured locally allows to make use of tools such as PROBE
> (https://tools.ietf.org/html/rfc8335) to remotely assess the status of 
> the IPv4aaS component via an IPv6 network.
> >
> >>
> >> DHCPDISCOVER/OFFER/REQUEST/ACK (stops at OFFER), this work could 
> >> not be used to assign any address.
> >>
> >> - Bernie
> >>
> >> Subject: Re: [dhcwg] Fwd: New Version Notification for 
> >> draft-link-dhc- v6only-01.txt
> >>
> >> Hi Jen,
> >>
> >> Thank you for sharing this updated version. Below some points that 
> >> I do think need more clarification in the I-D:
> >>
> >> other IPv6-only deployment scenarios (typically, unmanaged 
> >> IPv6-only
> CPEs
> >> with IPv4aaS).
> >>
> >> existing signals (pref64, aftr_name, map_container...). For 
> >> example, a
> host
> >> that supports the option is ready to wait at minimum 300s and 
> >> disable
> its
> >> IPv4 configuration regardless of what is happening on the IPv6 leg. 
> >> How
> is
> >> (3) How "IPv6-only preferred" mode is supposed to be set at the 
> >> host
> side:
> >>
> >> ==
> >> * I guess the default value when the option is supported by a host 
> >> is to disable including it in the request. The document should 
> >> include a discussion on the default behavior.
> >> * If an explicit action is needed from the user to enable including 
> >> the option, having a discussion to what extent the feature is 
> >> likely to be enabled would be needed.
> >>
> >> connectivity" rather than "IPv4" in general. This is because an 
> >> IPv4 address is required for CLAT for example.
> >>
> >> ==
> >>> De : dhcwg [mailto:[email-masked]] De la part de Jen 
> >>> Linkova Envoyé : mardi 10 décembre 2019 01:02 À : [email-masked] 
> >>> Cc : V6 Ops List Objet : [dhcwg] Fwd: New Version Notification for
> >>> - The option is not zero length anymore. It has 4-bytes value 
> >>> which might contain V6ONLY_WAIT timer. Benefits:
> >>> - Using a dedicated address to return to clients is now an 
> >>> optional optimisation. By default the server is expected just to 
> >>> return a random address (as usual).
> >>>

---

From: <[email-masked]>
Date: Wed, 11 Dec 2019 14:12:57 +0000

Re-,

The draft says the following: 

   The client SHOULD stop the DHCP
   configuration process for at least V6ONLY_WAIT seconds or until a
   network attachment event happens.

While I interpret your response as: 

   The client MUST stop the DHCP
   configuration process for at least V6ONLY_WAIT seconds or until a
   network attachment event happens.

Bernie, OK to close (8) from my initial review list.  

Cheers,
Med

> Envoyé : mercredi 11 décembre 2019 14:30
> If this option is in play, no address is "assigned" to the client as that
> requires the DHCPREQUEST/DHCPACK messages and the client "stops" after a
> DHCPOFFER if the option was returned. So, you can't use this if you want to
> assign an address.
> 
> 1) Are you saying there is no support for this in DHCP. If so, then this is
> not something that can be used to activate this support.
> 2) Are you saying that it works fine as is today (since the DHCP server can
> be configured (somehow) to return this). If so, then don't use the option
> (at least on the server for the pools).
> 
> I think your request is different than this ipv6-only option. So, if you
> feel that something is needed, feel free to write a draft (likely it would
> require a new option that the server is told to do this special behavior).
> 
> - Bernie
> 
> [Med] DHCP servers are not used today to assign these addresses. The
> selection of the address is local to the host. There is no ambiguity for
> some IPv4aaS techniques (DS-Lite uses 192.0.0.2) but not for CLAT
> (192.0.0.0/29).
> 
>  If so, why
> [Med] That wouldn't work because my proposal is for the server to return
> the ** same ** address to all requesting hosts with ipv6-only enabled. That
> address will be passed to modules such as CLAT. This behavior is already
> required by this draft:
> 
> The value I see in returning an address from this well-known range is that
> the host does not even need to pause, i.e., this text won't be required
> anymore in the draft:
> 
> ==
> If the
> > >>   Router (AFTR) and never emits packets from this prefix "on the
> wire".
> > >> <---