Subject: [v6ops] IPv6-only Terminology Definition

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 09 Mar 2020 19:47:46 +0100

Hi all,

After the recent discussion, I've posted a new version (minor changes) for this document:

https://datatracker.ietf.org/doc/draft-palet-v6ops-ipv6-only/?include_text=1

Comments welcome!

Regards,
Jordi
@jordipalet

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Fred Baker <[email-masked]>
Date: Wed, 11 Mar 2020 23:57:20 -0700

Section 2, fourth paragraph.

   However, the "end-networks", in general, need to continue supporting
   IPv4, as there are many devices or apps, in both corporate and end-
   user networks (smartTV, IP cameras, etc.), which are IPv4-only and it
   is not always feasible to update or replace them.  Also if customer
   devices in a LAN are IPv6-only, they will not be able to access
   IPv6-only services, so this means that IPv6-only services can't be
   deployed unless it is done in such way that some transition mechanism
   solves that problem as well (example an IPv6-only Data Center,
   requires SIIT-DC)

I don't understand why an IPv6-only device would not be able to access an IPv6-only services. I can understand IPv4-only devices not being able to access IPv6-only services, but that's not the statement. This paragraph seems to not follow.

> On Mar 9, 2020, at 11:47 AM, JORDI PALET MARTINEZ <jordi.palet=[email-masked]> wrote:
> 
> Hi all,
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 12 Mar 2020 11:44:43 +0100

Yes, sorry, there is a typo there.

       devices in a LAN are ***IPv4-only***, they will not be able to access

I've corrected in my internal draft v-06, but will wait for more inputs before publishing it.

Or maybe we could even consider a call for WG adoption?

Thanks for spotting it!

El 12/3/20 7:58, "v6ops en nombre de Fred Baker" <[email-masked] en nombre de [email-masked]> escribió:

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 12 Mar 2020 12:59:43 +0100

> Or maybe we could even consider a call for WG adoption?

If call for adoption there is, I will be supportive.

As usual, I will suggest to say somewhere in an appendix or so, that a 
possible definition of IPv6-only is "no IPv4 stack in linux kernel, 
unchecked IPv4 in Windows interface properties, no A entry in DNS and no 
127.0.0.1 in /etc/hosts".

I would also suggest the use of the term IPv4-only, in a similar 
mannner.  Or maybe one wants to be silent about IPv4-only.

Finally, from an earlier conversation I remember the term "double stack" 
which would be clearer than the existing but ambiguous "dual stack".

Alex

---

From: Fred Baker <[email-masked]>
Date: Thu, 12 Mar 2020 17:48:16 -0700

Right now, as always, I’m looking for supportive working group commentary.

Sent using a machine that autocorrects in interesting ways...

> On Mar 12, 2020, at 3:45 AM, JORDI PALET MARTINEZ <jordi.palet=[email-masked]> wrote:
>