Subject: [v6ops] About Req for Comments - "Transition to IPv6"

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 5 Mar 2020 13:13:06 +0100

I learned from an IPv6 old timer at an ITU meeting about this "Request
for Comments on Updated Guidance for Completing the Transition to the
Next Generation Internet Protocol, Internet Protocol Version 6 (IPv6)"

https://www.federalregister.gov/documents/2020/03/02/2020-04202/request-for-comments-on-updated-guidance-for-completing-the-transition-to-the-next-generation

It mainly concerns organisations in the United States of America, but
they seek 'public' comment in 30 days, which amounts to about everyone,
I think.

One comment that I would like to make is to better explain what
IPv6-only is.  To distinguish from the IPv6-only claimed in some cases,
at mobile operators, which is carried by IPv4 in fact.  And to comment
that I hope that Request for Comments' hope of transition to IPv6 is
pure IPv6 not carried by IPv4.

I could send that comment to the indicated email address
"[email-masked]" but I suppose there might be some risk of that
message getting lost.

Alex

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 05 Mar 2020 13:25:38 +0100

This is why I've insisted several times in having a document describing what is IPv6-only ...

I can update it again if the WG is interested ...

https://tools.ietf.org/html/draft-palet-v6ops-ipv6-only-04

El 5/3/20 13:13, "v6ops en nombre de Alexandre Petrescu" <[email-masked] en nombre de [email-masked]> escribió:

    

    
    Alex
    
    _______________________________________________
    v6ops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/v6ops

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 5 Mar 2020 14:07:51 +0100

> https://tools.ietf.org/html/draft-palet-v6ops-ipv6-only-04

To me it might make sense to start from there.

At this time, although I can click on the URL, it leads to a phrase "The 
attached draft memorandum prepared by the Office of Management and 
Budget, in collaboration with the Federal Chief Information Officers 
Council and Federal Chief Information Security Officers Council, 
supports the Administration’s goals for modernizing Federal Information 
Technology".  I can not find that 'draft memorandum'.

I can not find precisely what are the questions to comment on.  Or there 
might be no precise question, just an overall indication of ambition.

Alex

---

From: Morizot Timothy S <[email-masked]>
Date: Thu, 5 Mar 2020 13:33:26 +0000

Since the formal request for comment has been published on the federal register, a direct link to the draft as published on the Federal CIO website (within OMB) might facilitate review and comment. I see some confusion about how to read the draft memorandum itself.

https://www.cio.gov/assets/resources/internet-protocol-version6-draft.pdf

HTH,

Scott

-----Original Message-----
From: v6ops <[email-masked]> On Behalf Of Alexandre Petrescu
Sent: Thursday, March 5, 2020 7:08 AM
To: [email-masked]
Subject: Re: [v6ops] About Req for Comments - "Transition to IPv6"

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 5 Mar 2020 15:02:43 +0100

Thank you very much for the pointer.  In it I could spot
the following footnote: "[4] IPv6-Only refers to network environments in
which use of the IPv4 protocol has been eliminated."

In my humble opinion,

I think, if I am not wrong, that there are no such networks in which
IPv4 protocol has been eliminated.  On one hand, a network is made of
computers, and IPv4 stacks are still present in almost all computers.
On another hand, there might be some ptp links (not networks, but
individual links) that run IPv6 only.

That is why it is hard to agree on the assumption of IPv4 being 
eliminated somewhere.  Worse, it makes look as if the goal of that 
'IPv6-only' is to arrive at that same situation which in fact does use IPv4.

There is a draft at IETF in this v6ops WG, about the term 'IPv6-only'.
We could improve that draft.  We could refer to it as well.

Further, in this Req for Comments 'Transition to IPv6' this text makes 
me think they set the wrong goal:
> In fact, many of these organizations have migrated, or are planning 
> to migrate, to “IPv6-only”4 infrastructures to reduce operational 
> concerns associated with maintaining two distinct network 
> infrastructures. The intent of this updated memorandum is to 
> communicate the requirements for completing the operational 
> deployment of IPv6 across all Federal information systems and 
> services, and help agencies overcome barriers that prevent them from 
> migrating to IPv6-only systems. Going forward, the Federal
> government plans to deliver its information services, operate its
> networks, and access the services of others using only IPv6.

The guidance would, better, make think about the removal of the IPv4
stack.  For example, uncheck the IPv4 box in Windows ethernet interface
properties, or remove 127.0.0.1 from /etc/hosts, remove A entries from
DNS, or similar.  These are criteria easily checked by more people.

In my humble opinion.

Alex

Le 05/03/2020 à 14:33, Morizot Timothy S a écrit :
> Since the formal request for comment has been published on the 
> federal register, a direct link to the draft as published on the 
> Federal CIO website (within OMB) might facilitate review and comment.
> I see some confusion about how to read the draft memorandum itself.
> 
HTH,
> 
> Scott
> 
> -----Original Message----- From: v6ops <[email-masked]> On 
> Behalf Of Alexandre Petrescu Sent: Thursday, March 5, 2020 7:08 AM 
> To: [email-masked] Subject: Re: [v6ops] About Req for Comments - 
> "Transition to IPv6"
> 
> 
> 
> At this time, although I can click on the URL, it leads to a phrase 
> "The attached draft memorandum prepared by the Office of Management 
> and Budget, in collaboration with the Federal Chief Information 
> Officers Council and Federal Chief Information Security Officers 
> Council, supports the Administration’s goals for modernizing Federal
>  Information Technology".  I can not find that 'draft memorandum'.
> 
> I can not find precisely what are the questions to comment on.  Or 
> there might be no precise question, just an overall indication of 
> ambition.
> 
> Alex
> 
> _______________________________________________ v6ops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Erik Kline <[email-masked]>
Date: Thu, 5 Mar 2020 08:38:06 -0800

Eliminating IPv4 implies eliminating the use of IPv4.

Eliminating the *use* of IPv4 does not imply eliminating IPv4.

I don't see any real problem here.  Maybe they *want* the vagueness (i.e.
absence of over-specificity) to have some grey area to support NAT64/DNS64
(or maybe even 464xlat).

---

From: Owen DeLong <[email-masked]>
Date: Thu, 5 Mar 2020 08:46:03 -0800

> On Mar 5, 2020, at 6:02 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> which use of the IPv4 protocol has been eliminated.”

No.

IPv6-Only refers to network environments which are not using IPv4. That could be a network where IPv4 has been eliminated (rare at this time, though Facebook is a significant example) or it could be a greenfield deployment where IPv4 was never deployed.

> individual links) that run IPv6 only.

You are wrong… There are examples at various levels of IPv6-only networks. Many mobile carriers are IPv6-only in the US, though they do provide some apparent IPv4 capability to the end user through mechanisms such as 464XLAT and/or NAT64.

Another significant example is Facebook where they are essentially IPv6-only throughout their network and provide minimal IPv4 translation shim at the edge to cope with end users that lack IPv6 capability.

> That is why it is hard to agree on the assumption of IPv4 being eliminated somewhere.  Worse, it makes look as if the goal of that 'IPv6-only' is to arrive at that same situation which in fact does use IPv4.

As a general rule, once IPv6 is ubiquitously deployed in a network, the preservation of IPv4 in the majority of that network becomes an unnecessary cost factor and a security risk (increased attack surface, if nothing else). As such, I think you will see an increasing number of organizations follow on to the way Facebook has managed their transition and start eliminating IPv4 wherever possible and replacing it with translation shims as far out towards the border as practical.

Owen

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 5 Mar 2020 17:48:25 +0100

Le 05/03/2020 à 17:38, Erik Kline a écrit :
> I don't see any real problem here.  Maybe they *want* the vagueness 
> (i.e. absence of over-specificity)

Indeed.

It might be better to progress along the lines of that 'IPv6 only' even
though that might mean some IPv4 too, than to not progress.  I agree.

> to have some grey area to support NAT64/DNS64 (or maybe even
> 464xlat).

I bet that if they wrote 'NAT64' themselves then they'd wonder about the 
presence of '4'.

So, I guess we might ask them whether they understand that 'IPv6-only' 
requires NAT64 which requires 4 which is IPv4.

Alex

> 
> On Thu, Mar 5, 2020 at 6:03 AM Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> 
> Thank you very much for the pointer.  In it I could spot the
> following footnote: "[4] IPv6-Only refers to network environments in 
> IPv4 protocol has been eliminated.  On one hand, a network is made
> of computers, and IPv4 stacks are still present in almost all
> computers. On another hand, there might be some ptp links (not
> networks, but individual links) that run IPv6 only.
> 
> There is a draft at IETF in this v6ops WG, about the term
> 'IPv6-only'. We could improve that draft.  We could refer to it as
> well.
> 
> Further, in this Req for Comments 'Transition to IPv6' this text
> makes me think they set the wrong goal:
>> In fact, many of these organizations have migrated, or are
>> planning to migrate, to “IPv6-only”4 infrastructures to reduce
>> operational concerns associated with maintaining two distinct
>> network infrastructures. The intent of this updated memorandum is
>> to communicate the requirements for completing the operational 
>> services, and help agencies overcome barriers that prevent them
>> from migrating to IPv6-only systems. Going forward, the Federal 
> stack.  For example, uncheck the IPv4 box in Windows ethernet
> interface properties, or remove 127.0.0.1 from /etc/hosts, remove A
> entries from DNS, or similar.  These are criteria easily checked by
> more people.
> 
> In my humble opinion.
> 
> Alex
> 
> 
>> Federal CIO website (within OMB) might facilitate review and
>> comment. I see some confusion about how to read the draft
>> memorandum itself.
>> 
>> 
>> -----Original Message----- From: v6ops <[email-masked]
> <mailto:[email-masked]>> On
>> To: [email-masked] <mailto:[email-masked]> Subject: Re: [v6ops]
> About Req for Comments -
>> "Transition to IPv6"
>> 
>> 
>> 
>> At this time, although I can click on the URL, it leads to a
>> phrase "The attached draft memorandum prepared by the Office of
>> Management and Budget, in collaboration with the Federal Chief
>> Information Officers Council and Federal Chief Information Security
>> Officers Council, supports the Administration’s goals for
>> modernizing Federal Information Technology".  I can not find that
>> 'draft memorandum'.
>> 
>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 5 Mar 2020 17:51:23 +0100

Le 05/03/2020 à 17:46, Owen DeLong a écrit :
>> following footnote: "[4] IPv6-Only refers to network environments
>> in which use of the IPv4 protocol has been eliminated.”
> 
> No.
> 
> IPv6-Only refers to network environments which are not using IPv4.
> That could be a network where IPv4 has been eliminated (rare at this
> time, though Facebook is a significant example) 

Is facebook a network?  I thought of it like a server farm.

or it could be a
> greenfield deployment where IPv4 was never deployed.
> 
>> 
>> In my humble opinion,
>> 
>> I think, if I am not wrong, that there are no such networks in
>> which IPv4 protocol has been eliminated.  On one hand, a network is
>> made of computers, and IPv4 stacks are still present in almost all
> You are wrong… There are examples at various levels of IPv6-only
> networks. Many mobile carriers are IPv6-only in the US,

The IPv6-only of mobile carriers in the US - is it carried in IPv4?  The 
last packet dump I saw was IPv6 carried in IPv4.

I stop here thank you.

Alex

---

From: Morizot Timothy S <[email-masked]>
Date: Thu, 5 Mar 2020 17:48:59 +0000

Facebook operates a massive global network. And yes, they are IPv6 only everywhere except their edge network where incoming connections are terminated. I don't believe the way their network operates today would function over IPv4. Microsoft is working toward that goal for their enterprise network. I'm not sure where they are for their content networks. LinkedIn is establishing all new data centers as IPv6 only. Cisco has one of their corporate site networks to IPv6 only if I recall correctly and are continuing to work toward that goal. The list is large and growing.

There are a few points about the language that may help those who are less familiar with the workings of government bodies, though, especially for people outside the US. First, this is a policy document not detailed technical implementation guidance. It's not going to drill down to device specific network configuration details. It establishes reporting requirements and compliance metrics which means that it must be possible to count whatever is being reported. "IP-enabled assets" should be interpreted in the same broad sense that applies in the federal acquisition guidelines. Basically, it means any asset that connects to a network using IP. That could be an end user client system, server, any network device, appliances, IOT devices (sensors, cameras, lights, etc.), etc. If it connects to a network at layer 3, including all the devices providing that network service, it should be considered an IP-enabled asset. If there's an IP configured anywhere on it, it's an IP enabled asset. A device providing NAT64 would still have IPv4 configured on it. A device encapsulating IPv6 in IPv4 would still have IPv4 configured on it. Perhaps that helps interpret the scope and intent of the draft policy? IPv6-only is used in contrast to dual-stacked or other transition mechanisms. The policy draft language provides no exemptions or exceptions.

HTH,

Scott

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 05 Mar 2020 19:12:39 +0100

If you read my draft, my opinion is different:

  Definition of IPv6-only

   Consequently, considering the context described in the section above,
   if we want to be precise and avoid confusing others, we can not use
   the terminology "IPv6-only" in a generic way, and we need to define
   what part of the network we are referring to.

   From that perspective, we define the "IPv6-only" status in a given
   part(s) of a network, depending on if there is actual native
   forwarding of IPv4, so IPv4 is not configured neither managed.

So IPv4 may be not configured, or not used natively, but there is no way to prevent that "is there" by means of tunneling of translation.

*unless* you make sure that any encapsulation or translation is filtered, which is close to impossible.

Because we disagree, it seems clear that this document is needed.

So if anyone has inputs, I will consider them in a new version during the weekend.

Regards,
Jordi
@jordipalet

El 5/3/20 17:46, "v6ops en nombre de Owen DeLong" <[email-masked] en nombre de [email-masked]> escribió:

    
    No.

    

    
    
    Owen

---

From: Owen DeLong <[email-masked]>
Date: Fri, 6 Mar 2020 11:53:58 -0800

> On Mar 5, 2020, at 8:51 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> 

How does one run a distributed server farm throughout the world without connecting it with a network? Am I missing something?

> The IPv6-only of mobile carriers in the US - is it carried in IPv4?  The last packet dump I saw was IPv6 carried in IPv4.

At least on T-Mo, it appears to be native IPv6 from what I can see. However, if it’s tunneled in v4 somewhere, that would likely be entirely transparent and I’d have no way to tell.

Owen

---

From: "[email-masked]" <[email-masked]>
Date: Sun, 8 Mar 2020 18:29:48 +0800

Hi, Jordi, 
First , I agree with you that the definition of IPv6-only needs to consider the what part of the network we are referring to, for example, ISP network, IDC, Cloud platform and Service system should have their own specific definition of IPv6-only.  I hope this draft can go on.
Secondly. for ISP network, the definition of IPv6 should be based on whether it can allocates only IPv6 addresses to most of its customers for service provisioning, if yes, it can be consider as IPv6-only. If it allocates IPv4 address to most of its customers, then it is not IPv6-only. My personal opionion is that the definition should not be based on whether to eliminate IPv4 protocol in the network.  At present stage, it is unrealistic to eliminate IPv4 protocol in most networks, for the networks still need to provide access service to some customers who do not support IPv6-only due to their poor-capability CPE or terminals. Moreever, some networks still need to use IPv4 for network management . If the definition it too strict, I guess none of the network can meet the standard, including those who have deplyed 464XLAT. In addition, an IPv6-only network should be open and interconnected with OTTs and other ISPs, some closed system, such as VoLTE in mobile network, should not be consider as IPv6-only, even though it only allocates IPv6 addresses to it customer.

Best regards
Chongfeng 

From: JORDI PALET MARTINEZ
Date: 2020-03-06 02:12
To: [email-masked]
Subject: Re: [v6ops] About Req for Comments - "Transition to IPv6"
If you read my draft, my opinion is different:
 
  Definition of IPv6-only

 

 
 
Regards,
Jordi
@jordipalet

    
    
    No.

    

    
    
    Owen

---

From: Clark Gaylord <[email-masked]>
Date: Sun, 8 Mar 2020 07:36:34 -0400

It seems to me the context of the OMB guidance is relevant to the question
of "IPv6-only". The draft memo is reasonably good at this, but succinctly
something like "agency internal networks use single-stack IPv6 with any
external connectivity supporting IPv6. External connectivity that requires
connectivity to legacy Internet hosts can be accomplished via appropriate
gateway technologies such as NAT64". A provision for "specific applications
where IPv6 is not supportable may be able to use internal gateway
technologies such as 464XLAT with a plan for migration to support IPv6
natively." These aren't exact quotes, just my suggested ideas, but this
seems to capture the spirit of the initiative.

On Sun, Mar 8, 2020 at 6:30 AM [email-masked] <
[email-masked]> wrote:

> Hi, Jordi,
> First , I agree with you that the definition of IPv6-only needs to
> consider the what part of the network we are referring to, for example,
> ISP network, IDC, Cloud platform and Service system should have their own
> specific definition of IPv6-only.  I hope this draft can go on.
> Secondly. for ISP network, the definition of IPv6 should be based on
> whether it can allocates only IPv6 addresses to most of its customers for
> service provisioning, if yes, it can be consider as IPv6-only. If it
> allocates IPv4 address to most of its customers, then it is not IPv6-only.
> My personal opionion is that the definition should not be based on whether
> to eliminate IPv4 protocol in the network.  At present stage, it is
> unrealistic to eliminate IPv4 protocol in most networks, for the networks
> still need to provide access service to some customers who do not support
> IPv6-only due to their poor-capability CPE or terminals. Moreever, some
> networks still need to use IPv4 for network management . If the
> definition it too strict, I guess none of the network can meet the
> standard, including those who have deplyed 464XLAT. In addition, an
> IPv6-only network should be open and interconnected with OTTs and other
> ISPs, some closed system, such as VoLTE in mobile network, should not be
> consider as IPv6-only, even though it only allocates IPv6 addresses to it
> customer.
>
> Best regards
> Chongfeng
>
> *From:* JORDI PALET MARTINEZ <jordi.palet=[email-masked]>
> *Date:* 2020-03-06 02:12
> *To:* [email-masked]
> *Subject:* Re: [v6ops] About Req for Comments - "Transition to IPv6"
> So IPv4 may be not configured, or not used natively, but there is no way
> to prevent that "is there" by means of tunneling of translation.
>
> That could be a network where IPv4 has been eliminated (rare at this time,
> though Facebook is a significant example) or it could be a greenfield
> deployment where IPv4 was never deployed.
>
>     >
>     > In my humble opinion,
>     >
> networks. Many mobile carriers are IPv6-only in the US, though they do
> provide some apparent IPv4 capability to the end user through mechanisms
> such as 464XLAT and/or NAT64.
>
>     Another significant example is Facebook where they are essentially
> IPv6-only throughout their network and provide minimal IPv4 translation
> shim at the edge to cope with end users that lack IPv6 capability.
>
>     As a general rule, once IPv6 is ubiquitously deployed in a network,
> the preservation of IPv4 in the majority of that network becomes an
> unnecessary cost factor and a security risk (increased attack surface, if
> nothing else). As such, I think you will see an increasing number of
> organizations follow on to the way Facebook has managed their transition
> and start eliminating IPv4 wherever possible and replacing it with
> translation shims as far out towards the border as practical.
>
>     Owen
>
>
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the exclusive use of
> the individual(s) named above and further non-explicilty authorized
> disclosure, copying, distribution or use of the contents of this
> information, even if partially, including attached files, is strictly
> prohibited and will be considered a criminal offense.. If you are not the
> intended recipient be aware that any disclosure, copying, distribution or
> use of the contents of this information, even if partially, including
> attached files, is strictly prohibited, will be considered a criminal
> offense, so you must reply to the original sender to inform about this
> communication and delete it.
>
>
>

-- 
Clark Gaylord
[email-masked]

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 09 Mar 2020 09:32:26 +0100

Hi Chongfeng,

Thanks for your inputs!

Below, in-line …

El 8/3/20 11:31, "v6ops en nombre de [email-masked]" <[email-masked] en nombre de [email-masked]> escribió:

Hi, Jordi, 

Secondly. for ISP network, the definition of IPv6 should be based on whether it can allocates only IPv6 

[Jordi] I don’t agree on this point. An ISP may have different parts of its network with or without IPv6/IPv4, even different services, so I don’t think it can be split that way.

addresses to most of its customers for service provisioning, if yes, it can be consider as IPv6-only. If it

[Jordi] Now, the part you mention as if it is allocating only IPv6 addresses, is also not valid, in my opinion. Because in some of the IPv6-only with IPv4aaS, the ISP allocate private IPv4 addresses.

allocates IPv4 address to most of its customers, then it is not IPv6-only. My personal opionion is that the definition should not be based on whether to eliminate IPv4 protocol in the network.  At present stage, it is unrealistic to eliminate IPv4 protocol in most networks, for the networks still need to provide access service to some customers who do not support IPv6-only due to their poor-capability CPE or terminals.

[Jordi] I agree is unrealistic to disable IPv4 in most of the customer LANs, but not in the access network. Until 90-99% of the home devices of an ISP customers have IPv6 in their LAN devices, an IPv6 with IPv4aaS is needed.

 Moreever, some networks still need to use IPv4 for network management . If the definition it too strict, I guess none of the network can meet the standard, including those who have deplyed 464XLAT. In addition, an IPv6-only network should be open and interconnected with OTTs and other ISPs, some closed system, such as VoLTE in mobile network, should not be consider as IPv6-only, even though it only allocates IPv6 addresses to it customer.

[Jordi] If IPv4 is used for management in the access network and provides native IPv4 to the CE (for example), then it is not IPv6-only. We could say in that case: This access network is IPv6-only for the customer service, but still IPv4-only or dual-stack for the management.

[Jordi] So I still believe that the “nature” of the definition should be based in if IPv4 is used natively in a specific part of a network (then it is IPv6-only) or otherwise is IPv4-only or dual-stack. What do you think?

Best regards

Chongfeng 

Date: 2020-03-06 02:12

To: [email-masked]

  Definition of IPv6-only

Regards,

Jordi

@jordipalet

    

    No.

    Owen

    v6ops mailing list

    [email-masked]

 

IPv4 is over

The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense.. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

v6ops mailing list

[email-masked]

_______________________________________________ v6ops mailing list [email-masked] https://www.ietf.org/mailman/listinfo/v6ops

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 09 Mar 2020 09:42:29 +0100

Hi Clark,

El 8/3/20 12:38, "v6ops en nombre de Clark Gaylord" <[email-masked] en nombre de [email-masked]> escribió:

It seems to me the context of the OMB guidance is relevant to the question of "IPv6-only". The draft memo is reasonably good at this, but succinctly something like "agency internal networks use single-stack IPv6 with any 

[Jordi] I don’t think is so clear. Footnote 4 “IPv6-Only refers to network environments in which use of the IPv4 protocol has been eliminated” will be much clear if it says “IPv6-Only refers to network environments in which use of the *native* IPv4 protocol has been eliminated”.

If a Federal office decides to have its DC with IPv6-only, then IPv4-only users will not be able to access it. In that case the DC must use, for example SIIT-DC. That will mean that the DC (internally) is IPv6-only, but the DC-to-Internet is dual-stack, in order to be able to use SIIT-DC.

Furthermore, footnote 5, “Note that for public Internet services, maintaining viable IPv4 interfaces and transition mechanisms at the edge of service infrastructure may be necessary for additional time, but this does not preclude operating the backend infrastructure as IPv6-only.” Is precisely saying that.

It may happen that some of the LANs in the Federal office itself, are dual-stack still. Otherwise, employees will not be able to use Internet resources that don’t work well with NAT64+DNS64, for example, web sites or apps that use literal IPv4-addresses and are out of the control of the Federal office. So, in this case they still need to use IPv4aaS.

 

external connectivity supporting IPv6. External connectivity that requires connectivity to legacy Internet hosts can be accomplished via appropriate gateway technologies such as NAT64". A provision for "specific applications where IPv6 is not supportable may be able to use internal gateway technologies such as 464XLAT with a plan for migration to support IPv6 natively." These aren't exact quotes, just my suggested ideas, but this seems to capture the spirit of the initiative.

On Sun, Mar 8, 2020 at 6:30 AM [email-masked] <[email-masked]> wrote:

Hi, Jordi, 

Best regards

Chongfeng 

Date: 2020-03-06 02:12

To: [email-masked]

  Definition of IPv6-only

Regards,

Jordi

@jordipalet

    

    No.

    Owen

    v6ops mailing list

    [email-masked]

 

IPv4 is over

http://www..theipv6company.com

The IPv6 Company

 

v6ops mailing list

[email-masked]

 

-- 

Clark Gaylord

[email-masked]

---

From: Owen DeLong <[email-masked]>
Date: Tue, 10 Mar 2020 11:02:50 -0700

> On Mar 9, 2020, at 01:42 , JORDI PALET MARTINEZ <jordi.palet=[email-masked]> wrote:
> 
> Hi Clark,
>  
> El 8/3/20 12:38, "v6ops en nombre de Clark Gaylord" <[email-masked] <mailto:[email-masked]> en nombre de [email-masked] <mailto:[email-masked]>> escribió:
>  

I don’t believe that what you propose is the intent in the memo.

I believe they intend to eliminate the use of ALL IPv4, not just native IPv4 on government networks.
 
> If a Federal office decides to have its DC with IPv6-only, then IPv4-only users will not be able to access it. In that case the DC must use, for example SIIT-DC. That will mean that the DC (interna…

I believe that _IS_ the intent (no support for SIIT/NAT64/etc.).

Remember, this is referring to the INTERNAL networks of the federal government agencies… Not the public-facing networks.

Unless I misread the memo, the intent is to preserve dual-stack functionality on public-facing services, but ensure that there are no remaining IPv4 dependencies in providing those services over IPv6.
 
> Furthermore, footnote 5, “Note that for public Internet services, maintaining viable IPv4 interfaces and transition mechanisms at the edge of service infrastructure may be necessary for additional…

Correct.
 
> It may happen that some of the LANs in the Federal office itself, are dual-stack still. Otherwise, employees will not be able to use Internet resources that don’t work well with NAT64+DNS64, for ex…

That’s not the desired outcome in this process.

Indeed, my impression is that the government is, through this memo, intending to put suppliers and web sites on notice that if they do not have IPv6 accessibility they are likely to lose their government customers.

I see that as a good thing.
 
> external connectivity supporting IPv6. External connectivity that requires connectivity to legacy Internet hosts can be accomplished via appropriate gateway technologies such as NAT64". A provision…

I don’t think that’s the actual spirit of the initiative…

See above.

Owen

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 10 Mar 2020 19:25:31 +0100

Hi Owen,

Responses below with ***.

El 10/3/20 19:03, "v6ops en nombre de Owen DeLong" <[email-masked] en nombre de [email-masked]> escribió:

Hi Clark,

*** Then there is a problem. If they really want to have ALL the way thru only IPv6 in the LANs, the federal employees will not be able to use *ANY* application that uses literal addresses (even a simple web page that is doing that). Because there is NO transition mechanism that allows that. They are able to force all their internal apps to use only IPv6, fine, but they have no control over the rest of the Internet. If they are thinking that NAT64+DNS64 resolves that, they lost this “small” bit in their thinking. I’ve already reported them to the site that is asking for comments, hopefully they really pay attention to the inputs.

Correct.

*** I will be glad if they can send this memo to every small web site in the world, because even if one of them is missing it, and need to be accessed by the employees, will not work!

See above.

Owen

---

From: Morizot Timothy S <[email-masked]>
Date: Tue, 10 Mar 2020 19:27:21 +0000

JORDI PALET MARTINEZ wrote:
>*** Then there is a problem. If they really want to have ALL the way thru only IPv6 in the LANs, the federal employees
>will not be able to use *ANY* application that uses literal addresses (even a simple web page that is doing that).
>Because there is NO transition mechanism that allows that. They are able to force all their internal apps to use only
>IPv6, fine, but they have no control over the rest of the Internet. If they are thinking that NAT64+DNS64 resolves
>that, they lost this “small” bit in their thinking. I’ve already reported them to the site that is asking for comments,
>hopefully they really pay attention to the inputs.

I'm intrigued that you believe that's inherently a problem. Perhaps you're not aware how restrictive
US federal government networks often are? There are a great many things on the Internet I cannot
access from my work computer, even for official work purposes. For example, I am the designated representative
for my organization with ARIN. But during remote participation, I could not access jabber and
cannot access slack from my work computer. I cannot access any conferencing platform from
my work computer even for official, approved purposes. There are multiple levels of firewalls when
I am connected to the enterprise network, all operating in default deny mode. My work computer
presently has no direct access to any endpoint on the Internet. Every service allowed is proxied.
And if things on the Internet do not work within our requirements, we don't use them.
Now, removing even the perimeter service proxies to the public IPv4 Internet would fall
into that last 20% that does not yet have a specifically mandated date. The emphasis,
though, should likely be on *yet*. I know many of the people who contributed to
the draft. I don't think they "lost" anything in their thinking.
 
>*** I will be glad if they can send this memo to every small web site in the world,
>because even if one of them is missing it, and need to be accessed by
>the employees, will not work!

It's published in the Federal Register. Those interested in advance warning about the
steps the US government is planning to take on their own networks have it available.
It will remain published by OMB when formally released. However, restricting access
for federal employees is perfectly normal and occurs today for all sorts of
reasons. Our networks do not operate under the premise that any system
on our network must be able to access any arbitrary system, service,
site, or application on the Internet. In fact, more the opposite applies.

I believe Owen captured more the spirit and intent of this next step in
the progression of the US federal government IPv6 transition. Despite
the mandated dates, progress will almost certainly continue to be uneven across agencies.
But the reporting requirements are something of a stick. Compliance with
regulations and other requirements tends to be one of the drivers
in government decision-making, especially since profit is not normally
the factor it is in commercial decision-making.

Scott

---

From: Owen DeLong <[email-masked]>
Date: Tue, 10 Mar 2020 13:47:22 -0700

> On Mar 10, 2020, at 11:25 , JORDI PALET MARTINEZ <jordi.palet=[email-masked]> wrote:
> 
> Hi Owen,
>  
> El 10/3/20 19:03, "v6ops en nombre de Owen DeLong" <[email-masked] <mailto:[email-masked]> en nombre de [email-masked] <mailto:[email-masked]>> escribió:
>  
>  
> 
> 
>> On Mar 9, 2020, at 01:42 , JORDI PALET MARTINEZ <jordi.palet=[email-masked] <mailto:jordi.palet=[email-masked]>> wrote:
>>  
>> Hi Clark,
>>  

I don’t see that as a problem… I see that as a benefit.

I think that the US Federal government is one of the few organizations in a position to actually put the kind of pressure that will be necessary to effectuate this change.

So, personally, I don’t see it so much as “they lost this in their thinking” as in they are choosing to stop supporting certain “broken by design” ways of thinking.

I hope that they stick to their guns and do not soften their position.

> *** I will be glad if they can send this memo to every small web site in the world, because even if one of them is missing it, and need to be accessed by the employees, will not work!

I’m pretty sure that the employees that encounter difficulty will make it known to the web sites in question.

In reality, in terms of actual job-related usage, the federal government is unlikely to need access to every small web site in the world. As a general rule, every small web site in the world has no ability to support things at the scale of US Government usage.

If some employe can’t surf their favorite mom-and-pop cat video site while they are supposed to be working for their taxpayer supported salary, I won’t actually be upset.

So from my perspective, this memo puts government contractors on notice that their network-based systems providing services to the federal government damn well better fully support IPv6 in the next few years, or they’re going to experience an increasing level of disconnect followed by a very likely contract termination. I see this as a good thing.

Owen

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 11 Mar 2020 09:03:40 +0800

Hi, Jordi,
Thank you for your consideration of my comments. Please find my new notes in-line below.
 
Date: 2020-03-09 16:32
To: v6ops
 
Thanks for your inputs!
 
Below, in-line …

 
Hi, Jordi, 

 

[Chongfeng] If ISP allocates IPv4 private address to  large quatity of its customers, it should not be considered as IPv6-only, this should be the bottom line.

[Jordi] I agree is unrealistic to disable IPv4 in most of the customer LANs, but not in the access network. Until 90-99% of the home devices of an ISP customers have IPv6 in their LAN devices, an IPv6 with IPv4aaS is needed.
[Chongfeng]  In China, access network adopts  layer-two approach, it is independent to layer-three procotols. It seems to much more difficult  to make transition to IPv6 in wireline broadband network, due to the slow upgradation of home routers.

 
[Jordi] So I still believe that the “nature” of the definition should be based in if IPv4 is used natively in a specific part of a network (then it is IPv6-only) or otherwise is IPv4-only or dual-stack. What do you think?
 [Chongfeng] In general, I agree with this point.

Best regards
Chongfeng 

  Definition of IPv6-only

 

 
 
Regards,
Jordi
@jordipalet

    
    
    No.

    

    
    
    Owen

---

From: Fred Baker <[email-masked]>
Date: Wed, 11 Mar 2020 19:06:41 -0700

> On Mar 5, 2020, at 8:46 AM, Owen DeLong <[email-masked]> wrote:
> 

<sans hats>

This, I think, is where the v6ops discussion has travelled in circles forever. To me, I would drop the word "network" and say that it is a specified environment. If I say that a system is IPv6-only, it is not using IPv6 internally or externally. It might or might not have IPv4 code in it, but it's not using it. If I say that a LAN, building, etc is IPv6-only, it is not to say that it couldn't have IPv4 in it if a DHCP server started handing out such addresses, but that it *doesn't*. If it is an Autonomous System, it means that only IPv6 is in use in that domain.

As soon as we get into the "but it could" or "was it translated from something else" or whatever rathole, we're into a discussion of angels, pins, and heads of pins. It will not end, because it can't. Someone will forever come up with a "what if" scenario to stir the pot.

Speaking for myself, I would have the user of the term identify the environment s/he is talking about, and say that *within*that*domain* communication is entirely accomplished using IPv6.

And STOP.

---

From: Owen DeLong <[email-masked]>
Date: Thu, 12 Mar 2020 01:20:19 -0700

> On Mar 11, 2020, at 19:06 , Fred Baker <[email-masked]> wrote:
> 
> 
> 

It seems to me that you are saying essentially the same thing I intended to say, Fred.

My key point was that IPv6-only could mean either of:

	+	Any environment where IPv4 usage has been discontinued and IPv6 is the sole remaining active protocol
OR
	+	Any environment where IPv4 was never deployed and IPv6 is the only protocol ever deployed

It was in response to a statement that IPv6-only could only mean an environment where IPv4 once existed and had been removed.

Owen

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 12 Mar 2020 10:22:55 +0100

Hi Owen,

Using +++ below …

El 10/3/20 21:49, "v6ops en nombre de Owen DeLong" <[email-masked] en nombre de [email-masked]> escribió:

Hi Owen,

 

Hi Clark,

+++ Somehow, I agree, is not a “problem”, depending on how you see it. As moving on to a real IPv6-only world, it is good. But we are interpreting the document as they really want that. They don’t say explicitly, so we don’t know. If they want that effect, I think it will be much better message to say “we know this will create this problem for people still using literal IPv4 addresses in web sites, but they should react if they want to work with us” or whatever.

Correct.

+++ Not sure, it may get ignored, as they ignore problems in their deployment. Last time I tried to fill in the ESTA for traveling to US, it was not working in some of the final steps. I did some debugging and realized that they were dual stack, but filtering PTB, so because the MTU at some point in the network, it never worked until I disabled IPv6 to complete the form and pay the fee. I tried to tell them. I recall there was even a thread about that in NANOG (talking from the top of my head, it may be in a different list). They never responded or resolved it. I’m not sure if now the problem is still there.

+++ Sometimes this happens even in bigger sites … so yes and not.

+++  Fully agree!

+++  Fully agree! But some text could make it more clear, so nobody believes “they didn’t though about this issue” as I did.

Owen

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 12 Mar 2020 10:32:15 +0100

Hi Scott,

I worked for the equivalent Spanish government network (SARA) in the IPv6 deployment, so I understand how restritive is it.

I think my responses to Owen also cover your points, to avoid repetition. I can agree that they probably knew about the "issues", but as said, I think is better the clearly say it "yes we know, we don't care, is up to you, if you want to offer services to us".

I just wrote them again, asking to read this discussion, in case they aren't already following it and considering including an explicit note about "yes, we know ... is your problem".

El 10/3/20 20:29, "v6ops en nombre de Morizot Timothy S" <[email-masked] en nombre de Timothy.S.Morizot=[email-masked]> escribió:

     

    
    Scott

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 12 Mar 2020 11:23:35 +0100

Hi Chongfeng,

I think we basically agree then.

I’ve only one question. You said the access network is layer 2, right, this is common in many places, but on top of the layer 2, there is either IPv6 only to the CE. If that’s the case, then my definition is still good (the CE may be running CLAT or whatever so IPv4 is somehow transported on top of IPv6). Right?

Regards,

Jordi

@jordipalet

El 11/3/20 2:04, "v6ops en nombre de [email-masked]" <[email-masked] en nombre de [email-masked]> escribió:

Hi, Jordi,

Date: 2020-03-09 16:32

To: v6ops

Hi Chongfeng,

Thanks for your inputs!

Below, in-line …

Hi, Jordi, 

 

Best regards

Chongfeng 

Date: 2020-03-06 02:12

To: [email-masked]

  Definition of IPv6-only

Regards,

Jordi

@jordipalet

    

    No.

    > individual links) that run IPv6 only.

    You are wrong… There are examples at various levels of IPv6-only networks. Many mobile carriers are IPv6-only in the US, though they do provide some apparent IPv4 capability to the end user through mechanisms such as 464XLAT and/or NAT64..

    Owen

    v6ops mailing list

    [email-masked]

 

IPv4 is over

The IPv6 Company

 

v6ops mailing list

[email-masked]

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 12 Mar 2020 11:33:11 +0100

Hi Fred,

In my document, instead of network, I try to explain that "what part of the network" should be explicited.

If you use IPv6-only network, then we mean "the complete network".

If you want to say in the WAN/access network, this is clear as well.

I think using scenario will present the same problem. If we call scenario a given network, we are talking about the full network. If we say WAN-scenario, is the same as WAN-network, we are just expliciting that is not the full network, but only that specific part.

I know that you are talking here about the OMB document, but I will like to understad if you think (hat-off) the way the document try to work on this terminology is good enough, or you suggest any changes.

Thanks!

El 12/3/20 3:07, "v6ops en nombre de Fred Baker" <[email-masked] en nombre de [email-masked]> escribió:

    
    <sans hats>

    
    
    And STOP.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 12 Mar 2020 12:04:44 +0100

[Jordi] I think we agree in that, if at the same time we don't exclude that this scenario may have (end-to-end) some form of IPv4-transport or tunnel on top of IPv6, unless it is specifically "filtered" or "avoided" by the network (obvious security reasons).

So, in those cases, I think it should be stated as well, to make it clear.

Is the same as if you have a lot of security filtering in the firewall, but you allow an employee to setup a VPN ...

I think I could include something about that in the next version, to make it clear.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 12 Mar 2020 12:17:50 +0100

Would this work?

12.  IPv4 Exclusion

   If an IPv6-only network or part of it, has strict filtering rules to
   avoid IPv4 to be transported on top of IPv6, this should be
   explicitly cited.  For example, and enterprise LAN, where employees
   can't use VPNs, tunnels, or even translations, could be named as
   "IPv6-only LAN with IPv4 Exclusion".

El 12/3/20 12:04, "JORDI PALET MARTINEZ" <[email-masked]> escribió:

---

From: Owen DeLong <[email-masked]>
Date: Fri, 13 Mar 2020 15:16:41 -0700

> On Mar 12, 2020, at 02:22 , JORDI PALET MARTINEZ <jordi.palet=[email-masked]> wrote:
> 
> Hi Owen,
> 
> Using +++ below …
> 
I have to again restate that it would be vastly preferable if you got an MUA that actually worked.

>  
>  
> El 10/3/20 21:49, "v6ops en nombre de Owen DeLong" <[email-masked] <mailto:[email-masked]> en nombre de [email-masked] <mailto:[email-masked]>> escribió:
>  
>  
> 
> 
>> On Mar 10, 2020, at 11:25 , JORDI PALET MARTINEZ <jordi.palet=[email-masked] <mailto:jordi.palet=[email-masked]>> wrote:
>>  
>> Hi Owen,
>>  
> +++ Somehow, I agree, is not a “problem”, depending on how you see it. As moving on to a real IPv6-only world, it is good. But we are interpreting the document as they really want that. They don’t say explicitly, so we don’t know. If they want that effect, I think it will be much better message to say “we know this will create this problem for people still using literal IPv4 addresses in web sites, but they should react if they want to work with us” or whatever..

I know many of the people involved. I suspect that the authors of the document do, in fact, intend that.

What you propose would be the customer friendly way for a business to approach it. It isn’t culturally typical of the US Government to approach anything in a customer friendly manner.

> +++ Not sure, it may get ignored, as they ignore problems in their deployment. Last time I tried to fill in the ESTA for traveling to US, it was not working in some of the final steps. I did some d…

We’re talking about two different things here…

In your case, you were  trying to get the government to fix something they broke. The government is very good at ignoring such feedback.

In this case, we’re talking about government employees informing web sites they are trying to visit that they are no longer accessible from US Government networks. That’s not something web sites are nearly as likely to ignore.
 
> +++ Sometimes this happens even in bigger sites … so yes and not.

I’m quite certain the bigger sites will get the memo somehow. If they don’t get it before this starts taking hold of their USG customers, they will certainly learn about it and quickly mitigate it afterwards. ;-)

> +++  Fully agree! But some text could make it more clear, so nobody believes “they didn’t though about this issue” as I did.

I’m not sure how much experience you have with the USG, but if you think clarity is their strong suit, I suggest you read 14CFR121 and get back to me.

Owen

---

From: Fred Baker <[email-masked]>
Date: Sun, 15 Mar 2020 10:30:58 -0700

> On Mar 12, 2020, at 4:17 AM, JORDI PALET MARTINEZ <jordi.palet=[email-masked]> wrote:
> 
> 12.  IPv4 Exclusion
> 

Sigh. You have heard me say this before, and I'll say it again. This is me saying it now.

"I'm sure we can make this complicated if we try hard enough."

To me, and yes, Owen, I'm agreeing with you, an IPv6-only *anything* is a thing that is only using IPv6. If the character string "IPv4" shows up somewhere in the definition, it is overly complex. If you want to discuss an IPv6-only puppy kennel, there are two things that should show up in the dentition: that it is a puppy kennel, and that it only uses IPv6 to communicate.

---

From: Owen DeLong <[email-masked]>
Date: Sun, 15 Mar 2020 10:48:12 -0700

> On Mar 15, 2020, at 10:30 , Fred Baker <[email-masked]> wrote:
> 
> 
> 

Fair enough, and I somewhat agree with you, but even that statement runs into problems if one gets pedantic. IPv6 only surely isn’t intended to exclude, e.g. UNIX domain sockets, named pipes, etc.

In fact, is it even our intent that “IPv6-only” should preclude the use of other non-IP networking protocols?

Perhaps: IPv6-only means a system or environment where the only version of Internet Protocol in use is Version 6.

Does that work?

Owen

---

From: Fred Baker <[email-masked]>
Date: Sun, 15 Mar 2020 11:44:31 -0700

> On Mar 15, 2020, at 10:48 AM, Owen DeLong <[email-masked]> wrote:
> 

Close enough for government work :-)

---

From: Alexandre Petrescu <[email-masked]>
Date: Sun, 15 Mar 2020 22:08:24 +0100

> Perhaps: IPv6-only means a system or environment where the only version of Internet Protocol in use is Version 6.

works for me.

Alex

---

From: Matthew Petach <[email-masked]>
Date: Sun, 15 Mar 2020 16:32:43 -0700

On Fri, Mar 6, 2020 at 11:54 AM Owen DeLong <[email-masked]> wrote:

> How does one run a distributed server farm throughout the world without
> connecting it with a network? Am I missing something?
>

I believe for a very long time, that would have accurately described Akamai.

Until their announcement, long after they had established themselves in the
marketplace, that they were going to deploy a network:
https://pc.nanog.org/static/published/meetings/NANOG71/1532/20171003_Kaufmann_Lightning_Talk_Akamai_v1.pdf

Matt

---

From: Owen DeLong <[email-masked]>
Date: Mon, 16 Mar 2020 00:05:59 -0700

> On Mar 15, 2020, at 16:32 , Matthew Petach <[email-masked]> wrote:
> 
> 
> 
> On Fri, Mar 6, 2020 at 11:54 AM Owen DeLong <[email-masked] <mailto:[email-masked]>> wrote:
> > On Mar 5, 2020, at 8:51 AM, Alexandre Petrescu <[email-masked] <mailto:[email-masked]>> wrote:

Akamai didn’t run a backbone. I’d argue that they did run many rather sizable networks.

> Until their announcement, long after they had established themselves in the marketplace, that they were going to deploy a network: https://pc.nanog.org/static/published/meetings/NANOG71/1532/20171003_Kaufmann_Lightning_Talk_Akamai_v1.pdf <https://pc.nanog.org/static/published/meetings/NANOG71/1532/20171003_Kaufmann_Lightning_Talk_Akamai_v1.pdf>
Oh, I’m very familiar with that particular project… It was in it’s startup hey day during my tenure in Mr. Kaufmann’s group. That was Akamai building a backbone to connect many (not nearly all) of their networks together.

I stand by my original statement. One cannot (usefully) run a server farm without a network. Network != backbone.

Owen

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 16 Mar 2020 12:03:00 +0100

Le 16/03/2020 à 08:05, Owen DeLong a écrit :
>
>
>> On Mar 15, 2020, at 16:32 , Matthew Petach <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>
>>
>>     > On Mar 5, 2020, at 8:51 AM, Alexandre Petrescu
>>     <[email-masked]
>>     <mailto:[email-masked]>> wrote:
>>     How does one run a distributed server farm throughout the world
>>     without connecting it with a network? Am I missing something?
>>
>>
>> Until their announcement, long after they had established themselves 
>> in the marketplace, that they were going to deploy a network: 
> Oh, I’m very familiar with that particular project… It was in it’s 
> startup hey day during my tenure in Mr. Kaufmann’s group. That was 
> Akamai building a backbone to connect many (not nearly all) of their 
> networks together.
>
> I stand by my original statement. One cannot (usefully) run a server 
> farm without a network. Network != backbone.

I agree a server farm needs a network.  But that network might be a 
switched Ethernet with VLANs in a large building, or it might be made of 
long haul links (ATM, FDDI, multi-Gigabit Ethernet fiber).

In the first case (call it VLAN) it is highly possible that VLAN in a 
building, or a set of close by buildings, are IPv6 only, and no IPv4.

But if the facebook system is a geographically distributed server farm 
with a large network, it might be that at some point the data is carried 
on IPv4 even though it is IPv6 over IPv4.

 From an end user perspective it is hard to find out on what is 
transported her data: IPv4, VLAN, gigabit Ethernet, whatever. Because 
traceroute does not show this (some times one can see somethings about 
ipv4 or ipv6 acronyms in the name of the hosts, but rarely).

But the builders of these networks do know whether or not that is 
carried in IPv4, or in MPLS, or so.  It is them that could say what is 
there, underlying.

Alex

Alex

---

From: Owen DeLong <[email-masked]>
Date: Mon, 16 Mar 2020 12:42:22 -0700

> On Mar 16, 2020, at 04:03 , Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> 
>>> On Mar 15, 2020, at 16:32 , Matthew Petach <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> 
>>> 
> I agree a server farm needs a network.  But that network might be a switched Ethernet with VLANs in a large building, or it might be made of long haul links (ATM, FDDI, multi-Gigabit Ethernet fiber).
> 
> In the first case (call it VLAN) it is highly possible that VLAN in a building, or a set of close by buildings, are IPv6 only, and no IPv4.
> 

This is just silly… For the server farm to be useful, that “VLAN” still needs a larger network in front of it that eventually makes contact (ideally in multiple diverse ways) with a larger internet.
> But if the facebook system is a geographically distributed server farm with a large network, it might be that at some point the data is carried on IPv4 even though it is IPv6 over IPv4.
> 
In talking to Facebook’s engineers, they claim to do v4<->6 translation at the edge where necessary to talk to IPv4-only clients and are IPv6-only throughout their datacenters and other networks.

I have no reason to doubt the veracity of their claims and indeed everything I have seen leads me to believe that they would be jumping for joy if they could shut down those remaining systems supporting IPv4.
> From an end user perspective it is hard to find out on what is transported her data: IPv4, VLAN, gigabit Ethernet, whatever.  Because traceroute does not show this (some times one can see somethings about ipv4 or ipv6 acronyms in the name of the hosts, but rarely).
> 
While this is a valid and true statement, I’m not sure how it is relevant to this discussion.
> But the builders of these networks do know whether or not that is carried in IPv4, or in MPLS, or so.  It is them that could say what is there, underlying.
> 
Which is why I base my statements on discussions with them. Were you assuming I was looking at this from my own perspective as an end-user of facebook?

Owen

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 16 Mar 2020 21:40:52 +0100

Le 16/03/2020 à 20:42, Owen DeLong a écrit :
>
>
>> On Mar 16, 2020, at 04:03 , Alexandre Petrescu 
>>>> Until their announcement, long after they had established 
>>>> themselves in the marketplace, that they were going to deploy a 
>>>> network: 
>> switched Ethernet with VLANs in a large building, or it might be made 
>> of long haul links (ATM, FDDI, multi-Gigabit Ethernet fiber).
>>
> This is just silly… For the server farm to be useful, that “VLAN” 
> still needs a larger network in front of it that eventually makes 
> contact (ideally in multiple diverse ways) with a larger internet.
>>
>> But if the facebook system is a geographically distributed server 
>> farm with a large network, it might be that at some point the data is 
>> carried on IPv4 even though it is IPv6 over IPv4.
>>
> In talking to Facebook’s engineers, they claim to do v4<->6 
> translation at the edge where necessary to talk to IPv4-only clients 
> and are IPv6-only throughout their datacenters and other networks.

that v4<->v6 means facebook network is not IPv6-only

Alex

>
> I have no reason to doubt the veracity of their claims and indeed 
> everything I have seen leads me to believe that they would be jumping 
> for joy if they could shut down those remaining systems supporting IPv4.
>>
>> transported her data: IPv4, VLAN, gigabit Ethernet, whatever.  
>> Because traceroute does not show this (some times one can see 
>> somethings about ipv4 or ipv6 acronyms in the name of the hosts, but 
>> rarely).
>>
>> carried in IPv4, or in MPLS, or so.  It is them that could say what 
>> is there, underlying.
>>
> Which is why I base my statements on discussions with them. Were you 
> assuming I was looking at this from my own perspective as an end-user 
> of facebook?
>
> Owen
>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 16 Mar 2020 22:11:47 +0100

I can confirm what Owen said.

I’ve several friends working at Facebook, and actually I’ve seen several of their presentations where the DCs are IPv6-only.

This was done circa 2014-2015 if I recall correctly.

So, following what I’m suggesting FB DC is and IPv6-only DC.

They have some transition at the border of the network. So their global network is dual-stack, but the DC is IPv6-only.

Regards,

Jordi

@jordipalet

El 16/3/20 21:41, "v6ops en nombre de Alexandre Petrescu" <[email-masked] en nombre de [email-masked]> escribió:

 

 

Until their announcement, long after they had established themselves in the marketplace, that they were going to deploy a network: https://pc.nanog.org/static/published/meetings/NANOG71/1532/20171003_Kaufmann_Lightning_Talk_Akamai_v1.pdf

Alex

Owen

---

From: Owen DeLong <[email-masked]>
Date: Mon, 16 Mar 2020 14:20:45 -0700

> On Mar 16, 2020, at 13:40 , Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> 
>>> On Mar 16, 2020, at 04:03 , Alexandre Petrescu <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> 
>>> 

No, it doesn’t. A few translation gateways at the very edge of the network are precisely what allows the network itself to be IPv6-only.

Owen

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 16 Mar 2020 22:57:27 +0100

Le 16/03/2020 à 22:20, Owen DeLong a écrit :
>
>
>> On Mar 16, 2020, at 13:40 , Alexandre Petrescu 
>>>>>>     How does one run a distributed server farm throughout the
>>>>>>     world without connecting it with a network? Am I missing
>>>>>>     something?
>>>>>>
>>>>>>
>>>>> Akamai building a backbone to connect many (not nearly all) of 
>>>>> their networks together.
>>>>>
>>>>> I stand by my original statement. One cannot (usefully) run a 
>>>>> server farm without a network. Network != backbone.
>>>>
>>>>
>>>> switched Ethernet with VLANs in a large building, or it might be 
>>>> made of long haul links (ATM, FDDI, multi-Gigabit Ethernet fiber).
>>>>
>>>> In the first case (call it VLAN) it is highly possible that VLAN in 
>>>> a building, or a set of close by buildings, are IPv6 only, and no IPv4.
>>>>
>>>
>>>> farm with a large network, it might be that at some point the data 
>>>> is carried on IPv4 even though it is IPv6 over IPv4.
>>>>
> No, it doesn’t. A few translation gateways at the very edge of the 
> network are precisely what allows the network itself to be IPv6-only.

Here' s where we differ in the definition of 'IPv6-only'.  I disagree 
with the above statement.  An IPv6-only network has no translatio 
gateways.  But it's just a definition, no problem :-)

Alex

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 16 Mar 2020 23:15:23 +0100

That’s why the *only* objective way to define it is to clearly state what part of the network you’re referring to.

Regards,

Jordi

@jordipalet

El 16/3/20 22:58, "v6ops en nombre de Alexandre Petrescu" <[email-masked] en nombre de [email-masked]> escribió:

 

 

 

Here' s where we differ in the definition of 'IPv6-only'.  I disagree with the above statement.  An IPv6-only network has no translatio gateways.  But it's just a definition, no problem :-)

Alex

Owen

---

From: Matthew Petach <[email-masked]>
Date: Wed, 18 Mar 2020 12:32:08 -0700

On Fri, Mar 6, 2020 at 11:54 AM Owen DeLong <[email-masked]> wrote:
> Until their announcement, long after they had established themselves in
> the marketplace, that they were going to deploy a network:
> Oh, I’m very familiar with that particular project… It was in it’s startup
> hey day during my tenure in Mr. Kaufmann’s group. That was Akamai building
> a backbone to connect many (not nearly all) of their networks together.
>

Fair point.

Having spent so much of my career focusing on global backbones, I did
become somewhat myopic in my focus on what Networks were.

Yes, datacenter have networks as well.

Apologies for brushing them off so cavalierly.  ^_^;;

Matt