Subject: [v6ops] IETF 108 planning

From: Fred Baker <[email-masked]>
Date: Sat, 18 Apr 2020 12:25:29 -0700

Ron and I are starting the planning for IETF 108. Alissa has told the working group chairs that there is a distinct chance that it will be entirely virtual. Whatever the rest of the IETF does, I expect there will be some of us that are not permitted to travel there - at least one speaker has told me that. And I’m scratching my head on the agenda.

Each meeting, I say about 30 days before the repository closes that “if someone has a draft they want to file, now would be the perfect time to do so.” Consider that said. We are in the process of working group last calls on five drafts, which I expect to result in updated drafts placed in Warren’s in-basket. Those are each named “draft-Ietf-v6ops-*” or “draft-Ietf-dhc-*”. 

My understanding is that, with one possible exception, the working group doesn’t find our other posted individual submissions (draft-name-v6ops-*) operationally interesting. So I’m looking for one, perhaps both, of two things: new drafts that the working group, when asked, says “this is important; we need to discuss this”, or statements by other than an author/editor that the individual submissions are operationally interesting. In each case, as always, I’m looking for supportive list discussion; that can include the authors/editors, of course, but most interesting are folks that have no vested interest saying “I would like to implement this in my network.”

So, I’m looking for drafts to discuss.

We also, for the past several years, been giving operators an opportunity to talk about IPv6 (and especially IPv6-only) deployment in their networks. If you look in the proceedings starting with about IETF 98, we have had one per meeting with the exception of IETF 107. What I am looking for there is

   - letting operators talk with each other
   - is there work that we, the IETF, need to be doing and haven’t done?

Right now, I have three folks that have asked me for air time:

      Ben Kyemba, RENU (IPv6 deployment in RENU, NREN in Uganda)
      Jen Linkova, Google, (the process of turning off IPv4)
      Chifei Xie, China Telecom (Chinese IPv6 usage statistics, which differ from Google, Akamai, and APNIC numbers)

A topic I would like to see discussed (but I’m missing some important details) would be an IPv6-capable network security survey tool. One issue enterprises raise with IPv6 is that appliances and tools they use for IPv4 security are not available (or not well known) as applying the same tests to IPv6 and thereby testing a network’s IPv6 security In a comparable way. If someone has one they would recommend, especially if they have experience using it, I’d like to add a talk on that topic to the above four.

So, to put hands and feet on this, I’m thinking of scheduling a two hour virtual interim and asking those three or four speakers to participate in it. If we have new draft(s) with working group support, I’ll include those as well, of course, but that would be in a separate meeting.

So, I have a couple of questions, besides “please post drafts”.

1) do you find the speakers listed above interesting?
2) would you rather meet f2f in Madrid during the scheduled IETF week?
     “ “ “ meet virtually during the scheduled IETF week
     “ “ “ would you rather have one or two virtual interims?
3) if you’re interested in a virtual interim, when would you like to do it? Fill in the doodle poll: https://doodle.com/poll/4fw2d6d56fyi2tw4

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 19 Apr 2020 09:56:42 +1200

On 19-Apr-20 07:25, Fred Baker wrote:
...
>       Chifei Xie, China Telecom (Chinese IPv6 usage statistics, which differ from Google, Akamai, and APNIC numbers)

Great topics, but I would be 100% happy to read three drafts about them. I'd be willing to flip through slide decks. I'd be unlikely to listen to narrated slide decks or watch videos.

As for live air time, I would consider tuning in for Q/A on these topics. I see no reason to waste air time on slides, since we can all read stuff in advance. I think that using virtual meeting time for topics where there is no draft should be avoided.

<snip>

> 1) do you find the speakers listed above interesting?

As stated: good topics for drafts + Q/A

> 2) would you rather meet f2f in Madrid during the scheduled IETF week?

Zero chance. At least where I live, international travel will be impossible then.

>      “ “ “ meet virtually during the scheduled IETF week

No particular advantage to that week.

>      “ “ “ would you rather have one or two virtual interims?

I think you might want to plan on one every couple of months for the indefinite future. That's twice as many deadlines per year, so the pace of work might pick up :-).

> 3) if you’re interested in a virtual interim, when would you like to do it? Fill in the doodle poll: https://doodle.com/poll/4fw2d6d56fyi2tw4

Done, but you're unlikely to cater for my time zone (UTC+12).

Stay well,
    Brian