Subject: Re: [v6ops] RFC 6877 to Proposed Standard

From: <[email-masked]>
Date: Thu, 6 Aug 2020 13:42:25 +0000

I agree, I would like to see 464xlat promoted to standards track, with appropriate context and lessons learned.
Regards,
Nick

-----Original Message-----
From: v6ops <[email-masked]> On Behalf Of Tim Chown
Sent: 19 July 2020 10:34
To: Owen DeLong <[email-masked]>
Cc: IPv6 Operations <[email-masked]>
Subject: Re: [v6ops] RFC 6877 to Proposed Standard

I assume the original RFC 6877 essentially documented what T-Mobile did for their IPv6 deployment back in around 2013.  464XLAT. has been used by other operators since, on millions of handsets they have sold, so it would seem more than timely to get the approach promoted to Standards Track, with an update from seven years of experience if required.

Tim

> On 16 Jul 2020, at 18:29, Owen DeLong <[email-masked]> wrote:
> 
> I have no strong opinion one way or the other.
> 
> I will say that if making it a proposed standard somehow helps people get on with IPv6 deployment, I’m all for it. This transition has taken far too long already.
> 
> Owen
> 
> 
>> On Jul 16, 2020, at 10:07 , Fred Baker <[email-masked]> wrote:
>> 
>> In today's Interim Meeting, Jordi pointed out that all transition mechanisms are at Proposed Standard except 464XLAT, and asked the working group to advance it to that status.
>> 
>> /* Personal Opinion */
>> I have no problem with doing so, but I would ask whether 464XLAT is indeed a transition mechanism. It is an operational procedure (and therefore within v6ops' charter to produce, which it did) that uses RFCs 6146, 6147, 7915, and possibly 6092, which are at Proposed Standard.
>> /* Personal Opinion */
>> 
>> My huffing and puffing aside, I'd like to poll the opinion of the working group.
>>  - does RFC 6877 need to be updated? A good approach to doing so would be to file errata (https://www.rfc-editor.org/errata.php).
>>    The document currently has no errata filed. Consider this an invitation to file any needed errata and tell v6ops you have done so.
>> 
>>  - failing that, we certainly have operational experience with it. It is currently an informational document. 
>>    Would it be appropriate to raise it to Proposed Standard?
>> 
>>  - Per RFC 6410, we may be in a position to advance 6877, 6146, 6147, and/or 7915 to Internet Standard. The criterion and process are
>>    described in https://tools.ietf.org/html/rfc6410, and boil down to (1) multiple interoperable implementations and (2)
>>    a general belief that the technology works. From my perspective, if we believe that 464XLAT is widely deployed and useful,
>>    we believe that each of those are
>> 
>>     "characterized by a high degree of
>>     technical maturity and by a generally held belief that the
>>     specified protocol or service provides significant benefit to the
>>     Internet community."
>> 
>> Please reply all with your viewpoint.
>> 
>> If the answer is "yes", fair warning: Ron and I are going to be looking for someone to write an internet draft documenting the fact and the deployment status.
>> _______________________________________________
>> v6ops mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/v6ops
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Xipengxiao <[email-masked]>
Date: Thu, 6 Aug 2020 14:13:34 +0000

I will support promoting 464xlat to standards track.

XiPeng Xiao

-----Original Message-----
From: v6ops <[email-masked]> On Behalf Of Tim Chown
Sent: 19 July 2020 10:34
To: Owen DeLong <[email-masked]>
Cc: IPv6 Operations <[email-masked]>
Subject: Re: [v6ops] RFC 6877 to Proposed Standard

Tim