Subject: Re: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

From: Fred Baker <[email-masked]>
Date: Thu, 24 Sep 2020 14:44:41 -0700

On Sep 21, 2020, at 3:57 AM, Khaled Omar <[email-masked]> wrote:
> Maybe if you can provide me with all the statistics I need that shows the deployment so I can believe.
>  
> Khaled Omar

Sure. I'm using a site that Eric Vyncke has put together and can discuss with you. He uses Google (Erik Kline), Akamai (Jared Mauch), and APNIC (George Michelson/Geoff Huston) numbers; there are other services that publish statistics, he just hasn't included them. As of this instant, Google reports that requests that come to it from 73 countries exceed at least 5% of its workload from that country, and traffic from 37 countries exceed 35% of its workload in that country. Its Eric's site, but the data is from Google, and the site can get you to Akamai and APNIC data as well for the price of a mouse-click.

What I do is download the Google statistics, select the countries that exceed some cut-off, and then ask Eric's or APNIC's site to display the data.

5% cut-off
https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,de,in,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br,th,fi,mq,uy,gb,ec,ee,lk,ca,hu,ae,gp,re,nl,tt,ie,au,nz,pe,sa,ga,bo,ro,at,gt,no,ph,cz,sg,il,mo,pl,ar,sx,tg,si,np,mm,om,bt,kr,ke,fo,co,md,zw,cg,pr,is,lv,am,se,ru,li,jo,sk

35% cut-off
https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,de,in,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br

APNIC's display of its data on India is interesting
https://stats.labs.apnic.net/ipv6/CC?x=1&s=1&p=1&w=30&c=IN

If you scroll down, you will get a break-out by AS. APNIC reports that customers from 12 ASs use IPv6 when accessing APNIC with 50%+ probability ("ipv6-capable" and carrying that amount of data), and given a choice of IPv6 or IPv4, most of them are "ipv6-preferred" (eg, use IPv6 when given a choice). But about 50 ASs actually have users *using* IPv6 for some subset of their workload. In a Financial Times blog a week or two ago, the chair of India's IPv6 deployment task force argued that it should have an IPv6-only DNS Root Server on the basis of its IPv6 deployment and usage. I disagree with him (remarks available on request; they only have 38 IPv6-capable root servers in country), but the basis for the argument was interesting.

I think the APNIC data is interesting because it crosses the backbone. Google and Akamai run CDNs, which means that traffic can be between a residential subscriber and its CDN server without materially touching the ISP. APNIC runs no CDN, which means that traffic has to *also* traverse the ISP and the backbone to APNIC - there is and end-to-end path across the backbone. Think about this: when a user accesses a service using IPv6 (or IPv4 for that matter), the packet has to go from his computer, IOT device, or telephone to the site in question and the response has to come back; there has to be a complete end-to-end path in each direction. Miss one IPv6 connection in one direction, and it may as well be IPv4-only, because that's the only thing the end system will use.

From 73 countries, there is an end-to-end path of sufficient strength that a significant proportion of data *can* traverse it using IPv6, and the end system - which chooses whether to use IPv4 or IPv6 - will *choose* IPv6.

My search engine tells me "There are 195 countries in the world today. This total comprises 193 countries that are member states of the United Nations and 2 countries that are non-member observer states: the Holy See and the State of Palestine." 37% of them, 73, have significant IPv6 usage.

Define "widely deployed"? I'll add "and used?" That's pretty wide, in my book.

What prevents this from being IPv6-only? Computers and network equipment used by residential and enterprise subscribers have supported both IPv4 and IPv6 for years. The most commonly used applications are quite happy with either. The issue I see is primarily enterprise lack of IPv6 adoption in its customer-facing services. Even an "IPv6-preferred" site will use IPv4 when talking with something that will only use IPv4.

There is nothing proprietary here. Forward if you like.

>  From: Fred Baker <[email-masked]> 
> Sent: Monday, September 21, 2020 4:49 AM
> To: Khaled Omar <[email-masked]>
> Cc: Erik Kline <[email-masked]>; Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>; [email-masked]
> Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)
>  
> Boy. If “millions and billions” isn’t wide deployment, maybe I need to go back to grammar school.
> 
> Sent from my iPad
> 
> 
> On Sep 19, 2020, at 4:18 PM, Khaled Omar <[email-masked]> wrote:
> 
> 
> But none of these transitioning solutions are widely deployed, maybe it is IPv10 time ;-)
>  
> Khaled Omar
>  
> From: Erik Kline <[email-masked]> 
> Sent: Sunday, September 20, 2020 1:05 AM
> To: Khaled Omar <[email-masked]>
> Cc: Fred Baker <[email-masked]>; Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>; [email-masked]
> Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)
>  
> As noted before: RFCs 6052, 6146, 6147, 6877, 7915, and others comprise the solution deployed to literally hundreds of millions if not billions of mobile devices and numerous access networks worldwide.
>  
> On Fri, Sep 18, 2020 at 5:24 AM Khaled Omar <[email-masked]> wrote:
> >> Who are these “many people”, and what problem do they see being solved?
> 
> Network engineers everywhere, they are waiting for the announcement of an official robust solution to the depletion of the IPv4 address space and the division that occurs recently on the Internet.
> 
> People read the draft and many wrote about it because the idea is simple and requires no intervention from their side, that’s why I ask the IETF to take the draft seriously and put personal benefits aside for now, as LATER everything will back to normal, believe me, all are in need for this.
> 
> Khaled Omar
> 
> -----Original Message-----
> From: Fred Baker <[email-masked]> 
> Sent: Friday, September 18, 2020 12:24 PM
> To: Khaled Omar <[email-masked]>
> Cc: Roland Bless <[email-masked]>; Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>; [email-masked]
> Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)
> 
> 
> 
> Sent from my iPad
> 
> > On Sep 17, 2020, at 2:08 PM, Khaled Omar <[email-masked]> wrote:
> > 
> > Regarding the confusion, the community is curious about the idea, many people support it as it solves the problem that they think they are not part of it.
> 
> This statement has me a little confused. I see a lot of commentary, but I don’t see people commenting along those lines. I frankly see commentary similar to what I sent you declining a v6ops slot,
> 
> Who are these “many people”, and what problem do they see being solved?
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: Khaled Omar <[email-masked]>
Date: Thu, 24 Sep 2020 21:59:25 +0000

Hi Fred,

That’s a powerful reply from you both, but let me try to check these statistics for 1 week and do some analysis to know whether I can depend on the result without any kind of forcing the end result, and I feel optimistic that the result will be reflecting the real case, I just need some time to be able to go with a conclusion as I have nothing to check out right now.

As you know from the IPv10 I-D, it requires the network between hosts to be IPv4/IPv6 ready, so it still can be considered, as I still think that the movement to IPv6 still need some time and arrangement to get the best result for the coming generations.

So, let me ask Eric if we can reserve a slot in the next meeting to present IPv10.

Thanks,

Khaled Omar

-----Original Message-----
From: Fred Baker <[email-masked]> 
Sent: Thursday, September 24, 2020 11:45 PM
To: Khaled Omar <[email-masked]>
Cc: Erik Kline <[email-masked]>; Eric Vyncke (evyncke) <evyncke=[email-masked]>; int-area <[email-masked]>; IPv6 Operations <[email-masked]>
Subject: Re: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

5% cut-off

35% cut-off

APNIC's display of its data on India is interesting https://stats.labs.apnic.net/ipv6/CC?x=1&s=1&p=1&w=30&c=IN

> Cc: Erik Kline <[email-masked]>; Eric Vyncke (evyncke) 
> <evyncke=[email-masked]>; int-area <[email-masked]>; 
> [email-masked]
> Subject: Re: [Int-area] Still need to know what has changed.... Re: 
> IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request 
> for IETF 109 - IPv10)
>  
> Cc: Fred Baker <[email-masked]>; Eric Vyncke (evyncke) 
> <evyncke=[email-masked]>; int-area <[email-masked]>; 
> [email-masked]
> Subject: Re: [Int-area] Still need to know what has changed.... Re: 
> IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request 
> for IETF 109 - IPv10)
>  
> Cc: Roland Bless <[email-masked]>; Eric Vyncke (evyncke) 
> <evyncke=[email-masked]>; int-area <[email-masked]>; 
> [email-masked]
> Subject: Re: [Int-area] Still need to know what has changed.... Re: 
> IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request 
> for IETF 109 - IPv10)
> 
> 
> 
> Sent from my iPad
> 
> This statement has me a little confused. I see a lot of commentary, 
> but I don’t see people commenting along those lines. I frankly see 
> commentary similar to what I sent you declining a v6ops slot,
>

---

From: Fred Baker <[email-masked]>
Date: Thu, 24 Sep 2020 15:14:19 -0700

Another link you may find interesting is https://stats.labs.apnic.net/ipv6/CC?x=1&s=1&p=1&w=30&c=EG.

As you scroll down, you'll find that Egypt had very promising trial IPv6 service until early 2018. I don't know what happened then, but traffic plummeted dramatically, as if someone had simply turned it off. It might be worth your while to find out what happened.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 24 Sep 2020 22:24:52 +0000

Here is Egypt we have 3 or 4 Big Providers, I attended one of the trainings held by AFRINIC in 2016 about IPv6 and guys were still unfamiliar with IPv6, I encourage AFRINIC to do another visit to check it out with them to override the implications and for sure I will be there.

They had concerns regarding the Link Locals addresses and SLAAC.

Khaled Omar

---

From: Fred Baker <[email-masked]>
Date: Thu, 24 Sep 2020 16:53:01 -0700

Moving this to v6ops, as these are IPv6 questions.

> On Sep 24, 2020, at 3:24 PM, Khaled Omar <[email-masked]> wrote:
> 

I would be interested to understand the issues that Egyptian service providers have with Link Local Addresses and SLAAC. My first guess is that these differ from IPv4, and any way in which IPv6 differs from IPv4 tends to be a stumbling point. However, they have DHCP/DHCPv6 as options to SLAAC, so they can allocate addresses (and prefixes) using DHCP - and many enterprises do. Do they have additional questions regarding address assignment?

What are the Link Local Address issues? Is it just that they don't get to micromanage them? If they have a substantive issue to point out, there might be value in a discussion paper on the topic.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 24 Sep 2020 23:58:15 +0000

Yes, they will catch me and keep asking about link local addresses and what they are used significantly for.

Arranging answers before a meeting would help to open the discussion freely without complications.

Regarding address assignment, it is good that there are many options where they can choose, but still SLAAC a point of concern because it is very important to Give answers regarding all concerns.

Khaled Omar

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Fred Baker <[email-masked]>
Sent: Friday, September 25, 2020 1:53:01 AM
To: Khaled Omar <[email-masked]>
Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]>; IPv6 Operations <[email-masked]>
Subject: Egyptian service provider issues with IPv6

---

From: Gert Doering <[email-masked]>
Date: Fri, 25 Sep 2020 08:50:38 +0200

Hi,

> As you know from the IPv10 I-D, it requires the network between hosts to be IPv4/IPv6 ready, so it still can be considered, as I still think that the movement to IPv6 still need some time and arran…

The transit networks are all ready today.  If IPv6 is not available, it's 
the endpoints or the applications.

Gert Doering
        -- NetMaster
-- 
have you enabled IPv6 on something today...?

SpaceNet AG                      Vorstand: Sebastian v. Bomhard, Michael Emmer
Joseph-Dollinger-Bogen 14        Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                 HRB: 136055 (AG Muenchen)
Tel: +49 (0)89/32356-444         USt-IdNr.: DE813185279

---

From: "Carsten Strotmann" <[email-masked]>
Date: Fri, 25 Sep 2020 11:07:26 +0200

Hi,

On 25 Sep 2020, at 8:50, Gert Doering wrote:

>> As you know from the IPv10 I-D, it requires the network between hosts 
>> to be IPv4/IPv6 ready, so it still can be considered, as I still 
>> think that the movement to IPv6 still need some time and arrangement 
>> to get the best result for the coming generations.
>

I did a measurement of the use of IP protocols on a large (> 1M 
customers) DNS resolver in Germany in July. More than 2/3 of all DNS 
traffic from that resolver to the Internet was over IPv6, less than 1/3 
over IPv4.

At least for DNS, IPv6 is doing pretty good.

Greetings

Carsten

---

From: Vasilenko Eduard <[email-masked]>
Date: Fri, 25 Sep 2020 11:15:09 +0000

Hi all,
Fred has formalized below something like 25% of the good White Paper!

There is one recent WP on IPv6 status: https://www.etsi.org/images/files/ETSIWhitePapers/etsi_WP35_IPv6_Best_Practices_Benefits_Transition_Challenges_and_the_Way_Forward.pdf
Where some additional facts could be found.

Eduard
> From: v6ops [mailto:[email-masked]] On Behalf Of Fred Baker
> Sent: 25 сентября 2020 г. 0:45
> Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]>; IPv6
> Operations <[email-masked]>; int-area <[email-masked]>
> Subject: Re: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10
> draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)
> 
> Sure. I'm using a site that Eric Vyncke has put together and can discuss with you.
> He uses Google (Erik Kline), Akamai (Jared Mauch), and APNIC (George
> Michelson/Geoff Huston) numbers; there are other services that publish
> statistics, he just hasn't included them. As of this instant, Google reports that
> requests that come to it from 73 countries exceed at least 5% of its workload
> from that country, and traffic from 37 countries exceed 35% of its workload in
> that country. Its Eric's site, but the data is from Google, and the site can get you
> to Akamai and APNIC data as well for the price of a mouse-click.
> 
> What I do is download the Google statistics, select the countries that exceed
> some cut-off, and then ask Eric's or APNIC's site to display the data.
> 
> 5% cut-off
> https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,de,in
> ,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br,th,fi,mq,uy,gb,ec,ee,lk,ca,hu,ae,gp,re,
> nl,tt,ie,au,nz,pe,sa,ga,bo,ro,at,gt,no,ph,cz,sg,il,mo,pl,ar,sx,tg,si,np,mm,om,bt,k
> r,ke,fo,co,md,zw,cg,pr,is,lv,am,se,ru,li,jo,sk
> 
> 35% cut-off
> https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,de,in
> ,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br
> 
> If you scroll down, you will get a break-out by AS. APNIC reports that customers
> from 12 ASs use IPv6 when accessing APNIC with 50%+ probability ("ipv6-
> capable" and carrying that amount of data), and given a choice of IPv6 or IPv4,
> most of them are "ipv6-preferred" (eg, use IPv6 when given a choice). But about
> 50 ASs actually have users *using* IPv6 for some subset of their workload. In a
> Financial Times blog a week or two ago, the chair of India's IPv6 deployment
> task force argued that it should have an IPv6-only DNS Root Server on the basis
> of its IPv6 deployment and usage. I disagree with him (remarks available on
> request; they only have 38 IPv6-capable root servers in country), but the basis
> for the argument was interesting.
> 
> I think the APNIC data is interesting because it crosses the backbone. Google
> and Akamai run CDNs, which means that traffic can be between a residential
> subscriber and its CDN server without materially touching the ISP. APNIC runs no
> CDN, which means that traffic has to *also* traverse the ISP and the backbone
> to APNIC - there is and end-to-end path across the backbone. Think about this:
> when a user accesses a service using IPv6 (or IPv4 for that matter), the packet
> has to go from his computer, IOT device, or telephone to the site in question
> and the response has to come back; there has to be a complete end-to-end path
> in each direction. Miss one IPv6 connection in one direction, and it may as well
> be IPv4-only, because that's the only thing the end system will use.
> 
> From 73 countries, there is an end-to-end path of sufficient strength that a
> significant proportion of data *can* traverse it using IPv6, and the end system -
> which chooses whether to use IPv4 or IPv6 - will *choose* IPv6.
> 
> My search engine tells me "There are 195 countries in the world today. This total
> comprises 193 countries that are member states of the United Nations and 2
> countries that are non-member observer states: the Holy See and the State of
> Palestine." 37% of them, 73, have significant IPv6 usage.
> 
> What prevents this from being IPv6-only? Computers and network equipment
> used by residential and enterprise subscribers have supported both IPv4 and IPv6
> for years. The most commonly used applications are quite happy with either.
> The issue I see is primarily enterprise lack of IPv6 adoption in its customer-facing
> services. Even an "IPv6-preferred" site will use IPv4 when talking with something
> that will only use IPv4.
> 
> > As noted before: RFCs 6052, 6146, 6147, 6877, 7915, and others comprise the
> solution deployed to literally hundreds of millions if not billions of mobile
> devices and numerous access networks worldwide.
> >
> > Network engineers everywhere, they are waiting for the announcement of an
> official robust solution to the depletion of the IPv4 address space and the
> division that occurs recently on the Internet.
> >
> > People read the draft and many wrote about it because the idea is simple and
> requires no intervention from their side, that’s why I ask the IETF to take the
> draft seriously and put personal benefits aside for now, as LATER everything will
> back to normal, believe me, all are in need for this.
> >
> > Khaled Omar
> >
> > > Regarding the confusion, the community is curious about the idea, many
> people support it as it solves the problem that they think they are not part of it.
> >
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Gabor LENCSE <[email-masked]>
Date: Fri, 25 Sep 2020 13:15:46 +0200

Dear Carsten,

On 9/25/2020 11:07 AM, Carsten Strotmann wrote:

[...]

> traffic from that resolver to the Internet was over IPv6, less than 
> 1/3 over IPv4.

Thank you very much for this result! It is important for me, because I 
experienced that some authoritative DNS server implementations had 
higher performance over IPv4 than over IPv6 and I used IPv4 for their 
benchmarking. (My original motivation was to find a suitable 
authoritative DNS server implementation to support then benchmarking of 
DNS64 implementations according to RFC 8219, thus I wanted to achieve as 
high as possible performance. But I think that my results are relevant 
from the viewpoint of "normal" DNS usage, too.) Thus your results 
suggest me that I should repeat my measurements over IPv6, too.

As for my results regarding the performance of the tested authoritative 
DNS servers, both Knot DNS and NSD radically outperformed BIND. If you 
are interested in, you can find all the details in my open access paper:

G. Lencse, "Benchmarking Authoritative DNS Servers", /IEEE Access/, vol. 
8. pp. 130224130238, July 2020. 
https://doi.org/10.1109/ACCESS.2020.3009141<http://www.hit.bme.hu/~lencse/publications/IEEE-Access-2020-AuthDNS-revised.pdf>

Best regards,

Gábor

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 11:36:11 +0000

Hi,

From the collection of statistics you all provided, I can come to a conclusion that around an average of 40% of the world traffic became IPv6, which is still something we cannot depend on as if you compare the time since IPv6 was firstly deployed till now, I can expect that after +10 years we can come to 70 or 75% world-wide, during this time we will have blocks of IPv6 only and blocks of IPv4, which means the clear division.

That’s why looking into the transitions solutions became a mandatory or a peaceful solution such as IPv10 that will allow both version to coexist and communicate until the full migration. 

Khaled Omar

-----Original Message-----
From: Vasilenko Eduard <[email-masked]> 
Sent: Friday, September 25, 2020 1:15 PM
To: Fred Baker <[email-masked]>; Khaled Omar <[email-masked]>
Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]>; IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: RE: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

Hi all,

Eduard
> Subject: Re: [v6ops] [Int-area] Still need to know what has 
> changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session 
> Request for IETF 109 - IPv10)
> 
> > Maybe if you can provide me with all the statistics I need that 
> > shows the
> deployment so I can believe.
> >
> > Khaled Omar
> 
> statistics, he just hasn't included them. As of this instant, Google 
> reports that requests that come to it from 73 countries exceed at 
> least 5% of its workload from that country, and traffic from 37 
> countries exceed 35% of its workload in that country. Its Eric's site, 
> but the data is from Google, and the site can get you to Akamai and APNIC data as well for the price of a mouse-click.
> 
> What I do is download the Google statistics, select the countries that 
> exceed some cut-off, and then ask Eric's or APNIC's site to display the data.
> 
> 5% cut-off
> nl,tt,ie,au,nz,pe,sa,ga,bo,ro,at,gt,no,ph,cz,sg,il,mo,pl,ar,sx,tg,si,n
> p,mm,om,bt,k r,ke,fo,co,md,zw,cg,pr,is,lv,am,se,ru,li,jo,sk
> 
> 35% cut-off
> https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,de
> ,in ,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br
> 
> If you scroll down, you will get a break-out by AS. APNIC reports that 
> customers from 12 ASs use IPv6 when accessing APNIC with 50%+ 
> probability ("ipv6- capable" and carrying that amount of data), and 
> given a choice of IPv6 or IPv4, most of them are "ipv6-preferred" (eg, 
> use IPv6 when given a choice). But about
> 50 ASs actually have users *using* IPv6 for some subset of their 
> workload. In a Financial Times blog a week or two ago, the chair of 
> India's IPv6 deployment task force argued that it should have an 
> IPv6-only DNS Root Server on the basis of its IPv6 deployment and 
> usage. I disagree with him (remarks available on request; they only 
> have 38 IPv6-capable root servers in country), but the basis for the argument was interesting.
> 
> I think the APNIC data is interesting because it crosses the backbone. 
> Google and Akamai run CDNs, which means that traffic can be between a 
> residential subscriber and its CDN server without materially touching 
> the ISP. APNIC runs no CDN, which means that traffic has to *also* 
> traverse the ISP and the backbone to APNIC - there is and end-to-end path across the backbone. Think about this:
> when a user accesses a service using IPv6 (or IPv4 for that matter), 
> the packet has to go from his computer, IOT device, or telephone to 
> the site in question and the response has to come back; there has to 
> be a complete end-to-end path in each direction. Miss one IPv6 
> connection in one direction, and it may as well be IPv4-only, because that's the only thing the end system will use.
> 
> From 73 countries, there is an end-to-end path of sufficient strength 
> that a significant proportion of data *can* traverse it using IPv6, 
> and the end system - which chooses whether to use IPv4 or IPv6 - will *choose* IPv6.
> 
> My search engine tells me "There are 195 countries in the world today. 
> This total comprises 193 countries that are member states of the 
> United Nations and 2 countries that are non-member observer states: 
> the Holy See and the State of Palestine." 37% of them, 73, have significant IPv6 usage.
> 
> What prevents this from being IPv6-only? Computers and network 
> equipment used by residential and enterprise subscribers have 
> supported both IPv4 and IPv6 for years. The most commonly used applications are quite happy with either.
> The issue I see is primarily enterprise lack of IPv6 adoption in its 
> customer-facing services. Even an "IPv6-preferred" site will use IPv4 
> when talking with something that will only use IPv4.
> 
> > Boy. If “millions and billions” isn’t wide deployment, maybe I need 
> > to go back
> to grammar school.
> >
> > Sent from my iPad
> >
> >
> > On Sep 19, 2020, at 4:18 PM, Khaled Omar 
> > <[email-masked]>
> wrote:
> >
> > 
> solution deployed to literally hundreds of millions if not billions of 
> mobile devices and numerous access networks worldwide.
> >
> official robust solution to the depletion of the IPv4 address space 
> and the division that occurs recently on the Internet.
> >
> requires no intervention from their side, that’s why I ask the IETF to 
> take the draft seriously and put personal benefits aside for now, as 
> LATER everything will back to normal, believe me, all are in need for this.
> >
> > Khaled Omar
> >

---

From: Ola Thoresen <[email-masked]>
Date: Fri, 25 Sep 2020 13:59:10 +0200

> That’s why looking into the transitions solutions became a mandatory or a peaceful solution such as IPv10 that will allow both version to coexist and communicate until the full migration.

But you keep on either lying or actively misunderstanding your own solution.

"IPv10" is not "peaceful coexistence of IPv4 and IPv6". You have 
designed a _new_ protocol that would need to be implemented in every 
operating system, every router and every other layer 3 device on the 
entire internet.

Basically every single host on the internet would need to have either 
both IPv4 and IPv10, or IPv6 and IPv10.  If every IPv4 host need to have 
another protocol added to them, why can't that protocol just be IPv6, 
which is already widely deployed - as several people have pointed out to 
you many, many times. And then you could just leave all the hosts that 
already have IPv6 alone.

There simply is no _need_ for your IPv10. And as a transition solution 
it is extremely invasive. The whole point of transition solutions is 
that you do NOT need to modify every single host to use them.  You just 
need to add some translators or endpoints.

Rgds.

Ola (T)

>> ,in

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 12:04:45 +0000

Why repeating same incorrect statements about IPv10?!

The update process is simple, the migration process is difficult.

The update process is easy, the translation process requires more efforts.

And so on, I don't like to keep repeating same words for same questions.

Users will do nothing except accepting updates.

Best regards,

Khaled Omar

-----Original Message-----
From: v6ops <[email-masked]> On Behalf Of Ola Thoresen
Sent: Friday, September 25, 2020 1:59 PM
To: [email-masked]
Subject: Re: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

"IPv10" is not "peaceful coexistence of IPv4 and IPv6". You have designed a _new_ protocol that would need to be implemented in every operating system, every router and every other layer 3 device on the entire internet.

Basically every single host on the internet would need to have either both IPv4 and IPv10, or IPv6 and IPv10.  If every IPv4 host need to have another protocol added to them, why can't that protocol just be IPv6, which is already widely deployed - as several people have pointed out to you many, many times. And then you could just leave all the hosts that already have IPv6 alone.

There simply is no _need_ for your IPv10. And as a transition solution it is extremely invasive. The whole point of transition solutions is that you do NOT need to modify every single host to use them.  You just need to add some translators or endpoints.

Rgds.

Ola (T)

> Subject: RE: [v6ops] [Int-area] Still need to know what has 
> There is one recent WP on IPv6 status: 
> https://www.etsi.org/images/files/ETSIWhitePapers/etsi_WP35_IPv6_Best_
> Practices_Benefits_Transition_Challenges_and_the_Way_Forward.pdf
>> On Sep 21, 2020, at 3:57 AM, Khaled Omar 
>> Michelson/Geoff Huston) numbers; there are other services that 
>> publish statistics, he just hasn't included them. As of this instant, 
>> Google reports that requests that come to it from 73 countries exceed 
>> at least 5% of its workload from that country, and traffic from 37 
>> countries exceed 35% of its workload in that country. Its Eric's 
>> site, but the data is from Google, and the site can get you to Akamai and APNIC data as well for the price of a mouse-click.
>>
>> What I do is download the Google statistics, select the countries 
>> that exceed some cut-off, and then ask Eric's or APNIC's site to display the data.
>>
>> 5% cut-off
>> ,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br,th,fi,mq,uy,gb,ec,ee,lk,ca
>> ,
>> hu,ae,gp,re,
>> nl,tt,ie,au,nz,pe,sa,ga,bo,ro,at,gt,no,ph,cz,sg,il,mo,pl,ar,sx,tg,si,
>> n p,mm,om,bt,k r,ke,fo,co,md,zw,cg,pr,is,lv,am,se,ru,li,jo,sk
>>
>> 35% cut-off
>> https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,d
>> e ,in ,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br
>>
>> If you scroll down, you will get a break-out by AS. APNIC reports 
>> that customers from 12 ASs use IPv6 when accessing APNIC with 50%+ 
>> given a choice of IPv6 or IPv4, most of them are "ipv6-preferred" 
>> (eg, use IPv6 when given a choice). But about
>>  From 73 countries, there is an end-to-end path of sufficient 
>> strength that a significant proportion of data *can* traverse it 
>> using IPv6, and the end system - which chooses whether to use IPv4 or IPv6 - will *choose* IPv6.
>>
>> solution deployed to literally hundreds of millions if not billions 
>> of mobile devices and numerous access networks worldwide.
>> requires no intervention from their side, that’s why I ask the IETF 
>> to take the draft seriously and put personal benefits aside for now, 
>> as LATER everything will back to normal, believe me, all are in need for this.
>>> Khaled Omar
>>>

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 25 Sep 2020 14:42:52 +0200 (CEST)

On Fri, 25 Sep 2020, Khaled Omar wrote:

> That’s why looking into the transitions solutions became a mandatory or 
> a peaceful solution such as IPv10 that will allow both version to 
> coexist and communicate until the full migration.

No, any change now just resets the clock and postpones the transition by 
another 20 years.

Meaningful support for IPv6 has been available in end-devices since the 
2006-2008 timeframe when Windows Vista was released and around the same 
timeframe other end-user operating systems gained support as well.

We're now in 2020 in a situation where basically every end user device in 
use has IPv6 support, even laggards like Smart TVs have started to gain 
IPv6 support. Printers have had IPv6 support for 10+ years.

For your proposal, you have zero running code and thus zero devices 
supporting your proposal.

You keep making these statements that upgrades are easy. They are not. 
Ecosystems take a long time to build. You don't even have running code to 
be able to verify that your proposal actually works (it doesn't).

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 13:04:29 +0000

>> You don't even have running code to be able to verify that your proposal actually works (it doesn't).

Do you have a running code to state this?

Khaled Omar

-----Original Message-----
From: Mikael Abrahamsson <[email-masked]> 
Sent: Friday, September 25, 2020 2:43 PM
To: Khaled Omar <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: Re: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

On Fri, 25 Sep 2020, Khaled Omar wrote:

> That’s why looking into the transitions solutions became a mandatory 
> or a peaceful solution such as IPv10 that will allow both version to 

No, any change now just resets the clock and postpones the transition by another 20 years.

Meaningful support for IPv6 has been available in end-devices since the
2006-2008 timeframe when Windows Vista was released and around the same timeframe other end-user operating systems gained support as well.

We're now in 2020 in a situation where basically every end user device in use has IPv6 support, even laggards like Smart TVs have started to gain
IPv6 support. Printers have had IPv6 support for 10+ years.

For your proposal, you have zero running code and thus zero devices supporting your proposal.

You keep making these statements that upgrades are easy. They are not. 
Ecosystems take a long time to build. You don't even have running code to be able to verify that your proposal actually works (it doesn't).

---

From: [email-masked]
Date: Fri, 25 Sep 2020 15:04:59 +0200

Ah, but you are looking at it from the wrong level of abstraction.
What I believe Khaled has in mind is something like (in pseudocode):

#!/usr/bin/env python14

from MachineLearning.Magic import NewIPStackGenerator
from InternetRouting import Discover

nodes = Discover.AllNodesInTheInternet()
v10stack_template.Merge(IP4Stack, IP6Stack)
for n in nodes:
   v10stack = NewIPStack.AutoGenerate(n.hw_sw_properties, v10stack_template)
   n.deploy(v10stack)   

See, simple. ;-)
Have a nice weekend.

Ole

> On 25 Sep 2020, at 13:59, Ola Thoresen <[email-masked]> wrote:
>

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 25 Sep 2020 14:07:48 +0100

> The update process is easy, the translation process requires more efforts.

That's great.  Where can I download your code to test how easy it is to 
upgrade to ipv10?

v6ops@ietf is IPv6 operations, i.e. for discussion where the code has 
already been written and people are having operational issues.

If you haven't written code, then v6ops is automatically the wrong IETF 
working group.

Nick

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 13:13:32 +0000

Yes Ole, very simple ;-)

Khaled

-----Original Message-----
From: v6ops <[email-masked]> On Behalf Of [email-masked]
Sent: Friday, September 25, 2020 3:05 PM
To: Ola Thoresen <[email-masked]>
Cc: [email-masked]
Subject: Re: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

#!/usr/bin/env python14

from MachineLearning.Magic import NewIPStackGenerator from InternetRouting import Discover

nodes = Discover.AllNodesInTheInternet() v10stack_template.Merge(IP4Stack, IP6Stack) for n in nodes:
   v10stack = NewIPStack.AutoGenerate(n.hw_sw_properties, v10stack_template)
   n.deploy(v10stack)   

See, simple. ;-)
Have a nice weekend.

Ole

>> https://www.etsi.org/images/files/ETSIWhitePapers/etsi_WP35_IPv6_Best
>> _Practices_Benefits_Transition_Challenges_and_the_Way_Forward.pdf
>>> publish statistics, he just hasn't included them. As of this 
>>> instant, Google reports that requests that come to it from 73 
>>> countries exceed at least 5% of its workload from that country, and 
>>> traffic from 37 countries exceed 35% of its workload in that 
>>> country. Its Eric's site, but the data is from Google, and the site can get you to Akamai and APNIC data as well for the price of a mouse-click.
>>> 
>>> ,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br,th,fi,mq,uy,gb,ec,ee,lk,c
>>> a,
>>> hu,ae,gp,re,
>>> nl,tt,ie,au,nz,pe,sa,ga,bo,ro,at,gt,no,ph,cz,sg,il,mo,pl,ar,sx,tg,si
>>> ,n p,mm,om,bt,k r,ke,fo,co,md,zw,cg,pr,is,lv,am,se,ru,li,jo,sk
>>> 
>>> 35% cut-off
>>> https://www.vyncke.org/ipv6status/compare.php?metric=p&countries=be,
>>> de ,in ,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br
>>> 
>>> Google and Akamai run CDNs, which means that traffic can be between 
>>> a residential subscriber and its CDN server without materially 
>>> touching the ISP. APNIC runs no CDN, which means that traffic has to 
>>> *also* traverse the ISP and the backbone to APNIC - there is and end-to-end path across the backbone. Think about this:
>>> customer-facing services. Even an "IPv6-preferred" site will use 
>>> IPv4 when talking with something that will only use IPv4.
>>> 
>>>> IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session 
>>>> IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session 
>>>> IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session

---

From: Ola Thoresen <[email-masked]>
Date: Fri, 25 Sep 2020 15:13:31 +0200

> Users will do nothing except accepting updates.

_Users_ don't need to do anything for IPv6 either.  IPv6 has been 
default enabled in all major operating systems for years.

And IPv6 has been supported in all the big vendors routers for even longer.

IPv6 is not held back by lack of support in hardware, software or 
operating systems.  IPv6 is held back by policy and lack of demand.

IPv6 is held back by policy in the big enterprises, that don't want to 
deal with another protocol.

IPv6 is held back by lack of demand at the service providers, as the 
customers don't ask for it, so they see no business cases.

None of these issues are resolved by adding another protocol.  It would 
still require the enterprises to deal with the new protocol in all their 
security policies, in their monitoring and support platforms etc.

And it would still require a customer demand for the ISPs to add it.  If 
IPv4-only customers are not requesting IPv6 today - why would they start 
requesting "IPv10" tomorrow?  What would they gain from that, that the 
ISPs can create a business model out of? Asking for "IPv10" would not 
give them anything more than they get by just asking for IPv6 in the 
first place.

I am sorry you don't understand this.

Rgds.

/Ola (T)

>>> e

---

From: Ola Thoresen <[email-masked]>
Date: Fri, 25 Sep 2020 15:15:28 +0200

> Have a nice weekend.

Surely hope so!

=;-)

/Ola

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 13:20:03 +0000

>> IPv6 is not held back by lack of support in hardware, software or operating systems.  IPv6 is held back by policy and lack of demand.

This is what we call "Migration" which requires user's dependence.

>> IPv6 is held back by policy in the big enterprises, that don't want to deal with another protocol.

That’s why IPv10 is needed, they have to do nothing about it, only keep using your IP version and that’s it.

>> And it would still require a customer demand for the ISPs to add it.  If IPv4-only customers are not requesting IPv6 today - why would they start requesting "IPv10" tomorrow?  

They will not request IPv10, they will have hosts support IPv10, this will not be accomplished by them but by OS developers.

Khaled Omar

-----Original Message-----
From: v6ops <[email-masked]> On Behalf Of Ola Thoresen
Sent: Friday, September 25, 2020 3:14 PM
To: [email-masked]
Subject: Re: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

> Users will do nothing except accepting updates.

_Users_ don't need to do anything for IPv6 either.  IPv6 has been default enabled in all major operating systems for years.

IPv6 is not held back by lack of support in hardware, software or operating systems.  IPv6 is held back by policy and lack of demand.

IPv6 is held back by policy in the big enterprises, that don't want to deal with another protocol.

IPv6 is held back by lack of demand at the service providers, as the customers don't ask for it, so they see no business cases.

None of these issues are resolved by adding another protocol.  It would still require the enterprises to deal with the new protocol in all their security policies, in their monitoring and support platforms etc.

And it would still require a customer demand for the ISPs to add it.  If IPv4-only customers are not requesting IPv6 today - why would they start requesting "IPv10" tomorrow?  What would they gain from that, that the ISPs can create a business model out of? Asking for "IPv10" would not give them anything more than they get by just asking for IPv6 in the first place.

Rgds.

/Ola (T)

>> _ Practices_Benefits_Transition_Challenges_and_the_Way_Forward.pdf
>>> d
>>> a
>>> , n p,mm,om,bt,k r,ke,fo,co,md,zw,cg,pr,is,lv,am,se,ru,li,jo,sk
>>>
>>> 35% cut-off
>>> d e ,in ,my,gr,yt,tw,gf,vn,ch,us,fr,mx,pt,jp,lu,br
>>>

---

From: Ola Thoresen <[email-masked]>
Date: Fri, 25 Sep 2020 15:54:01 +0200

> This is what we call "Migration" which requires user's dependence.

For an enterprise _user_, nothing is needed. It is managed by the 
enterprises IT-department, and is either enabled or disabled by them.

For a home user, nothing is needed.  Their ISP just needs to support it, 
and it must be enabled in their CPE with some sane security policies.

And trust me. I have done multiple IPv4 -> Dual Stack "migrations" for 
both enterprises and ISPs.  No involvement of the end users is required.

But a LOT of work is required both in the enterprise IT department and 
at the ISPs to ensure that everything works as expected.

> That’s why IPv10 is needed, they have to do nothing about it, only keep using your IP version and that’s it.

No, they don't.

They need to enable this IPv10 protocol in their network, just as they 
need to enable IPv6 today.  And they need to be sure that ALL their back 
office systems support it, that all their firewalls, access lists, 
applications etc. are up to date with new source and destination 
addresses (since they can now be both IPv4 and IPv6).   And not only 
that.  Today, if you are dual stack enabled.  You need one access list 
for IPv4 -> IPv4 and one for IPv6 -> IPv6.  With your suggestion, you 
would ALSO need to update all policies and firewalls and access lists 
and whatnot with policies for IPv4 -> IPv6 and IPv6 -> IPv4 as well, 
because some hosts are suddenly talking to hosts that they should not be 
allowed to, using another protocol than they would previously do.

To me, this sounds like MORE work than to just going for dual stack in 
the first place.  So, no.  They can't just keep their IP-version.

And they still need to update all other systems, logg-parsers, 
monitoring applications, you name it, from one protocol (most likely 
IPv4 only) to two protocols.  IPv4 + IPv6.

> They will not request IPv10, they will have hosts support IPv10, this will not be accomplished by them but by OS developers.

It does not matter if my host has IPv10 activated, if my ISP does not 
route IPv10 packets.  And it does not even matter if my ISP routes IPv10 
packets, if somewhere along the path from source to destination, there 
is a single router that does not support this protocol.  So, yes.  Even 
if my OS has IPv10, I would have to request my ISP to enable it to be 
able to talk to IPv6 hosts.  And all their peers would have to enabled 
it.  And in that case, I can just as well ask my ISP to enable IPv6, as 
that is already a mature protocol that is well implemented in all OSes 
already.

Don't you see this simple thing?

The problem is not the address of the source or destination host.  The 
problem is all the hosts in between, which must be able to parse and 
understand this new protocol.  And all the package-mangling that is done 
in hardware and software along the path of a packet traversing the internet.

And _even_ if they all actually had the new protocol implemented in 
hardware and software (which in itself will take many, many years), you 
would STILL have the problem of the enterprises not wanting to deal with 
multiple protocols and of ISPs not wanting to turn in on for their 
customers because it might lead to more support requests, less security 
and added complexity, and we would basically be exactly where we are 
today with IPv6.

Rgds,

/Ola (T)

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 14:03:01 +0000

I agree with most of what you said, but regarding ACLs and firewalls, they will use the same configuration after IPv10 and then they can add more configuration if needed when there are different source or destination addresses.

Regarding the path, as mentioned, when ALL are updated (of course there will be a flag day) then everything will work in the best way and we will use both address spaces till full migration is accomplished.

Best Regards,

Khaled Omar 

-----Original Message-----
From: v6ops <[email-masked]> On Behalf Of Ola Thoresen
Sent: Friday, September 25, 2020 3:54 PM
To: [email-masked]
Subject: Re: [v6ops] [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

> This is what we call "Migration" which requires user's dependence.

For an enterprise _user_, nothing is needed. It is managed by the enterprises IT-department, and is either enabled or disabled by them.

For a home user, nothing is needed.  Their ISP just needs to support it, and it must be enabled in their CPE with some sane security policies.

And trust me. I have done multiple IPv4 -> Dual Stack "migrations" for both enterprises and ISPs.  No involvement of the end users is required.

But a LOT of work is required both in the enterprise IT department and at the ISPs to ensure that everything works as expected.

No, they don't.

Rgds,

/Ola (T)

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Fri, 25 Sep 2020 16:37:50 +0200

Hi Khaled,

> Do you have a running code to state this?

How should one create running code out of a flawed specification?
The following picture from your draft already shows that
it definitely cannot work, thus no code needed:
an IPv4-_only_ host by definition does NOT support IPv10
and thus CANNOT send any IPv10 tunnel packets. Same for an
IPv6-_only_ host.

IPv10 Host                                         IPv10 Host
    PC-1                                                PC-2
   +----+                                              +----+
   |    |                                              |    |
   |    |                                              |    |
   +----+                                              +----+
  /    /   <--------------------------------------->  /    /
 +----+              IPv10 Header (Tunnel)           +----+
                              (3)
IPv4-Only Host                                    IPv6-Only Host

Do you see the contradiction here?

Roland

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 14:41:10 +0000

Roland, the sending host will encapsulate an extension header with two different IP versions, where is the contradiction here? I don't see it.

Khaled Omar

-----Original Message-----
From: Bless, Roland (TM) <[email-masked]> 
Sent: Friday, September 25, 2020 4:38 PM
To: Khaled Omar <[email-masked]>; Mikael Abrahamsson <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: Re: [Int-area] [v6ops] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

Hi Khaled,

How should one create running code out of a flawed specification?
The following picture from your draft already shows that it definitely cannot work, thus no code needed:
an IPv4-_only_ host by definition does NOT support IPv10 and thus CANNOT send any IPv10 tunnel packets. Same for an IPv6-_only_ host.

IPv10 Host                                         IPv10 Host
    PC-1                                                PC-2
   +----+                                              +----+
   |    |                                              |    |
   |    |                                              |    |
   +----+                                              +----+

Roland

> We're now in 2020 in a situation where basically every end user device 
> in use has IPv6 support, even laggards like Smart TVs have started to 
> gain

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Fri, 25 Sep 2020 17:11:10 +0200

Hi Khaled,

> Roland, the sending host will encapsulate an extension header with two different IP versions, where is the contradiction here? I don't see it.

This is a bit sad, but probably one last try:
An IPv4-only host does only understand a single IP version, namely IPv4.
Inside an IPv4-only host there is NO understanding of a
different packet format (IPv10) or IP address format (neither IPv6 nor
IPv10) by definition. Consequently, it cannot encapsulate an IPv4 packet
into an IPv10 packet by lack of knowing the format and functionality.
Otherwise you have an IPv4/IPv10 _dual_ stack host, but that
is then not an IPv4-only host by definition.

Regards
 Roland

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 15:13:09 +0000

Ok, I have no energy to keep repeating, I'm sorry, read the full draft please again.

Khaled Omar

-----Original Message-----
From: Bless, Roland (TM) <[email-masked]> 
Sent: Friday, September 25, 2020 5:11 PM
To: Khaled Omar <[email-masked]>; Mikael Abrahamsson <[email-masked]>
Cc: IPv6 Operations <[email-masked]>; int-area <[email-masked]>
Subject: Re: [Int-area] [v6ops] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

Hi Khaled,

This is a bit sad, but probably one last try:
An IPv4-only host does only understand a single IP version, namely IPv4.
Inside an IPv4-only host there is NO understanding of a different packet format (IPv10) or IP address format (neither IPv6 nor
IPv10) by definition. Consequently, it cannot encapsulate an IPv4 packet into an IPv10 packet by lack of knowing the format and functionality.
Otherwise you have an IPv4/IPv10 _dual_ stack host, but that is then not an IPv4-only host by definition.

Regards
 Roland

> Subject: Re: [Int-area] [v6ops] Still need to know what has 
>> We're now in 2020 in a situation where basically every end user 
>> device in use has IPv6 support, even laggards like Smart TVs have 
>> started to gain

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Fri, 25 Sep 2020 17:30:05 +0200

Khaled,

> Ok, I have no energy to keep repeating, I'm sorry, read the full draft please again.

Be assured that I read the draft, but that does not solve the problem
with your draft/proposal. Unless you see the contradiction I pointed out
here, there is no common ground for ANY further discussion on this
topic. Most of us may have different views on proposals, but at least
no different views on logical inferences like this one.
  Roland

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Fri, 25 Sep 2020 20:45:46 +0000

Khaled,

You have received significant feedback from representatives of network/cloud operators, network equipment vendors, mobile device makers, academia, SW providers and developers. 

We will not consider your draft for presentation until a version of your proposal responds to the different technical issues that have been pointed out.

If you are interested in pursuing, please update your draft taking into account all these considerations. Running code with proven results would also help.

Once you get positive support on the mailing list, we will gladly consider it for presentation at the meeting.

Best regards,

Juan Carlos Zuniga & Wassim Haddad
(Internet Area WG Chairs)

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 20:52:45 +0000

I still don't see any technical concerns received from the members, all are to understand the way how IPv10 works, some had a misunderstanding that’s why I wanted to answer all these question during the meeting so no duplicated questions be received.

It is good to take all into my account but regarding the running code, is out of my hands, so without your help, nothing will go forward.

Thanks Juan,

Khaled Omar

-----Original Message-----
From: Juan Carlos Zuniga <[email-masked]> 
Sent: Friday, September 25, 2020 10:46 PM
To: Khaled Omar <[email-masked]>; Wassim Haddad <[email-masked]>
Cc: Eric Vyncke (evyncke) <evyncke=[email-masked]>; IPv6 Operations <[email-masked]>; int-area <[email-masked]>; Fred Baker <[email-masked]>; Juan Carlos Zuniga <[email-masked]>
Subject: RE: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

Khaled,

Best regards,

---

From: Fred Baker <[email-masked]>
Date: Fri, 25 Sep 2020 14:14:14 -0700

> On Sep 25, 2020, at 4:36 AM, Khaled Omar <[email-masked]> wrote:
> 

I already wrote that white paper, in 2017. Numbers were a little different, but take a look at:
https://www.internetsociety.org/resources/doc/2017/state-of-ipv6-deployment-2017/

---

From: Khaled Omar <[email-masked]>
Date: Fri, 25 Sep 2020 21:19:21 +0000

I agree, but where we can found a live statistics other than Google to keep tracking?

Khaled Omar

---

From: Erik Kline <[email-masked]>
Date: Fri, 25 Sep 2020 14:46:29 -0700

https://www.worldipv6launch.org/measurements/ has some aggregated
statistics.

On Fri, Sep 25, 2020 at 2:19 PM Khaled Omar <[email-masked]>
wrote:

> Cc: Vasilenko Eduard <[email-masked]>; Eric Vyncke (evyncke)
> <evyncke=[email-masked]>; IPv6 Operations <[email-masked]>;
> int-area <[email-masked]>
> Subject: Re: [v6ops] [Int-area] Still need to know what has changed....
> Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF
> 109 - IPv10)
>
>
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 25 Sep 2020 21:52:27 +0000

Khaled,

I fully support the intarea Working Group chairs' decision as the responsible AD for this WG.

As long as you do not execute the work of updating your draft (and I gave you last week the bare minimum things to do) it will not get a slot in any IETF WG. Its content has not really changed since last presentation.

So, when you have a new improved draft, the WG chairs and myself will reconsider the situation. But not before.

Regards

-éric

PS: and to be clear, I do not want any more discussion about presenting this draft on the intarea mailing list until it is vastly improved.

-----Original Message-----
From: Juan Carlos Zuniga <[email-masked]>
Date: Friday, 25 September 2020 at 22:46
To: Khaled Omar <[email-masked]>, Wassim Haddad <[email-masked]>
Cc: Eric Vyncke <[email-masked]>, IPv6 Operations <[email-masked]>, int-area <[email-masked]>, Fred Baker <[email-masked]>, Juan Carlos Zuniga <[email-masked]>
Subject: RE: [Int-area] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: [v6ops] v6ops - New Meeting Session Request for IETF 109 - IPv10)

    Khaled,

    Best regards,

---

From: Simon Hobson <[email-masked]>
Date: Mon, 28 Sep 2020 09:22:07 +0100

> Ok, I have no energy to keep repeating, I'm sorry, read the full draft please again.

And therein lies a big part of your problem.

Constantly repeating something which is incorrect does not make it correct - well not in our world anyway ! You can say "it's not a problem" as many times as you like, that does not make it so.

People have tried to explain to you in many ways that upgrading hosts that are easy to upgrade is not the problem - that's mostly solved.
Firewall rules/ACLs/etc do not stay the same - they must all be updated to cope with the new combinations of addresses that can be employed. Routers everywhere must be updated - believe it or not, IPv4 routers are usually hardware tied to the format of an IPv4 packet - they simply will not understand any other packet. And by requiring a different packet format end-end you are enforcing that your packet format cannot be used (reliably) until 100% of the internet has been upgraded.

And as already said, pretty well all the changes needed to support your IPv10 are much the same as needed to support IPv6. But, with IPv6 once you get there then you've reached the end-game (IPv6) rather than having reached just a milestone on the way to IPv6. And there are migration options to handle "bits" (whether that's hosts, bits of the internet, services, whatever) that still can't manage IPv6.

So, some specific questions you've been asked but refused to answer. I say refused, because saying "just read the draft again, you don't understand" is refusing to answer legitimate questions about what is in your draft. The questions asked show that people have looked at and understood your draft - they can see reasons why it cannot work, but you are failing to address those issues.

Q: In your IPv10 world, what happens when an IPv4 only host (and by that, I mean a host that cannot talk anything but plain vanilla IPv4) tries to talk to an IPv6 only host ?
A: It fails. If you believe otherwise, please explain how it works - without requiring the host to be IPv10 capable. In reality (in the absence of network based migration techniques), it'll do an A lookup in DNS, get no result, and just fail. It won't know what to do with an AAAA record.
Bonus answer: Explain how hosts that are no longer supported, or have hardware restrictions (limited RAM/ROM space), are owned/used by people who have no idea what a "firmware upgrade" is and have even less idea why they'd want to do one, etc get upgrades ?

Q: In your IPv10 world, what happens when one of your new format packets hits a router/firewall/load balancer/other network equipment that doesn't understand it ?
A: The packet gets dropped<period>. If it isn't an IPv4 packet, then an IPv4 device won't handle it - by definition, your IPv10 packets are not IPv4 packets. Your IPv10 host cannot communicate along that path. Thus it must fall back to trying either IPv4 or IPv6 - so it might as well have just used IPv4 or IPv6 in the first place. Again, if you believe my answer to be wrong, then explain in detail why - not just "you don't understand, read the draft again".

Simon

---

From: Vasilenko Eduard <[email-masked]>
Date: Mon, 28 Sep 2020 08:45:02 +0000

Hi all,

In my humble opinion: the best statistics is from APNIC, because it is collected from random Google Ads - representative for almost all world (except a few countries where Google Ads is not doing well for some reasons):
https://stats.labs.apnic.net/ipv6
It is very reach on detalization per country and per AS# (possible to translate to Carrier).

The next one is probably Google itself. Just keep in mind that is it is related only to google traffic:
http://www.google.com/intl/en/ipv6/statistics.html
Anyway, very representative too.

The next one is probably Akamai:
https://www.akamai.com/es/es/resources/our-thinking/state-of-the-internet-report/state-of-the-internet-ipv6-adoption-visualization.jsp
It is a little distorted (about 2-3% by country) from 2 previous, because more related to Enterprises (who has ordered CDN).

All give very close numbers per every country.

Eduard
> From: v6ops [mailto:[email-masked]] On Behalf Of Khaled Omar
> Sent: 25 сентября 2020 г. 17:03
> To: Ola Thoresen <[email-masked]>; [email-masked]
> I agree with most of what you said, but regarding ACLs and firewalls, they will
> use the same configuration after IPv10 and then they can add more
> configuration if needed when there are different source or destination
> addresses.
> 
> Regarding the path, as mentioned, when ALL are updated (of course there will
> be a flag day) then everything will work in the best way and we will use both
> address spaces till full migration is accomplished.
> 
> Best Regards,
> 
> Khaled Omar
> 
> >>> IPv6 is not held back by lack of support in hardware, software or operating
> systems.  IPv6 is held back by policy and lack of demand.
> For an enterprise _user_, nothing is needed. It is managed by the enterprises IT-
> department, and is either enabled or disabled by them.
> 
> For a home user, nothing is needed.  Their ISP just needs to support it, and it
> must be enabled in their CPE with some sane security policies.
> 
> And trust me. I have done multiple IPv4 -> Dual Stack "migrations" for both
> enterprises and ISPs.  No involvement of the end users is required.
> 
> But a LOT of work is required both in the enterprise IT department and at the
> ISPs to ensure that everything works as expected.
> 
> 
> They need to enable this IPv10 protocol in their network, just as they need to
> enable IPv6 today.  And they need to be sure that ALL their back office systems
> support it, that all their firewalls, access lists, applications etc. are up to date
> with new source and destination addresses (since they can now be both IPv4 and
> IPv6).   And not only that.  Today, if you are dual stack enabled.  You need one
> access list for IPv4 -> IPv4 and one for IPv6 -> IPv6.  With your suggestion, you
> would ALSO need to update all policies and firewalls and access lists and
> whatnot with policies for IPv4 -> IPv6 and IPv6 -> IPv4 as well, because some
> hosts are suddenly talking to hosts that they should not be allowed to, using
> another protocol than they would previously do.
> 
> To me, this sounds like MORE work than to just going for dual stack in the first
> place.  So, no.  They can't just keep their IP-version.
> 
> And they still need to update all other systems, logg-parsers, monitoring
> applications, you name it, from one protocol (most likely
> >>> And it would still require a customer demand for the ISPs to add it.  If IPv4-
> only customers are not requesting IPv6 today - why would they start requesting
> "IPv10" tomorrow?
> > They will not request IPv10, they will have hosts support IPv10, this will not be
> accomplished by them but by OS developers.
> 
> It does not matter if my host has IPv10 activated, if my ISP does not route IPv10
> packets.  And it does not even matter if my ISP routes IPv10 packets, if
> somewhere along the path from source to destination, there is a single router
> that does not support this protocol.  So, yes.  Even if my OS has IPv10, I would
> have to request my ISP to enable it to be able to talk to IPv6 hosts.  And all their
> peers would have to enabled it.  And in that case, I can just as well ask my ISP to
> enable IPv6, as that is already a mature protocol that is well implemented in all
> OSes already.
> 
> The problem is not the address of the source or destination host.  The problem is
> all the hosts in between, which must be able to parse and understand this new
> protocol.  And all the package-mangling that is done in hardware and software
> along the path of a packet traversing the internet.
> 
> And _even_ if they all actually had the new protocol implemented in hardware
> and software (which in itself will take many, many years), you would STILL have
> the problem of the enterprises not wanting to deal with multiple protocols and
> of ISPs not wanting to turn in on for their customers because it might lead to
> more support requests, less security and added complexity, and we would
> basically be exactly where we are today with IPv6.
> 
> 
> Rgds,
> 
> /Ola (T)
>

---

From: Khaled Omar <[email-masked]>
Date: Mon, 28 Sep 2020 11:18:51 +0000

Well, think of it like that, once all hosts support IPv10 (as all hosts now support IPv6) network engineers will cope up with the new header, because the destination will be from a different version, Old firewall configuration will be the same but new configuration will be addred because new IPv6 only devices will be on place (this is their normal job).

>> Q: In your IPv10 world, what happens when an IPv4 only host (and by that, I mean a host that cannot talk anything but plain vanilla IPv4) tries to talk to an IPv6 only host ?

This host must be updated, no reason not to accept the updates.

>> Q: In your IPv10 world, what happens when one of your new format packets hits a router/firewall/load balancer/other network equipment that doesn't understand it ?

These devices must be updated, that's why the word ALL answer all your questions.

Khaled Omar 

-----Original Message-----
From: Int-area <[email-masked]> On Behalf Of Simon Hobson
Sent: Monday, September 28, 2020 10:22 AM
To: IPv6 Operations <[email-masked]>
Cc: int-area <[email-masked]>
Subject: Re: [Int-area] [v6ops] Still need to know what has changed.... Re: IPv10 draft (was Re: FW: v6ops - New Meeting Session Request for IETF 109 - IPv10)

Simon

---

From: Fernando Gont <[email-masked]>
Date: Mon, 28 Sep 2020 10:18:39 -0300

> At least for DNS, IPv6 is doing pretty good.

Modulo fragmentation? ;-)

Thanks,
-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1