Subject: Re: [v6ops] Scope of Unique Local IPv6 Unicast Addresses (Fwd: New Version Notification for draft-gont-6man-ipv6-ula-scope-00.txt)

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 18 Feb 2021 16:12:15 +0000

Hi, I have seen the discussion on LLA/ULA/GUA and even think I understand it. But,
I’d like to add another twist to the discussion. There is another “kind” of IPv6 address
called the “HIT” defined in RFC7401, and a variant called the “HHIT” that is defined
in ‘draft-ietf-drip-rid’. These addresses use a common GUA prefix (shorter than /64)
with the remainder of the address containing a cryptographically generated suffix.
They therefore resemble GUAs, but they are not aggregatable so at best could be
used as host routes. The documents are vague on whether the (H)HIT is assigned
to an interface (which is a necessary property of any IPv6 address), but if they were
couldn’t the (H)HIT be used as an IPv6 source/destination address within a limited
scope – perhaps in an edge network that deals only with host routes? If so, then
where would (H)HIT fall in terms of the scoped addressing architecture?

Fred

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 18 Feb 2021 17:37:01 +0000

Another aspect I failed to mention is that the use of (H)HITs does not necessarily
mean that all aspects of the HIP protocol must be used. (H)HITs could be used
with the AERO/OMNI services instead, for example.

Anyone care to comment?

Fred

From: v6ops [mailto:[email-masked]] On Behalf Of Templin (US), Fred L
Sent: Thursday, February 18, 2021 8:12 AM
To: IPv6 Operations <[email-masked]>; [email-masked]
Subject: Re: [v6ops] Scope of Unique Local IPv6 Unicast Addresses (Fwd: New Version Notification for draft-gont-6man-ipv6-ula-scope-00.txt)

Fred

---

From: Fernando Gont <[email-masked]>
Date: Thu, 18 Feb 2021 14:59:46 -0300

Hi, Fred,

On 18/2/21 14:37, Templin (US), Fred L wrote:
> Another aspect I failed to mention is that the use of (H)HITs does not 
> necessarily  mean that all aspects of the HIP protocol must be used. (H)HITs could be 
> used with the AERO/OMNI services instead, for example.

Questions: Are these addresses globally-unique?

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 18 Feb 2021 19:11:53 +0000

Hi Fernando,

> -----Original Message-----
> From: Fernando Gont [mailto:[email-masked]]
> Sent: Thursday, February 18, 2021 10:00 AM
> To: Templin (US), Fred L <[email-masked]>; IPv6 Operations <[email-masked]>; [email-masked]

Yes - global uniqueness is a key objective of (H)HIT. Aggregation is not within
scope, however.

Fred

---

From: David Farmer <[email-masked]>
Date: Thu, 18 Feb 2021 13:20:37 -0600

At least in my opinion it is a GUA, GUAs of prefix length /64 and /128 are
both completely legal, it is in between the two that violate the /64 rule.

On Thu, Feb 18, 2021 at 10:14 AM Templin (US), Fred L <
[email-masked]> wrote:

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: David Farmer <[email-masked]>
Date: Thu, 18 Feb 2021 13:23:43 -0600

Oh, and /127 for point-to-point links.

---

From: Fernando Gont <[email-masked]>
Date: Thu, 18 Feb 2021 16:28:12 -0300

Hi, Fred,

On 18/2/21 16:11, Templin (US), Fred L wrote:
[...]
> Yes - global uniqueness is a key objective of (H)HIT. Aggregation is not within

If that's the case, then, according to RFC4007, they are global addresses.

(I'd argue that if they cannot be aggregated, that's because they 
resulting "addresses" are not really topologically-dependent, in which 
case you might probably argue that they are not addresses in the first 
place :-) )

Thanks,