Subject: [v6ops] Update of draft-vf-v6ops-ipv6-deployment and IPv4 exhaustion

From: Paolo Volpato <[email-masked]>
Date: Mon, 22 Feb 2021 14:46:32 +0000

Dear WG,

We have just submitted a new version of draft-vf-v6ops-ipv6-deployment (https://datatracker.ietf.org/doc/draft-vf-v6ops-ipv6-deployment/), where we included more sections about IPv6 deployment.
Specifically, we added considerations on IPv6 for enterprises, industrial Internet and cloud providers. We also updated the statistics on the use of IPv6, as of Dec 2020.
There is also a new section, at the beginning of the draft, related to the exhaustion of the IPv4 address space, in this regard we used some of the references shared by Fred on this mailing list.

While writing this section, we noticed that the total remaining IPv4 address pool, as reported by the five RIRs at the end of 2020, has a bit more than 18 million addresses (either available or reserved). This data is summarized for example in https://www.potaroo.net/ispcol/2021-01/addr2020.html.
However, from the same article, it appears that the pool of unadvertised addresses has grown in the past few years. From 2018 to the end of 2020 this pool rose to around 50 /8s that were unadvertised in the public Internet.
On the one hand this seems a good sign for IPv6 deployment. On the other, one may think that the IPv4 addresses are more than expected.
This is a good point for discussion within the working group. Any opinion on this?

Comments and suggestions to the draft are always welcome.

BR
Paolo

Paolo Volpato
Senior IP Product Manager
Europe Standardization & Industry Development Dept [2012 Labs]
____________________________________________________________________________
Huawei Technologies Italia S.r.l.
Address: via Lorenteggio 240, Torre A, 20147 Milano Italy
Mobile: +39 344 019 7606
E-mail: [email-masked]
_____________________________________________________________________________
Huawei Technologies Italia S.r.l. is a company registered in Italy at the Company Registration Office of Milan, with registered number 04501190963 and equity capital €3,000,000 fully paid up, whose registered office is in Milan, Via Lorenteggio 257, Tower B, 20152 Milan. Huawei Technologies Italia S.r.l. is 100% owned by Huawei Technologies Cooperatief U.A
_____________________________________________________________________________
This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
PRIVACY NOTICE: Pursuant to Art. 13 of Legislative Decree 196/03, so called "Data Protection Code", Huawei Technologies Italia Srl. informs you that the personal data provided by you will be treated for the acquisition of information preliminary to the conclusion of contracts, for the definition and formalization of contractual relationship with you as well as for their management and for the fulfillment of legal requirements related to civil, tax and accounting law. Data are processed both through computer or paper in a lawful and correct manner and in compliance with the Decree. Personal data and its processing are necessary for business negotiation and will not be subject to disclosure and spread out the circumstances permitted by law, on the same you can exercise your rights under art. 7 of the above mentioned decree. The Data Controller is Huawei Technologies Italia Srl, which has appointed Data Processors, the list of which is available at [email-masked]<mailto:[email-masked]>.

---

From: Fred Baker <[email-masked]>
Date: Mon, 22 Feb 2021 23:38:35 -0800

The chairs are watching this thread to see if there is working group interest in adding it to the IETF 110 agenda. If you would like that to happen, please comment in the thread.

> On Feb 22, 2021, at 6:46 AM, Paolo Volpato <[email-masked]> wrote:
> 
> Dear WG,
> 
> PRIVACY NOTICE: Pursuant to Art. 13 of Legislative Decree 196/03, so called "Data Protection Code", Huawei Technologies Italia Srl. informs you that the personal data provided by you will be treated for the acquisition of information preliminary to the conclusion of contracts, for the definition and formalization of contractual relationship with you as well as for their management and for the fulfillment of legal requirements related to civil, tax and accounting law. Data are processed both through computer or paper in a lawful and correct manner and in compliance with the Decree. Personal data and its processing are necessary for business negotiation and will not be subject to disclosure and spread out the circumstances permitted by law, on the same you can exercise your rights under art. 7 of the above mentioned decree. The Data Controller is Huawei Technologies Italia Srl, which has appointed Data Processors, the list of which is available at [email-masked].
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Fred Baker <[email-masked]>
Date: Mon, 22 Feb 2021 23:41:10 -0800

> This is a good point for discussion within the working group. Any opinion on this?

Well, one thing you might comment on - in the draft, perhaps, or at least this thread, is how this all relates to IPv4 address availability. A question recently raised on NANOG was "are there any RIRs from which one actually can't get IPv4 addresses at all?" It would be good to have a definitive answer.

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 23 Feb 2021 10:43:04 +0100

Le 22/02/2021 à 15:46, Paolo Volpato a écrit :
> Dear WG,
> 
> We have just submitted a new version of 
> draft-vf-v6ops-ipv6-deployment 
> (https://datatracker.ietf.org/doc/draft-vf-v6ops-ipv6-deployment/ 
> <https://datatracker.ietf.org/doc/draft-vf-v6ops-ipv6-deployment/>), 
> where we included more sections about IPv6 deployment.
> 
> Specifically, we added considerations on IPv6 for enterprises, 
> industrial Internet and cloud providers. We also updated the 
> statistics on the use of IPv6, as of Dec 2020.
> 
> There is also a new section, at the beginning of the draft, related 
> to the exhaustion of the IPv4 address space, in this regard we used 
> some of the references shared by Fred on this mailing list.
> 
> While writing this section, we noticed that the total remaining IPv4 
> address pool, as reported by the five RIRs at the end of 2020, has a 
> bit more than 18 million addresses (either available or reserved). 
> This data is summarized for example in 
> https://www.potaroo.net/ispcol/2021-01/addr2020.html 
> <https://www.potaroo.net/ispcol/2021-01/addr2020.html>.
> 
> However, from the same article, it appears that the pool of 
> unadvertised addresses has grown in the past few years. From 2018 to 
> the end of 2020 this pool rose to around 50 /8s that were 
> unadvertised in the public Internet.
> 
> On the one hand this seems a good sign for IPv6 deployment. On the 
> other, one may think that the IPv4 addresses are more than expected.
> 

I would like to ask whether these unadvertised addresses are up for
allocation by RIRs to operators?  Or is it just it has been observed
that they are not advertised in the network?

Maybe these IPv4 addresses are not advertised in the network but are set
apart by their owners for use at a later time?

Alex

> *Paolo Volpato***
*Huawei Technologies Italia S.r.l.*
> E-mail: [email-masked]
Huawei Technologies Italia S.r.l. is a company registered in Italy
> at the Company Registration Office of Milan, with registered number 
> 04501190963 and equity capital €3,000,000 fully paid up, whose 
> registered office is in Milan, Via Lorenteggio 257, Tower B, 20152 
> Milan. Huawei Technologies Italia S.r.l. is 100% owned by Huawei 
> Technologies Cooperatief U.A
> 
This e-mail and its attachments contain confidential information
> from HUAWEI, which is intended only for the person or entity whose 
> address is listed above. Any use of the information contained herein 
> in any way (including, but not limited to, total or partial 
> disclosure, reproduction, or dissemination) by persons other than
> the intended recipient(s) is prohibited. If you receive this e-mail
> in error, please notify the sender by phone or email immediately and 
> delete it!
> 
> /----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------/
>
>
> 
*/PRIVACY NOTICE:/*/Pursuant to Art. 13 of Legislative Decree
> 196/03, so called "Data Protection Code", Huawei Technologies Italia 
> Srl. informs you that the personal data provided by you will be 
> treated for the acquisition of information preliminary to the 
> conclusion of contracts, for the definition and formalization of 
> contractual relationship with you as well as for their management
> and for the fulfillment of legal requirements related to civil, tax
> and accounting law. Data are processed both through computer or paper
> in a lawful and correct manner and in compliance with the Decree. 
> Personal data and its processing are necessary for business 
> negotiation and will not be subject to disclosure and spread out the 
> circumstances permitted by law, on the same you can exercise your 
> rights under art. 7 of the above mentioned decree. The Data 
> Controller is Huawei Technologies Italia Srl, which has appointed 
> Data Processors, the list of which is available at 
> //[email-masked] <mailto:[email-masked]>//./
> 
> 
> _______________________________________________ v6ops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Paolo Volpato <[email-masked]>
Date: Tue, 23 Feb 2021 10:24:35 +0000

Hi Alexandre,

It seems that those addresses were already allocated in the past but they are simply unadvertised.
As you mentioned, a possible reason for that is related to their use or transfer in the future.
Further pieces of information would be needed to have a better understanding. 

BR
Paolo

-----Original Message-----
From: v6ops [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Tuesday, February 23, 2021 10:43 AM
To: [email-masked]
Subject: Re: [v6ops] Update of draft-vf-v6ops-ipv6-deployment and IPv4 exhaustion

Le 22/02/2021 à 15:46, Paolo Volpato a écrit :
> Dear WG,
> 
> We have just submitted a new version of draft-vf-v6ops-ipv6-deployment 
> There is also a new section, at the beginning of the draft, related to 
> the exhaustion of the IPv4 address space, in this regard we used some 
> of the references shared by Fred on this mailing list.
> 
> the end of 2020 this pool rose to around 50 /8s that were unadvertised 
> in the public Internet.
> 

I would like to ask whether these unadvertised addresses are up for allocation by RIRs to operators?  Or is it just it has been observed that they are not advertised in the network?

Maybe these IPv4 addresses are not advertised in the network but are set apart by their owners for use at a later time?

Alex

> disclosure, reproduction, or dissemination) by persons other than the 
> intended recipient(s) is prohibited. If you receive this e-mail in 
> error, please notify the sender by phone or email immediately and 
> delete it!
> 
> /---------------------------------------------------------------------
> ----------------------------------------------------------------------
> ----------------------------------------------------------------------
> -----------/
>
>
> 
> contractual relationship with you as well as for their management and 
> for the fulfillment of legal requirements related to civil, tax and 
> accounting law. Data are processed both through computer or paper in a 
> lawful and correct manner and in compliance with the Decree.
> rights under art. 7 of the above mentioned decree. The Data Controller 
> is Huawei Technologies Italia Srl, which has appointed Data 
> Processors, the list of which is available at

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 23 Feb 2021 13:19:15 +0100

> Further pieces of information would be needed to have a better understanding.

In that sense, maybe there is a rule at RIRs that mandate the ISPs that 
received IPv4 blocks to actually use them right away?  Or are RIRs 
allowing ISPs to not use the IP blocks immediately?

Alex

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 23 Feb 2021 13:41:05 +0100

Each RIR has its own policies, developed by the community. They are close, but not necessarily matching 100%.

In some case, you need to announce all them, or only a % of what you're using now, unless you can justify that they are being used in private networks, etc., etc. Policy can also mandate you announce it within a certain period of time.

Also remember that there is space not allocated by RIRs (legacy space), which is not necessarily subjected to those policies. Again, it depends on the region and if you have signed a contract with the relevant RIR.

Yes, private networks should use RFC1918 space, but sometimes even network 10/8 is not enough, or you can find other justifications, accepted by policies for allowing you not to announce the space.

Not so easy! Legacy space + 5 different set of policies and not all the RIRs ensuring 100% (and all the time) compliance with the policies.

Regards,
Jordi
@jordipalet

El 23/2/21 13:20, "v6ops en nombre de Alexandre Petrescu" <[email-masked] en nombre de [email-masked]> escribió:

    Alex

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Nick Hilliard <[email-masked]>
Date: Tue, 23 Feb 2021 13:19:12 +0000

> allowing ISPs to not use the IP blocks immediately?

bear in mind that RIRs are registries, not behavioral enforcement agencies.

Nick