Subject: [v6ops] FW: New Version Notification for draft-thubert-v6ops-yada-yatt-03.txt

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 7 Apr 2022 09:07:46 +0000

Dear all (and welcoming XiPeng in his new role)

There was yet another long thread on NANOG with tenants of v4 and v6 fighting and complaining about how the IETF provided a mission impossible migration plan with too large a chasm between IPv4 and IPv6, and using that as the argument of still stalling after all those years.

At some point, someone indicated that if no strategy had been found in 20 years, there was none to be found. To which I felt compelled to reply that effectively things were proposed 20 years ago, and that the fact that the war still rages today is an indication that there was neither a smashing victory nor enough sufferance on either side to accept a compromise.

But there was sufferance indeed, and as deep entrenchment. Dual stack and CG NATs mean ever growing OPEX and CAPEXs. Do we have to live with that? 

So I dug through ideas which were on the table 20 years (close to 30 years ago see a ref to Brian's work) and gave the broad lines of what a compromise could be. After a few discussions and one thing leading to another, I turned that into a draft. 

There it is. Baby steps and opposed to a leap that too many refused. A chance for the IPv4 tenants not to remain behind like England after the first industrial revolution. An effort from both the IPv4 and the IPv6 side, with suggested benefits beyond connectivity for each side. And a reduced chasm between those who made at least a step, and an incentive to make more.

It's still rough but I hope you'll like it. At least, please read the intro / motivation piece, and comments are more than ever welcome.

Keep safe;

Pascal

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: jeudi 7 avril 2022 10:28
To: Pascal Thubert (pthubert) <[email-masked]>
Subject: New Version Notification for draft-thubert-v6ops-yada-yatt-03.txt

A new version of I-D, draft-thubert-v6ops-yada-yatt-03.txt
has been successfully submitted by Pascal Thubert and posted to the IETF repository.

Name:		draft-thubert-v6ops-yada-yatt
Revision:	03
Title:		Yet Another Double Address and Translation Technique
Document date:	2022-04-07
Group:		Individual Submission
Pages:		18
URL:            https://www.ietf.org/archive/id/draft-thubert-v6ops-yada-yatt-03.txt
Status:         https://datatracker.ietf.org/doc/draft-thubert-v6ops-yada-yatt/
Html:           https://www.ietf.org/archive/id/draft-thubert-v6ops-yada-yatt-03.html
Htmlized:       https://datatracker.ietf.org/doc/html/draft-thubert-v6ops-yada-yatt
Diff:           https://www.ietf.org/rfcdiff?url2=draft-thubert-v6ops-yada-yatt-03

Abstract:
   This document provides a stepwise migration between IPv4 and IPv6
   with baby steps from an IPv4-only stack/gateway/ISP to an IPv6-only
   version, that allows portions of the nodes and of the networks to
   remain IPv4, and reduces the need for dual stack and CG NATs between
   participating nodes.  A first mechanism named YADA to augment the
   capacity of the current IPv4 Internet by interconnecting IPv4 realms
   via a common footprint called the shaft.  YADA extends RFC 1122 with
   the support of an IP-in-IP format used to forward the packet between
   parallel IPv4 realms.  This document also provides a stateless
   address and IP header translation between YADA and IPv6 called YATT
   and extends RFC 4291 for the YATT format.  The YADA and YATT formats
   are interchangeable, and the stateless translation can take place as
   a bump in the stack at either end, or within the network at any
   router.  This enables an IPv6-only stack to dialog with an IPv4-only
   stack across a network that can be IPv6, IPv4, or mixed.  YATT
   requires that the IPv6 stack owns a prefix that derives from a YADA
   address and that the IPv4 stack in a different realm is capable of
   YADA, so it does not replace a generic 4 to 6 translation mechanism
   for any v6 to any v4.

The IETF Secretariat

---

From: Ca By <[email-masked]>
Date: Fri, 8 Apr 2022 08:43:31 -0700

On Thu, Apr 7, 2022 at 2:08 AM Pascal Thubert (pthubert) <pthubert=
[email-masked]> wrote:

> There was yet another long thread on NANOG with tenants of v4 and v6
> fighting and complaining about how the IETF provided a mission impossible
> migration plan with too large a chasm between IPv4 and IPv6, and using that
> as the argument of still stalling after all those years.

I saw it

Nothing new here.

>
> At some point, someone indicated that if no strategy had been found in 20
> years, there was none to be found. To which I felt compelled to reply that
> effectively things were proposed 20 years ago, and that the fact that the
> war still rages today is an indication that there was neither a smashing
> victory nor enough sufferance on either side to accept a compromise.
>

There is no war.  You cannot write an I-D and expect some flame war of
micro-network operators and hobbyist to subside

> But there was sufferance indeed, and as deep entrenchment. Dual stack and
> CG NATs mean ever growing OPEX and CAPEXs. Do we have to live with that?
>
> So I dug through ideas which were on the table 20 years (close to 30 years
> ago see a ref to Brian's work) and gave the broad lines of what a
> compromise could be. After a few discussions and one thing leading to
> another, I turned that into a draft.
>
> There it is. Baby steps and opposed to a leap that too many refused. A
> chance for the IPv4 tenants not to remain behind like England after the
> first industrial revolution. An effort from both the IPv4 and the IPv6
> side, with suggested benefits beyond connectivity for each side. And a
> reduced chasm between those who made at least a step, and an incentive to
> make more.
>
> It's still rough but I hope you'll like it. At least, please read the
> intro / motivation piece, and comments are more than ever welcome.

I do not think this I-D should be adopted or otherwise moved forward.
Speaking from my own experience in the usa, ipv6 is pervasive.  All the
mobile operators ship ipv6 default on, major content is on v6, ipv6 is
common in home broadband.

Ipv6 economics work for anyone with a growing edge. Ipv4 will remain
prominent for folks who are not growing or are otherwise resistant to
change. That is fine.

There is no problem. Multiprotocol networks have always been the norm.

> URL:
> https://www.ietf.org/archive/id/draft-thubert-v6ops-yada-yatt-03.txt
> Status:
> https://datatracker.ietf.org/doc/draft-thubert-v6ops-yada-yatt/
> Html:
> https://www.ietf.org/archive/id/draft-thubert-v6ops-yada-yatt-03.html
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-thubert-v6ops-yada-yatt
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-thubert-v6ops-yada-yatt-03
>
> Abstract:
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Lorenzo Colitti <[email-masked]>
Date: Sun, 10 Apr 2022 11:02:25 +0900

> There is no problem. Multiprotocol networks have always been the norm.

+1. FWIW I don't think the basic premise of the draft is correct.

In particular, I think "The IPv4 and IPv6 camps are quite entrenched, and
there's no indication that things will change any time soon." is
demonstrably false.

The truth is that things are changing, and have been changing for years.

The Google stats say that IPv6 adoption in the internet is 35-40% and still
growing. It took about 10 years to get from 1% to 35-40%, and it will
probably take at least another 10-15 years to get to 95%; there's
definitely going to be a long tail there, just look at how long it took to
move off Windows XP even after it was fully unsupported.

I don't think defining yet another transition mechanism that requires
changes to IPv4 stacks, new DNS records, etc. will make things change any
faster.

As Cameron says: there is no problem.