Subject: Re: [VCARDDAV] PIDs proposal

From: "Javier Godoy" <[email-masked]>
Date: Tue, 24 Jun 2008 20:23:35 -0300

On Tue, 24 Jun 2008 09:35:35 -0400 Darryl Champagne wrote:

> If you would look at the text I wrote (has anyone?) - I specifically said
> that:  "It MUST NOT appear on properties that only may have one instance
> per vCard.".

I did, but the only property which cannot be repeated are UID (a fix in this
revision, as this was not explicit in vCard 3.0), and obviously BEGIN and
END. There are other properties about which we can reasonably assume they
can only occur once (such as N, FN, BDAY...) but it should be stated
somewhere.

Proposal: define the cardinality of each property (it may be done by
including a separate slot on each definition). Just a few properties are 
(1,1), most of them are either (0,1) or (0,n); and
I think there are no (1,n) cases.

Best Regards

Javier

_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav

---

From: "Darryl Champagne" <[email-masked]>
Date: Tue, 24 Jun 2008 20:46:30 -0400

> -----Original Message-----
> From: Javier Godoy [mailto:[email-masked]]
> Sent: Tuesday, June 24, 2008 7:24 PM
> To: Darryl Champagne; [email-masked]
> Subject: Re: [VCARDDAV] PIDs proposal
> 
> 

+1

---

From: Simon Perreault <[email-masked]>
Date: Wed, 25 Jun 2008 07:43:50 -0400

+1

This is now issue #306.

-- 
Please try Numb, a STUN/TURN server implementation.
Free access at http://numb.viagenie.ca/.
_______________________________________________
VCARDDAV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vcarddav