Subject: [VCARDDAV] Problem with ORG syntax in -15

From: Cyrus Daboo <[email-masked]>
Date: Mon, 03 Jan 2011 11:12:55 -0500

Hi,
In Section 6.6.4 of draft -15 the ORG property value is defined as:

     ORG-value = component *(";" component)

     component = "\\" / "\;" / "\n" / WSP / NON-ASCII
               / %x21-3A / %x3C-5B / %x5D-7E

What is odd here is that COMMA is not backslash escaped. In all other cases 
where a value uses backslash escaping COMMA is included as a backslash 
escape.

What is more, paragraph 3 of Section 3.3 implies that backslash COMMA must 
always be used. I believe \, was used in vCard 3 as well. Therefore I 
propose changing the ORG syntax to be:

     ORG-value = component *(";" component)

     component = "\\" / "\," / "\;" / "\n" / WSP / NON-ASCII
               / %x21-2B  / %x2D-3A / %x3C-5B / %x5D-7E

-- 
Cyrus Daboo

---

From: Simon Perreault <[email-masked]>
Date: Mon, 03 Jan 2011 11:22:33 -0500

On 01/03/11 11:12, Cyrus Daboo wrote:
> I propose changing the ORG syntax to be:
>

Agreed. This will be in the next revision.

Thanks,
Simon

---

From: Arnaud Quillaud <[email-masked]>
Date: Thu, 06 Jan 2011 11:24:41 +0100

> Agreed. This will be in the next revision.
There are 3 examples with ORG containing a comma:
* two in 6.1.5 (KIND definition)
* one in 6.6.4 (ORG definition)

If I understand the above change correctly, all 3 need fixing as well, 
ie from:

ORG:ABC, Inc.;North American Division;Marketing

to

ORG:ABC\, Inc.;North American Division;Marketing

Arnaud Quillaud

---

From: Simon Perreault <[email-masked]>
Date: Thu, 06 Jan 2011 08:59:32 -0500

> ORG:ABC\, Inc.;North American Division;Marketing

Yes! Thanks for fixing these bugs!

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca