Subject: Re: [VCARDDAV] syntax for property value

From: Simon Perreault <[email-masked]>
Date: Tue, 04 Jan 2011 08:44:21 -0500

Sorry for not replying earlier. I lost track of this thread.

Le 17/12/2010 11:29 AM, Arnaud Quillaud a écrit :
> In section 4, the text value is defined as a VALUE-CHAR where VALUE-CHAR
> can be any character, including backslash, comma or newline.
> This contradicts with section 3.3 and section 4.1 where it is mentioned
> that backslash, comma and newline need to be encoded in text values.

I think you're right.

Proposal:

      text = *TEXT-CHAR

      text-list = text *("," text)

      TEXT-CHAR = "\\" / "\," / "\n"
                / <any VALUE-CHAR except , or \>
         ; Backslashes, commas, and newlines must be encoded.

Would that make sense?

Thanks,
Simon

---

From: Arnaud Quillaud <[email-masked]>
Date: Tue, 04 Jan 2011 19:06:33 +0100

>         ; Backslashes, commas, and newlines must be encoded.
Sounds good to me.