Subject: Re: [VCARDDAV] [Technical Errata Reported] RFC6350 (4261)

From: Barry Leiba <[email-masked]>
Date: Sun, 1 Mar 2015 12:29:08 +0100

Simon, can you please comment on this errata report also?

Thanks,
Barry

On Thu, Feb 5, 2015 at 10:42 AM, RFC Errata System
<[email-masked]> wrote:
> The following errata report has been submitted for RFC6350,
> "vCard Format Specification".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=6350&eid=4261
>
> --------------------------------------
> Type: Technical
> Reported by: Ivan Enderlin <[email-masked]>
>
> Section: 4.3
>
> Original Text
> -------------
> In RFC6351 (Appendice A), we have a Relax NG Schema defining date and
> time format:
>
> # 4.3.1
> value-date = element date {
>     xsd:string { pattern = "\d{8}|\d{4}-\d\d|--\d\d(\d\d)?|---\d\d" }
>   }
>
> # 4.3.2
> value-time = element time {
>     xsd:string { pattern = "(\d\d(\d\d(\d\d)?)?|-\d\d(\d\d?)|--\d\d)"
>                          ~ "(Z|[+\-]\d\d(\d\d)?)?" }
>   }
>
> # 4.3.3
> value-date-time = element date-time {
>     xsd:string { pattern = "(\d{8}|--\d{4}|---\d\d)T\d\d(\d\d(\d\d)?)?"
>                          ~ "(Z|[+\-]\d\d(\d\d)?)?" }
>   }
>
> # 4.3.4
> value-date-and-or-time = value-date | value-date-time | value-time
>
> We assume this is the format from ISO.8601.2004 mentioned in RFC6350.
> There is no link on ISO.8601.2004 because ISO documents are not free.
> So this is our guess: These formats are very close based on different
> examples in RFC6350 and RFC6351.
>
>
> Corrected Text
> --------------
> See notes.
>
> Notes
> -----
> Question: --10 is October or 10 seconds?
>
> --10 can fit into value-date and value-time:
>
>   * From value-date, the 3rd element in the disjunction is --\d\d(\d\d)?, so it matches --10,
>   * From value-time, the last element in the first disjunction is --\d\d, so it matches --10.
>
> value-date-and-or-time matches value-date before value-time. Conclusion: --10 is always October and never 10 seconds. Is it a technical error in the RFC.
>
>
> PS: This erratum can be applied on RFC6350 and RFC6351.
> PPS: Consider the following erratum http://www.rfc-editor.org/errata_search.php?rfc=6351&eid=4247 on value-time also.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC6350 (draft-ietf-vcarddav-vcardrev-22)
> --------------------------------------
> Title               : vCard Format Specification
> Publication Date    : August 2011
> Author(s)           : S. Perreault
> Category            : PROPOSED STANDARD
> Source              : vCard and CardDAV
> Area                : Applications
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: Simon Perreault <[email-masked]>
Date: Mon, 2 Mar 2015 09:46:34 -0500

This errata highlights a real problem that was not foreseen by the WG at
the time when the RFC was published. Interoperability issues could result.
Fixing the problem would require revising the RFC, possibly in a
non-backward-compatible manner. The fix is not trivial and discussion would
be necessary.

Simon

On Sun, Mar 1, 2015 at 6:29 AM, Barry Leiba <[email-masked]> wrote:

> > value-date-and-or-time matches value-date before value-time. Conclusion:
> --10 is always October and never 10 seconds. Is it a technical error in the
> RFC.
> >
> >
> > PPS: Consider the following erratum
> http://www.rfc-editor.org/errata_search.php?rfc=6351&eid=4247 on
> value-time also.
> >
> > Instructions:
> > -------------