Subject: [vnfpool] Great effort

From: "Susan Hares" <[email-masked]>
Date: Fri, 13 Sep 2013 19:31:58 -0400

Thomas:

The work in Reliable Server Pooling (RSerPool) may be quite interesting in
the context of Virtualized Network Function (VNF) is quite interesting.  

My company (ADARA) uses reliable server pools in a product that provides NfV
functions.  We had demoed this product at ONS 2012, and have deployed
portions of this product line in Enterprise customers.  We really would
prefer to have a standardize reliable pool.  

Thank you for starting this effort. 

Sue Hares

---

From: "Y. Richard Yang" <[email-masked]>
Date: Sun, 15 Sep 2013 15:21:42 -0400

Dear all,

Very interesting work indeed. Sue made a good point of using a standardized
approach, which makes a lot of sense.

As I am getting to become familiar with RServPool, when I first tried to
think about the problem of reliable server pool, a system such as Zookeeper
comes to mind, as it appears to be more publicized in academia. Is there a
technical comparison between the two designs? At an entity level, I see
similar entities. But the detailed designs appear to be different, e.g.,
hierarchical name space. It will be a good study to look into such
differences in the context of vnf, given the interest. Does anyone have a
pointer or this is a space that has not been explored.

Thanks.

Richard
On Sep 13, 2013 7:32 PM, "Susan Hares" <[email-masked]> wrote:

> ** **
>
> Thomas:****
>
> ** **
>
> The work in Reliable Server Pooling (RSerPool) may be quite interesting
> in the context of Virtualized Network Function (VNF) is quite interesting.
> ****
>
> ** **
>
> My company (ADARA) uses reliable server pools in a product that provides
> NfV functions.  We had demoed this product at ONS 2012, and have deployed
> prefer to have a standardize reliable pool.  ****
>
> ** **
>
> Thank you for starting this effort. ****
>
> ** **
>
> Sue Hares ****
>
> _______________________________________________
> vnfpool mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vnfpool
>
>

---

From: Zongning <[email-masked]>
Date: Mon, 16 Sep 2013 02:53:30 +0000

Hi, Richard,

Thank you for your interest and information!
Pointer to Zookeeper:
http://zookeeper.apache.org/
Some useful slides:
https://cwiki.apache.org/confluence/display/ZOOKEEPER/ZooKeeperPresentations
I also see some similarity of design goal between Zookeeper service and Server Pool, both consist of multiple servers including leader and followers to provide client reliable service. However, as you also mentioned, there are difference in details such as name space - Zookeeper is based on file system APIs, whilst RSerPool utilizes flat handle space (e.g. SIP, Web, etc). Another gap between Zookeeper and Reliable VNF may be that Zookeeper basically targets on client-server mode but Reliable VNF is actually in a mode of directly connected servers with different functionalities. Please correct me if I am wrong. :)
I am think of documenting these implementations as well as the gaps to Reliable VNF in a draft...

-Ning

From: [email-masked] [mailto:[email-masked]] On Behalf Of Y. Richard Yang
Sent: Monday, September 16, 2013 3:22 AM
To: N:
Cc: [email-masked]; Zongning
Subject: Re: [vnfpool] Great effort

Dear all,

Very interesting work indeed. Sue made a good point of using a standardized approach, which makes a lot of sense.

As I am getting to become familiar with RServPool, when I first tried to think about the problem of reliable server pool, a system such as Zookeeper comes to mind, as it appears to be more publicized in academia. Is there a technical comparison between the two designs? At an entity level, I see similar entities. But the detailed designs appear to be different, e.g., hierarchical name space. It will be a good study to look into such differences in the context of vnf, given the interest. Does anyone have a pointer or this is a space that has not been explored.

Thanks.

Richard
On Sep 13, 2013 7:32 PM, "Susan Hares" <[email-masked]<mailto:[email-masked]>> wrote:

Thomas:

The work in Reliable Server Pooling (RSerPool) may be quite interesting in the context of Virtualized Network Function (VNF) is quite interesting.

My company (ADARA) uses reliable server pools in a product that provides NfV functions.  We had demoed this product at ONS 2012, and have deployed portions of this product line in Enterprise customers.  We really would prefer to have a standardize reliable pool.

Sue Hares

_______________________________________________
vnfpool mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/vnfpool

---

From: "Y. Richard Yang" <[email-masked]>
Date: Tue, 17 Sep 2013 23:32:34 -0400

Hi Ning,

On Sunday, September 15, 2013, Zongning wrote:

>  Hi, Richard,****
>
> ** **
>
> Thank you for your interest and information!****
>
> Pointer to Zookeeper:****
>
> http://zookeeper.apache.org/****
>
> Some useful slides:****
>
>
> I also see some similarity of design goal between Zookeeper service and
> Server Pool, both consist of multiple servers including leader and
> followers to provide client reliable service. However, as you also
> mentioned, there are difference in details such as name space – Zookeeper
> is based on file system APIs, whilst RSerPool utilizes flat handle space
> (e.g. SIP, Web, etc). Another gap between Zookeeper and Reliable VNF may be
> that Zookeeper basically targets on client-server mode
>
>
zookeeper may not be limited to client-server. It is a service for a pool
of other servers to coordinate, for example, to elect the next meta server.

> but Reliable VNF is actually in a mode of directly connected servers with
> different functionalities.
>
>
Not clear about the meaning of different functionalities. Here is a dummy
logical model using which I am trying to make sense of the problem setting:

- the system consists of a set of deployed service chains, sc1, sc2, sc3,
..., scN, where sci is a directed graph in the general case, and a sequence
in a typical case; this set can be dynamic;

- there are modes, constraints, and policies placed on each service chain,
such as there should be x active instances of sc_ij, which is the j-th
element of the service chain sc_i; sc_ij runs in single master + x-1 backup
mode; sc_ij and sc_ik masters must be on the same subnet, ... The
parameters can be dynamic as applications scale;

The goal is to monitor the preceding, the reserves, start/stop/migrate to
enforce the policies?

Richard

> Please correct me if I am wrong. J****
>
> I am think of documenting these implementations as well as the gaps to
> Reliable VNF in a draft…****
>
> ** **
>
> -Ning****
>
> ** **
>
> ** **
>
> *From:* [email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');> [mailto:[email-masked]<javascript:_e({}, 'cvml', [email-masked]');>]
> *On Behalf Of *Y. Richard Yang
> *Sent:* Monday, September 16, 2013 3:22 AM
> *To:* N:
> *Cc:* [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>;
> Zongning
> *Subject:* Re: [vnfpool] Great effort****
>
> ** **
>
> Dear all,****
>
> Very interesting work indeed. Sue made a good point of using a
> standardized approach, which makes a lot of sense.****
>
> pointer or this is a space that has not been explored.****
>
> Thanks.****
>
> Richard****
>
> On Sep 13, 2013 7:32 PM, "Susan Hares" <[email-masked]<javascript:_e({}, 'cvml', [email-masked]');>>
> wrote:****
>
>  ****
>
> Thomas:****
>
>  ****
>
> the context of Virtualized Network Function (VNF) is quite interesting.  *
> ***
>
>  ****
>
> [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>
> https://www.ietf.org/mailman/listinfo/vnfpool****
>

---

From: Melinda Shore <[email-masked]>
Date: Tue, 17 Sep 2013 19:40:28 -0800

On 9/17/13 7:32 PM, Y. Richard Yang wrote:
> zookeeper may not be limited to client-server. It is a service for a 
> pool of other servers to coordinate, for example, to elect the next
> meta server.

Hi, Richard:

I am not previously familiar with Zookeeper so I may be
misunderstanding something fundamental, but it seems to
me from what I've read that Zookeeper may not be
suitable for HA applications, in that it may not meet
performance requirements. In this case "distributed
synchronization" means something more closely aligned
with, say, rsync than with keeping stateful network
devices in sync.  If you think about, say, a firewall
in a service provider network, do you think that
Zookeeper is suitable for moving firewall-associated
state from one device to another within extremely
constrained elapsed time requirements?  To me it looks
more like a network configuration platform.

Melinda

---

From: Melinda Shore <[email-masked]>
Date: Tue, 17 Sep 2013 20:10:49 -0800

On 9/17/13 7:40 PM, Melinda Shore wrote:
> misunderstanding something fundamental, 

Which, in fact, turns out to be the case.  Here's my
next round of ignorant comments and questions:

It looks like they've really focused very closely
on ordered delivery.  I could be wrong but it seems
to me that in a VNF failover scenario we really don't
care about anything (in terms of node state) but having
a correct picture of a network function at or very near
to the time it fails (or is failed-over), and because
previous state snapshots are not relevant it's actually
disadvantageous to make guarantees about delivering
something which may not be used.  Something along the
lines of distributed shared memory may be more applicable
but I think is still not quite the right solution
for this problem.

Melinda

-- 
Melinda Shore
No Mountain Software
[email-masked]

"Software longa, hardware brevis."

---

From: "Y. Richard Yang" <[email-masked]>
Date: Wed, 18 Sep 2013 00:14:25 -0400

Hi Melinda,

On Tuesday, September 17, 2013, Melinda Shore wrote:

> constrained elapsed time requirements?

Good question.

Is there any reference (sub-ms, 10s ms, ...) on the requirement of latency
for a backup device (e.g., firewal) to take over? What is the persistency
requirement
regarding NF state recovery: no loss because master state is not
recoverable
or the state is reconstructable and fast recovery is just an optimization?

Richard

> To me it looks
> [email-masked] <javascript:;>

---

From: Zongning <[email-masked]>
Date: Wed, 18 Sep 2013 09:21:15 +0000

Hi, Richard,

From: [email-masked] [mailto:[email-masked]] On Behalf Of Y. Richard Yang
Sent: Wednesday, September 18, 2013 11:33 AM
To: Zongning
Cc: Y. Richard Yang; N:; [email-masked]
Subject: Re: [vnfpool] Great effort

Hi Ning,

Thank you for your interest and information!
Pointer to Zookeeper:
http://zookeeper.apache.org/
Some useful slides:
https://cwiki.apache.org/confluence/display/ZOOKEEPER/ZooKeeperPresentations
I also see some similarity of design goal between Zookeeper service and Server Pool, both consist of multiple servers including leader and followers to provide client reliable service. However, as you also mentioned, there are difference in details such as name space - Zookeeper is based on file system APIs, whilst RSerPool utilizes flat handle space (e.g. SIP, Web, etc). Another gap between Zookeeper and Reliable VNF may be that Zookeeper basically targets on client-server mode

zookeeper may not be limited to client-server. It is a service for a pool of other servers to coordinate, for example, to elect the next meta server.

[Ning] Yes, you are right. Zookeeper service is for coordinating a set of servers which implement single application or multiple applications. But I am not sure if Zookeeper service also includes selecting appropriate server(s) for any specific application? Considering the model of VNF pools, there are multiple, distributed pools where each pool contains a set of servers of a specific application. We probably need coordination service that synchronizes the status of the servers within pool, across different pools, as well as selecting/replacing servers for further chaining them together...
but Reliable VNF is actually in a mode of directly connected servers with different functionalities.

Not clear about the meaning of different functionalities. Here is a dummy logical model using which I am trying to make sense of the problem setting:

- the system consists of a set of deployed service chains, sc1, sc2, sc3, ..., scN, where sci is a directed graph in the general case, and a sequence in a typical case; this set can be dynamic;

- there are modes, constraints, and policies placed on each service chain, such as there should be x active instances of sc_ij, which is the j-th element of the service chain sc_i; sc_ij runs in single master + x-1 backup mode; sc_ij and sc_ik masters must be on the same subnet, ... The parameters can be dynamic as applications scale;

The goal is to monitor the preceding, the reserves, start/stop/migrate to enforce the policies?

[Ning] The model is basically correct. The parameters need to reflect the policies. When I say servers with different functionalities, I mean FW server, DPI server, etc... So I am not sure "sc_ij and sc_ik must be on the same subnet" is correct statement?

Richard
Please correct me if I am wrong. :)
I am think of documenting these implementations as well as the gaps to Reliable VNF in a draft...

-Ning

From: [email-masked]<javascript:_e(%7b%7d,%20'cvml',[email-masked]');> [mailto:[email-masked]<javascript:_e(%7b%7d,%20'cvml',[email-masked]');>] On Behalf Of Y. Richard Yang
Sent: Monday, September 16, 2013 3:22 AM
To: N:
Cc: [email-masked]<javascript:_e(%7b%7d,%20'cvml',[email-masked]');>; Zongning
Subject: Re: [vnfpool] Great effort

Dear all,

Thanks.

Richard
On Sep 13, 2013 7:32 PM, "Susan Hares" <[email-masked]<javascript:_e(%7b%7d,%20'cvml',[email-masked]');>> wrote:

Thomas:

Sue Hares

_______________________________________________
vnfpool mailing list
[email-masked]<javascript:_e(%7b%7d,%20'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/vnfpool