Subject: [vnfpool] Manage PE list in RSerPool

From: Zongning <[email-masked]>
Date: Mon, 23 Sep 2013 03:57:15 +0000

Hi,

When reading some RSerPool documents, I noticed there are several mechanisms proposed to manage pool element (PE) list.
One is that a pool user (PU) fetches a PE list from pool registrar (PR) to store the list locally, then selects and connects to a PE. When the selected PE fails, PU will connect to another PE from the list to continue the service.
Another is that the PE can tell the PU backup PEs via business card message when they are communicating. In this way, when the PE fails, PU will connect to a backup PE obtained from the business card message.
I am not sure about the relation between these two PE lists. Are they necessarily consistent? I.e. if the PR needs to tell exactly the same list (as the one returned to the PU) to the PE for constructing business card message? Or they actually serve totally different purpose, but still related?
Moreover, considering the dynamic situation of VNF instances, the PE list stored in PU could be more dynamic than before. In such case, I suppose an "active push" mechanism maybe useful to be adopted by both PR and PE when telling PU some updates happened to PE list. How do you think?
Thanks.

-Ning

---

From: Thomas Dreibholz <[email-masked]>
Date: Mon, 30 Sep 2013 09:45:05 +0200

Mandag 23. september 2013 03.57.15 skrev Zongning:
> Hi,
> 
> When reading some RSerPool documents, I noticed there are several mechanisms
> proposed to manage pool element (PE) list. One is that a pool user (PU)
> fetches a PE list from pool registrar (PR) to store the list locally, then
> selects and connects to a PE. When the selected PE fails, PU will connect
> to another PE from the list to continue the service. Another is that the PE
> can tell the PU backup PEs via business card message when they are
> communicating. In this way, when the PE fails, PU will connect to a backup
> PE obtained from the business card message. I am not sure about the
> relation between these two PE lists. Are they necessarily consistent? I.e.

No, the PE can decide on what to send in the ASAP Business Card to the PU. 
That is, it is independent of the information stored by the PRs.

> if the PR needs to tell exactly the same list (as the one returned to the
> PU) to the PE for constructing business card message? Or they actually
> serve totally different purpose, but still related? 

The content of the ASAP Business Card may be specific for a certain session. 
That is, depending on the redundancy configuration, the PE may tell the PU 
certain other PEs to fail over to in case of its own failure. This information 
may only be valid for the session (for which the Business Card is sent) 
itself.

> Moreover, considering
> the dynamic situation of VNF instances, the PE list stored in PU could be
> more dynamic than before. In such case, I suppose an "active push"
> mechanism maybe useful to be adopted by both PR and PE when telling PU some
> updates happened to PE list. How do you think? Thanks.

An ASAP Business Card may be sent at any time the PE decides. Therefore, a new 
one can be sent as soon as information needs to be updated.

The ASAP Handle Resolution also provides the possibility to register for 
active pushes from a PR. That is, once the information for a pool changes, a 
PU will receive an update.

-- 
Best regards / Mit freundlichen Grüßen / Med vennlig hilsen

=======================================================================
 Thomas Dreibholz

 Simula Research Laboratory
 Simula Innovation AS, Network Systems Group
 Visiting address: Martin Linges vei 17, 1364 Fornebu, Norway
 Mailing address:  P.O.Box 134, 1325 Lysaker, Norway
-----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://simula.no/people/dreibh
=======================================================================

---

From: Thomas Dreibholz <[email-masked]>
Date: Mon, 30 Sep 2013 09:53:39 +0200

---

From: Zongning <[email-masked]>
Date: Mon, 30 Sep 2013 08:40:35 +0000

Thanks, Thomas for your clarification.

Please see one more question inline. :)

-Ning

> -----Original Message-----
> From: Thomas Dreibholz [mailto:[email-masked]]
> Sent: Monday, September 30, 2013 3:45 PM
> To: [email-masked]
> Cc: Zongning
> Subject: Re: [vnfpool] Manage PE list in RSerPool
> 
> > When reading some RSerPool documents, I noticed there are several
> > mechanisms proposed to manage pool element (PE) list. One is that a
> > pool user (PU) fetches a PE list from pool registrar (PR) to store the
> > list locally, then selects and connects to a PE. When the selected PE
> > fails, PU will connect to another PE from the list to continue the
> > service. Another is that the PE can tell the PU backup PEs via
> > business card message when they are communicating. In this way, when
> > the PE fails, PU will connect to a backup PE obtained from the
> > business card message. I am not sure about the relation between these two
> PE lists. Are they necessarily consistent? I.e.
> 
> certain other PEs to fail over to in case of its own failure. This information may
> only be valid for the session (for which the Business Card is sent) itself.
> 

[Ning]: If the backup PEs are configured in PE before the session start? Or dynamically collected in runtime, e.g. by receiving registration messages from available PEs, like PR does?

> 
> > Moreover, considering
> > the dynamic situation of VNF instances, the PE list stored in PU could
> > be more dynamic than before. In such case, I suppose an "active push"
> > mechanism maybe useful to be adopted by both PR and PE when telling PU
> > some updates happened to PE list. How do you think? Thanks.
> 
> An ASAP Business Card may be sent at any time the PE decides. Therefore, a
> new one can be sent as soon as information needs to be updated.
> 
> The ASAP Handle Resolution also provides the possibility to register for active
> pushes from a PR. That is, once the information for a pool changes, a PU will
> receive an update.

[Ning]: This sounds reasonable.

>  Simula Innovation AS, Network Systems Group  Visiting address: Martin
> Linges vei 17, 1364 Fornebu, Norway  Mailing address:  P.O.Box 134, 1325
> Lysaker, Norway

---

From: Thomas Dreibholz <[email-masked]>
Date: Mon, 30 Sep 2013 11:09:44 +0200

Hi,

Mandag 30. september 2013 08.40.35 skrev Zongning:
> > The content of the ASAP Business Card may be specific for a certain
> > session. That is, depending on the redundancy configuration, the PE may
> > tell the PU certain other PEs to fail over to in case of its own failure.
> > This information may only be valid for the session (for which the
> > Business Card is sent) itself.
> [Ning]: If the backup PEs are configured in PE before the session start? Or
> dynamically collected in runtime, e.g. by receiving registration messages
> from available PEs, like PR does?

The backup PEs can be configured at any time you like. Also, this configuration 
can be updated at any time you like. Once there is an update, you just need to 
send a new ASAP Business Card with the updated information.

Particularly, this means that the ASAP Business Card mechanism allows to 
dynamically change the configuration. For example, additional backup PEs could 
be configured to improve redundancy, some backup PEs could be removed, or 
different (e.g. nearer, cheaper, etc.) PEs could be chosen as backup PEs.