Subject: [vnfpool] Information on Reliable Server Pooling (RSerPool)

From: Thomas Dreibholz <[email-masked]>
Date: Wed, 11 Sep 2013 15:23:57 +0200

Dear all,

as I had discussed with some of you at the IETF meeting in Berlin, Reliable Server 
Pooling (RSerPool) may be quite interesting in the context of Virtualized Network 
Function (VNF). Therefore, I have shortly summarized some useful RSerPool links for 
further information:

- There is an Open Source implementation of RSerPool available. It is called RSPLIB. It 
provides an ENRP server (registrar) and a library to write pool users (PU) and pool 
elements (PE) as well as lots of examples. RSPLIB can be downloaded here 
http://www.exp-math.uni-essen.de/~dreibh/rserpool/#Download . It is also included in 
Ubuntu Linux as well as in form of a port in FreeBSD. The implementation currently 
works under Linux, FreeBSD, Solaris and MacOS X. RSPLIB is GPL-licensed.

- There is also an OMNeT++-based simulation model available. This is called RSPSIM 
and can be found here: http://www.exp-math.uni-essen.de/~dreibh/rserpool/#Simulation . The model is also Open Source under GPL 
license as well.

- I maintain an up-to-date web page with lots of material on RSerPool. It is located 
here: http://www.exp-math.uni-essen.de/~dreibh/rserpool/ . It particularly also 
contains a complete collection of RFCs, I-Ds as well as research documents.

- For an introduction to RSerPool and RSPLIB, I suggest to have a look into 
Dreibholz, Thomas: ``Reliable Server Pooling – Evaluation, Optimization and Extension 
of a Novel IETF Architecture[1]´´ (_PDF_, 9080 KiB), Ph.D. Dissertation, University of 
Duisburg-Essen, Faculty of Economics, Institute for Computer Science and Business 
Information Systems, URN urn:nbn:de:hbz:465-20070308-164527-0[2], March 7, 2007.

- If you are interested in current research on resilient networks, also have a look at the 
NorNet project website http://www.nntb.no/ . The Simula Research Laboratory is 
currently building up a testbed infrastructure for such research purposes.

Just write me an e-mail in case of any questions.

-- 
Best regards / Mit freundlichen Grüßen / Med vennlig hilsen

=====================================================================
==
 Thomas Dreibholz

 Simula Research Laboratory
 Simula Innovation AS, Network Systems Group
 Visiting address: Martin Linges vei 17, 1364 Fornebu, Norway
 Mailing address:  P.O.Box 134, 1325 Lysaker, Norway
-----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://simula.no/people/dreibh
=====================================================================
==

--------
[1] http://duepublico.uni-duisburg-essen.de/servlets/DerivateServlet/Derivate-16326/Dre2006_final.pdf
[2] http://www.nbn-resolving.de/urn:nbn:de:hbz:465-20070308-164527-0

---

From: Zongning <[email-masked]>
Date: Thu, 12 Sep 2013 03:58:06 +0000

Hi, Thomas,

Thank you very much for sharing such useful information with us. I have briefly browsed your website and found it is really impressive!
I agree that Server Pooling idea is quite interesting in the context of VNF. We will definitely look at its applicability to NFV. It is also great that you have Open Source LIB for your implementation. ☺
I noticed that you have actually maintained several IETF drafts on the applicability & extension of Server Pooling to various use cases like distributed computing, mobility. Maybe now it is time to writing-up a draft on applicability to NFV? ☺
Thanks.

-Ning

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Dreibholz
Sent: Wednesday, September 11, 2013 9:24 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [vnfpool] Information on Reliable Server Pooling (RSerPool)

Dear all,

as I had discussed with some of you at the IETF meeting in Berlin, Reliable Server Pooling (RSerPool) may be quite interesting in the context of Virtualized Network Function (VNF). Therefore, I have shortly summarized some useful RSerPool links for further information:

- There is an Open Source implementation of RSerPool available. It is called RSPLIB. It provides an ENRP server (registrar) and a library to write pool users (PU) and pool elements (PE) as well as lots of examples. RSPLIB can be downloaded here http://www.exp-math.uni-essen.de/~dreibh/rserpool/#Download . It is also included in Ubuntu Linux as well as in form of a port in FreeBSD. The implementation currently works under Linux, FreeBSD, Solaris and MacOS X. RSPLIB is GPL-licensed.

- There is also an OMNeT++-based simulation model available. This is called RSPSIM and can be found here: http://www.exp-math.uni-essen.de/~dreibh/rserpool/#Simulation . The model is also Open Source under GPL license as well.

- I maintain an up-to-date web page with lots of material on RSerPool. It is located here: http://www.exp-math.uni-essen.de/~dreibh/rserpool/ . It particularly also contains a complete collection of RFCs, I-Ds as well as research documents.

- For an introduction to RSerPool and RSPLIB, I suggest to have a look into Dreibholz, Thomas: ``Reliable Server Pooling – Evaluation, Optimization and Extension of a Novel IETF Architecture<http://duepublico.uni-duisburg-essen.de/servlets/DerivateServlet/Derivate-16326/Dre2006_final.pdf>´´ (PDF<http://duepublico.uni-duisburg-essen.de/servlets/DerivateServlet/Derivate-16326/Dre2006_final.pdf>, 9080 KiB), Ph.D. Dissertation, University of Duisburg-Essen, Faculty of Economics, Institute for Computer Science and Business Information Systems, URN urn:nbn:de:hbz:465-20070308-164527-0<http://www.nbn-resolving.de/urn:nbn:de:hbz:465-20070308-164527-0>, March 7, 2007.

- If you are interested in current research on resilient networks, also have a look at the NorNet project website http://www.nntb.no/ . The Simula Research Laboratory is currently building up a testbed infrastructure for such research purposes.

--

=======================================================================

Thomas Dreibholz

E-Mail: [email-masked]

=======================================================================

---

From: Thomas Dreibholz <[email-masked]>
Date: Wed, 18 Sep 2013 23:50:27 +0200

Torsdag 12. september 2013 03.58.06 skrev Zongning:
> Hi, Thomas,
> 
> Thank you very much for sharing such useful information with us. I have
> briefly browsed your website and found it is really impressive!
 I agree
> that Server Pooling idea is quite interesting in the context of VNF. We
> will definitely look at its applicability to NFV. It is also great that you
> have Open Source LIB for your implementation. ☺ I noticed that you have
> actually maintained several IETF drafts on the applicability & extension of
> Server Pooling to various use cases like distributed computing, mobility.
> Maybe now it is time to writing-up a draft on applicability to NFV? ☺

Yes, this is a good idea. I will do that. It can, however, take a few days. 
But I will definitely do that.

Does anybody want to join as a co-author?

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 19 Sep 2013 00:04:34 +0200

> Does anybody want to join as a co-author?
I can help if you want... Being pretty busy right now, but we should
be able to have an ID ready before the Vancouver time frame.

Best regards
Michael
> =======================================================================_______________________________________________
> vnfpool mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vnfpool

---

From: Thomas Dreibholz <[email-masked]>
Date: Wed, 18 Sep 2013 23:45:50 +0200

I agree

---

From: Zongning <[email-masked]>
Date: Thu, 19 Sep 2013 02:36:30 +0000

Hi, Michael and Thomas,

Thank you so much for taking lead of the draft about applicability of RSerPool to VNF Pools. This is important to reliable VNF issues.
I am also pleased to give any help you want from my side.

-Ning

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Michael Tuexen
发送时间: 2013年9月19日 6:05
收件人: Thomas Dreibholz
抄送: [email-masked]
主题: Re: [vnfpool] Information on Reliable Server Pooling (RSerPool)

On Sep 18, 2013, at 11:50 PM, Thomas Dreibholz <[email-masked]> wrote:

>> Thank you very much for sharing such useful information with us. I 
>> have briefly browsed your website and found it is really impressive!
> I agree
>> that Server Pooling idea is quite interesting in the context of VNF. 
>> We will definitely look at its applicability to NFV. It is also great 
>> that you have Open Source LIB for your implementation. ☺ I noticed 
>> that you have actually maintained several IETF drafts on the 
>> applicability & extension of Server Pooling to various use cases like distributed computing, mobility.
I can help if you want... Being pretty busy right now, but we should be able to have an ID ready before the Vancouver time frame.

Best regards
Michael
> Simula Innovation AS, Network Systems Group Visiting address: Martin 
> Linges vei 17, 1364 Fornebu, Norway Mailing address:  P.O.Box 134, 
> 1325 Lysaker, Norway
> ======================================================================
> =_______________________________________________
> vnfpool mailing list
> [email-masked]

_______________________________________________
vnfpool mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vnfpool

---

From: Thomas Dreibholz <[email-masked]>
Date: Mon, 30 Sep 2013 09:34:50 +0200

Hi,

we should have an SVN server to manage the draft XML file. Michael, could we 
use your server for that purpose? I could then check in a template document 
and we can discuss on the document structure.

---

From: Melinda Shore <[email-masked]>
Date: Sun, 29 Sep 2013 23:41:07 -0800

> and we can discuss on the document structure.

I've used github for several documents and it's been good.
I'd like to encourage people to double-check that whatever
server they use for this sort of thing is accessible from
China.

Melinda

---

From: Thomas Dreibholz <[email-masked]>
Date: Mon, 30 Sep 2013 09:47:34 +0200

Hi,

Søndag 29. september 2013 23.41.07 skrev Melinda Shore:
> > we should have an SVN server to manage the draft XML file. Michael, could
> > we use your server for that purpose? I could then check in a template
> > document and we can discuss on the document structure.
> 

GitHub is fine for me, too. Do you already have a repository there? Otherwise, 
I would create one.

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 30 Sep 2013 14:52:56 +0200

>> server they use for this sort of thing is accessible from
I'm fine with using the server in my lab, but using GitHub might
be easier...
> GitHub is fine for me, too. Do you already have a repository there? Otherwise, 
I think you might want to create one...

Best regards
Michael