Subject: simple doubt

From: Srinivas Akkipeddi <[email-masked]>
Date: Sun, 25 Jun 2000 11:51:37 -0500 (CDT)

Hi ,
	I have this simple doubt . Consider a suitiation where there are 2
Routers A,B on a common lan . Some hosts on the lan have the default route
set to A and others to B .So there are 2 virtual routers with A being
master for one virtual router and B its backup and vice versa . If router
A goes down then B becomes the master for both the virtual routers . when
B receives an ARP request for virtual router (initially for which A was
the master) then which virtual MAC ID does it send in reply to the request
. I hope you understand my question . It is a simple one but i could not
put it in a better fashion
thanks
akki

-------------------------------------------------------------------------------
		1301 W 24th Street    		Ph: 785-840-0350 (home)
 		 Apt : #P34                          785-864-3041 (off)
		Lawrence			email:
		kansas-66046			  [email-masked]
		USA				  [email-masked]
						  [email-masked]

---

From: Ayikudy Srikanth <[email-masked]>
Date: Sun, 25 Jun 2000 15:41:09 -0400

I think I understand your question. It will send the VRRP MAC of A because it is
backing up for router A . Essentially there are 2 VRs in your scenario. VR1 has A
has owner and B as backup and VR2 has B has owner and A as backup.
VR1 has Mac X and VR2 has Mac Y and so when B is a master and it gets a ARP query
with A's IP address, then it will respond with Mac X

Hope this clarifies!

Srikanth

---

From: Aruneesh Salhotra <[email-masked]>
Date: Mon, 26 Jun 2000 09:49:22 +0530

Hi Srinivas
Surely your question is a simple one. Here lies the solution.
There are two points to note in VRRP.
1. There is a VR-ID, for every VRRP address.
2. There is a VMAC address, for every VRRP address (5EA0XXXXXX-YY).
**here YY is same as the VR-ID.

Now the case you have mentioned will have the following setup.
** Sp. you assign VR-ID 1 to Router A, and VR-ID 2 to Router B.
Now A will have two MACs 5EA0XXXXXX-01 (master) & 5EA0XXXXXX-02 (backup).
Now A will have two MACs 5EA0XXXXXX-02 (master)& 5EA0XXXXXX-01 (backup).

A responds to an ARP request with its First MAC address and B responds to an ARP
request with its Second MAC address.
Now when Router A goes down, both the MAC addresses which B is responsible for, are
activated.

When a request for the IP address of A is received, then B responds to the request,
with the Second MAC address it has (5EA0XXXXXX-01).
Aruneesh