Subject: vrrp vs. esrp

From: "Fernandes, Flavio" <[email-masked]> (by way of Bob Hinden <[email-masked]>)
Date: Thu, 15 Mar 2001 16:21:17 -0800

Hello there,

I've been doing a little exploring on vrrp and finding out what companies
have deployed
it these days. In doing that, I came across an interesting article from
Extreme Networks.
Extreme seems eager to point out limitations on vrrp that I'm not sure are
true. I'm attaching
the urls for the articles:

	http://www.extremenetworks.com/technology/how/esrp.asp
	http://www.extremenetworks.com/technology/whitepapers/Redundancy.pdf

In summary, it seems to me that Extreme chose to ignore the fact that:

   * a virtual router is identified by (ifIndex, vrid) pair. In their
diagram, the ifIndex should be
     the index of the port/vlan they are using, and not the ip address that
sits on top of it. That way
     they would need 4 virtual routers, and not 2. That would have taken care
of what they
     see as the show stopper;

   * vrrp does NOT advertise while in backup mode, which is the opposite of
what is being
     mentioned in the article;

   * vrrp has nothing to do with the routing protocol, and they seem to
indicate that it should;

If you could, please take a look at the article, and confirm my findings.

Thanks,

-- flavio

---

From: "Erick B." <[email-masked]>
Date: Thu, 15 Mar 2001 20:54:07 -0800 (PST)

Hi Flavio,

I looked over the articles you reference. I don't see
where the points you mentioned are made in the article
however. 

ESRP counts the # of ports/links within a VLAN and has
a metric. This is used so that the device with the
most # of active links in a VLAN is primary/active for
the virtual IP. ESRP can also look at the routing
table and adjust whos primary/active on that. HSRP and
VRRP don't count the # of connections a device has
within a VLAN/subnet yet. On legacy routers usually
you can't configure multiple interfaces with the same
subnet. This means they only had 1 port/interface in
that subnet. Switches have many ports/interfaces
within the same VLAN/subnet and the VLAN IP subnet
isn't tied to port/interface but is logical. 

HSRP can track other interfaces on the router and
adjust the priority when a interface goes down. VRRP
has a feature called Critical IP which is similar to
HSRPs tracking feature. As far as I know, HSRP and
VRRP don't keep # of active ports per device or use
routing table to adjust whos master/primary/active
router. The ESRP extensions do make sense and maybe a
future revision of VRRP will include similar features.

--- "Fernandes, Flavio"
> If you could, please take a look at the article, and

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/