Subject: vrrp vs. esrp

From: "Fernandes, Flavio" <[email-masked]>
Date: Thu, 15 Mar 2001 18:49:16 -0500

Hello there,

I've been doing a little exploring on vrrp and finding out what companies
have deployed
it these days. In doing that, I came across an interesting article from
Extreme Networks.
Extreme seems eager to point out limitations on vrrp that I'm not sure are
true. I'm attaching
the urls for the articles:

	http://www.extremenetworks.com/technology/how/esrp.asp
	http://www.extremenetworks.com/technology/whitepapers/Redundancy.pdf

In summary, it seems to me that Extreme chose to ignore the fact that:

  * a virtual router is identified by (ifIndex, vrid) pair. In their
diagram, the ifIndex should be
    the index of the port/vlan they are using, and not the ip address that
sits on top of it. That way
    they would need 4 virtual routers, and not 2. That would have taken care
of what they
    see as the show stopper;

  * vrrp does NOT advertise while in backup mode, which is the opposite of
what is being
    mentioned in the article;

  * vrrp has nothing to do with the routing protocol, and they seem to
indicate that it should;
  
If you could, please take a look at the article, and confirm my findings.

Thanks,

-- flavio

---

From: "Fernandes, Flavio" <[email-masked]>
Date: Fri, 16 Mar 2001 08:37:52 -0500

Thanks for your message, Erick.

After reading your msg, I re-visited the article, and it now
makes more sense on what ESRP does. Out of the 3 points I mentioned:

* the first one (using ifIndex of physical ports, instead of the ip (or
vlan) interfaces)
  I derived from the diagram the article shows, on page 6. Nonetheless, my
suggested
  'fix' brings serious scaling issues as the number of virtual routers would
have to
  grow proportionally with the number of physical ports. From what I gather,

  most VRRP implementations we have today use the ifIndex of either the IP
interface
  or the VLAN, which does indeed miss out on the actual ports under it. So
  1 vrid per physical port would work, but it would be an expensive
implementation for
  boxes with restricted CPU and many ports. Is that the case for Extreme
boxes?

* the second one (advertising in backup mode) was mentioned on page 7, 5th
  paragraph of the "tech brief" document. It is now clear to me that they
were
  talking about advertisements from the routing protocol, not VRRP.

* the third and final one actually goes along with the previous one. It
strikes
  me that VRRP already influences the net2media code via ARP, the driver
forwarding
  code via MAC registration, the routing code via ICMP redirects... and soon
the
  routing table code, via values in the metrics? 'Lots' of internal APIs to
get this
  guy happy! :)

Thanks again,

-- flavio

-----Original Message-----
From: Erick B. [mailto:[email-masked]]
Sent: Thursday, March 15, 2001 11:54 PM
To: Fernandes, Flavio; [email-masked]'
Cc: Fernandes, Flavio
Subject: Re: vrrp vs. esrp

Hi Flavio,

I looked over the articles you reference. I don't see
where the points you mentioned are made in the article
however. 

ESRP counts the # of ports/links within a VLAN and has
a metric. This is used so that the device with the
most # of active links in a VLAN is primary/active for
the virtual IP. ESRP can also look at the routing
table and adjust whos primary/active on that. HSRP and
VRRP don't count the # of connections a device has
within a VLAN/subnet yet. On legacy routers usually
you can't configure multiple interfaces with the same
subnet. This means they only had 1 port/interface in
that subnet. Switches have many ports/interfaces
within the same VLAN/subnet and the VLAN IP subnet
isn't tied to port/interface but is logical. 

HSRP can track other interfaces on the router and
adjust the priority when a interface goes down. VRRP
has a feature called Critical IP which is similar to
HSRPs tracking feature. As far as I know, HSRP and
VRRP don't keep # of active ports per device or use
routing table to adjust whos master/primary/active
router. The ESRP extensions do make sense and maybe a
future revision of VRRP will include similar features.

--- "Fernandes, Flavio"
> If you could, please take a look at the article, and

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/