Subject: Gratuitous ARP request or reply.

From: "Harish M" <[email-masked]>
Date: Tue, 26 Feb 2002 14:31:06 +0800

I have a question reguarding IPv4 VRRP RFC.

As per the RFC, whenever VRRP virtual router becomes
master, it shall broadcast a gratuitous *ARP request*
containing virtual router MAC address for each IP address
associated with the virtual router.

Is this a ARP request or ARP reply, or in other words, what
is the operation type in ARP header? Is it ARP_REQUEST = 1
or ARP_REPLY = 2

Thanks in advance for your valuable suggestions.
Harish

---

From: "Casey S. Ajalat" <[email-masked]>
Date: Tue, 26 Feb 2002 11:33:29 -0500

A Gratuitous ARP is nothing more than an ARP REQUEST sent from an interface 
looking for its own IP address.

Casey