Subject: RE: [VRRP] VRRPv3 Review

From: [email-masked]
Date: Wed, 2 Apr 2003 12:00:52 -0600

Hi Hideki,

Thanks for the comments.

Have you implemented any security related features (clear text password or IPsec AH) in VRRPv3 ? I am asking this because we are removing the security from the draft soon.

regards
Mukesh

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, April 02, 2003 12:26 AM
> To: [email-masked]
> Subject: Re: [VRRP] VRRPv3 Review
> 
> 
> Hi all,
> 
> I have implemented VRRPv3 for {Free,Net,Open}BSD/KAME and I have some
> comments to 'draft-ietf-vrrp-ipv6-spec-03.txt'. 
> 
> Most of them seems good for me. I have some comments below.
> 
> I suggest that a sentence to mention DAD should be included 
> in this draft.
> 
> ex:
>   Duplicated Address Detection(DAD) for IPv6 link-local address
>   associated with the virtual routerSHOULD(?) be suppressed about .  
> 
> >6.4.1   Initialize
> >       o Send an unsolicited ND Neighbor Advertisement with 
> the Router
> >         Flag (R) set, the Solicited Flag (S) unset, the 
> Override flag
> >         (O) set, the Target Address set to the IPv6 
> link-local address
> >         of the Virtual Router, and the Target Link Layer 
> address set to
> >         the virtual router MAC address.
> 
> "IPv6 link-local address of the Virtual Router"
> sould be
> "IPv6 link-local address associated with the Virtual Router"
> There is a same sentence at 6.4.2.
> 
> >6.4.2   Backup
> >       o Compute and join the Solicited-Node multicast 
> address [ADD-ARH]
> >         for the link-local IPv6 address of the Virtual Router.
> 
> This sentence doesn't appear at 6.4.1.
> I think this should be located at 6.4.1 too. 
> 
> --
> Hideki ONO
> _______________________________________________
> vrrp mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/vrrp
> 
_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: [email-masked]
Date: Thu, 03 Apr 2003 07:53:06 +0900

> Have you implemented any security related features (clear text password or IPsec AH) in VRRPv3 ? I am asking this because we are removing the security from the draft soon.

My implementation is based on freevrrpd which has the featrure of
clear text password but not IPsec AH.  So, clear text password is also
available in my implementation.  I have no plan to implement IPsec AH. 

I have no objection to remove the security stuff from the draft.
--
Hideki ONO
_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp