Subject: RE: [VRRP] Referring VRRP by version

From: [email-masked]
Date: Sat, 18 Oct 2003 12:34:42 -0500

Kalyan,

Both the names have their own advantages but I think, "VRRP for IPv4"
and "VRRP for IPv6" will be better because they could accomodate minor
future upgrades to the VRRP versions.

Regards
Mukesh

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Friday, October 17, 2003 4:44 PM
> To: [email-masked]
> Subject: [VRRP] Referring VRRP by version
> 
> 
> Hi,
> 	We are submitting a draft for managed objects (MIB) 
> 	that can be used by both VRRPv2 and VRRPv3 protocols.
> 
> 	We are using the word "VRRPv2" and "VRRP for IPv4" 
> interchangeably
> 	in the draft. Similarly both "VRRPv3" and "VRRP for IPv6" are 
> 	being used in the draft.
> 
> 	I want to know what is the correct way to identify 
> these protocols?
> 	
> 	I feel that referring as "VRRP for IPv4" and "VRRP for 
> IPv6" would 
> 	be more explanatory and the MIB can be used in unlikely case of 
> 	more than one VRRP versions for IPv4 and IPv6. On the 
> other hand the 
> 	MIB may have to be revised any way in the above scenario.
> 
> 	VRRPv2 and VRRPv3 may be the best way to refer too.
> 
> 	Please let me know your thoughts on this.
> 
> thanks
> kalyan
> 
> _______________________________________________
> vrrp mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/vrrp
> 

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: [email-masked]
Date: Sun, 19 Oct 2003 23:35:31 -0700

hi, My original question was regarding the text describing the two VRRP
protocols. Right now the draft (for MIB) uses both VRRP v2 and VRRP for IPv4.

The MIB itself has a version field in the table entry that describes a virtual 
router (uniquely identified by interfaceIndex/VRID )

I need to reformat the doc if I have to change the draft to use "VRRP for IPvx"
every where, So I am going to submit it as it is and will correct this once
we reach a consensus on how best to describe these two protocols.

Thanks
-kalyan

-----Original Message-----
From: ext Bob Hinden [mailto:[email-masked]]
Sent: Saturday, October 18, 2003 4:33 PM
To: [email-masked]
Cc: Mark & Jeanne Zelios; Tata Kalyan (NES/MtView); [email-masked]
Subject: Re: [VRRP] Referring VRRP by version

Radia,

Such weighty issues :-)

Seems to me that the MIB should deal in version numbers as it is the 
version number that defines the fields in the header, etc.  If a new 
version is done, the MIB will need to be able to tell the difference 
(independent of if it is for IPv4 or IPv6).

I agree that for the names of the protocol, "VRRP for IPv4" and "VRRP 
for IPv6" are best.

We could agree to use even version number for "VRRP for IPv4" and odd 
versions numbers for "VRRP for IPv6".

I don't think it is wise to get a new protocol number if the only 
reason is to make the MIB a little simpler.  It's an 8 bit field and 
the values are shared for IPv4 and IPv6.

Bob

---

From: Bob Hinden <[email-masked]>
Date: Tue, 21 Oct 2003 10:27:05 -0700

Kalyan,

>we reach a consensus on how best to describe these two protocols.

Sound to me like there is agreement to have the text describing the name of 
the two VRRP protocols as "VRRP for IPv4" and "VRRP for IPv6".

Bob

---

From: [email-masked]
Date: Tue, 21 Oct 2003 17:41:20 -0700

hi bob,
 yes, I think we have a consensus. I will update our 
 draft with these text changes in the next revision.

Thanks
kalyan 

-----Original Message-----
From: Bob Hinden [mailto:[email-masked]]
Sent: 21 October, 2003 10:27
To: Tata Kalyan (NES/MtView)
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [VRRP] Referring VRRP by version

Kalyan,

Bob