Subject: Re: [VRRP] Referring VRRP by version

From: Radia Perlman - Boston Center for Networking <[email-masked]>
Date: Sat, 18 Oct 2003 18:16:32 -0400

I always disliked the names "VRRPv2" and VRRPv3 to refer to IPv4 and IPv6, respectively.

What happens if a new version of VRRP for IPv4 happens? What would it be called?

So I like "VRRP for IPv4" and "VRRP for IPv6" as the names.
But then what should be done about the version number? With a combined
MIB, does that mean that what we've been calling VRRPv3 would really
be for both IPv4 and IPv6?

Should these be really two different "protocols", which I think means that
they'd get different IP IANA-assigned protocol types? Or maybe in addition
to a version number there should be a field that says what version(s) of
IP are supported?

Radia

>VRRPv4   and VRRPv6 perhaps?
>... unless all version numbers need to be accounted for.
>Just a thought.
>Mark
>----- Original Message ----- 
>From: <[email-masked]>
>To: <[email-masked]>
>Sent: Friday, October 17, 2003 7:43 PM
>Subject: [VRRP] Referring VRRP by version
>
>
>Hi,
>We are submitting a draft for managed objects (MIB) 
>that can be used by both VRRPv2 and VRRPv3 protocols.
>
>We are using the word "VRRPv2" and "VRRP for IPv4" interchangeably
>in the draft. Similarly both "VRRPv3" and "VRRP for IPv6" are 
>being used in the draft.
>
>I want to know what is the correct way to identify these protocols?
>
>I feel that referring as "VRRP for IPv4" and "VRRP for IPv6" would 
>be more explanatory and the MIB can be used in unlikely case of 
>more than one VRRP versions for IPv4 and IPv6. On the other hand the 
>MIB may have to be revised any way in the above scenario.
>
>VRRPv2 and VRRPv3 may be the best way to refer too.
>
>Please let me know your thoughts on this.
>
>thanks
>kalyan
>
>_______________________________________________
>vrrp mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/vrrp
>
>
>
>
>_______________________________________________
>vrrp mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/vrrp

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Bob Hinden <[email-masked]>
Date: Sat, 18 Oct 2003 16:33:13 -0700

Radia,

Such weighty issues :-)

Seems to me that the MIB should deal in version numbers as it is the 
version number that defines the fields in the header, etc.  If a new 
version is done, the MIB will need to be able to tell the difference 
(independent of if it is for IPv4 or IPv6).

I agree that for the names of the protocol, "VRRP for IPv4" and "VRRP 
for IPv6" are best.

We could agree to use even version number for "VRRP for IPv4" and odd 
versions numbers for "VRRP for IPv6".

I don't think it is wise to get a new protocol number if the only 
reason is to make the MIB a little simpler.  It's an 8 bit field and 
the values are shared for IPv4 and IPv6.

Bob