Subject: [VRRP] Re: vrrp Digest, Vol 25, Issue 4

From: "Vedavinayagam Ganesan" <[email-masked]>
Date: 14 Sep 2006 15:57:33 -0000

The header will have the interface's link locak address. First address in the address list is the virtual IPv6 address. This may be different from the interface's link locak address, if A VR is configured with virtual IPv6 address that is not same as the interface link local address.

On Wed, 13 Sep 2006 [email-masked] wrote :
>Send vrrp mailing list submissions to
> 	[email-masked]
>
>To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www1.ietf.org/mailman/listinfo/vrrp
>or, via email, send a message with subject or body 'help' to
> 	[email-masked]
>
>You can reach the person managing the list at
> 	[email-masked]
>
>When replying, please edit your Subject line so it is more specific
>than "Re: Contents of vrrp digest..."
>
>
>Today's Topics:
>
>    1. link local address used in VRRPv3 (Mansu Kim)
>
>
>----------------------------------------------------------------------
>
>Message: 1
>Date: Tue, 12 Sep 2006 20:17:14 -0500
> From: "Mansu Kim" <[email-masked]>
>Subject: [VRRP] link local address used in VRRPv3
>To: <[email-masked]>
>Message-ID:
> 	<[email-masked]>
>Content-Type: text/plain;	charset="us-ascii"
>
>Hello all,
>
>I would like to ask your comments on " The first address must be the
>IPv6 link-local
>    address associated with the virtual router.  " from VRRP v3 draft.
>
>As Link Local address is already used at IPv6 header of VRRP
>announcement, I think this information is redundant.
>I wonder you opinion on this.
>
>
>http://www.ietf.org/internet-drafts/draft-ietf-vrrp-ipv6-spec-07.txt
>5.3.8  IPv6 Address(es)
>
>    One or more IPv6 addresses associated associated with the virtual
>    router.  The number of addresses included  is specified in the "Count
>    IP Addr" field.  The first address must be the IPv6 link-local
>    address associated with the virtual router.  These fields are used
>    for troubleshooting misconfigured routers.  If more than one address
>    is sent it is recommended that all routers be configured to send
>    these addresses in the same order to make it easier to do this
>    comparison.
>
>
>Thanks,
>-mansu
>
>
>
>
>
>------------------------------
>
>_______________________________________________
>vrrp mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/vrrp
>
>
>End of vrrp Digest, Vol 25, Issue 4
>***********************************
_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: "Mansu Kim" <[email-masked]>
Date: Thu, 14 Sep 2006 16:11:44 -0500

Now I think this could happen, thanks for different point of view.

But if packet must start with Link Local that related with Virtual IPv6
address, 

VRRPv3 Packet always has at least two ipv6 addresses and 

receiving part(backup) should discard Link Local Address in that List.

Is that what this specification wants to recommend?

Thanks for comments,

-mansu

________________________________

From: Vedavinayagam Ganesan
[mailto:[email-masked]] 
Sent: Thursday, September 14, 2006 8:58 AM
To: [email-masked]
Subject: [VRRP] Re: vrrp Digest, Vol 25, Issue 4

The header will have the interface's link locak address. First address
in the address list is the virtual IPv6 address. This may be different
from the interface's link locak address, if A VR is configured with
virtual IPv6 address that is not same as the interface link local
address.

>    these addresses in the same order to make it easier to do this

<http://adworks.rediff.com/cgi-bin/AdWorks/sigclick.cgi/www.rediff.com/s
ignature-home.htm/1507191490@Middle5?PARTNER=3>