Subject: Re: [VRRP] draft-ietf-vrrp-unified-mib-07.txt MIB Dr. Review

From: "Kalyan (Srinivas)Tata" <[email-masked]>
Date: Thu, 10 Jun 2010 12:34:03 -0700

Hi Joan,
Sorry for the delay (The usual got busy excuse :) ). I started on the edits for new draft and would like your comments/input on the following. Also as I started to edit, I needed some clarifications on your earlier input. 

This would be the new draft name: draft-ietf-vrrp-v3-mib-00.txt 

I also have to get an IANA assigned OID under mib-2.

VRRPv3-MIB DEFINITIONS ::= BEGIN
   Vrrpv3MIB  MODULE-IDENTITY
   . . 
   ::= { mib-2 ZZZ } 

    -- EdNote: Please replace ZZZ with a real OID once it is 
    -- allocated and remove this note.

I will have an IANA considerations section. 
[Kalyan>] Is this OK?
[Kalyan>] Also, I am using the same group/table names as the previous draft - I think that should be OK. Just want to confirm with you. 

I also have some questions on your earlier comments: 

>>
>> I would like to see a discussion of the indexing wrt the device.
>> The warnings from the MIB compiler indicate that there may be a
>> better indexing (table structure) available.  That doesn't mean
>> that you need to resolve the warnings, but I would like to see
>> some text included which shows why the chosen indexes are
>> advantageous for the VRRP router, and the Virtual Routers.
>>
>> IMHO, if an interface goes down,
>> then would be probably more advantageous
>> to know the Virtual router(s) associated with that interface.
>> (and subsequently the IP addresses on those Virtual Routers).
>>>>
> [Kalyan>] I do not have any strong reasons for the indexing, As I
> mentioned, It was suggested in the earlier meeting and it remained that
> way during all these revisions. I will change this to ifIndex, VrId,
> AddrType
>

So will revisit this in the next email or two.

[Kalyan>] Shell I go ahead and change the order of indexing to ifindex, VrId, AddrType?

11) Section 10.  Please specify that this is
the VRRP MIB Module Definition

[Kalyan>]  I am not sure if you wanted me to specify this some place other than in Description section. Following is what I had.
       DESCRIPTION 
            "This MIB describes objects used for managing Virtual 
             Router Redundancy Protocol version 3 (VRRPv3) for IPv4 
             and IPv6.
    
             Copyright (C) The Internet Society (2010)."

* VrId (Textual Convention)

There is already a VrId in RFC2787. While it looks as if the
only difference is the DESCRIPTION clause, need to caution against
doing redefining this.  I would suggest creating a VRID TC and
making the DESCRIPTION simple, for example:  This value uniquely identifies 
a
Virtual Router on a VRRP router.

While the remaining text is informative, it is not really necessary.
Please also give a REFERENCE clause for this.

[Kalyan>] 
[Kalyan>] I see the problem of defining VrId. 
[Kalyan>] I am thinking that you are suggesting that I create a new VRRP-TC-MIB which would define VrId separately and import in this MIB. Is this correct? Even if I define a new TC-MIB I would have to use a different name like VrrpId or should I reuse VrId? If I am changing to VrrpId then do I really need to define a new TC-MIB? I don't see any other MIB importing this either.

[Kalyan>] 

_______________________________________________
vrrp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vrrp

Scanned by Check Point Total Security Gateway.

---

From: "Joan Cucchiara" <[email-masked]>
Date: Fri, 18 Jun 2010 10:06:26 -0400

> ----- Original Message ----- 
> From: "Kalyan (Srinivas)Tata" <[email-masked]>
> To: "Joan Cucchiara" <[email-masked]>; "Adrian Farrel"
> <[email-masked]>; <[email-masked]>; <[email-masked]>
> Cc: "MIB Doctors (E-mail)" <[email-masked]>;
> <[email-masked]>; <[email-masked]>
> Sent: Thursday, June 10, 2010 3:34 PM
> Subject: RE: [VRRP] draft-ietf-vrrp-unified-mib-07.txt MIB Dr. Review
>

Hi Kalyan,

>
> Hi Joan,
> Sorry for the delay (The usual got busy excuse :) ). I started on the 
> edits
> for new draft and would like your comments/input on the following. Also as 
> I
> started to edit, I needed some clarifications on your earlier input.
>

No problem.  Thanks for following up.  Better to get all the comments 
clarified
prior to updating.

> This would be the new draft name: draft-ietf-vrrp-v3-mib-00.txt

I would leave it as "draft-ietf-vrrp-unified-mib" and continue to bump the
number.  That way it will match the "draft-ietf-vrrp-unified-spec".
Also, eventually it will get an RFC number.

> I also have to get an IANA assigned OID under mib-2.

Yes.  You do this within the draft itself in an "IANA Considerations"
Section.  One recent example is the OSPFv3-MIB
(see the draft form of it 
http://tools.ietf.org/id/draft-ietf-ospf-ospfv3-mib-16.txt
since the IANA Considerations section is removed when doc becomes an RFC).

> I will have an IANA considerations section.

Yes, this section is needed.

> [Kalyan>] Also, I am using the same group/table names as the previous
> draft - I think that should be OK. Just want to confirm with you.
>

No. Please preface names using "vrrpv3".   Again, the OSPFv3-MIB prefaces 
using "ospfv3"
if you want to see a recent example of a MIB that has a v3 (like vrrpv3) and 
makes a fresh
start under mib-2.

> [Kalyan>] Shell I go ahead and change the order of indexing to ifindex,

Yes.  Those indexes uniquely identify the vr, so essentially, the tables are 
listed
by vr.   Please note, this is only a suggestion/proposal and the indexing is 
upto the
WG.  I didn't see any comments about this during Last Call, so as far as I'm 
aware
this is good with the WG, right?

> [Kalyan>]  I am not sure if you wanted me to specify this some place other
> than in Description section. Following is what I had.
>       DESCRIPTION

That's fine.  I suggested (or tried to ;) that you change the Section name 
from "Definition" to
VRRPv3 MIB Module Definition, but this is editorial/NIT.

> [Kalyan>] I am thinking that you are suggesting that I create a new
> VRRP-TC-MIB which would define VrId separately and import in this MIB. Is
> this correct? Even if I define a new TC-MIB I would have to use a 
> different
> name like VrrpId or should I reuse VrId? If I am changing to VrrpId then 
> do
> I really need to define a new TC-MIB? I don't see any other MIB importing
> this either.
>

No, I wasn't suggesting a new MIB module, but definitely a new TC is needed.
This should have a name that indicates v3 and TC like:   Vrrpv3VrIdTC.

After reading this over again, would like to keep your original description, 
but switch
the wording from:

"A number which, along with the IP version and interface index (IfIndex), 
serves..."

to:

"A number which, along with the interface index (IfIndex) and the IP 
version, serves...."

(If you agree with the proposed indexes (above) for  the 
vrrpv3OperationsTable, etc.,
then the proposed wording above for the TC agrees.  In other words, the 
ordering for the
indexes agrees with how this TC is worded.

Thanks,
  -Joan

---

From: "Kalyan (Srinivas)Tata" <[email-masked]>
Date: Mon, 21 Jun 2010 17:02:08 -0700

Thanks Joan,
	Most of the comments are clear to me now. I Will try to finalize the draft this week.

[Kalyan>] I did not see any comments either. So I will change the indexing.

to:

[Kalyan>] I misunderstood your originally comment. I will change as you proposed.

[Kalyan>] Thanks
Kalyan