Subject: Re: [Webtransport] Choosing the Transport

From: Bernard Aboba <[email-masked]>
Date: Thu, 23 Jul 2020 13:04:13 -0700

Virat —

The ability to share a QUIC connection between HTTP3 (e.g. fetch) and WebTransport (via WebTransport API) has come up from time to time. Do you have a use case where this would be valuable?

> On Jul 23, 2020, at 11:34 AM, virat tara <[email-masked]> wrote:
>

---

From: Ben Schwartz <[email-masked]>
Date: Thu, 23 Jul 2020 16:07:11 -0400

I view this as useful for both privacy and performance.  Bundling different
kinds of connections into a single QUIC session exposes less information
about the size and timing of transfers, and allows the congestion
controller to jointly optimize all of these flows (instead of having
multiple congestion controllers fighting over the same link).

On Thu, Jul 23, 2020 at 4:04 PM Bernard Aboba <[email-masked]>
wrote:

> Virat —
>
> The ability to share a QUIC connection between HTTP3 (e.g. fetch) and
> WebTransport (via WebTransport API) has come up from time to time. Do you
> have a use case where this would be valuable?
>
> --
> Webtransport mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webtransport
>