Subject: [weirds] I-D Action: draft-ietf-weirds-rdap-query-14.txt

From: [email-masked]
Date: Mon, 22 Sep 2014 10:06:09 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Web Extensible Internet Registration Data Service Working Group of the IETF.

        Title           : Registration Data Access Protocol Query Format
        Authors         : Andrew Lee Newton
                          Scott Hollenbeck
	Filename        : draft-ietf-weirds-rdap-query-14.txt
	Pages           : 19
	Date            : 2014-09-22

Abstract:
   This document describes uniform patterns to construct HTTP URLs that
   may be used to retrieve registration information from registries
   (including both Regional Internet Registries (RIRs) and Domain Name
   Registries (DNRs)) using "RESTful" web access patterns.  These
   uniform patterns define the query syntax for the Registration Data
   Access Protocol (RDAP).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-weirds-rdap-query/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-weirds-rdap-query-14

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-weirds-rdap-query-14

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 22 Sep 2014 17:10:01 +0000

> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Monday, September 22, 2014 1:06 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-weirds-rdap-query-14.txt
> 
> 

This version addresses WG last call comments, incorporating discussion results as appropriate. Please let me and Andy know if we missed anything. A diff is the best way to see the changes.

http://www.ietf.org/rfcdiff?url1=draft-ietf-weirds-rdap-query-13&url2=draft-ietf-weirds-rdap-query-14

Scott

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 22 Sep 2014 10:29:32 -0700

On Mon, Sep 22, 2014 at 10:10 AM, Hollenbeck, Scott <
[email-masked]> wrote:

> This version addresses WG last call comments, incorporating discussion
> results as appropriate. Please let me and Andy know if we missed anything.
> A diff is the best way to see the changes.
>

Hi Scott, thanks for driving this forward.

The only outstanding issue for me is the fact that REST is mentioned, but
there's no reference describing or defining it.  Anticipating someone
bringing this up during IETF Last Call or IESG Evaluation (in the "please
expand this acronym on first use" kind of way), I brought this question up
on apps-discuss and created quite a stir as to what the right solution
might be.  There are several suggestions on a thread over there if you care
to look and see if you want to make any changes based on those proposals.

This isn't major enough to wait for, but if you spot something that looks
palatable, please go ahead and make the change.  I'll probably not get to
the PROTO writeup until this afternoon or evening.

-MSK

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 22 Sep 2014 18:04:53 +0000

The document already includes an informative reference to Roy Fielding’s dissertation (look for “[REST]” in the text). Do we need to do more than that? I didn’t think so based on this:

http://www.ietf.org/mail-archive/web/apps-discuss/current/msg12976.html

Scott

From: Murray S. Kucherawy [mailto:[email-masked]]
Sent: Monday, September 22, 2014 1:30 PM
To: Hollenbeck, Scott
Cc: [email-masked]
Subject: Re: [weirds] I-D Action: draft-ietf-weirds-rdap-query-14.txt

On Mon, Sep 22, 2014 at 10:10 AM, Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> wrote:
This version addresses WG last call comments, incorporating discussion results as appropriate. Please let me and Andy know if we missed anything. A diff is the best way to see the changes.

Hi Scott, thanks for driving this forward.
The only outstanding issue for me is the fact that REST is mentioned, but there's no reference describing or defining it.  Anticipating someone bringing this up during IETF Last Call or IESG Evaluation (in the "please expand this acronym on first use" kind of way), I brought this question up on apps-discuss and created quite a stir as to what the right solution might be.  There are several suggestions on a thread over there if you care to look and see if you want to make any changes based on those proposals.
This isn't major enough to wait for, but if you spot something that looks palatable, please go ahead and make the change.  I'll probably not get to the PROTO writeup until this afternoon or evening.
-MSK

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 22 Sep 2014 11:13:05 -0700

On Mon, Sep 22, 2014 at 11:04 AM, Hollenbeck, Scott <
[email-masked]> wrote:

>  The document already includes an informative reference to Roy Fielding’s
> dissertation (look for “[REST]” in the text). Do we need to do more than
> that? I didn’t think so based on this:
>
>
>
I thought it was done there too but the thread continued for quite a while,
with more people making suggestions or expressing concern that the
dissertation reference shouldn't be used.

I don't feel like we need to spend a lot more time on it.  My purpose in
mentioning it once more is to point out the suggestions made on that thread
in case any of them improve our document at all and/or complaint-proof it.
If you think we're good to go as we have it, then that's fine with me.

-MSK

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 22 Sep 2014 18:22:22 +0000

From: Murray S. Kucherawy [mailto:[email-masked]]
Sent: Monday, September 22, 2014 2:13 PM
To: Hollenbeck, Scott
Cc: [email-masked]
Subject: Re: [weirds] I-D Action: draft-ietf-weirds-rdap-query-14.txt

On Mon, Sep 22, 2014 at 11:04 AM, Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> wrote:
The document already includes an informative reference to Roy Fielding’s dissertation (look for “[REST]” in the text). Do we need to do more than that? I didn’t think so based on this:

I thought it was done there too but the thread continued for quite a while, with more people making suggestions or expressing concern that the dissertation reference shouldn't be used.

I don't feel like we need to spend a lot more time on it.  My purpose in mentioning it once more is to point out the suggestions made on that thread in case any of them improve our document at all and/or complaint-proof it.  If you think we're good to go as we have it, then that's fine with me.
[SAH] Let’s leave the informative reference as-is and let the chips fall where they may.

Scott