Subject: Re: [weirds] [eppext] Adding missing RDAP event action types for gTLDs

From: Gustavo Lozano <[email-masked]>
Date: Wed, 9 Dec 2015 01:25:26 +0000

Thank you for the feedback Roger,

This email slipped through the cracks, apologies for the
late response. 

Comments inline.

Regards,
Gustavo

From:  EppExt <[email-masked]> on behalf of Roger D Carney
<[email-masked]>
Date:  Tuesday, November 10, 2015 at 13:19
To:  "[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject:  Re: [eppext] Adding missing RDAP event action types for gTLDs

>Thanks Gustavo.
> 
>I agree with Scott, from what I recall this is just a proposed timeline.
> 
>As for this I-D, one comment, one clarification:
>·        
>Comment: in reading Appendix B of RFC 7483 it states that events
>represent actions that have taken place against a registered object
> at a certain date and time. I don¹t see that Last Update of RDAP
>Database is an action against a registered object, against the
>³container² of these registered objects but not against a registered
>object. This may be just a definition issue, I don¹t recall
> reading a definition of Last Update of RDAP Database so it could be
>defined as: the date/time of the last change to a registration object
>(domain, host, contact) in the RDAP database. Lacking a definition I
>would have defined Last Update of RDAP Database literally,
> so any maintenance including restoration, reference table updates,
>etc I would say changes the Last Update of RDAP Database. Again maybe
>just a definition issue.
>
>
>

The draft provides a definition for "last update of RDAP database" in
section 2. The definition is: An action noting when the information in the
object instance in the RDAP database was last synchronized from the
authoritative database (e.g. registry database).

The RDAP profile published for public comments (i.e.
https://whois.icann.org/sites/default/files/files/gtld-rdap-operational-pro
file-draft-03dec15-en.pdf) uses this event action, you may want to take a
look at this document to have a better idea of the intended use.

>
>·        
>Clarification: this I-D tries to address the lack of some RDAP data
>modeling in regards to Registrar Expiration Date but there still
> is work needed to address getting this data from registrar to registry,
>correct? I am not aware of a way to do this currently or of work to make
>this happen.
> 
>
>
>

Correct, I am working on an I-D (EPP extension) to fill this gap.

> 
>Thanks
>Roger
> 
> 
>From:
> EppExt [mailto:[email-masked]] On Behalf Of Hollenbeck, Scott
>Sent: Tuesday, November 10, 2015 12:48 PM
>To: Gustavo Lozano; [email-masked]
>Cc: [email-masked]
>Subject: Re: [eppext] Adding missing RDAP event action types for gTLDs
>
>
> 
>From: weirds [mailto:[email-masked]]
>On Behalf Of Gustavo Lozano
>Sent: Tuesday, November 10, 2015 1:29 PM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [weirds] Adding missing RDAP event action types for gTLDs
> 
>Hello colleagues,
>
> 
>
>As you may know, two of the open issues in the RDAP profile for gTLDs
>(http://mm.icann.org/pipermail/gtld-tech/attachments/20150928/35901409/gTL
>DRDAPOperationalProfile-v06-0001.pdf)
> are missing event action types in the base RDAP specification for:
>
>* Last update time of the RDAP database
>
>* Registrar registration expiration date
>
> 
>
>You may find the details in the following I-D:
>
>https://www.ietf.org/id/draft-lozano-rdap-gtld-whois-additional-events-00.
>txt 
><https://www.ietf.org/id/draft-lozano-rdap-gtld-whois-additional-events-00
>.txt>
>
> 
>
>It's important to promptly add these two event action types based on the
>timeline for deployment of RDAP in the gTLDs.
>
> 
>
>[snip]
> 
>If a recall what I heard in Dublin and Yokohama, the timeline is
>*proposed* and subject to a community review process that is supposed to
>start later this month  correct?
> 
>Scott

---

From: Roger D Carney <[email-masked]>
Date: Tue, 15 Dec 2015 18:44:36 +0000

Thanks for the reference Gustavo.

Just for clarity the suggestion is to make a new RDAP event for Last update of RDAP database as defined as "the last date and time the database used by the RDAP service was updated from the Registry or Registrar database". I don't think this definition of "Last update" matches the definition of an event as defined in Appendix B of RFC 7483: "actions that have taken place against a registered object at a certain date and time". A small nit, but I just wanted to make sure that I understand the proposal and the components involved.

Thanks
Roger

-----Original Message-----
From: Gustavo Lozano [mailto:[email-masked]] 
Sent: Tuesday, December 08, 2015 7:25 PM
To: Roger D Carney; [email-masked]; [email-masked]
Subject: Re: [eppext] Adding missing RDAP event action types for gTLDs

Comments inline.

Regards,
Gustavo