Subject: [Wish] Ice passive TCP-ICE allowed?

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 03 Aug 2021 00:54:08 +0200

Dear all,

Sergio's draft does not specify which kinds of ICE candidates are allowed.
I assume that this means that the server is free to announce any kind of
candidate, including passive ICE-TCP, and the client will ignore the ones
it doesn't understand.

Is my understanding correct?

-- Juliusz

---

From: Nils Ohlmeier <[email-masked]>
Date: Mon, 2 Aug 2021 17:24:18 -0700

Hi Juliusz,

(As and individual contributor)

> On Aug 2, 2021, at 15:54, Juliusz Chroboczek <[email-masked]> wrote:
> 

All ICE clients are suppose to ignore ICE candidates which they don’t understand.
So yes client should ignore ICE TCP candidates if they don’t understand them.
If servers start offering ICE QUIC or ICE SCTP tomorrow client should ignore them.

So I don’t think there is any additional normative language for this scenario needed.

Best
  Nils Ohlmeier