Subject: [woes] JSON Web Token (JWT) Draft -04

From: Mike Jones <[email-masked]>
Date: Wed, 30 Mar 2011 08:57:41 +0000

Draft -04 of the JSON Web Token (JWT)<http://self-issued.info/docs/draft-jones-json-web-token.html> specification is available.  It corrects a typo found by John Bradley in -03.

The draft is available at these locations:

*        http://www.ietf.org/internet-drafts/draft-jones-json-web-token-04.txt

*        http://www.ietf.org/internet-drafts/draft-jones-json-web-token-04.xml

*        http://self-issued.info/docs/draft-jones-json-web-token-04.html

*        http://self-issued.info/docs/draft-jones-json-web-token-04.txt

*        http://self-issued.info/docs/draft-jones-json-web-token-04.xml

*        http://self-issued.info/docs/draft-jones-json-web-token.html (will point to new versions as they are posted)

*        http://self-issued.info/docs/draft-jones-json-web-token.txt (will point to new versions as they are posted)

*        http://self-issued.info/docs/draft-jones-json-web-token.xml (will point to new versions as they are posted)

*        http://svn.openid.net/repos/specifications/json_web_token/1.0/ (Subversion repository, with html, txt, and html versions available)

                                                            -- Mike

---

From: Mike Jones <[email-masked]>
Date: Wed, 30 Mar 2011 15:37:21 +0000

Thanks, Bob.  That's great to hear!

I look forward to your feedback on the spec based upon your actual use.

                                                            -- Mike

From: Bob Gregory [mailto:[email-masked]]
Sent: Wednesday, March 30, 2011 8:36 AM
To: Mike Jones
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [OAUTH-WG] JSON Web Token (JWT) Draft -04

I've just uploaded a .Net implementation of JWT issuance and consumption to GitHub @ https://github.com/BobFromHuddle/Jwt4Net

This is no way ready for public release, but is in use in a production system. It's based on draft 1, and I'll try and update it to draft 4 compliance next week.

We're intending to provide full coverage of  the JWT spec as it matures, the major block for us at the moment is the lack of a specification for the "jku" key encoding scheme. Until that's decided, we're using .Net's default serialization of private keys which is based on RFC 4050.

 -- Bob Gregory

On Wed, Mar 30, 2011 at 9:57 AM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
Draft -04 of the JSON Web Token (JWT)<http://self-issued.info/docs/draft-jones-json-web-token.html> specification is available.  It corrects a typo found by John Bradley in -03.

                                                            -- Mike

--
An infinite number of mathematicians walk into a bar. The first one orders a beer. The second orders half a beer. The third, a quarter of a beer. The bartender says "You're all idiots", and pours two beers.

---

From: Bob Gregory <[email-masked]>
Date: Wed, 30 Mar 2011 16:35:43 +0100

I've just uploaded a .Net implementation of JWT issuance and consumption to
GitHub @ https://github.com/BobFromHuddle/Jwt4Net

<https://github.com/BobFromHuddle/Jwt4Net>This is no way ready for public
release, but is in use in a production system. It's based on draft 1, and
I'll try and update it to draft 4 compliance next week.

We're intending to provide full coverage of  the JWT spec as it matures, the
major block for us at the moment is the lack of a specification for the
"jku" key encoding scheme. Until that's decided, we're using .Net's default
serialization of private keys which is based on RFC 4050.

 -- Bob Gregory

On Wed, Mar 30, 2011 at 9:57 AM, Mike Jones <[email-masked]>wrote:

>  Draft -04 of the JSON Web Token (JWT)<http://self-issued.info/docs/draft-jones-json-web-token.html>specification is available.  It corrects a typo found by John Bradley in
> -03.
>
>
>
> ·
> http://www.ietf.org/internet-drafts/draft-jones-json-web-token-04.txt
>
> ·
> http://www.ietf.org/internet-drafts/draft-jones-json-web-token-04.xml
>
> ·        http://self-issued.info/docs/draft-jones-json-web-token-04.html
>
> ·        http://self-issued.info/docs/draft-jones-json-web-token-04.txt
>
> ·        http://self-issued.info/docs/draft-jones-json-web-token-04.xml
>
> ·        http://self-issued.info/docs/draft-jones-json-web-token.html(will point to new versions as they are posted)
>
> ·        http://self-issued.info/docs/draft-jones-json-web-token.txt (will
> point to new versions as they are posted)
>
> ·        http://self-issued.info/docs/draft-jones-json-web-token.xml (will
> point to new versions as they are posted)
>
> ·        http://svn.openid.net/repos/specifications/json_web_token/1.0/(Subversion repository, with html, txt, and html versions available)
>
>
>
>                                                             -- Mike
>
>
>

-- 
An infinite number of mathematicians walk into a bar. The first one orders a
beer. The second orders half a beer. The third, a quarter of a beer. The
bartender says "You're all idiots", and pours two beers.