Subject: [woes] Fwd: I-D Action:draft-rescorla-jsms-00.txt

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 09 Mar 2011 15:10:19 -0700

FYI.

-------- Original Message --------
Subject: I-D Action:draft-rescorla-jsms-00.txt
Date: Mon, 07 Mar 2011 15:30:03 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : JavaScript Message Security Format
	Author(s)       : E. Rescorla, J. Hildebrand
	Filename        : draft-rescorla-jsms-00.txt
	Pages           : 24
	Date            : 2011-03-07

Many applications require the ability to send cryptographically
secured messages.  While the IETF has defined a number of formats for
such messages (e.g.  CMS) those formats use encodings which are not
congenial for Web applications.  This document describes a new
cryptographic message format which is based on JavaScript Object
Notation (JSON) and thus is easy for Web applications to generate and
parse.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-rescorla-jsms-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 09 Mar 2011 17:09:11 -0700

There is no WG yet, but yes I think the [email-masked] list is the best
place to discuss this proposal.

On 3/9/11 4:56 PM, Dick Hardt wrote:
> Hi Peter
> 
> Is there a different WG working on this draft, or is this draft part of this WG?
> 
> It is unclear to me where comments would be posted.
> 
> -- Dick
> 
> On 2011-03-09, at 2:10 PM, Peter Saint-Andre wrote:
> 
>> FYI.
>>
>> <draft-rescorla-jsms-00.txt><Attached Message Part.txt>_______________________________________________
>> woes mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/woes
> 

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: <[email-masked]>
Date: Thu, 10 Mar 2011 09:31:47 +0100

It seems that the authors of the new draft do not know about 
 http://self-issued.info/docs/draft-jones-json-web-token-01.html

-Axel 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Peter Saint-Andre
> Sent: Thursday, March 10, 2011 1:09 AM
> To: Dick Hardt
> Cc: [email-masked]
> Subject: Re: [woes] Fwd: I-D Action:draft-rescorla-jsms-00.txt
> 
> >> <draft-rescorla-jsms-00.txt><Attached Message 
> Part.txt>_______________________________________________
> >> woes mailing list
> >> [email-masked]

---

From: Joe Hildebrand <[email-masked]>
Date: Thu, 10 Mar 2011 08:06:07 -0700

We actually are aware of that draft.  What we had agreed was that they would
both be inputs to the WOES bar BoF in Prague, where we can talk about scope
and layering.

-- 
Joe Hildebrand

---

From: Dick Hardt <[email-masked]>
Date: Wed, 9 Mar 2011 15:56:46 -0800

Hi Peter

-- Dick

---

From: Dick Hardt <[email-masked]>
Date: Wed, 9 Mar 2011 16:03:35 -0800

Hi Peter

-- Dick

---

From: Dick Hardt <[email-masked]>
Date: Wed, 9 Mar 2011 16:17:08 -0800

Eric

An example or commentary explaining going from a JSON message to signing would be useful. 

I read over the document twice and I cannot figure out how it all fits together.

-- Dick

---

From: Joe Hildebrand <[email-masked]>
Date: Thu, 10 Mar 2011 13:17:13 -0700

We cut a couple of corners to make the -00 deadline, sorry.  More to come.

On 3/9/11 5:17 PM, "Dick Hardt" <[email-masked]> wrote:

> _______________________________________________
> woes mailing list
> [email-masked]

-- 
Joe Hildebrand

---

From: Joe Hildebrand <[email-masked]>
Date: Thu, 10 Mar 2011 13:17:58 -0700

The WOES list is probably the best place to discuss.

By the way, you're not subscribed, which is why it took a while for me to
find the admin password and get your messages through.

-- 
Joe Hildebrand