Subject: Re: Joe Touch: Re: Taxonomy draft - web replication problems

From: Joe Touch <[email-masked]>
Date: Fri, 20 Aug 1999 15:56:10 -0700 (PDT)

> From [email-masked]  Fri Aug 20 15:42:53 1999
> Delivery-Date: Fri, 20 Aug 1999 15:42:54 -0700
> Return-Path: [email-masked]
> To: [email-masked]
> Subject: Joe Touch: Re: Taxonomy draft - web replication problems
> Date: Fri, 20 Aug 1999 18:42:25 -0400
> From: Micah Beck <[email-masked]>
> List-Unsubscribe: <mailto:[email-masked]?Subject=unsubscribe>
> 
> Joe Touch wrote:
> 
> > > > The difference between a mirror and a replica, IMO, is that
> > > > 
> > > >         a mirror is a copy of an entire server
> > > >         a replicate is a copy of one of the files on a server
> > > 
> > > but then we run into problem of defining what is an 'entire server' ?
> > 
> > "entire database" - a related collection of data.
> > 
> > I.e., mirror refers to the server,or collection, not the
> > individual items. A datum is replicated; the collection is
> > mirrored. (at least that's what I'm trying to convey).
> 
> I think the distinction here is "on-demand" vs. "a-priori"  not whether
> the whole database (or channel, as we would say in I2-DSI) is copied.

> One can have a dynamic cache which fetches the whole channel when any object
> is referenced. Similarly a-priori strategies for copying can be based on
> factors other than "the whole database".  The difference is whether it is
> a the copying is a response to a request or made prior to the request. > 

Prefetching or push caches can grab the copies of an 
entire server (assuming it's completely 'connected' via internal
links) a-priori. Isn't that all prior to the request?

I see the difference as a combination of all three factors
	- ahead of time
	- entire database
	- permanent copy (source invalidated, vs. timeout in a cache)

---

From: Wojtek Sylwestrzak <[email-masked]>
Date: Sun, 22 Aug 1999 13:40:09 +0200

Joe Touch wrote:
[...]
>         - permanent copy (source invalidated, vs. timeout in a cache)

and perhaps:

	- single origin server of a mirror (vs. multiple for a cache),

if it adds something to the picture. but this is perhaps just a
rewording
of the 'entire database' criterium: a mirror keeps more or less a
one-to-one
complete copy, while a cache can have many chunks of many origins.

(however, an exception here would be a reverse proxy)

--w