Subject: Re: Taxonomy draft - web replication problems

From: "Gary Tomlinson" <[email-masked]>
Date: Fri, 20 Aug 1999 15:20:49 -0600

>Micah Beck <[email-masked]> 08/20/99 11:08AM >>>

>> Wojtek Sylwestrzak <[email-masked]> 08/20/99 10:17AM 

>> My understnding is that both mirroring and caching are various means of
>> replication,
>> but some people, notably the I2-DSI, tend to understand that replication
>> is more
>> a synonym of mirroring with caching being something other. There was no
>> problem
>> until we spok of caching and mirroring, but then came 'replication' ...

>The point of view of the I2-DSI project is that caching and mirroring are
>both  *mechanisms* which implement *service replication*.  Service replication
>simply means having equivalent services available at more than one >location.

I agree with this point of view.  Both caches and mirrors do service replication, and for that matters, so do replicas in general. 

>Mirroring works by copying the server source files while caching works
>by replicating the server's output.  Mirroring is not tied to a static policy,
>and caching is not tied to a dynamic policy - these are specific choices.
>There are other service replication mechanisms which are neither mirroring
>nor caching.

Yes, the mechanics and strategies of replicated origin servers  (mirrors included) and caches are what differ about caches and replication.  Caches are generally sparse data set replicas, rather than complete data set replicas.  This is due the primary focus of a cache on storing the working set only.  Also, caches provide best effort on data persistence  and rely on a origin point (can be a replica) for strong persistence.  Also, caches genreally don't provide dynamic logic services.  It is these fundamental difference s that seperates caches from complete replicas.

>Admitted there is a confusion in terminology because mirroring uses
>*file replication* as a mechanism to implement *service replication*.  

>Service replication is a higher-level concept than mirroring and caching,
>and correctness is relative to the specification of the service.
>For example, some services might require bit-for-bit identical responses from
>the replicas whereas others might only require that they fit the same
>general description.

>I2-DSI admits both mirroring and caching as examples of service replication,
>but since there is so much mature work in caching the project is focusing
>on generalizations of file mirroring.  We seek to eventually integrate
>caches as a service replication mechanism for use when appropriate.

>If WREC wants to talk about caching and mirroring as instances of something,
>then I suggest that "service replication" is a good candidate.

So, we end up with both caches and replicated origin servers as forms of replication. What we really need to do is unambiguously define these terms (which has proven to be very difficult in terse form).  Once this is done, we can cleanup sections 5.2 and 5.3.

I like the notion of service replication.  How does the group feel about working this concept into the taxonomy?

>Micah Beck                     Research Associate Professor
>[email-masked]               Innovative Computing Laboratory
 >                              Department of Computer Science
>(423) 974 - 3548               University of Tennessee
>          - 8296 (FAX)	       Knoxville, TN  37996-1301

Gary

---

From: Wojtek Sylwestrzak <[email-masked]>
Date: Fri, 20 Aug 1999 23:57:12 +0200

Gary Tomlinson wrote:
[...]
> So, we end up with both caches and replicated origin servers as forms of replication. What we really need to do is unambiguously define these terms (which has proven to be very difficult in terse f…

Yes.

> I like the notion of service replication.  How does the group feel about working this concept into the taxonomy?

I'm not sure if service replication does not constitute a little
artificial term here.
When I hear service replication, I picture manually configuring remote
servers
(FTP, Web or other) and then mirroring the data from the origin server
onto them.

The  first part of this process is more or less manual, and one-time
only.
The second task is automated and periodical/continuous.

Performing these both steps allow us to provide service on the replica,
but i'm not sure if it's necessary to have a special terminology for
this.

Do I understand service replication right, or does it have a broader
sense ?

(sorry, I'm not trying to be difficult)

--w

---

From: William Maggs <[email-masked]>
Date: Fri, 20 Aug 1999 15:23:49 -0700

i am warm to it, but the concept of service as defined elsewhere in the Apps area would need to be included, and I don"t want to create more fights.  That being said, I think that Micah's basic statement is a good distinction.  But keep in mind that databases, file systems, processes, and machines are all possible things that can  be replicated, and the these are not necessarily only services.

Bill