Subject: Re: Taxonomy draft - web replication problems

From: Joe Touch <[email-masked]>
Date: Fri, 20 Aug 1999 14:23:34 -0700 (PDT)

It seems like there are a few dimensions in which caching and replication 
differ:

			Caching		Replication

what is copied		server output	server source 
					(as Micah observed, though
					I would apply it to all replication,
					not just mirroring)

who initiates it	client		server
			(unless push-
			cached, which
			blurs the line)

how permanent is it	temporary 	permanent
					(managed by the server,
					flushed or updated via overwrites
					by the server)

The difference between a mirror and a replica, IMO, is that

	a mirror is a copy of an entire server
	a replicate is a copy of one of the files on a server

I think this takes into account part of the 
definitions of Micah, Wojtek, and Gary.
Does it unify them?? 

Joe

---

From: Wojtek Sylwestrzak <[email-masked]>
Date: Fri, 20 Aug 1999 23:46:47 +0200

>                                         flushed or updated via overwrites

i think it's a good start summing up our intuitions so far.
however for each of these definitions it would be relatively easy to
find a counterexample. it might be premature to consider these now,
but i'm sure we could give examples of mechanisms that copy server
output but can hardly be called caching, are initiated by server,
but are still considered to be caches etc.

>         a replicate is a copy of one of the files on a server

but then we run into problem of defining what is an 'entire server' ?
e.g. is CPAN mirror a mirror or replica then ?
or I'm sure you remember 'The Louvre' of Nicolas Pioch,
was it mirrored or replicated ?

--w

---

From: [email-masked] (Jon Zeeff)
Date: Fri, 20 Aug 1999 18:09:07 -0400 (EDT)

A common real-world difference is that one can execute cgi programs on 
a mirror and not on a cache.  Other distinctions are more easily 
blurred.

---

From: George Michaelson <[email-masked]>
Date: Mon, 23 Aug 1999 09:05:57 +1000

Here are some others. 
  
 		Caching			Replication
  
		cgi-bin refers		cgi-bin can refer to
		to original     	replicant.

		cgi-bin output		cgi-bin output may need to be
		refers to original      munged to refer to replicant.

		unlikely to		can exploit BASE override
		set BASE= in		with base-relative URLs. 
		header

		(ie cache calc		(replicant-calc
		 per hit, not		 at start of nexus of hits
		 per nexus-of-hits)	 only)

		may not be URI		will work for ftp/http forms
		neutral			in many cases

					will work for alternate replicants
					eg if MIRROR.txt is being tried in
					order, can cover for 'sister' 
				 	replicants
			
		search db		site-managed search DB may
		doesn't require 	require re-calc to reform resultant
		re-calc			URI output

		per-hit ICP or other	content assumed current. not checked
		refresh checks		at hit-time.

		non-local fetch to	non-origin fetch may be from another
		origin URL always	replicant

		weak admin controls	stronger admin control on replication

cheers
	-George