Subject: Re: Taxonomy draft - web replication problems

From: "Gary Tomlinson" <[email-masked]>
Date: Thu, 19 Aug 1999 18:53:07 -0600

The taxonomy draft is about what is in the Internet today, not what we would like it to be.  WREC's charter at this time is to document the current taxonomy of replication and caching in the web (including HTTP, FTP, NNTP, Gopher, etc).  We are also producing two companion RFC's, one on research issues and the other on known problems.  The scope of the charter was directed by the IESG in order for the group to develop a broad and common understanding of this problem domain prior to undertaking forward looking work.

I personally know of several people interested in replication, myself included.  Looking forward, many of us would like to have the WG rechartered to develop a standardized architecture and framework for relpication and caching in the web.

Most of the replication comments regarding the current taxonomy have centered around mirrors and distributed file systems.  Other comments have been made about experimental systems and research.  These have been directed to the research RFC.

We need to complete and deliver the 3 comitted RFCs in order to apply for an expanded charter to do forward looking work.  I appreciate your comments made on 8/15 regarding replication.  Lets all work these into our current taxonomy and improve the definition and accuracy of replication currently employed broadly in the web today.

Gary

>>> Wojtek Sylwestrzak <[email-masked]> 08/18/99 04:30PM >>>
>hm, hm, noone seems to be into replication here ?

>perhaps the WREC group should be renamed WC then ...

>--w

---

From: Wojtek Sylwestrzak <[email-masked]>
Date: Fri, 20 Aug 1999 18:17:53 +0200

> We need to complete and deliver the 3 comitted RFCs in order to apply for an expanded charter to do forward looking work.  I appreciate your comments made on 8/15 regarding replication.  Lets all w…

To start with, what confuses me is the relation of 'replication' and
'caching'.
I think the taxonomy draft is the place to specify this.

Is caching just a special case of replication or are these terms
exlusive ?

My understnding is that both mirroring and caching are various means of
replication,
but some people, notably the I2-DSI, tend to understand that replication
is more
a synonym of mirroring with caching being something other. There was no
problem
until we spok of caching and mirroring, but then came 'replication' ...

my vague definition would be:

replication = distribution of data to remote locations in order to
localize traffic

caching     = on-demand replication of individual files

mirroring   = permanent replication of complete data packages

and my question is: 
shall we move along these lines, or does this make no sense at all.

Gary ? 

--w

---

From: Micah Beck <[email-masked]>
Date: Fri, 20 Aug 1999 13:08:12 -0400

> until we spok of caching and mirroring, but then came 'replication' ...

The point of view of the I2-DSI project is that caching and mirroring are
both  *mechanisms* which implement *service replication*.  Service replication
simply means having equivalent services available at more than one location.

Mirroring works by copying the server source files while caching works
by replicating the server's output.  Mirroring is not tied to a static policy,
and caching is not tied to a dynamic policy - these are specific choices.
There are other service replication mechanisms which are neither mirroring
nor caching.

Admitted there is a confusion in terminology because mirroring uses
*file replication* as a mechanism to implement *service replication*.  

Service replication is a higher-level concept than mirroring and caching,
and correctness is relative to the specification of the service.
For example, some services might require bit-for-bit identical responses from
the replicas whereas others might only require that they fit the same
general description.

I2-DSI admits both mirroring and caching as examples of service replication,
but since there is so much mature work in caching the project is focusing
on generalizations of file mirroring.  We seek to eventually integrate
caches as a service replication mechanism for use when appropriate.

If WREC wants to talk about caching and mirroring as instances of something,
then I suggest that "service replication" is a good candidate.

Micah Beck                     Research Associate Professor
[email-masked]               Innovative Computing Laboratory
                               Department of Computer Science
(423) 974 - 3548               University of Tennessee
          - 8296 (FAX)	       Knoxville, TN  37996-1301