Subject: Re: [XCON] WG Issues with XML Schema

From: "Pete Cordell" <[email-masked]>
Date: Tue, 10 Apr 2007 12:30:15 +0100

In order to give something back to the group (whether you want it or not!) I 
thought I'd summarize the sorts of things that might change in XSD1.1 with 
respect to the issues listed below:

----- Original Message ----- 
From: "Pete Cordell"

> Many thanks for this Oscar.  If I try and summarise each of James' points, 
> I'd be interested know which are, say, the top 4 that you (or any one else 
> on the list) were most affected by that led you to move away from XSD (I 
> hope the focussed input can be of use to the schema working group):
>
> 1. XSD requires significant expertise with things like the merging of 
> wildcards in attribute groups being counter-intuitive.

I don't think this will change.

> 2. The XSD spec is hard to understand and not amenable to being easily 
> referred to.

It is a stated aim of the requirements to make the spec easier to 
understand.  However, I only expect it to change by a few percent, rather 
than the order of magnitude it perhaps needs!

> 3. XSD does not have a formal theoretical basis behind it (whereas RNG 
> does).

Personally I'm not bothered by this.  However, there is more theoretical 
basis for some of the constructs.

> 4. XSD does not have co-constraints, e.g. you can't make element X and 
> attribute Y mutually exclusive.

This is being looked at.  Elements and types etc. may allow XPath style 
constraints to be specified (assertions).  Depending on what is finally 
decided, this could be very powerful (and very hard to implement!).

> 5. The xs:all (analogous to rng's interleave) feature is too weak.

This should be addressed.  The maxOccurs on an xs:all member could be any 
number (rather than being restricted to 0 or 1).  I still don't think it 
will be possib____________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Pete Cordell" <[email-masked]>
Date: Tue, 10 Apr 2007 12:30:15 +0100

----- Original Message ----- 
From: "Pete Cordell"

This should be addressed.  The maxOccurs on an xs:all member could be any 
number (rather than being restricted to 0 or 1).  I still don't think it 
will be possible to have an xs:all within an xs:sequence/xs:choice though.

> 6. XSD's datatypes are not flexible/open enough (and yet saddled with 
> things like gMonthDay).

No change

> 7. An XSD schema can validate seemingly bogus things such as <bogus/> when 
> the schema never actually mentions a bogus element (I hope he's wrong 
> about this!).

If you specify strict validation, this should not be a problem.

> 8. Implicitly defined attributes such as xsi:schemaLocation and xsi:type 
> conflict with your ability to define the grammer you want.

No change

> 9. Allowing the specification of default and fixed values is problematic.

No change

> And if I can add a few of my own issues:
>
> 10. The rules for wildcards (xs:any) conflicting with element names can 
> make versioning of a schema from V1 to V2 problematic.

Addressed in previous e-mail.

> 11. Enumerations are not readily extensible.

As mentioned in other e-mail, I tried proposing xs:anyEnumeration, but most 
people seem to see versionable schemas as a major problem rather than a 
major benefit!

> 12. There's no modularity in the schema definitions such that schema B can 
> precisely add extensions to a core schema A.

I quickly jotted down a proposal to address this 
(http://www.tech-know-ware.com/lmx/download/named-wildcards.pdf), but I 
think it is, sadly, way, way, way beyond what they are currently 
considering.

> Many, many thanks,

BTW - currently I'm only making comments on the W3C's [email-masked] 
mailing list (http://lists.w3.org/Archives/Public/xmlschema-dev/).  This is 
an open list, so if you would like to make your own comments, feel free to 
do so.

Thanks again,

Pete.
--
=============================================
Pete Cordell
Tech-Know-Ware Ltd
for XML to C++ data binding visit
http://www.tech-know-ware.com/lmx/
http://www.codalogic.com/lmx/
=============================================

> From: "Oscar Novo (JO/LMF)" <[email-masked]>
> To: "Pete Cordell" <[email-masked]>; <[email-masked]>
> Sent: Thursday, March 22, 2007 12:03 PM
> Subject: RE: [XCON] WG Issues with XML Schema
>
>
> Hi Pete,
>
> I suggest you to read the following e-mail from James Clark:
>
> http://www.imc.org/ietf-xml-use/mail-archive/msg00217.html
>
> He's the designer of TREX. RELAX NG is based on TREX and RELAX.
> I think in this e-mail he explains very well the motivations inside the
> IETF to move towards RELAX NG.
>
> Cheers,
>
> Oscar
>
> -----Original Message-----
> From: Pete Cordell [mailto:[email-masked]]
> Sent: 20. maaliskuuta 2007 19:01
> To: [email-masked]
> Subject: [XCON] WG Issues with XML Schema
>
> I hope this isn't a mis-use of this list, but.....
>
> As you may know, W3C XML Schema is in the process of being extended to
> version 1.1.  I know that XCON started out using XML Schema, but has
> since moved more towards Relax-NG.
>
> I'm hoping that those making that change of direction will share with me
> their motivation for making that decision.  My intention would be, if
> appropriate, to share any gathered opinions with the XSD 1.1 working
> group (probably in some summarized form).  (BTW - Just to be clear, I'm
> not on the
> WG.)
>
> For example, is XML schema just too difficult to learn?  Is the
> versioning and extensibility of elements, attributes and enumerations
> too restricted?
> Were there constraints on your syntax that you couldn't (readily)
> express using schema?  What else?
>
> My motivation for doing this is that I feel that the usage scenarios for
> XCON, SIP and other similar IETF style protocols are very different from
> the sorts of use-cases that the majority of the W3C members are familiar
> with, and hence the requirements are under represented.  There's a
> chance that by giving me feedback, XSD 1.1 will do a better job of
> meeting the needs of working groups in the IETF.
>
> I'm interested to hearing from anybody involved in schema work, whether
> it be in XCON, SIP, SIPPING, AVT, some other IETF group, or for private
> purposes.  However, I'm only posting this mele to have an xs:all within an xs:sequence/xs:choice though.

> 6. XSD's datatypes are not flexible/open enough (and yet saddled with 
> things like gMonthDay).

No change

> 7. An XSD schema can validate seemingly bogus things such as <bogus/> when 
> the schema never actually mentions a bogus element (I hope he's wrong 
> about this!).

If you specify strict validation, this should not be a problem.

> 8. Implicitly defined attributes such as xsi:schemaLocation and xsi:type 
> conflict with your ability to define the grammer you want.

No change

> 9. Allowing the specification of default and fixed values is problematic.

No change

> And if I can add a few of my own issues:
>
> 10. The rules for wildcards (xs:any) conflicting with element names can 
> make versioning of a schema from V1 to V2 problematic.

Addressed in previous e-mail.

> 11. Enumerations are not readily extensible.

As mentioned in other e-mail, I tried proposing xs:anyEnumeration, but most 
people seem to see versionable schemas as a major problem rather than a 
major benefit!

> 12. There's no modularity in the schema definitions such that schema B can 
> precisely add extensions to a core schema A.

I quickly jotted down a proposal to address this 
(http://www.tech-know-ware.com/lmx/download/named-wildcards.pdf), but I 
think it is, sadly, way, way, way beyond what they are currently 
considering.

> Many, many thanks,

BTW - currently I'm only making comments on the W3C's [email-masked] 
mailing list (http://lists.w3.org/Archives/Public/xmlschema-dev/).  This is 
an open list, so if you would like to make your own comments, feel free to 
do so.

Thanks again,

Pete.
--
=============================================
Pete Cordell
Tech-Know-Ware Ltd
for XML to C++ data binding visit
http://www.tech-know-ware.com/lmx/
http://www.codalogic.com/lmx/
=============================================

> From: "Oscar Novo (JO/LMF)" <[email-masked]>
> To: "Pete Cordell" <[email-masked]>; <[email-masked]>
> Sent: Thursday, March 22, 2007 12:03 PM
> Subject: RE: [XCON] WG Issues with XML Schema
>
>
> Hi Pete,
>
> I suggest you to read the following e-mail from James Clark:
>
> http://www.imc.org/ietf-xml-use/mail-archive/msg00217.html
>
> He's the designer of TREX. RELAX NG is based on TREX and RELAX.
> I think in this e-mail he explains very well the motivations inside the
> IETF to move towards RELAX NG.
>
> Cheers,
>
> Oscar
>
> -----Original Message-----
> From: Pete Cordell [mailto:[email-masked]]
> Sent: 20. maaliskuuta 2007 19:01
> To: [email-masked]
> Subject: [XCON] WG Issues with XML Schema
>
> I hope this isn't a mis-use of this list, but.....
>
> As you may know, W3C XML Schema is in the process of being extended to
> version 1.1.  I know that XCON started out using XML Schema, but has
> since moved more towards Relax-NG.
>
> I'm hoping that those making that change of direction will share with me
> their motivation for making that decision.  My intention would be, if
> appropriate, to share any gathered opinions with the XSD 1.1 working
> group (probably in some summarized form).  (BTW - Just to be clear, I'm
> not on the
> WG.)
>
> For example, is XML schema just too difficult to learn?  Is the
> versioning and extensibility of elements, attributes and enumerations
> too restricted?
> Were there constraints on your syntax that you couldn't (readily)
> express using schema?  What else?
>
> My motivation for doing this is that I feel that the usage scenarios for
> XCON, SIP and other similar IETF style protocols are very different from
> the sorts of use-cases that the majority of the W3C members are familiar
> with, and hence the requirements are under represented.  There's a
> chance that by giving me feedback, XSD 1.1 will do a better job of
> meeting the needs of working groups in the IETF.
>
> I'm interested to hearing from anybody involved in schema work, whether
> it be in XCON, SIP, SIPPING, AVT, some other IETF group, or for private
> purposes.  However, I'm only posting this message to the XCON list in
> the hope this will capture most of the feedback (the membership of the
> previously mentioned groups is probably much the same anyway).
>
> Depending on what you think is appropriate, you can either reply to the
> list, or direct to me.
>
> Many, many thanks for you help in trying to make XSD 1.1. better!

Pete.
--
=============================================
Pete Cordell
Tech-Know-Ware Ltd
for XML to C++ data binding visit
http://www.tech-know-ware.com/lmx/
http://www.codalogic.com/lmx/
=============================================

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

ssage to the XCON list in
> the hope this will capture most of the feedback (the membership of the
> previously mentioned groups is probably much the same anyway).
>
> Depending on what you think is appropriate, you can either reply to the
> list, or direct to me.
>
> Many, many thanks for you help in trying to make XSD 1.1. better!

Pete.
--
=============================================
Pete Cordell
Tech-Know-Ware Ltd
for XML to C++ data binding visit
http://www.tech-know-ware.com/lmx/
http://www.codalogic.com/lmx/
=============================================

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon