Subject: [xcon] Question about draft-ietf-xcon-common-data-model-05

From: paul <[email-masked]>
Date: Thu, 19 Jul 2007 10:27:17 +0800

Hi  Oscar 

I have a question on this draft.

In chapter 4.4 it said:

   "The <allow-floor-events> element represents a boolean action.  If set

   to TRUE, the focus is instructed to accept the subscription to floor

   control events.  If set to FALSE, the focus is instructed to reject

   the subscription.  If this element is undefined, it has a default

   value of FALSE, causing the subscription to floor control events to

   be rejected."

Does "subscription" here mean the SIP SUBSCRIBE request initiated
subscription?

However I know the BFCP protocol is used for floor control, and there is no
concept of subscription.

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Oscar Novo (JO/LMF)" <[email-masked]>
Date: Thu, 19 Jul 2007 09:27:45 +0200

Hi Paul,
 
Actually a conference participant has two methods to 'subscribe' himself to the floor events. One method is using offer/answer exchange mechanism (rfc3264) using SIP INVITE and BFCP parameters in the SDP (rfc4583). The other method is a general authorization mechanism described in section 9 of rfc4582 and in draft-ietf-xcon-bfcp-connection-05 draft.  
When we talk about 'subscription' in chapter 4.4 we're talking about those two connection methods. Future documentation may define additional connection mechanisms.
 
Cheers,
 
Oscar
 
________________________________

From: paul [mailto:[email-masked]] 
Sent: 19. heinäkuuta 2007 5:27
To: Oscar Novo (JO/LMF)
Cc: [email-masked]
Subject: [xcon] Question about draft-ietf-xcon-common-data-model-05

Hi  Oscar 

In chapter 4.4 it said:

   be rejected."

Does "subscription" here mean the SIP SUBSCRIBE request initiated subscription?

However I know the BFCP protocol is used for floor control, and there is no concept of subscription.

---

From: "Chris Boulton" <[email-masked]>
Date: Thu, 19 Jul 2007 13:35:11 +0100

Hi Paul,

Actually a conference participant has two methods to 'subscribe' himself
to the floor events. One method is using offer/answer exchange mechanism
(rfc3264) using SIP INVITE and BFCP parameters in the SDP (rfc4583). The
other method is a general authorization mechanism described in section 9
of rfc4582 and in draft-ietf-xcon-bfcp-connection-05 draft.  

When we talk about 'subscription' in chapter 4.4 we're talking about
those two connection methods. Future documentation may define additional
connection mechanisms. 

[Chris Boulton] Oscar - it might be worth expanding this text to clearly
state and reference the current subscription mechanisms (or point to the
appropriate section).

Chris.

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation. All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email. Ubiquity Software Corporation plc, a company registered under the laws of England and Wales, Registration 2719723, registered offices at Eastern Business Park, Building 3, Wern Fawr Lane, St. Mellons, Cardiff CF3 5EA, Wales, United Kingdom.

---

From: "Oscar Novo (JO/LMF)" <[email-masked]>
Date: Thu, 19 Jul 2007 14:40:43 +0200

OK, I'll do that in the new version of the draft.
 
Thanks,
 
Oscar

From: Chris Boulton [mailto:[email-masked]] 
Sent: 19. heinäkuuta 2007 15:35
To: Oscar Novo (JO/LMF); paul
Cc: [email-masked]
Subject: RE: [xcon] Question about draft-ietf-xcon-common-data-model-05

Hi Paul,

[Chris Boulton] Oscar - it might be worth expanding this text to clearly state and reference the current subscription mechanisms (or point to the appropriate section).

Chris.