Subject: Re: [XCON] I-D Action:draft-ietf-xcon-examples-02.txt

From: "Duddy, Sean (Sean)" <[email-masked]>
Date: Fri, 15 Jan 2010 12:26:37 -0000

I believe these drafts are nearing completion, so could I get some
responses to these questions please? 

-----Original Message-----
From: Duddy, Sean (Sean) 
Sent: 04 January 2010 15:27
To: [email-masked]'; [email-masked]
Cc: [email-masked]
Subject: RE: [XCON] I-D Action:draft-ietf-xcon-examples-02.txt

Hi All,

Some questions/issues on this draft:-

General:-
	In section 6.4(Muting a party), an update user request is sent
specifying the status value.
None of the other <user-type> elements are present in this update
request. I assume their absence does not imply that the server set null
values for these fields in its data model? 
e.g. if the endpoint been muted had a <display-text> value, this would
be untouched during the update.
This question would apply to any update question.

6.1.
"1.  Upon receipt of the userRequest from "Alice" to be added to
       "Bob's" conference (i.e., an "update" operation on "Bob's"...."
There is no update operation for this scenario, it is a create user
operation on the conference.

6.3 Adding a party
	How can an 'adhoc' user be added to a conference? e.g. I want to
add someone to the conference but I do not want their details to be
created in the
	conferencing server for future use.
	
Sean

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: 29 December 2009 12:45
To: [email-masked]
Cc: [email-masked]
Subject: [XCON] I-D Action:draft-ietf-xcon-examples-02.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Centralized Conferencing Working Group
of the IETF.

	Title           : Centralized Conferencing Manipulation Protocol
(CCMP) Call Flow Examples
	Author(s)       : M. Barnes, et al.
	Filename        : draft-ietf-xcon-examples-02.txt
	Pages           : 80
	Date            : 2009-12-29

This document provides detailed call flows for the scenarios documented
in the Centralized Conferencing (XCON) Framework and the XCON Scenarios.
The call flows document the use of the interface between a conference
control client and a conference control server using the Centralized
Conferencing Manipulation Protocol (CCMP).  The objective is to provide
a base reference for both protocol researchers and developers.

Status of this Memo

This Internet-Draft is submitted to IETF in full conformance with the
provisions of BCP 78 and BCP 79.

Internet-Drafts are working documents of the Internet Engineering Task
Force (IETF), its areas, and its working groups.  Note that other groups
may also distribute working documents as Internet- Drafts.

Internet-Drafts are draft documents valid for a maximum of six months
and may be updated, replaced, or obsoleted by other documents at any
time.  It is inappropriate to use Internet-Drafts as reference material
or to cite them other than as "work in progress."

The list of current Internet-Drafts can be accessed at
http://www.ietf.org/ietf/1id-abstracts.txt.

The list of Internet-Draft Shadow Directories can be accessed at
http://www.ietf.org/shadow.html.

This Internet-Draft will expire on July 2, 2010.Copyright Notice

Copyright (c) 2009 IETF Trust and the persons identified as the document
authors.  All rights reserved.

This document is subject to BCP 78 and the IETF Trust's Legal Provisions
Relating to IETF Documents
(http://trustee.ietf.org/license-info) in effect on the date of
publication of this document.  Please review these documents carefully,
as they describe your rights and restrictions with respect to this
document.  Code Components extracted from this document must include
Simplified BSD License text as described in Section 4.e of the Trust
Legal Provisions and are provided without warranty as described in the
BSD License.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-xcon-examples-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Lorenzo Miniero" <[email-masked]>
Date: Sat, 16 Jan 2010 15:23:07 +0100

Hi Sean,

I apogize for the late reply, but I've just checked in my
old mail and could find no trace of your 4th January post.
Maybe it got lost?

Here's a few comments inline ([LM]).

----- Original Message -----
From: "Duddy, Sean (Sean)" <[email-masked]>
To: <[email-masked]>, <[email-masked]>
Cc: [email-masked]
Subject: Re: [XCON] I-D
Action:draft-ietf-xcon-examples-02.txt
Date: Fri, 15 Jan 2010 12:26:37 -0000

> I believe these drafts are nearing completion, so could I
> get some responses to these questions please? 
> 
>     In section 6.4(Muting a party), an update user request
> is sent specifying the status value.
> None of the other <user-type> elements are present in this
> update request. I assume their absence does not imply that
> the server set null values for these fields in its data
> model?  e.g. if the endpoint been muted had a
> <display-text> value, this would be untouched during the
> update. This question would apply to any update question.
> 

[LM] You're right in assuming that not specifying something
in an update does not mean that it is removed from the
conference description. An update only modifies what is
included, and leaves the rest untouched. We'll add some text
(maybe at the beginning of the doc, before the call flows)
to better clarify these generic aspects of the protocol, so
that it doesn't confuse people reading it.

>        "Bob's" conference (i.e., an "update" operation on
> "Bob's"...." There is no update operation for this
> scenario, it is a create user operation on the conference.
> 

[LM] It's not an update operation, in fact. What we meant is
that the conference info is updated with the details on the
new user, Bob. So, it was just a poor choice of words, we'll
correct this in the next version of the doc.

> 6.3 Adding a party
>     How can an 'adhoc' user be added to a conference? e.g.
> I want to add someone to the conference but I do not want
> their details to be created in the

[LM] This is a good point, and it may be useful to add a
scenario for that in the doc as well. The CCMP doc explains
how to do this in Section 6.3.6, at the end of page 34. It
basically consists in an userRequest with no entity
attribute in the userInfo: the conferencing system takes
care of creating both this entity and a valid XCON user ID.

Thanks for your feedback,
Lorenzo

> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of [email-masked]
> A New Internet-Draft is available from the on-line
> Internet-Drafts directories.
> This draft is a work item of the Centralized Conferencing
> Working Group of the IETF.
> 
> 
>     Title           : Centralized Conferencing
> Manipulation Protocol (CCMP) Call Flow Examples
> This document provides detailed call flows for the
> scenarios documented in the Centralized Conferencing
> (XCON) Framework and the XCON Scenarios. The call flows
> document the use of the interface between a conference
> control client and a conference control server using the
> Centralized Conferencing Manipulation Protocol (CCMP). 
> The objective is to provide a base reference for both
> protocol researchers and developers.
> 
> Status of this Memo
> 
> This Internet-Draft is submitted to IETF in full
> conformance with the provisions of BCP 78 and BCP 79.
> 
> Internet-Drafts are working documents of the Internet
> Engineering Task Force (IETF), its areas, and its working
> groups.  Note that other groups may also distribute
> working documents as Internet- Drafts.
> 
> Internet-Drafts are draft documents valid for a maximum of
> six months and may be updated, replaced, or obsoleted by
> other documents at any time.  It is inappropriate to use
> Internet-Drafts as reference material or to cite them
> other than as "work in progress."
> 
> The list of Internet-Draft Shadow Directories can be
> accessed at http://www.ietf.org/shadow.html.
> 
> Copyright (c) 2009 IETF Trust and the persons identified
> as the document authors.  All rights reserved.
> 
> This document is subject to BCP 78 and the IETF Trust's
> Legal Provisions Relating to IETF Documents
> (http://trustee.ietf.org/license-info) in effect on the
> date of publication of this document.  Please review these
> documents carefully, as they describe your rights and
> restrictions with respect to this document.  Code
> Components extracted from this document must include
> Simplified BSD License text as described in Section 4.e of
> the Trust Legal Provisions and are provided without
> warranty as described in the BSD License.
> 
> Below is the data which will enable a MIME compliant mail
> reader implementation to automatically retrieve the ASCII
> version of the Internet-Draft.
> _______________________________________________
> XCON mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xcon

Lorenzo Miniero
http://www.meetecho.com