Subject: [XCON] Possible bug in the data model document

From: Simon Pietro Romano <[email-masked]>
Date: Fri, 05 Nov 2010 11:29:21 +0100

Hi,

we noticed that, in the latest version of the data model draft, the 
<endpoint>/<media>/<floor> element, described in par. 4.6.5.10, is 
missing both a RELAX-NG and an XML-Schema definition. In the 
non-normative diagram of the XML conference representationin par. 4, the 
above-mentioned <floor> element appears (by mistake?) under both 
<to-mixer> and <from-mixer> tags.

Simon

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]
           http://www.comics.unina.it/simonpietro.romano

     <<Molti mi dicono che lo scoraggiamento è l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/

---

From: Oscar Novo <[email-masked]>
Date: Wed, 10 Nov 2010 11:26:52 +0100

Hi Simon,

Thanks for the note! That was a big mistake indeed. 
I've submitted a new version of the draft. I guess in few hours will be visible in the IETF repository. In the new draft, both schemas should be corrected (XML and RELAX-NG) as well as the text in the document.

Cheers,

Oscar

-----Original Message-----
From: Simon Pietro Romano [mailto:[email-masked]] 
Sent: 5. marraskuuta 2010 12:29
To: Oscar Novo
Cc: [email-masked]
Subject: Possible bug in the data model document

Hi,

we noticed that, in the latest version of the data model draft, the <endpoint>/<media>/<floor> element, described in par. 4.6.5.10, is missing both a RELAX-NG and an XML-Schema definition. In the non-normative diagram of the XML conference representationin par. 4, the above-mentioned <floor> element appears (by mistake?) under both <to-mixer> and <from-mixer> tags.

Simon

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 10 Nov 2010 20:18:36 +0800

Hi,

> I guess in few hours will be visible in the IETF repository. 

the announcement of the draft got to the list only 4 minutes after your
email :o)

Thanks,

Gonzalo

---

From: Oscar Novo <[email-masked]>
Date: Wed, 10 Nov 2010 13:42:55 +0100

Cool! That was fast. :)

So, here's the new version:
	http://tools.ietf.org/html/draft-ietf-xcon-common-data-model-21

Oscar

-----Original Message-----
From: Gonzalo Camarillo 
Sent: 10. marraskuuta 2010 14:19
To: Oscar Novo
Cc: Simon Pietro Romano; [email-masked]
Subject: Re: [XCON] Possible bug in the data model document

Hi,

> I guess in few hours will be visible in the IETF repository. 

the announcement of the draft got to the list only 4 minutes after your email :o)

Thanks,

Gonzalo