Subject: [Xml-sg-cmt] question: using entities to control line breaks

From: Alice Russo <[email-masked]>
Date: Thu, 3 Jun 2021 09:11:54 -0700

Greetings,

Re: using entities in titles to control placement of line breaks in specific rendered files. Is it accurate that we should not be using entities in this manner?

Example: to prevent a line break after hyphen in the text output

-- Before:

Deterministic Networking (DetNet) Data Plane: MPLS over IEEE 802.1 Time-
                       Sensitive Networking (TSN)

-- After (if &nbhy; is used in the XML):

   Deterministic Networking (DetNet) Data Plane: MPLS over IEEE 802.1 
                       Time-Sensitive Networking (TSN)

-- Or, even better (if &nbsp; is used as well):

             Deterministic Networking (DetNet) Data Plane:
          MPLS over IEEE 802.1 Time-Sensitive Networking (TSN)

[This would also yield the desired result in the PDF file.]

Background: This is something the RPC did commonly in v2 era, but our understanding is that we're not supposed to do this in the v3 era.   If that's accurate, then we'll add this to the list of 'guidance received'.

Thanks,
Alice

---

From: "John R Levine" <[email-masked]>
Date: 3 Jun 2021 13:40:58 -0400

> Re: using entities in titles to control placement of line breaks in specific rendered files. Is it accurate that we should not be using entities in this manner?

My inclination is to say that if this is an issue, the layout angine in 
xml2rfc should address it rather than hand-tweaks, but I'm also interested 
in what other people have to say.

> Background: This is something the RPC did commonly in v2 era, but our understanding is that we're not supposed to do this in the v3 era.   If that's accurate, then we'll add this to the list of 'gu…

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Sandy Ginoza <[email-masked]>
Date: Thu, 3 Jun 2021 22:23:55 -0700

Hi all,

Just checking to see if there are any further thoughts on this before we publish RFC 9023 (see https://www.rfc-editor.org/authors/rfc9023.txt). 

Thanks,
Sandy 

> On Jun 3, 2021, at 10:40 AM, John R Levine <[email-masked]> wrote:
> 
> My inclination is to say that if this is an issue, the layout angine in xml2rfc should address it rather than hand-tweaks, but I'm also interested in what other people have to say.
> 
>> 
> -- 
> Xml-sg-cmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml-sg-cmt
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 7 Jun 2021 17:57:25 +0200

Relying on the layout engine to always be so good that no human judgement
will be needed has proved to not hold in general.  I think there will
be occasional exceptions requiring tweaks, and we shouldn't prohibit
the use of things like &nbhy; if they can make things better.

	Henrik