Subject: [Xml-sg-cmt] Fwd: [xml2rfc] #647: Double quotes and <code>

From: Robert Sparks <[email-masked]>
Date: Thu, 8 Jul 2021 09:47:19 -0500

I assume everyone here is subscribed to the xml2rfc list?

Didn't we have a decision point around this recently? Or do I misremember?

RjS

-------- Forwarded Message --------
Subject: 	Re: [xml2rfc] #647: Double quotes and <code>
Date: 	Thu, 8 Jul 2021 08:28:48 +0200
From: 	Carsten Bormann <[email-masked]>
To: 	Kesara Rathnayake <[email-masked]>
CC: 	[email-masked], Julian Reschke <[email-masked]>, 
[email-masked], Robert Sparks <[email-masked]>, 
[email-masked], [email-masked], [email-masked]

Hi Kesara,

As long as RFCXML has had a <tt>-like construct (was <spanx 
style=“verb”> in RFCXMLv1/2), this has been rendered with some form of 
delimiters in the text form.
I.e., there is a difference between presence and absence of <tt>, and 
the start and end of a <tt> is clearly visible.

Now, double quotes has always been suboptimal, a compromise between the 
need to visualise and the usage of quotes in normal English.
This was bearable as long as we only had one target, .TXT, so we could 
choose between keeping something undecorated and getting quotes.

Now, we have .HTML (and .PDF) as another target format.
This makes the choice procrustean: We can either have visual 
highlighting (by font and by a gray underlay) in HTML *and* quotes in 
TXT, or none of those.
As Martin pointed out, that is not always the right combination.

We had s similar problem with <sup> and came up with a heuristic (to be 
supported by an attribute “paren” that fully controls it; we didn’t 
quite go the whole way by adding “op” as I suggested, but that’s a 
different story).

So what I was saying was that we couldn’t wholesale delete the quotes 
from TXT, as many documents will now miss the visual clue from presence 
and delimitation of <tt>, but that we need a heuristic and/or more control.

A pretty good basic heuristic would be that, if the <tt> is surrounded 
by quotes already, no second set it added by the TXT rendering.
That is probably hard to implement in xml2rfc’s current structure, so 
that is maybe something kramdown-rfc can prepare by turning “`foo`” into 
"<tt txtquotes=“false”>foo</foo>”.

We should discuss whether a simple solution like this could cover 80 % 
of the problem.

Grüße, Carsten

> On 8. Jul 2021, at 03:30, Kesara Rathnayake <[email-masked]> wrote:
>
> Can you elaborate?
> I may have misunderstood the requirements.
>
> -- Kesara
>
> On 8/07/21 1:23 pm, Carsten Bormann wrote:
>> Whoa, that’s radical.
>> Lots of text won’t work any more.
>> Sent from mobile, sorry for terse
>>> On 8. Jul 2021, at 02:57, xml2rfc issue tracker 
>>> <[email-masked]> wrote:
>>>
>>> #647: Double quotes and <code>
>>> ---------------------------------------+--------------------
>>> Reporter: [email-masked] | Owner:
>>> Type: defect | Status: closed
>>> Priority: minor | Milestone:
>>> Component: Version_3_cli_txt | Version:
>>> Resolution: fixed | Keywords:
>>> ---------------------------------------+--------------------
>>> Changes (by [email-masked]):
>>>
>>> * status: new => closed
>>> * resolution: => fixed
>>>
>>>
>>> Comment:
>>>
>>> Fixed in [4012]:
>>>
>>> Remove quotes from the text rendering of <tt>. Fixes #600 and #647. 
>>> Commit
>>> ready for merge.
>>>
>>> --
>>> Ticket URL: <https://trac.ietf.org/trac/xml2rfc/ticket/647#comment:4>
>>> xml2rfc <https://trac.ietf.org/trac/xml2rfc/>
>>>
>
> -- Kesara Rathnayake
> Senior Software Development Engineer - IETF LLC
> [email-masked]

---

From: "John R Levine" <[email-masked]>
Date: 8 Jul 2021 11:57:20 -0400

> Didn't we have a decision point around this recently? Or do I misremember?

We discussed it, I looked at all of the rendered <tt> I could find and I 
found that in nearly every case it would look better without the quotes.

For example <tt>2001:2345:5678::ABCD</tt> is not improved with quote marks.

R's,
John

> As long as RFCXML has had a <tt>-like construct (was <spanx style=“verb”> in 
> RFCXMLv1/2), this has been rendered with some form of delimiters in the text 
> form.
> I.e., there is a difference between presence and absence of <tt>, and the 
> start and end of a <tt> is clearly visible.
>
> Now, double quotes has always been suboptimal, a compromise between the need 
> to visualise and the usage of quotes in normal English.
> This was bearable as long as we only had one target, .TXT, so we could choose 
> between keeping something undecorated and getting quotes.
>
> This makes the choice procrustean: We can either have visual highlighting (by 
> font and by a gray underlay) in HTML *and* quotes in TXT, or none of those.
> supported by an attribute “paren” that fully controls it; we didn’t quite go 
> the whole way by adding “op” as I suggested, but that’s a different story).
>
> So what I was saying was that we couldn’t wholesale delete the quotes from 
> TXT, as many documents will now miss the visual clue from presence and 
> delimitation of <tt>, but that we need a heuristic and/or more control.
>
> A pretty good basic heuristic would be that, if the <tt> is surrounded by 
> quotes already, no second set it added by the TXT rendering.
> That is probably hard to implement in xml2rfc’s current structure, so that is 
> maybe something kramdown-rfc can prepare by turning “`foo`” into "<tt 
> txtquotes=“false”>foo</foo>”.
>
> We should discuss whether a simple solution like this could cover 80 % of the 
> problem.
>
> Grüße, Carsten
>
>
>
>>>> On 8. Jul 2021, at 02:57, xml2rfc issue tracker <[email-masked]> 
>>>> wrote:
>>>> 

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Robert Sparks <[email-masked]>
Date: Thu, 8 Jul 2021 11:16:40 -0500

I went looking for notes, but didn't find them. If you remember where 
they are, please point?

RjS

On 7/8/21 10:57 AM, John R Levine wrote:
> We discussed it, I looked at all of the rendered <tt> I could find and 
> I found that in nearly every case it would look better without the 
> quotes.
>
>> CC:     [email-masked], Julian Reschke 
>> <[email-masked]>, [email-masked], Robert Sparks 
>> <[email-masked]>, [email-masked], 
>> [email-masked], [email-masked]
>>
>>
>>
>> Hi Kesara,
>>
>> style=“verb”> in RFCXMLv1/2), this has been rendered with some form 
>> of delimiters in the text form.
>> Now, double quotes has always been suboptimal, a compromise between 
>> the need to visualise and the usage of quotes in normal English.
>> This was bearable as long as we only had one target, .TXT, so we 
>> could choose between keeping something undecorated and getting quotes.
>>
>> We had s similar problem with <sup> and came up with a heuristic (to 
>> be supported by an attribute “paren” that fully controls it; we 
>> didn’t quite go the whole way by adding “op” as I suggested, but 
>> that’s a different story).
>>
>> from TXT, as many documents will now miss the visual clue from 
>> presence and delimitation of <tt>, but that we need a heuristic 
>> and/or more control.
>>
>> A pretty good basic heuristic would be that, if the <tt> is 
>> surrounded by quotes already, no second set it added by the TXT 
>> rendering.
>> that is maybe something kramdown-rfc can prepare by turning “`foo`” 
>> into "<tt txtquotes=“false”>foo</foo>”.
>>
>> We should discuss whether a simple solution like this could cover 80 
>> % of the problem.
>>
>> Grüße, Carsten
>>
>>
>>
>>>>> Remove quotes from the text rendering of <tt>. Fixes #600 and 
>>>>> #647. Commit
>>>>> ready for merge.
>>>>>
>>>>> --

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 8 Jul 2021 10:31:23 -0600

There is some discussion of <tt> here:

https://codimd.ietf.org/cmt-20210208#

https://codimd.ietf.org/cmt-20210222#

---

From: Sandy Ginoza <[email-masked]>
Date: Thu, 8 Jul 2021 09:39:02 -0700

<https://trac.ietf.org/trac/xml2rfc/changeset/4012> includes: "Fixes #600 <https://trac.ietf.org/trac/xml2rfc/ticket/600> and #647 <https://trac.ietf.org/trac/xml2rfc/ticket/647>. Commit ready for merge.” 
<https://trac.ietf.org/trac/xml2rfc/ticket/600> points to https://codimd.ietf.org/cmt-20210222#

> On Jul 8, 2021, at 9:31 AM, Peter Saint-Andre <[email-masked]> wrote:
> 
> Xml-sg-cmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml-sg-cmt