Subject: Re: [Xml-sg-cmt] contact element

From: Sandy Ginoza <[email-masked]>
Date: Wed, 4 Aug 2021 15:32:26 -0700

Hi Peter, John,

> Did you two ever get a chance to write this up?

Finally getting back to this - sorry for the delay.  This is a clarification of item 2 on <https://www.rfc-editor.org/rse/wiki/doku.php?id=v3_guidance_received> and an attempt at building on Peter’s strawman text regarding how <contact> should be used.  

The following is based on how <contact> has been used in recent pubs from each stream.  

<contact> is recommended for the following:
names mentioned in the Acknowledgments and Contributors sections of documents. 
(not typically used for author names of draft itself, e.g., Author A would like to thank…)
individual names in the IANA registrations (e.g., contacts).
IAB members, workshop participants, and the program committee.
(not a list of names under position papers, as that is really about the referenced doc)
wherever needed to render names/organizations with non-ASCII characters correctly
The RPC will not proactively add the <contact> element to a document outside of the areas listed above, but authors are welcome to do so.  

The IAB workshop participants and program committee got thrown in because they usually contain one or more names with non-ASCII chars, so it seemed like we should use <contact> consistently within the section.  Based on the discussion below, would participants and committee members fall into the last category, where <contact> is only added where needed to display non-ASCII chars? 

These are a couple of recent RFCs from the IAB stream:
https://www.rfc-editor.org/rfc/rfc9075.html
https://www.rfc-editor.org/rfc/rfc8980.html

Thanks!
Sandy 

> On May 10, 2021, at 2:56 PM, Peter Saint-Andre <[email-masked]> wrote:
> 
> On 5/10/21 3:13 PM, Sandy Ginoza wrote:
>> You’re still incredibly fast with your replies! 
> 
> I'm either incredibly fast or incredibly slow. Not much in between. :-)
> 
>>> On May 10, 2021, at 1:30 PM, Peter Saint-Andre <[email-masked]> wrote:
>>> 
>>> That's a lot of contacts. :-)
>>> 
>>> Do we even have contact information for everyone who submitted position
>>> papers?
>> 
>> No, but we don’t necessarily have contact info for the individuals listed in the other sections either.
>> That said, I’m thinking that not using <contact> here makes sense in that a reader could go to the relevant reference and get the info from the paper directly. 
> 
> True.
> 
>> One problem with this approach might be if we need to use <contact> for names with non-ASCII characters.  Based on my quick spot check, I don’t think this is problematic for this document; the names seem to match what appears in the docs.  RFC 8980 included Stéphane Bortzmeyer, Moritz Müller, and Jörg Ott. 
>> 
>> Does it make sense to use <contact> in this section only for the names that contain non-ASCII chars?  Is it problematic that use of <contact> would be inconsistent? 
> 
> Hmm, well, <contact> is used for two purposes:
> 
> 1. Flagging that we have contact information for a person or entity.
> 
> 2. Kludging support for non-ASCII characters in the name of a person or
> entity.
> 
> :-)
> 
> Given that these purposes aren't consistent, I'm not sure that
> consistency in tagging is critically important.
> 
> Peter
> 
> -- 
> Xml-sg-cmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml-sg-cmt

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 5 Aug 2021 14:51:14 -0600

On 8/4/21 4:32 PM, Sandy Ginoza wrote:
> Finally getting back to this - sorry for the delay.  This is a
> clarification of item 2 on
> <https://www.rfc-editor.org/rse/wiki/doku.php?id=v3_guidance_received
> <https://www.rfc-editor.org/rse/wiki/doku.php?id=v3_guidance_received>>
> and an attempt at building on Peter’s strawman text regarding how
> <contact> should be used.  
> 
>   *
>   *
>   *
>   *
> The RPC will not proactively add the <contact> element to a document
> outside of the areas listed above, but authors are welcome to do so. 

The foregoing seems reasonable to me.

> The IAB workshop participants and program committee got thrown in
> because they usually contain one or more names with non-ASCII chars, so
> it seemed like we should use <contact> consistently within the section.
>  Based on the discussion below, would participants and committee members
> fall into the last category, where <contact> is only added where needed
> to display non-ASCII chars? 

It seems to me that the number of participants and committee members
tends to be fairly small (on the order of ~20 at most) and IAB workshop
RFCs are published relatively infrequently, so structuring them all via
the <contact> element is not onerous. But YMMV.

Peter

---

From: "John R Levine" <[email-masked]>
Date: 5 Aug 2021 17:04:59 -0400

Seems reasonable to me, too. Do we need more of a writeup?

>> <contact> should be used. 
??>
>> The following is based on how <contact> has been used in recent pubs
??>
>>     names mentioned in the Acknowledgments and Contributors sections of
??>     (not typically used for author names of draft itself, e.g., Author A
>>     would like to thank…)

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly