Subject: [Xml-sg-cmt] <postalline> vs <city> et al.

From: "John R Levine" <[email-masked]>
Date: 7 Jan 2022 12:40:21 -0500

Since xml2rfc 3.0, the format of postal addresses has allowed either the 
list of specific fields or a sequence of <postalline>

Since there turns out to be no reliable waay to render the specific 
fields, we need to stop using the fields in favor of postalline

To make it possible to render RFCs more reliably in the future, I want to 
get rid of the fields altogether, render them once into postalline and 
(gasp) reissue the RFCs.

The point of the fields was that the same address is rendered differently 
in English and in other languages such as Swedish.  While that is true, I 
don't care.  As RFC 7997 sec 3.9 says in the context of non-ASCII 
characters, the point of a postal address is to have an address to which 
one can send postal mail, so anything that will get the mail delivered 
will do.  As a fairly extreme case, in Japan addresses are written 
vertically in Japanese, but if you send mail to Japan with the address in 
horizontal Roman tranliteration, it works.

R's,
John

RFC grammar is:

   <define name="postal">
     <element name="postal">
       <optional>
         <attribute name="xml:base"/>
       </optional>
       <optional>
         <attribute name="xml:lang"/>
       </optional>
       <choice>
         <zeroOrMore>
           <choice>
             <ref name="city"/>
             <ref name="cityarea"/>
             <ref name="code"/>
             <ref name="country"/>
             <ref name="extaddr"/>
             <ref name="pobox"/>
             <ref name="region"/>
             <ref name="sortingcode"/>
             <ref name="street"/>
           </choice>
         </zeroOrMore>
         <oneOrMore>
           <ref name="postalLine"/>
         </oneOrMore>
       </choice>
     </element>
   </define>

---

From: Alice Russo <[email-masked]>
Date: Fri, 7 Jan 2022 10:10:19 -0800

Hi John,

In terms of operational practice, is it your expectation that documents in queue wouldn't have this change until the already published RFCs are updated? Or, you envision that it would start earlier? 

i.e., What is the timing for putting this into practice at the RPC? At what point do you envision that we do the following:
- request a change to the v2->v3 converter 
- update RPC procedures
- start publishing docs that only use postalLine and country

As far as documentation, where will this 'best practice' for using the existing vocabulary be located so that it can be pointed to when someone asks why we've removed the semantic info from their postal address?

Thanks,
Alice

> On Jan 7, 2022, at 9:40 AM, John R Levine <[email-masked]> wrote:
> 
> Since xml2rfc 3.0, the format of postal addresses has allowed either the list of specific fields or a sequence of <postalline>
> 
> Since there turns out to be no reliable waay to render the specific fields, we need to stop using the fields in favor of postalline
> 
> To make it possible to render RFCs more reliably in the future, I want to get rid of the fields altogether, render them once into postalline and (gasp) reissue the RFCs.
> 
> The point of the fields was that the same address is rendered differently in English and in other languages such as Swedish.  While that is true, I don't care.  As RFC 7997 sec 3.9 says in the context of non-ASCII characters, the point of a postal address is to have an address to which one can send postal mail, so anything that will get the mail delivered will do.  As a fairly extreme case, in Japan addresses are written vertically in Japanese, but if you send mail to Japan with the address in horizontal Roman tranliteration, it works.
> 
> R's,
> John
> 
> RFC grammar is:
> 
>  <define name="postal">
>    <element name="postal">
>      <optional>
> -- 
> Xml-sg-cmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml-sg-cmt
>

---

From: "John R Levine" <[email-masked]>
Date: 7 Jan 2022 13:23:12 -0500

> - start publishing docs that only use postalLine and country

I'd rather it be sooner than later to limit the number of RFCs we have to 
go back and fix.  Also, it's just <postalline>, with the country on the 
last line.  Earlier versions of the grammar were a mess trying to allow a 
mix of the two types, but now it's one or the other.

> As far as documentation, where will this 'best practice' for using the 
> existing vocabulary be located so that it can be pointed to when someone 
> asks why we've removed the semantic info from their postal address?

I can write something up.  The semantic info was an experiment that turned 
out not to work as hoped.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Sandy Ginoza <[email-masked]>
Date: Fri, 7 Jan 2022 15:39:24 -0800

> On Jan 7, 2022, at 10:23 AM, John R Levine <[email-masked]> wrote:
> 
> I'd rather it be sooner than later to limit the number of RFCs we have to go back and fix.  Also, it's just <postalline>, with the country on the last line.  Earlier versions of the grammar were a mess trying to allow a mix of the two types, but now it's one or the other.

To make sure I understand this correctly for our procedures, is it correct that: 

      <author fullname="Roy T. Fielding"
              initials="R."
              surname="Fielding"
              role="editor">
         <organization>Adobe</organization>
         <address>
            <postal>
               <street>345 Park Ave</street>
               <city>San Jose</city>
               <region>CA</region>
               <code>95110</code>
               <country>United States of America</country>
            </postal>
            <email>[email-masked]</email>
            <uri>https://roy.gbiv.com/</uri>
         </address>

Should be:

      <author fullname="Roy T. Fielding"
              initials="R."
              surname="Fielding"
              role="editor">
         <organization>Adobe</organization>
         <address>
           <postal>
             <postalLine>345 Park Ave</postalLine>
             <postalLine>San Jose, CA 95110</postalLine>
             <postalLine>United States of America</postalLine>
            </postal>
            <email>[email-masked]</email>
            <uri>https://roy.gbiv.com/</uri>
         </address>
       </author>

And the alternate format that would be accepted is <country> only, so:

      <author fullname="Roy T. Fielding"
              initials="R."
              surname="Fielding"
              role="editor">
         <organization>Adobe</organization>
         <address>
           <postal>
             <country>United States of America</country>
            </postal>
            <email>[email-masked]</email>
            <uri>https://roy.gbiv.com/</uri>
         </address>
       </author>

Is this correct?

> I can write something up.  The semantic info was an experiment that turned out not to work as hoped.

Great - what do you think the timeline is for this?  Ideally we’d document it somewhere before we start applying the updates; it would be a change to the majority of documents. 

Perhaps a post to rfc-interest or update https://authors.ietf.org/rfcxml-vocabulary#postal indicating that postalLine is preferred/recommended/required and the child elements outside of <country> are deprecated?  

Thanks!
Sandy

---

From: "John R Levine" <[email-masked]>
Date: 7 Jan 2022 20:18:57 -0500

>            <uri>https://roy.gbiv.com/</uri>

That looks right.

>            <uri>https://roy.gbiv.com/</uri>

Dunno, I was thinking we'd remove <country> as well and it'd just be a 
single postalline.

> Perhaps a post to rfc-interest or update https://authors.ietf.org/rfcxml-vocabulary#postal indicating that postalLine is preferred/recommended/required and the child elements outside of <country> a…

Makes sense.  It's on the List of Things to Do Immediately.

Regards,

---

From: Robert Sparks <[email-masked]>
Date: Sun, 9 Jan 2022 11:43:57 -0600

> Dunno, I was thinking we'd remove <country> as well and it'd just be a 

I remember having a longish discussion about why we would keep country - 
this feels like you are overturning what we had decided before.

We do have pressure to report statistics on drafts and rfcs including 
what country the authors came from.

This goes in the direction of making that harder again. What changed to 
make this the way you think we should go?

>
>>>> As far as documentation, where will this 'best practice' for using 
>>>> the existing vocabulary be located so that it can be pointed to 
>>>> when someone asks why we've removed the semantic info from their 
>>>> postal address?
>>>
>> Great - what do you think the timeline is for this?  Ideally we’d 
>> document it somewhere before we start applying the updates; it would 
>> be a change to the majority of documents.
>>
>> Perhaps a post to rfc-interest or update 
>> https://authors.ietf.org/rfcxml-vocabulary#postal indicating that 
>> postalLine is preferred/recommended/required and the child elements 
>> outside of <country> are deprecated?
>

---

From: "John R Levine" <[email-masked]>
Date: 9 Jan 2022 13:00:13 -0500

> I remember having a longish discussion about why we would keep country - this 
> feels like you are overturning what we had decided before.

I thought we agreed it was just the last postalline.

I suppose we could do yet another incompatible vocabulary change to allow
(or require?) <country> after a possibly empty set of <postalline> but I 
was hoping to avoid that.

Regards,

---

From: Robert Sparks <[email-masked]>
Date: Sun, 9 Jan 2022 13:56:40 -0600

So, notes are sparse

https://notes.ietf.org/cmt-20210712#ltpostalgt-again

but the list traffic supports what I remembered:

https://www.rfc-editor.org/pipermail/rfc-interest/2021-August/012171.html

RjS

ps - Tools team call topic next week - moving things like rfc-interest 
to where they can be archived by mailarchive

On 1/9/22 12:00 PM, John R Levine wrote:
>>> Dunno, I was thinking we'd remove <country> as well and it'd just be 
>>> a single postalline.
>>
>> I remember having a longish discussion about why we would keep 
>> country - this feels like you are overturning what we had decided 
>> before.
>
> (or require?) <country> after a possibly empty set of <postalline> but 
> I was hoping to avoid that.
>
> Regards,

---

From: "John R Levine" <[email-masked]>
Date: 9 Jan 2022 16:12:00 -0500

If people want to change the grammar so we put a country line after the 
postallline, I'm not strongly opposed, just one more fripping thing to 
organize.

On Sun, 9 Jan 2022, Robert Sparks wrote:

> ps - Tools team call topic next week - moving things like rfc-interest to 
> where they can be archived by mailarchive
>

Regards,