Subject: Re: [xmpp] 3921bis: probe + unavailable

From: Jonathan Schleifer <[email-masked]>
Date: Fri, 5 Mar 2010 11:14:49 +0100

Am 10.02.2010 um 17:53 schrieb Jonas Lindberg:

> Servers send probes on clients' behalf, for example when receiving  
> initial presence from a client.

Servers could filter them when they are from the initial presence. Or  
could only send the unavailable presence if another presence has been  
sent before. But I think the former is better, as it's also nice to  
know after you got a presence subscription request accepted whether  
the user is offline or you are still waiting for the presence.

--
Jonathan

---

From: Peter Saint-Andre <[email-masked]>
Date: Sat, 06 Mar 2010 19:16:12 -0700

On 2/10/10 1:59 PM, Joe Hildebrand wrote:
> On 2/4/10 1:35 AM, "Peter Saint-Andre" <[email-masked]> wrote:
> 
>> On 2/1/10 6:03 PM, Justin Karneges wrote:
>>> A large benefit is to prevent a jabber:iq:last storm.  We don't want there to
>>> be any reason for a client to poll its entire roster.
>>
>> I completely agree with that sentiment!
> 
> As do I, however without a timestamp in the unavailable presence (which in
> itself is a presence leak), I see many clients still doing iq:last scans --
> which are themselves a presence leak, but an unplugged one in many servers.

In my working copy I have specified that including a delayed delivery
extension (from XEP-0203) is a SHOULD here. We can discuss further in
Anaheim.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/