Subject: [xrblock] Proposed change to summary discard draft to address discard type issue

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Fri, 21 Sep 2012 01:41:09 +0000

Hi all,

In the last IETF meeting, one open issue of summary statistics draft (http://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-summary-stat-00) raised is to add some words to point out discard type chosen. Here  is the proposed text to address this issue.

In section 3.2.2, the description of Gap Discard Rate field, the third paragraph.
OLD TEXT:
"
      where "number of packets discarded" is obtained from the RTCP XR
      Discard Block [DISCARD] and Packets Expected is calculated as the
      difference between "extended last sequence number" and "extended
      first sequence number" (Interval or Cumulative) provided in the
      Measurement Information block [MEASIDENT].
"
NEW TEXT:
"
where "number of packets discarded" is filled with number of packets due to both
early and late to be played out which is obtained from the RTCP XR
Discard Block [DISCARD], and Packets Expected is calculated
as the difference between "extended last sequence number" and "extended
first sequence number" (Interval or Cumulative) provided in the
Measurement Information block [MEASIDENT].
"

Best Regards!
Rachel

Best Regards!
Rachel

---

From: Qin Wu <[email-masked]>
Date: Fri, 21 Sep 2012 10:02:23 +0800

Your proposed change looks good.

Regards!
-Qin
  ----- Original Message ----- 
  From: Huangyihong (Rachel) 
  To: xrblock 
  Sent: Friday, September 21, 2012 9:41 AM
  Subject: [xrblock] Proposed change to summary discard draft to address discard type issue

  Hi all,

  OLD TEXT:

  "

  "

  NEW TEXT:

  "

  "

  Best Regards!

  Rachel

  Best Regards!

  Rachel

------------------------------------------------------------------------------

  _______________________________________________
  xrblock mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/xrblock

---

From: Glen Zorn <[email-masked]>
Date: Fri, 21 Sep 2012 10:36:02 +0700

On 09/21/2012 08:41 AM, Huangyihong (Rachel) wrote:
>
> Hi all,
>
> In the last IETF meeting, one open issue of summary statistics draft 
> (http://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-summary-stat-00) raised 
> is to add some words to point out discard type chosen. Here is the 
> proposed text to address this issue.
>
> “
> “
> “
> early and late to be played outwhich is obtained from the RTCP XR
>
> “

I would rewrite this as

"where "number of packets discarded" is filled with the number of 
packets discarded due to both early and late arrivalwhich is obtained 
from the RTCP XRDiscard Block [DISCARD], and Packets Expected is 
calculatedas the difference between "extended last sequence number" and 
"extendedfirst sequence number" (Interval or Cumulative) provided in 
theMeasurement Information block [MEASIDENT]."

But even so, it would imply that two instances of the RTCP XR Discard 
Block are required, since a single Discard block can only report 
discards due to either early or late arrival, not both. Is that your 
intent? If so, then I would suggest making it explicit; if not, the 
maybe just leave the text as it is.

On a different topic (but somewhat related), should the references to 
draft-ietf-xrblock-rtcp-xr-discard and 
draft-ietf-xrblock-rtcp-xr-meas-identity be normative? It seems to me 
that it would be impossible to fully understand this draft w/o 
understanding them, too.

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Fri, 21 Sep 2012 05:55:57 +0000

Hi Glen,

See my replies inline.

Best Regards!
Rachel

-----Original Message-----
From: Glen Zorn [mailto:[email-masked]] 
Sent: Friday, September 21, 2012 11:36 AM
To: Huangyihong (Rachel)
Cc: xrblock; [email-masked]
Subject: Re: [xrblock] Proposed change to summary discard draft to address discard type issue

I would rewrite this as

The Measurement Information block [MEASIDENT]."

[Rachel]: I am okay with your proposed change. Also one instance is sufficient
since Discard draft supports reporting discards due to both.

[Rachel]: Good point and will change them into normative.

---

From: Glen Zorn <[email-masked]>
Date: Fri, 21 Sep 2012 13:26:29 +0700

On 09/21/2012 12:55 PM, Huangyihong (Rachel) wrote:

...

 > calculatedas the difference between "extended last sequence number"
 > and "extendedfirst sequence number" (Interval or Cumulative) provided
 > in The Measurement Information block [MEASIDENT]."
 >
 > [Rachel]: I am okay with your proposed change. Also one instance is
 > sufficient since Discard draft supports reporting discards due to
 > both.

Yes but the statement that the '"number of packets discarded" is filled 
with the number of
packets discarded due to both early and late arrival which is obtained 
from the RTCP XR Discard Block" is only true if a) the "Discard Type" 
field in the Discard block is set to 11 or b) two instances of the 
Discard block are present, one with the DT field set to 10 & the other 
with the DT field set to 01.  Do you think that that should be mentioned?

...

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Fri, 21 Sep 2012 06:48:26 +0000

Best Regards!
Rachel

-----Original Message-----
From: Glen Zorn [mailto:[email-masked]] 
Sent: Friday, September 21, 2012 2:26 PM
To: Huangyihong (Rachel)
Cc: Glen Zorn; xrblock
Subject: Re: [xrblock] Proposed change to summary discard draft to address discard type issue

...

[Rachel]: I got your point. How about changing the text to :
"
   where "number of packets discarded" is filled with the number of packets discarded 
   due to both early and late arrival (e.g. the discard type field in the Discard block is 
   set to 11) which is obtained from the RTCP XR Discard Block [DISCARD], and Packets 
   Expected is calculated as the difference between "extended last sequence number" 
   and "extended first sequence number" (Interval or Cumulative) provided in The 
   Measurement Information block [MEASIDENT].

"

...

---

From: Qin Wu <[email-masked]>
Date: Fri, 21 Sep 2012 15:36:34 +0800

Hi,
----- Original Message ----- 
From: "Huangyihong (Rachel)" <[email-masked]>
To: "Glen Zorn" <[email-masked]>
Cc: "xrblock" <[email-masked]>
Sent: Friday, September 21, 2012 2:48 PM
Subject: Re: [xrblock] Proposed change to summary discard draft to address discard type issue

>   set to 11) 

[Qin]: say "e.g." is not correct, it is better to rephrase as
(i.e.,Discard Type (DT) field set to 11 in the Discard block)

>which is obtained from the RTCP XR Discard Block [DISCARD], and Packets

---

From: Glen Zorn <[email-masked]>
Date: Fri, 21 Sep 2012 15:31:03 +0700

On 09/21/2012 02:36 PM, Qin Wu wrote:

...

>
 > Yes but the statement that the '"number of packets discarded" is
 > filled with the number of packets discarded due to both early and
 > late arrival which is obtained from the RTCP XR Discard Block" is
 > only true if a) the "Discard Type" field in the Discard block is set
 > to 11 or b) two instances of the Discard block are present, one with
 > the DT field set to 10 & the other with the DT field set to 01. Do
 > you think that that should be mentioned?
 >
 > [Rachel]: I got your point. How about changing the text to : " where
 > "number of packets discarded" is filled with the number of packets
 > discarded due to both early and late arrival (e.g. the discard type
 > field in the Discard block is set to 11)
 >

Yes, "e.g." is not right, but because it appears that this data is only 
valid under certain conditions, I think that it would be better to spell 
out those conditions precisely.

...

---

From: Qin Wu <[email-masked]>
Date: Sat, 22 Sep 2012 11:09:23 +0800

Hi,
----- Original Message ----- 
From: "Glen Zorn" <[email-masked]>
To: "Qin Wu" <[email-masked]>
Cc: "Huangyihong (Rachel)" <[email-masked]>; "Glen Zorn" <[email-masked]>; "xrblock" <[email-masked]>
Sent: Friday, September 21, 2012 4:31 PM
Subject: Re: [xrblock] Proposed change to summary discard draft to address discard type issue

> out those conditions precisely.

[Qin] I think calculate "number of packets discards" based on two instances of Discard Block is
not more straightforward than filling "number of packets discards" with the the number of packet 
discarded due to both early arrival and late arrival (DT=3) since you need to do the sum. But discard (DT=3)block may be not 
received in some case. So how about add the following text at the end of section 3.2.2:
OLD TEXT:
"
where "number of packets discarded" is obtained from the RTCP XR Discard Block [DISCARD] and 
Packets Expected is calculated as the difference between "extended last sequence number"
and "extended first sequence number" (Interval or Cumulative) provided in the
Measurement Information block [MEASIDENT].
"
NEW TEXT:
"
where "number of packets discarded" is obtained from the RTCP XR Discard Count Block [DISCARD] and 
Packets Expected is calculated as the difference between "extended last sequence number" 
and "extended first sequence number" (Interval or Cumulative) provided in the
Measurement Information block [MEASIDENT]. If Discard Count (DT=3) Block is received, 
"the number of packet discarded"is filled with the number of packets discarded due to both early 
and late arrival(DT=3). If Discard Count (DT=3) is not received, "the number of packet discarded"
 is calculated as the sum of packet discards due to early arrival (DT=1)and packet discards due to late arrival(DT=2).
"
Is that what you are looking for? Or you have other proposal?