Subject: Re: [xrblock] Fw: I-D Action: draft-ietf-xrblock-rtcp-xr-jb-08.txt

From: Kevin Gross <[email-masked]>
Date: Sun, 3 Mar 2013 15:13:13 -0700

I'm afraid we're still not there. There is trouble in section 3:

   The jitter buffer can be considered as a time window with one side
   (the early window) aligned with the delay corresponding to the
   earliest arriving packet and the other side (the late window)
   representing the maximum permissible delay before a late arriving
   packet would be discarded.  The delay applied to packets that arrive
   at their expected time is known as the Nominal Delay and this is
   equivalent to the late window.

   The "expected arrival time" is the time that a packet would arrive if
   there was no delay variation.  If all packets arrived at their
   expected arrival time then every packet would be delayed by exactly
   the Nominal Delay.  Early packets arrive before their expected
   arrival time and late packets arrive after.  The reference for the
   expected arrival time may, for example, be the first packet in the
   session or the running average delay.

Nominal delay is defined in the first paragraph as the delay inserted for
the latest arriving playable packet. I believe this is a reasonable
definition. The definition of expected arrival time is in error. If there
is no delay variation, there are no late packets and everything should
arrive before the expected arrival time and most likely at early window.
I suggest expected arrival time should be the same as late window. I also
find the "window", "early window", "late window" terminology unclear. Early
window and late window are actually the edges of a single receive buffering
"window".

I have not done a comprehensive re-review. There are possibly other
problems in this short draft.

Kevin Gross
+1-303-447-0517
Media Network Consultant
AVA Networks - www.AVAnw.com <http://www.avanw.com/>, www.X192.org

On Sun, Feb 24, 2013 at 6:28 PM, Qin Wu <[email-masked]> wrote:

> On 23 February , 2012 10:40 PM, [email-masked] wrote:
>
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> > This draft is a work item of the Metric Blocks for use with RTCP's
> Extended Report Framework Working Group of the IETF.
> >
> > Title           : RTP Control Protocol (RTCP) Extended Report (XR) Block
> for Jitter Buffer Metric Reporting
> > Author(s)       : Alan Clark
> >                          Varun Singh
> >                          Qin Wu
> > Filename        : draft-ietf-xrblock-rtcp-xr-jb-08.txt
> > Pages           : 17
> > Date            : 2013-02-23
> >
> > Abstract:
> >   This document defines an RTP Control Protocol (RTCP) Extended Report
> >   (XR) Block that allows the reporting of Jitter Buffer metrics for a
> >   range of RTP applications.
> >
> >
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcp-xr-jb
> >
> > There's also a htmlized version available at:
> > http://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-jb-08
> >
> > A diff from the previous version is available at:
> > http://www.ietf.org/rfcdiff?url2=draft-ietf-xrblock-rtcp-xr-jb-08
>
> [Qin]: Here is our another update to JB draft. In this version (-08),
> We rewrote descriptive text and definitions for clarification, thanks for
> Alan's proposed text change.
>
> Kevin: Would you like to take a look this version and see if your comments
> are addressed.

---

From: Qin Wu <[email-masked]>
Date: Mon, 4 Mar 2013 18:39:44 +0000

Thank for your confirmation. That is what I thought.

Regards!
-Qin
发件人: Alan Clark [mailto:[email-masked]]
发送时间: 2013年3月5日 2:06
收件人: Qin Wu; Kevin Gross
抄送: [email-masked]
主题: Re: 答复: 答复: Fw: I-D Action: draft-ietf-xrblock-rtcp-xr-jb-08.txt

It is incorrect to state that if packets arrive on-time “there are no late packets and everything should arrive before the expected arrival time and most likely at early window”

On time packets are delayed by the nominal delay (= late window) and by definition “on-time” means arriving “at the expected arrival time”.  If the jitter buffer is configured to use a 20ms nominal delay - then packets that arrive on-time are delayed by 20ms before being played out.  If a packet arrives 10ms early it will be delayed by 30ms before being played out, and if the packet arrives 5ms late then it will be delayed by 15ms before being played out.

The definition in the draft is correct

Best Regards

Alan

On 3/4/13 1:38 AM, "Qin Wu" <[email-masked]> wrote:
发件人: Kevin Gross [mailto:[email-masked]]
发送时间: 2013年3月4日 14:02
收件人: Qin Wu
抄送: [email-masked]; Alan Clark
主题: Re: 答复: Fw: I-D Action: draft-ietf-xrblock-rtcp-xr-jb-08.txt

Responses below.

On Sun, Mar 3, 2013 at 7:58 PM, Qin Wu <[email-masked]> wrote:

Hi, Kevin:
Please see my clarification below.
Alan, please correct me if I am wrong.

Regards!
-Qin

发件人: Kevin Gross [mailto:[email-masked]]
发送时间: 2013年3月4日 6:13
收件人: Qin Wu
抄送: [email-masked]; Alan Clark
主题: Re: Fw: I-D Action: draft-ietf-xrblock-rtcp-xr-jb-08.txt

Nominal delay is defined in the first paragraph as the delay inserted for the latest arriving playable packet. I believe this is a reasonable definition.
[Qin]: Agree.

The definition of expected arrival time is in error. If there is no delay variation, there are no late packets and everything should arrive before the expected arrival time and most likely at early window.
I suggest expected arrival time should be the same as late window.

[Qin]: I think “no delay variation” means packet arrives on time or the received packet, comparing with the reference packet, is neither a late packet nor a early packet.
So I think the intention here for the definition of expected arrive time is to emphasize the delay variation is zero by comparing with the reference packet,
So maybe we can do a little rewording to say:
“
 The "expected arrival time" is the time that a packet would arrive as if
  there was no delay variation.
“

[kg] Changing "if" to "as if" does not significantly clarify or change the meaning of the sentence. Are you saying you believe this paragraph is basically clear and correct as it stands?

[Qin]: yes, I think it stands, what I clarify here is delay variation of one packet is calculated with reference to the reference packet, e.g.,the first packet.

.

I also find the "window", "early window", "late window" terminology unclear. Early window and late window are actually the edges of a single receive buffering "window".

[Qin]: “Window” means time window or time segment not time instance or xxx millisecond (ms) point. You may look at section 4.1, 2nd paragraph of the following URL:
http://www.voiptroubleshooter.com/indepth/jittersources.html
which give a clear definition of time window we are talking about here.

[kg] I believe I understand what the draft is trying to say. My comment is that the draft does not say it clearly (i.e there is one window, not three). The draft needs to be clarified.

[Qin]:  Yes, you are correct, it is not suppose to define three window. How about rephrase the 2nd paragraph of section 3 as follows:
OLD TEXT:
“
   The jitter buffer can be considered as a time window with one side
   (the early window) aligned with the delay corresponding to the
   earliest arriving packet and the other side (the late window)
   representing the maximum permissible delay before a late arriving
   packet would be discarded.  The delay applied to packets that arrive
   at their expected time is known as the Nominal Delay and this is
   equivalent to the late window.
”
NEW TEXT:
“
  The jitter buffer can be considered as a time window with one side
   (the early side corresponding to left half window or early window) aligned with the delay corresponding to the
   earliest arriving packet and the other side (the late side corresponding to right half window or late window)
   representing the maximum permissible delay before a late arriving
   packet would be discarded.  The delay applied to packets that arrive
   at their expected time is known as the Nominal Delay and this is
   equivalent to the late window.

”

I have not done a comprehensive re-review. There are possibly other problems in this short draft.

Kevin Gross

+1-303-447-0517 <tel:%2B1-303-447-0517>

Media Network Consultant

AVA Networks - www.AVAnw.com <http://www.avanw.com/> , www.X192.org <http://www.X192.org>

On 23 February , 2012 10:40 PM, [email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Metric Blocks for use with RTCP's Extended Report Framework Working Group of the IETF.
>
> Title           : RTP Control Protocol (RTCP) Extended Report (XR) Block for Jitter Buffer Metric Reporting
> Author(s)       : Alan Clark
>                          Varun Singh
>                          Qin Wu

Kevin: Would you like to take a look this version and see if your comments are addressed.

---

From: Qin Wu <[email-masked]>
Date: Mon, 4 Mar 2013 19:35:51 +0000

Your window description proposal introduces new terms and has not retired the confusing ones. This is not an overall improvement.

[Qin]: Okay, my description proposal intends to try to clarify what you raised here. Maybe it is not necessary, do you have suggested change without considering what I have already proposed here?

Kevin Gross
+1-303-447-0517
Media Network Consultant
AVA Networks - www.AVAnw.com<http://www.avanw.com/>, www.X192.org<http://www.X192.org>

On Sun, Mar 3, 2013 at 11:38 PM, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:
发件人: Kevin Gross [mailto:[email-masked]<mailto:[email-masked]>]
发送时间: 2013年3月4日 14:02
收件人: Qin Wu
抄送: [email-masked]<mailto:[email-masked]>; Alan Clark
主题: Re: 答复: Fw: I-D Action: draft-ietf-xrblock-rtcp-xr-jb-08.txt

Responses below.

On Sun, Mar 3, 2013 at 7:58 PM, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:
Hi, Kevin:
Please see my clarification below.
Alan, please correct me if I am wrong.

Regards!
-Qin
发件人: Kevin Gross [mailto:[email-masked]<mailto:[email-masked]>]
发送时间: 2013年3月4日 6:13
收件人: Qin Wu
抄送: [email-masked]<mailto:[email-masked]>; Alan Clark
主题: Re: Fw: I-D Action: draft-ietf-xrblock-rtcp-xr-jb-08.txt

”

Kevin Gross
+1-303-447-0517<tel:%2B1-303-447-0517>
Media Network Consultant
AVA Networks - www.AVAnw.com<http://www.avanw.com/>, www.X192.org<http://www.X192.org>

On Sun, Feb 24, 2013 at 6:28 PM, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote: