Subject: Re: [xrblock] Additional PID parameter to PSI dependent Decodabilityreport

From: "Claire Bi(jiayu)" <[email-masked]>
Date: Sun, 8 Sep 2013 17:02:57 +0800

Hi Qin,

According to what you clarified below, “PID_error_count is used to report any error when any PID doesn’t refer to an actual data stream.” while "A Unreferenced PID is a packet with a PID that is not listed in the PMT",  it looks like unreferenced PID count and PID error count just have similar function. 
I think it's not necessary to  report this parameter.

Thanks and Regards,
Claire

> -----Original Message-----
> From:  Qin Wu 
> Date:  2013-08-19  11:40:42 
> To:  [email-masked] 
> Cc:  
> Subject:  [xrblock] Additional PID parameter to PSI dependent Decodabilityreport 

Hi, All:
During Berlin meeting, one comment raised to PSI dependent Decodability draft 
(http://tools.ietf.org/html/draft-bi-xrblock-rtcp-xr-psi-dep-decodability-01) in 
the XRBLOCK Session by Alan was suggesting the addition of the PID to the report.
In the current draft, we have already add PID_error_count under priority two to the report.
PID_error_count is used to report any error when any PID doesn’t refer to an actual data stream.
 
After doing a  little investigation to ETSI TR 101.290 specification, we believe it is 
useful to add “unreferenced PID count” to the report.
“Unreferenced PID” is under priority three and is a packet with a PID that is not 
listed in the PMT. This parameter is not critical, but it
indicates that packets are being disassociated from the PMT, possibly through
remultiplexing.
 
Therefore I propose to add “Unreferenced_PID_Count” as one addition to report as follows:
NEW TEXT:
“
Unreferenced_PID_count: 32 bits
 
A count of the number of Unrerenced_PIDs that occurred in the above
sequence number interval.  A Unreferenced PID is a packet with a PID
that is not listed in the PMT,as defined in the section 5.2.3 of 
[ETSI]. It indicates that packets are being disassociated from the 
PMT, possibly through remultiplexing.
”
 
Regards!
-Qin

__________ Information from ESET NOD32 Antivirus, version of virus signature database 8231 (20130415) __________

The message was checked by ESET NOD32 Antivirus.

http://www.eset.com

---

From: Qin Wu <[email-masked]>
Date: Mon, 9 Sep 2013 01:52:27 +0000

Good point,  I guess I misunderstand Alan's comment in last IETF meeting. What he asked for is not PID error count, but the actual PID.

Regards!
-Qin
From: Claire Bi(jiayu) [mailto:[email-masked]]
Sent: Sunday, September 08, 2013 5:03 PM
To: Qin Wu; [email-masked]
Subject: Re: [xrblock] Additional PID parameter to PSI dependent Decodabilityreport

Hi Qin,

According to what you clarified below, "PID_error_count is used to report any error when any PID doesn't refer to an actual data stream." while "A Unreferenced PID is a packet with a PID that is not listed in the PMT",  it looks like unreferenced PID count and PID error count just have similar function.
I think it's not necessary to  report this parameter.

Thanks and Regards,
Claire

________________________________

Hi, All:
During Berlin meeting, one comment raised to PSI dependent Decodability draft
(http://tools.ietf.org/html/draft-bi-xrblock-rtcp-xr-psi-dep-decodability-01) in<http://tools.ietf.org/html/draft-bi-xrblock-rtcp-xr-psi-dep-decodability-01)%20in>
the XRBLOCK Session by Alan was suggesting the addition of the PID to the report.
In the current draft, we have already add PID_error_count under priority two to the report.
PID_error_count is used to report any error when any PID doesn't refer to an actual data stream.

After doing a  little investigation to ETSI TR 101.290 specification, we believe it is
useful to add "unreferenced PID count" to the report.
"Unreferenced PID" is under priority three and is a packet with a PID that is not
listed in the PMT. This parameter is not critical, but it
indicates that packets are being disassociated from the PMT, possibly through
remultiplexing.

Therefore I propose to add "Unreferenced_PID_Count" as one addition to report as follows:
NEW TEXT:
"
Unreferenced_PID_count: 32 bits

"

Regards!
-Qin

http://www.eset.com