Subject: Re: [xrblock] Mail regarding draft-jayaprabhu-xrblock-rtcp-xr-viewership

From: Kevin Gross <[email-masked]>
Date: Tue, 25 Feb 2014 19:37:29 -0700

I can see the potential utility of this but I'd like to see it explained in
the introduction. All we have now is "As the number of IPTV deployments
continue to increase, it becomes necessary for the operator to collect
various information on the streams that are being delivered to the user."

Please add definitions of what it means to be recording and what it means
to be watching. The former is pretty obvious but the latter less so.

A couple technical comments:

Are you sure we need to worry about rollover of these counters? 2^31
seconds is 68 years.

Consider moving the V and R flags into the "rsvd" field so that the "time
watched" and "time recorded" fields can be interpreted as 32-bit numbers
without fuss.

Kevin Gross - AVA Networks

On Wed, Jan 15, 2014 at 7:56 PM, Huangyihong (Rachel) <
[email-masked]> wrote:

>  Hi Jp,
>
>
>
> Like RTCP SR/RR, RTCP XR is designed to covey the detailed QoS/QoE
> information for RTP, which could reflect the problems in RTP transmission.
> So the metrics defined in RTCP XR are usually closely related to RTP
> stream, and are standard and universal metrics. In this draft, the viewship
> metrics seem not so closely related to RTP streams, rather, they are
> produced by actions of users. IMHO, this kind of information could be
> conveyed by other ways, such as signaling. So why RTCP XR?
>
>
>
> Best regards,
>
> Rachel
>
>
>
> *From:* xrblock [mailto:[email-masked]] *On Behalf Of *Jayaprabhu
> Nadarajan -X (janadara - HCL TECHNOLOGIES LIMITED at Cisco)
> *Sent:* Wednesday, January 15, 2014 8:18 PM
> *To:* [email-masked]
> *Subject:* Re: [xrblock] Mail regarding
> draft-jayaprabhu-xrblock-rtcp-xr-viewership
>
>
>
> Dear All,
>
>
>
> I have submitted an internet draft,
> draft-jayaprabhu-xrblock-rtcp-xr-viewership-00.txt
>
>
>
> URL:             *http://www.ietf.org/internet-drafts/draft-jayaprabhu-xrblock-rtcp-xr-viewership-00.txt
> <http://www.ietf.org/internet-drafts/draft-jayaprabhu-xrblock-rtcp-xr-viewership-00.txt>*
>
>
>
>
>
> Is there any comments on the contents of the draft  or any queries related
> to the scope ?
>
>
>
> Regards,
>
> Jp
>
>
>
> *From:* Jayaprabhu Nadarajan -X (janadara - HCL TECHNOLOGIES LIMITED at
> Cisco)
> *Sent:* Wednesday, December 18, 2013 2:36 PM
> *To:* [email-masked]'
> *Subject:* Mail regarding draft-jayaprabhu-xrblock-rtcp-xr-viewership
>
>
>
> Dear All,
>
>
>
> I have submitted an internet draft,
> draft-jayaprabhu-xrblock-rtcp-xr-viewership-00.txt
>
>
>
> URL:
> http://www.ietf.org/internet-drafts/draft-jayaprabhu-xrblock-rtcp-xr-viewership-00.txt
>
>
>
> Could you please provide your comments/opinions regarding this I-D.
> Following is the brief introduction about this block
>
>
>
> This document defines a new report block type within the framework of RTP
> Control Protocol (RTCP) Extended Reports (XRs) that allows the reporting of
> the usage pattern of a receiver in a RTP session.  As the number of IPTV
> deployments continue to increase, it becomes necessary for the operator to
> collect various information on the streams that are being delivered to the
> user. This document defines a new report block type for the Extended Report
> (XR) packet type of the  RTP Control Protocol (RTCP) which allows IPTV
> clients to report to a server on the usage pattern of the stream that is
> being delivered to them.
>
>
>
> Thanks
>
>
>
> Regards,
>
> Jayaprabhu
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock
>
>

---

From: Qin Wu <[email-masked]>
Date: Thu, 27 Feb 2014 02:42:52 +0000

Regarding what is recorded and what is watched, It will be great the author of draft-jayaprabhu can clarify what use cases will look like?
How these use cases related to SIP-Based Media Recording use cases defined in section-4 of rfc6341?

Regards!
-Qin

From: xrblock [mailto:[email-masked]] On Behalf Of Kevin Gross
Sent: Wednesday, February 26, 2014 10:37 AM
To: Huangyihong (Rachel)
Cc: Jayaprabhu Nadarajan -X (janadara - HCL TECHNOLOGIES LIMITED at Cisco); [email-masked]
Subject: Re: [xrblock] Mail regarding draft-jayaprabhu-xrblock-rtcp-xr-viewership

I can see the potential utility of this but I'd like to see it explained in the introduction. All we have now is "As the number of IPTV deployments continue to increase, it becomes necessary for the operator to collect various information on the streams that are being delivered to the user."

Please add definitions of what it means to be recording and what it means to be watching. The former is pretty obvious but the latter less so.

Are you sure we need to worry about rollover of these counters? 2^31 seconds is 68 years.

Consider moving the V and R flags into the "rsvd" field so that the "time watched" and "time recorded" fields can be interpreted as 32-bit numbers without fuss.

On Wed, Jan 15, 2014 at 7:56 PM, Huangyihong (Rachel) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Jp,

Like RTCP SR/RR, RTCP XR is designed to covey the detailed QoS/QoE information for RTP, which could reflect the problems in RTP transmission. So the metrics defined in RTCP XR are usually closely related to RTP stream, and are standard and universal metrics. In this draft, the viewship metrics seem not so closely related to RTP streams, rather, they are produced by actions of users. IMHO, this kind of information could be conveyed by other ways, such as signaling. So why RTCP XR?

Best regards,
Rachel

From: xrblock [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Jayaprabhu Nadarajan -X (janadara - HCL TECHNOLOGIES LIMITED at Cisco)
Sent: Wednesday, January 15, 2014 8:18 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [xrblock] Mail regarding draft-jayaprabhu-xrblock-rtcp-xr-viewership

Dear All,

I have submitted an internet draft, draft-jayaprabhu-xrblock-rtcp-xr-viewership-00.txt

URL:             http://www.ietf.org/internet-drafts/draft-jayaprabhu-xrblock-rtcp-xr-viewership-00.txt

Is there any comments on the contents of the draft  or any queries related to the scope ?

Regards,
Jp

From: Jayaprabhu Nadarajan -X (janadara - HCL TECHNOLOGIES LIMITED at Cisco)
Sent: Wednesday, December 18, 2013 2:36 PM
To: [email-masked]<mailto:[email-masked]>'
Subject: Mail regarding draft-jayaprabhu-xrblock-rtcp-xr-viewership

Dear All,

I have submitted an internet draft, draft-jayaprabhu-xrblock-rtcp-xr-viewership-00.txt

URL:             http://www.ietf.org/internet-drafts/draft-jayaprabhu-xrblock-rtcp-xr-viewership-00.txt

Could you please provide your comments/opinions regarding this I-D. Following is the brief introduction about this block

This document defines a new report block type within the framework of RTP Control Protocol (RTCP) Extended Reports (XRs) that allows the reporting of the usage pattern of a receiver in a RTP session.  As the number of IPTV deployments continue to increase, it becomes necessary for the operator to collect various information on the streams that are being delivered to the user. This document defines a new report block type for the Extended Report (XR) packet type of the  RTP Control Protocol (RTCP) which allows IPTV clients to report to a server on the usage pattern of the stream that is being delivered to them.

Thanks

Regards,
Jayaprabhu

_______________________________________________
xrblock mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/xrblock