Subject: Re: [xrblock] ops-dir review of draft-ietf-xrblock-rtcp-xr-loss-conceal-10

From: Qin Wu <[email-masked]>
Date: Wed, 26 Mar 2014 02:44:40 +0000

Hi,
In the OPS-DIR review, our reviewer asked to provide the hex value of the default threshold setting and one rounding issue was brought up.
The related paragraph in the draft is:
"
> >    SCS Threshold: 8 bits
> >
> >       The SCS Threshold is defined as the percentage of packets
> >       corresponding to lost or discarded frames that must occur within a
> >       one second period in order for the second to be classified as a
> >       Severely Concealed Second.  This is expressed in numeric format
> >       0:8 and hence can represent a range of 0.1 to 25.5 percent loss or
> >       discard.
> >
> >       A default threshold of 5% effective frame loss (50ms effective
> >       frame loss ) per second is suggested.
"
The SCS threshold is represented in percentage. When we use numeric format 0:8
to represent the default value of SCS threshold, we only can represent 0.05078125
rather than 0.05 or 5% (which is set as the default value of threshold in the draft).

If we change the default threshold value into 0.05078125 and the hex value of 0.05078125 is 0x0D,
This rounding issue can be resolved. 

Alternatively, we can change unit of SCS threshold back into millisecond, we can precisely represent 5% 
frame loss per second or the default threshold value 0.05. The range of 0.1 to 25.5 percentage can be
represented into the range from 1ms effective frame loss to 255ms effective frame loss.

Regards!
-Qin

---

From: Kevin Gross <[email-masked]>
Date: Wed, 26 Mar 2014 07:23:33 -0600

Seems like 0:8 as it appears to be used here can support a range *0.0* to
25.5%. 5% would be exactly represented as 50 or 0x32.

Kevin Gross - AVA Networks

On Tue, Mar 25, 2014 at 8:44 PM, Qin Wu <[email-masked]> wrote:

> Hi,
> In the OPS-DIR review, our reviewer asked to provide the hex value of the
> default threshold setting and one rounding issue was brought up.
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock
>

---

From: Qin Wu <[email-masked]>
Date: Thu, 27 Mar 2014 02:07:42 +0000

Hi, Kevin:
If we use 50ms frame loss per second as default SCS threshold value, that means we are using millisecond as the unit of SCS Threshold.
If we use numeric format 0:8, that means we are using percentage of packets as the unit of SCS Threshold,

Numeric format 0:8 can represent an unsigned number in the range 0.0 to
0.99609375  with a granularity of 0.0039. Therefore using numeric format can represent larger range that using milliseconds as unit.

It looks to me rounding 0.05078125 into 0.05 or 5% is not a issue, since numeric format allows rounding.
5% can be easily transformed into 50ms frame loss per second.

Regards!
-Qin
发件人: Kevin Gross [mailto:[email-masked]]
发送时间: 2014年3月26日 21:24
收件人: Qin Wu
抄送: [email-masked]; [email-masked]
主题: Re: [xrblock] ops-dir review of draft-ietf-xrblock-rtcp-xr-loss-conceal-10

Seems like 0:8 as it appears to be used here can support a range 0.0 to 25.5%. 5% would be exactly represented as 50 or 0x32.

On Tue, Mar 25, 2014 at 8:44 PM, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:
Hi,
In the OPS-DIR review, our reviewer asked to provide the hex value of the default threshold setting and one rounding issue was brought up.
The related paragraph in the draft is:
"
"

Regards!
-Qin

_______________________________________________
xrblock mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/xrblock